Självstudiekurs: Skapa en Power View-rapport med data från Azure Marketplace

Viktigt!: Den här artikeln är maskinöversatt, se ansvarsfriskrivningen. Den engelska versionen av den här artikeln finns här för din referens.

I den här självstudiekursen för Power View hämtar du kostnadsfria data från Microsoft Azure Marketplace, lägger till mer data och skapar relationer mellan tabeller. Du skapar en serie visualiseringar i Power View som illustrerar vilken visualisering som passar en viss typ av data, t.ex. när du ska använda cirkel-, stapel- eller linjediagram, hur du sorterar och filtrerar data i visualiseringar och hur ökningar av detaljnivån fungerar. Du skapar också några enkla beräknade fält i Power Pivot så att Power View kan förmedla data i arbetsboken bättre, men först behöver du data.

Power View-blad med Windows Azure Marketplace-data med karta, liggande diagram och linjediagram

Skapa ett Power View-blad med en karta över amerikanska flygplatser, ett liggande diagram över genomsnittliga förseningar för flygavgångar och ett linjediagram som visar förseningar per månad.

I den här artikeln

Hämta data från Microsoft Azure Marketplace

Skapa ett Power View-blad med ett grupperat diagram

Ändra sorteringsordningen

Ändra mängdfunktion från summa till medelvärde

Hämta flygbolagsdata

Relatera tabeller i Power View

Filtrera diagrammet

Ändra diagrammets layout

Skapa ett annat diagram

Ändra sorteringsordningen för diagrammet

Hämta data om flygplatskoder

Relatera tabellen Airports till de andra tabellerna

Skapa en karta

Filtrera kartan

Korsfiltrera visualiseringar

Lägga till en tidsvisualisering

Skapa en tabell med månadsnamn

Lägga till tabellen i modellen

Skapa ett beräknat fält MonthName Year

Använda det nya beräknade fältet med MonthName Year i Power View

Sortera ett fält efter ett annat fält

Skapa ett linjediagram efter månader

Lägga till Granska nedåt i ett linjediagram

Mer skoj med flygbolagens förseningsdata

Teman och formatering

Relaterad information

Hämta data från Microsoft Azure Marketplace

  1. Klicka på fliken Power Pivot > Hantera datamodell i Excel.

Visas inte fliken Power Pivot ? Starta Power Pivot in Microsoft Excel 2013-tilläggsprogrammet.

  1. Klicka på Hämta externa data > Från datatjänst > Från Microsoft Azure Marketplace.

  2. I guiden Tabellimport under Typ > Data och under Pris > Gratis.

  3. Sök efter ”air carriers”.

  4. Intill US Air Carrier Delays klickar du på Prenumerera.

  5. Logga in med ett Microsoft-konto. Om du inte har ett sådant konto följer du stegen för att skapa ett.

Det här fönstret visar exempeldata.

  1. Bläddra till slutet av exempeldata och klicka på Urvalsfråga.

  2. Du kan skriva in ett användarvänligt namn för anslutningen och klicka på Nästa.

  3. Klicka på Förhandsgranskning och filter.

  4. I det här fönstret kan du välja vilka kolumner du vill importera genom att avmarkera kryssrutorna. Vi vill ha alla, så klicka på OK och klicka sedan på Slutför.

Hämtningen kan ta en stund. Datamängden har över 2,4 miljoner rader.

  1. Klicka på OK.

Har du just har skapat en datamodell i Excel.

Skapa ett Power View-blad med ett grupperat diagram

  1. Klicka på fliken Infoga > Power View-rapporter i Excel.

I fältlistan finns tabellen On_Time_Performance.

  1. Klicka på pilen intill tabellen On_Time_Performance.

Detta är fälten (kolumnerna) i tabellen.

  1. Markera rutan Carrier.

Detta visar en lista över förkortningar för bolag.

  1. Markera rutan ArrDelayMinutes.

Du får en mängd per bolag.

  1. I rutan Värden klickar du på pilen intill ArrDelayMinutes.

Du ser nu att du får en summa med förseningsminuter per bolag.

  1. På fliken Design klickar du på pilen under Liggande diagram och klickar på Grupperad liggande stapel.

  2. Ändra storleken på diagrammet så att det blir högre: dra i handtaget i nederkanten när markören ändras till en pekande hand. Pekande hand i Power View

  3. I fältlistan drar du DepDelayMinutes till rutan Värden under ArrDelayMinutes.

Nu kan vi se att en del bolag är bättre på att anlända i tid, medan andra är bättre på att avgå i tid.

Ändra sorteringsordningen

  1. Hovra över diagrammet för att se sortera efter i det övre vänstra hörnet. Klicka på Carrier.

Nu är det sorterat efter ArrDelayMinutes.

  1. Klicka återigen i det övre vänstra hörnet på stig. Nu är det sorterat fallande i stället.

Det är tydligt att WN har den största siffran.

Ändra mängdfunktion från summa till medelvärde

Men det kanske inte blir rätt om man summerar förseningarna, ett flygbolag med fler flighter kanske är i tid oftare, men har ändå ett större totalt antal.

  1. I rutan Värden klickar du på pilen intill ArrDelayMinutes och ändrar från Summa till Medelvärde.

  2. Gör samma sak med DepDelayMinutes.

  3. Sortera om efter ArrDelayMinutes.

Nu ändras bilden helt: WN har långt ifrån det sämsta medelvärdet för förseningar. Nu kan vi se att XE är sämst i genomsnitt.

Mer information om hur du ändrar summor till medelvärden eller andra mängdfunktioner i Power View.

Hämta flygbolagsdata

Det är bara ett problem: vem vet vad bolagsförkortningarna står för? Vilket flygbolag är XE? Men allt finns så klart på webben.

  1. Gå till den här webbplatsen med en lista med två bokstäver flygbolagskoder: http://www.airfarewatchdog.com/pages/3799702/airline-letter-codes/.

  2. Markera de två kolumnerna med data och kopiera dem.

  3. I Excel-arbetsboken klickar du på ett tomt kalkylblad och skriver AirlineCode i cell A1 och AirlineName i cell B1.

  4. Klicka i cell A2 och klistra in informationen.

  5. Formatera data som en tabell (Ctrl + T) och ge det namnet Airlines.

  6. Ändra även flikens namn till Airlines.

Relatera tabeller i Power View

  1. Gå tillbaka till Power View-bladet i Excel-arbetsboken.

  2. Tabellen Airlines finns redan i fältlistan.

Om du inte ser den klickar du på Alla i fältlistan.

  1. Kontrollera att det liggande stapeldiagrammet har valts och ta bort Carrier från rutan Axel.

Då visas den genomsnittliga förseningen för ankomst och avgång för alla bolag.

  1. Expandera tabellen Airlines och markera kryssrutan AirlineName.

Nu innehåller diagrammet flygbolagens namn. Det finns dock ett problem: alla värden är desamma. Power View visar ett meddelande i fältlistan: “Det kan behövas relationer mellan tabellerna.”

  1. Klicka på Skapa.

  2. I tabell klickar du på On_Time_Performance.

  3. I Kolumn (sekundär) klickar du på Carrier.

  4. I Relaterad tabell klickar du på Airlines.

  5. Klicka på i Relaterad kolumn (primär). AirlineCode.

Detta skapar en relation mellan de två tabellerna i fälten AirlineCode och Carrier.

  1. Klicka på OK.

  2. Sortera tabellen igen så att fältet ArrDelayMinutes sorteras fallande.

Titta: siffrorna i tabellen är inte likadana allihop längre och vi kan se namnen på flygbolagen i stället för flygbolagskoderna. XE är alltså koden för ExpressJet.

Filtrera diagrammet

Lägg märke till värdet (tom) i listan med flygbolag? Nu ska vi ta bort den genom att filtrera data.

  1. Markera stapeldiagrammet med flygbolag och klicka på Diagram i filterområdet.

    Tips: Visas inte filterområdet? Klicka på fliken Power View > Visa > Filterområde.

    Observera att filterområdet redan innehåller fälten i diagrammet. Filtren i diagramfiltret filtrerar endast detta diagram och inte några andra visualiseringar på bladet.

  2. Klicka på AirlineName, markera rutan (Alla) och avmarkera sedan rutan (Tom).
    (Tom) försvinner från diagrammet.

Ändra diagrammets layout

  1. Kontrollera att stapeldiagrammet är markerat.

  2. Klicka på fliken Layout > Förklaring > Visa förklaring i överkant.

Den här layouten utnyttjar utrymmet bättre.

  1. Markera diagrammet, klicka på storlekshandtaget på höger sida och gör diagrammet smalare.

  2. Nu finns det plats för en till visualisering.

Skapa ett annat diagram

  1. Starta en ny visualisering genom att klicka på det tomma bladet.

Tips: Det här är viktigt: så länge som en visualisering är markerad kommer alla fält du väljer att läggas till i den visualiseringen, i stället för att starta en ny.

  1. I tabellen On_Time_Performance i fältlistan klickar du på rutan Ursprung.

Ursprung är en annan lista med koder, den här gången för flygplatser.

  1. I tabellen On_Time_Performance markerar du rutan DepDelayMinutes.

  2. I rutan Fält klickar du på pilen intill DepDelayMinutes och klickar på Medelvärde.

Siffran har många decimaler.

  1. Klicka i Medelvärde för kolumnen DepDelayMinutes och välj fliken Design > Minska decimal.

Siffran har nu två decimaler.

  1. På fliken Design klickar du på pilen under Liggande stapeldiagram > Staplad liggande stapel.

  2. Dra de övre och nedre storlekshandtagen så att så många staplar som möjligt visas i diagrammet.

Ändra diagrammets sorteringsordning

  1. Hovra över diagrammet för att se sortera efter i det övre vänstra hörnet. Klicka på Ursprung.

Nu är det sorterat efter DepDelayMinutes.

  1. Klicka återigen i det övre vänstra hörnet på stig. Nu är det sorterat fallande i stället.

Det är tydligt att JLN har sämst statistik för att anlända i tid. Var är det? Än en gång har vi intressanta data, men vi kan inte tolka den eftersom vi inte känner till så många flygplatskoder.

Hämta data om flygplatskoder

  1. Gå till http://www.airportcodes.us/us-airports.htm.

  2. På webbplatsen markerar du och kopierar de fyra datakolumnerna, Code, Name, City och State, utan tabellrubriken “US Airports, Sorted by Airport Code”.

  3. I Excel klickar du på plustecknet (+) för att lägga till ett tomt kalkylblad.

  4. Klicka i cell A1 och klistra in informationen.

  5. Byt namn på kolumnerna:

    • Code = AirportCode

    • Name = AirportName

    • City = AirportCity

    • State = AirportState

  6. Formatera data som en tabell (Ctrl + T) och ge den namnet Airports.

  7. Ändra även flikens namn till Airports.

Relatera tabellen Airports till de andra tabellerna

  1. Gå tillbaka till Power View-bladet i Excel-arbetsboken.

  2. Tabellen Airports finns redan i fältlistan.

    Om du inte ser den klickar du på Alla i fältlistan.

  3. Se till att det stående stapeldiagrammet har valts och ta bort Origin från rutan Axel.

  4. Då visas den genomsnittliga förseningen för avgång för alla flygplatser.

  5. Expandera tabellen Airports och markera kryssrutan AirportName.

    Nu innehåller diagrammet flygbolagens namn. Men alla värden är återigen likadana och du ser meddelandet i fältlistan: “Det kan behövas relationer mellan tabellerna.”

    Nu ska vi skapa relationer på ett annat sätt.

  6. Gå till fliken Power Pivot > Hantera datamodell.

  7. Öppna Power Pivot-fönstret på fliken Start > Diagramvy.

    Nu visas tre tabeller i modellen. Det går en linje från On_Time_Performance till Airlines, men inte till Airports.

  8. Leta reda på ursprungsfältet i tabellen On_Time_Performance och dra från det till fältet AirportCode i tabellen Airports.

  9. Återgå till Power View-bladet i Excel.

  10. Klicka på OK i meddelandet om att datamodellen har ändrats.

    Siffrorna i tabellen är inte alla likadana längre och vi kan se namnen på flygplatserna i stället för flygbolagskoderna.

  11. Sortera diagrammet fallande efter medelvärdet i DepDelayMinutes.

JLN är alltså koden för Joplin Regional Airport.

Mer information om hur du skapar relationer mellan tabeller.

Skapa en karta

Skulle det här data vara mer intressant om vi har visats på en karta? Nu när vi har ort och region namnen i tabellen Airports kan mappa data. Först ska du flytta flygbolag diagrammet så att vi får mer plats.

  1. Dra flyttningshandtagen för flygbolagsdiagrammet så att det hamnar längs diagrammets vänstra sida och dra storlekshandtagen så att det blir högt och smalt.

  2. Markera flygplatsdiagrammet och gå till fliken Design > Karta.

Den första gången som du skapar en karta i Power View kan det visas en sekretessvarning om att data behöver geokodas genom att de skickas till Bing via en säker webbanslutning.

  1. Klicka på OK.

  2. Det kan hända att Power View placerar AirportName i rutan Färg. Om det händer drar du det till rutan Platser.

  3. Dra storlekshandtagen så att kartan passar in i hela bladets återstående bredd.

Det finns för många prickar. Vi väljer att fokusera på de flygplatser där förseningarna är längst. Ser du pricken norr om Australien? Det är Guam.

Filtrera kartan

  1. Markera kartan och klicka på Karta i filterområdet.

  2. Klicka på Medelvärde för DepDelayMinutes.

En rullningslist från 0 till 25,37 minuter visas.

  1. Dra den vänstra delen av bläddringslisten så att du endast ser förseningar som är längre än 10 minuter.

Tips:  Om du vill ha mer exakta siffror kan du även göra detta i avancerat filterläge. Klicka på ikonen till höger om filternamnet (Medelvärde för DepDelayMinutes) och Visa objekt med följande värdevillkor > är större än eller lika med > skriv in 10 i rutan.

  1. Nu ska du filtrera fram Guam. Klicka på AirportName i filterområdet. Markera rutan Alla och skriv Guam i sökrutan. Starta sökningen genom att klicka på förstoringsglasikonen.

Det enda resultatet är Guam International Airport.

  1. Avmarkera kryssrutan bredvid Guam.

  2. Klicka på plustecknet i kartans övre högra hörn för att zooma in och använd pekaren för att ändra placeringen så att du endast ser USA och Alaska.

  3. Hovra över den stora punkten i Berings hav, det är Adak Airport med nästan 24 minuters försening.

Korsfiltrera visualiseringar

Nu börjar det roliga – det är dags att leka med interaktionerna mellan visualiseringarna.

  1. Klicka på bubblan Adak Airport.

  2. Ta en titt på vad som hände i det liggande flygbolagsdiagrammet. Tydligen är Alaska det enda flygbolaget som flyger till Adak Airport. Lägg märke till att du fortfarande kan avläsa Alaskas medelvärde och alla de andra flygbolagens. Om medelvärdet för det individuella värdet överstiger totalvärdet blir den individuella medelvärdesstapeln smalare än den sammanlagda så att du fortfarande kan avläsa den i Power View.

  3. Zooma in och ändra placering till bara kontinentala USA.

  4. Klicka på ExpressJet i det liggande diagrammet.

Främst östra och mellersta USA.

  1. Klicka på stapeln för Frontier.

Bara tre: flygplatserna i San Francisco, Palm Springs och Greater Rockford. San Francisco kan nog vara den största flygplatsen på den här kartan.

  1. Klicka på bubblan för San Francisco på kartan.

Har man sett. Nästan alla flygbolag som avgår från San Francisco har ett sämre medelvärde där än på andra platser.

Mer information om filtrering och markering i Power View.

Lägga till en tidsvisualisering

Nu ska vi ta en titt på hur det har gått för flygbolagen under olika månader. Kanske kan du gissa vilka månader som är sämst. Vi får se om det stämmer. I tabellen On_Time_Performance finns flera datumfält. Fältet FlightDate har formatet M/D/YYYY HH:MM:SS AM – till exempel 1/1/2012 12:00:00 AM.

Det finns också ett månadsfält. Det är numeriskt – inga månadsnamn. Vi börjar med det.

  1. Börja på ett nytt Power View-blad: gå till Excel > Infoga > Power View-rapport.

  2. Maximera tabellen On_Time_Performance i fältlistan och markera Month.

Eftersom det är ett numeriskt fält (markerat med ett sigma, Σ) läggs värdena till i Power View.

  1. Klicka på pilen bredvid Month > Summera inte i rutan Fält.

I Power View skapas en tabell med månaderna i ordningsföljd. 1, 2, 10, 11 och 12. Men det finns ett problem: De är faktiskt inte i ordningsföljd.

  1. Markera månadstabellen i bladet och dra Year i tabellen On_Time_Performance så att det hamnar ovanför Month i rutan Fält.

  2. Klicka på pilen bredvid Year > Summera inte i rutan Fält.

  3. Nu ser du att månaderna 10, 11 och 12 faktiskt ska ligga före månaderna 1 och 2 eftersom de gäller 2011.

Skapa en tabell med månadsnamn

  1. Inled en tabell i Excel på ett nytt blad. Börja med cell A1:

MonthNumber

MonthName

1

Januari

2

Februari

  1. Markera cellerna A2 till B3 och dra sedan fyllningshandtaget i det nedre högra hörnet av cell B3 [ZA010278334] till cell B13.

fyllningshandtag

Då fylls raderna 4 till 13 i med resten av månadsnumren och månadsnamnen.

  1. Markera raderna 1 till 13, kolumn A och B och skapa en tabell (Ctrl + T).

  2. Kontrollera att Tabellen har rubriker är markerat.

  3. På fliken Excel Design > Tabellnamn skriver du MonthNames.

  4. Ändra kalkylbladets namn till Month Names.

Lägga till tabellen i modellen

  1. Markera tabellen i Excel och klicka på fliken Power Pivot > Lägg till i datamodell.

    Power Pivot-fönstret öppnas med MonthNames-bladet överst.

  2. Gå till Power Pivot-fönstret på fliken Start > Visa > Diagramvy.

  3. Skapa en relation mellan tabellerna genom att dra från fältet Månad i tabellen On_Time_Performance till fältet MonthNumber i tabellen MonthNames.

Skapa det beräknade fältet MonthName Year

  1. På fliken Power PivotStart klickar du på > Visa > Datavy.

  2. Gå till tabellen On_Time_Performance och klicka i kolumnen Lägg till kolumn.

    Du ska skapa en grundläggande beräknad kolumn.

  3. Typ

    = RELATERADE

  4. Klicka på MonthNames-bladet och klicka på MonthName-kolumnen.

    Nu hämtas MonthName-fältet från tabellen MonthNames och läggs (MonthNames [MonthName] till i din formel i tabellen On_Time_Performance.

  5. Typ

    ) & " " &

    Var noga med att skriva raka citattecken, inte typografiska.

  6. Klicka på kolumnen Year i tabellen On_Time_Performance.

    [Year] läggs till i din formel. Nu ser hela formeln ut så här:

    =RELATED(MonthNames[MonthName]) & " " & [Year]

  7. Tryck på Retur.

    I Power Pivot fylls ett fält automatiskt i med månadsnamnet från tabellen MonthNames, ett blanksteg och året från tabellen On_Time_Performance – till exempel Oktober 2011.

  8. Markera kolumnen, högerklicka och ändra namnet till MonthName Year.

Använda det nya beräknade fältet MonthName Year i Power View

  1. Gå tillbaka till Excel och Power View-bladet.

  2. Dra det nya fältet MonthName Year till bladet.

Hoppsan, någonting gick snett: Månaderna kommer i alfabetiskt ordning i stället för kronologisk.

Sortera ett fält efter ett annat fält

  1. Gå tillbaka till Power Pivot-fönstret.

  2. Skapa ytterligare ett grundläggande beräknat fält genom att gå till tabellen On_Time_Performance och klicka i kolumnen Lägg till kolumn.

  3. Typ

    = YEAR([

    Då visas en lista över kolumnerna i tabellen.

  4. Klicka på kolumnen flightdate och tryck på TABB-tangenten.

  5. Typ

    ) & FORMAT(MONTH([

  6. Klicka på kolumnen FlightDate igen i listan med kolumnerna i tabellen och tryck sedan på TABB.

  7. Typ

    ), “00”

    Nu ser hela formeln ut så här:

    =YEAR([FlightDate]) & FORMAT(MONTH([FlightDate]),”00″)

  8. Tryck på RETUR.

    I Power Pivot skapas en kolumn med endast året från fältet FlightDate och endast månadsnumret från samma fält. På grund av “00” visas månadsnumret med två siffror. Till exempel innebär 201201 januari 2012.

  9. Markera kolumnen, högerklicka och ändra Namnet till MonthNumber Year.

  10. Markera kolumnen MonthName Year och klicka på fliken Power PivotStart > Sortera efter kolumn.

    MonthName Year finns i fältet Sort Column.

  11. Klicka i fältet By ColumnMonthNumber Year > OK.

Skapa ett linjediagram efter månader

  1. Gå tillbaka till Excel och Power View-bladet och klicka på OK i meddelandet om att datamodellen har ändrats.

    Visst har den ändrats: nu sorteras månaderna i kronologisk ordning, oktober 2011 till och med februari 2012. En klar förbättring.

  2. Markera tabellen MonthName Year och markera fältet DepDelayMinutes i fältlistan > tabellen On_Time_Performance.

    Fältet läggs till som en summa.

  3. I rutan fält klickar du på DepDelayMinutes > medelvärde.

  4. Gå till fliken Design > Andra diagram > Linje.

    Jajamän. Precis som förväntat var december den sämsta månaden tätt följt av januari.

  5. Nu lägger vi till ytterligare en linje: Markera tabellen MonthName Year och dra fältet ArrDelayMinutes i fältlistan > tabellen On_Time_Performance till rutan Värden.

    Även det här fältet läggs till som en summa.

  6. Klicka på ArrDelayMinutes i rutan fält > medelvärde.

Nu kan du se att DepDelayMinutes – avgångarna – var sämst i december, medan ArrDelayMinutes – ankomsterna – var sämst i januari.

Nu ska vi ta reda på vilken dag i månaden som var sämst.

Lägga till funktionen för att öka detaljnivån i ett linjediagram

  1. Linjediagrammet från fältlistan > On_Time_Performance tabell och dra Day of Month till rutan axel under MonthName Year.

Linjediagrammet ändras inte.

  1. Dubbelklicka på punkten för december 2011.

Nu visas december månads förseningar 2011 dag för dag. Ser du de två topparna för DepDelayMinutes?

  1. Håll pekaren över topparna för DepDelayMinutes: den 22 och den 27 december – före och efter jul.

Hur ser det ut i november då?

  1. Klicka på pilen för att minska detaljnivån i det övre högra hörnet så återgår du till det månadsvisa diagrammet.

Pil för att minska detaljnivån i diagramvisualiseringar i Power View

  1. Dubbelklicka på november 2011.

Som väntat – den 29 november var den sämsta dagen för ankomster och avgångar.

Läs mer om att lägga till öka detaljnivån i en Power View-diagram eller en matris.

Mer skoj med flygbolagens förseningsdata

I den här självstudiekursen har du lärt dig att:

  • Hämta data från källor på Internet.

  • Skapa relationer

  • Skapa olika diagram och en karta.

  • Filtrera och korsfiltrera data

  • Skapa beräknade fält i Power Pivot.

  • Arbeta med tidsdata i Power Pivot och Power View.

  • Lägga till funktionen för att öka detaljnivån i ett diagram

Du kan själv fortsätta att leka med informationen. Till exempel kan du testa det här: Kopiera linjediagrammet MonthName Year från det här Power View-bladet och klistra in det i bladet med kartan. När du sedan klickar på flygplatser på kartan kan du jämföra dem månad för månad.

Teman och formatering

Spela upp med teman på fliken Power View för. Power View-bladet i bilden i början använder temat sammansatt med Light2 enfärgad bakgrund. Se vad du kommer på! Mer information om att Formatera Power View-rapporter.

Relaterad information

Diagram och andra visualiseringar i Power View

Filtrera, markera och utsnitt i Power View

Kartor i Power View

Nyheter i Power View för Excel 2013 och SharePoint Server

Power View: Utforska, visualisera och presentera dina data

Obs!: Ansvarsfriskrivning för maskinöversättning: Den här artikeln har översatts av ett datorsystem utan mänsklig inblandning. Microsoft erbjuder dessa maskinöversättningar för att hjälpa icke engelskspråkiga användare att ta del av information om Microsofts produkter, tjänster och tekniker. Eftersom artikeln är maskinöversatt kan den innehålla fel i ordval, syntax och grammatik.

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×