Självstudiekurs: Analysera data i en pivottabell med hjälp av en datamodell i Excel 2013

På mindre än en timme kan du skapa en pivottabellrapport i Excel som kombinerar data från flera tabeller. I den första delen av den här självstudiekursen lär du dig att importera och utforska data. I den andra delen får du använda Power Pivot-tilläggsprogrammet och förfina datamodellen som rapporten bygger på och lära dig hur du lägger till beräkningar, hierarkier och optimeringar för Power View-rapporter.

Vi börjar med att importera data.

  1. Hämta exempeldata för den här självstudiekursen. Mer information finns i Hämta exempeldata för självstudiekurser om DAX och datamodeller. Extrahera och spara datafilerna på en lättillgänglig plats, t.ex. i mappen Hämtade filer eller Mina dokument.

  2. Öppna en tom arbetsbok i Excel.

  3. Klicka på Data > Hämta externa data > Från Access.

  4. Gå till mappen som innehåller exempeldatafilerna och välj ContosoSales.

  5. Klicka på Öppna. Eftersom du ansluter till en databasfil som innehåller flera tabeller visas dialogrutan Välj tabell där du kan välja vilka tabeller du vill importera.

    Dialogrutan Välj tabell

  6. Markera Tillåt att flera tabeller markeras i Välj tabell.

  7. Markera alla tabeller och klicka på OK.

  8. Klicka på Pivottabellrapport i Importera data och klicka på OK.

    Meddelanden: 

    • Du kanske inte har förstått det än, men du har precis skapat en datamodell. Modellen är en dataintegreringsnivå som skapas automatiskt när du importerar eller arbetar med flera tabeller samtidigt i samma pivottabellrapport.

    • Modellen är till största delen transparent i Excel, men du kan visa och ändra den med hjälp av Power Pivot -tilläggsprogrammet. En uppsättning tabeller i fältlistan för pivottabellen tyder på att det finns en datamodell i Excel. Det finns flera sätt att skapa en modell. Mer information finns i Skapa en datamodell i Excel .

Utforska data med hjälp av en pivottabell

Du kan enkelt utforska data genom att dra fält till områdena Värden, Kolumner och Rader i fältlistan för pivottabellen.

  1. Rulla nedåt i fältlistan tills du hittar tabellen FactSales.

  2. Klicka på Försäljningsbelopp. Eftersom dessa data är numeriska placeras Försäljningsbelopp automatiskt i området Värden.

  3. Dra Kalenderår i NedtonatDatum till Kolumner.

  4. Dra UnderkategoriProdukt i NedtonadUnderkategoriProdukt till Rader.

  5. Dra Företagsnamn i NedtonadUnderkategoriProdukt till Rader, under underkategori.

Din pivottabell bör se ut ungefär som på skärmen nedan.

Pivottabell med exempeldata

Nu har du med minimal ansträngning skapat en enkel pivottabell med fält från fyra olika tabeller. Anledningen till att det gick så lätt är de fördefinierade relationerna mellan tabellerna. Eftersom det förekommer tabellrelationer i källan och du importerade alla tabeller genom en enda åtgärd, kunde relationerna återskapas i modellen.

Men vad händer om dina data kommer från olika källor eller importeras senare? Då kan du oftast infoga nya data genom att skapa relationer som baseras på överensstämmande kolumner. I nästa steg får du importera fler tabeller och lära dig hur du gör och vad som krävs för att skapa nya relationer..

Lägga till fler tabeller

När du ska lära dig att skapa tabellrelationer behöver du några tabeller som inte är ihopkopplade att arbeta med. I det här steget ska du hämta resten av informationen som används i guiden, genom att importera en ny databasfil och klistra in data från två andra arbetsböcker.

Lägga till produktkategorier

  1. Öppna ett nytt blad i arbetsboken. Du ska lagra ytterligare data i bladet.

  2. Klicka på Data > Hämta externa data > Från Access.

  3. Gå till mappen som innehåller exempeldatafilerna och välj ProductCategories. Klicka på Öppna.

  4. Välj Tabell i Importera data och klicka på OK.

Lägga till geografiska data

  1. Infoga ett till blad.

  2. Öppna Geography.xlsx i exempeldatafilen, placera markören i A1 och markera alla data genom att trycka på Ctrl+Skift+End.

  3. Kopiera data till Urklipp.

  4. Klistra in data i det tomma blad som du nyss lagt till.

  5. Klicka på Formatera som tabell och välj ett format. Genom att formatera data som en tabell kan du namnge den, vilket är praktiskt när du ska definiera relationer längre fram.

  6. Kontrollera att Tabellen har rubriker är markerat i Formatera som tabell. Klicka på OK.

  7. Döp tabellen till Geografi. Skriv Geografi i Tabellnamn i Tabellverktyg > Design.

  8. Rensa arbetsytan genom att stänga Geography.xlsx.

Lägga till butiksdata

  • Upprepa föregående steg för filen Stores.xlsx genom att klistra in innehållet i ett tomt blad. Döp tabellen till Stores.

Nu bör det finnas fyra blad. Blad1 innehåller pivottabellen, Blad2 innehåller ProductCategories, Blad3 innehåller Geography och Blad4 innehåller Stores. Eftersom du tog dig tid att namnge varje tabell blir det mycket lättare att skapa relationer i nästa steg.

Använda fält från de nyimporterade tabellerna

Du kan börja använda fält från de nyimporterade tabellerna på en gång. Om det inte går att avgöra hur ett fält ska infogas i pivottabellrapporten, blir du uppmanad att skapa en tabellrelation som associerar den nya tabellen med den som redan ingår i modellen.

  1. Visa hela listan med tillgängliga tabeller genom att klicka på Alla högst upp i Pivottabellfält.

  2. Rulla längst ned i listan. Där ser du de nya tabellerna som du just lagt till.

  3. Expandera Stores.

  4. Dra Butiksnamn till området Filter.

  5. Observera att du uppmanas att skapa en relation. Meddelandet visas eftersom du har använt fält från en tabell som inte är relaterad till modellen.

  6. Öppna dialogrutan Skapa relation genom att klicka på Skapa.

  7. Välj Försäljningsinfo i Tabell. I de exempeldata som du använder innehåller Försäljningsinfo detaljerad försäljnings- och kostnadsinformation om Contosos verksamhet, liksom nycklar till andra tabeller, inklusive butikskoder som även finns i filen Butiker.xlsx som du importerade i det föregående steget.

  8. Välj StoreKey i Kolumn (sekundär).

  9. Välj Stores i Relaterad tabell.

  10. Välj StoreKey i Relaterad kolumn (primär).

  11. Klicka på OK.

Excel bygger en datamodell i bakgrunden som kan användas i hela arbetsboken i valfritt antal pivottabeller, pivotdiagram eller Power View-rapporter. Tabellrelationerna är mycket viktiga i den här modellen. De bestämmer vägar för navigering och beräkningar i en pivottabellrapport. I nästa uppgift ska du skapa relationer manuellt som kopplar de data som du nyss importerat.

Lägga till relationer

Du kan systematiskt skapa tabellrelationer för alla nya tabeller som du importerar. Om du delar arbetsboken med kolleger kan det vara uppskattat att ha fördefinierade relationer om de andra inte känner till informationen lika bra som du.

När du skapar relationer manuellt arbetar du med två tabeller i taget. För varje tabell väljer du kolumner som instruerar Excel hur programmet ska leta upp relaterade rader i en annan tabell.

Din webbläsare har inte stöd för video. Installera Microsoft Silverlight, Adobe Flash Player eller Internet Explorer 9.

Koppla ProductSubcategory till ProductCategory

  1. Klicka på Data > Relationer > Ny i Excel.

  2. Välj DimProductSubcategory i Tabell.

  3. Välj ProductCategoryKey i Kolumn (sekundär).

  4. Välj Tabell_Produktkategori.accdb i Relaterad tabell.

  5. Välj ProductCategoryKey i Relaterad kolumn (primär).

  6. Klicka på OK.

  7. Stäng dialogrutan Hantera relationer.

Lägga till kategorier i pivottabellen

Datamodellen har uppdaterats med fler tabeller och relationer, men de används inte ännu i pivottabellen. I den här uppgiften ska du lägga till Produktkategori i fältlistan för pivottabellen.

  1. Visa tabellerna i datamodellen genom att klicka på Alla i fältlistan för pivottabellen.

  2. Rulla längst ned i listan.

  3. Ta bort Företagsnamn i området Rader.

  4. Expandera Table_DimProductCategories.accdb.

  5. Dra ProduktkategoriNamn till området Rader och släpp den ovanför UnderkategoriProdukt.

  6. Kontrollera att pivottabellen identifierar de tabeller som du precis använt genom att klicka på Aktiva i fältlistan för pivottabellen.

Repetera: gå igenom det du lärt dig

Nu har du en pivottabell med data från flera tabeller, där flera tabeller importerades i ett senare steg. För att få ihop alla data var du tvungen att skapa tabellrelationer som används i Excel för att korrelera raderna. Du lärde dig vikten av att ha kolumner som tillhandahåller matchande data för att kunna leta upp relaterade rader. I exempeldatafilerna innehåller alla tabellerna en kolumn som kan användas för detta ändamål.

Även om pivottabellen fungerar, har du säkert lagt märke till flera saker som skulle kunna förbättras. Fältlistan för pivottabellen verkar ha extra tabeller (NedtonadEnhet) och kolumner (ETLHämtaID) som inte relaterar till Contosos verksamhet. Och vi har fortfarande inte integrerat några Geografi-data.

Fortsättning: Visa och hantera modellen med Power Pivot

I följande uppgifter ska du utöka modellen med hjälp av tilläggsprogrammet Microsoft Office Power Pivot i Microsoft Excel 2013. Som du kommer att märka blir det enklare att skapa relationer med diagramvyn i tilläggsprogrammet. Du ska också använda tilläggsprogrammet för att skapa beräkningar och hierarkier, dölja objekt som inte ska visas i fältlistan och optimera data för ytterligare rapportering.

Obs!: Power Pivot i Microsoft Excel 2013 -tilläggsprogrammet ingår i Office Professional Plus. Mer information finns i Power Pivot i Microsoft Excel 2013-tilläggsprogrammet.

Lägg till Power Pivot i menyfliksområdet i Excel genom att aktivera Power Pivot-tilläggsprogrammet.

  1. Gå till Arkiv > Alternativ > Tillägg.

  2. Klicka på COM-tillägg i rutan Hantera och sedan på OK.

  1. Markera rutan Microsoft Office Power Pivot i Microsoft Excel 2013 och klicka på OK.

Nu visas fliken Power Pivot i menyfliksområdet.

Lägga till en relation från diagramvyn i Power Pivot

  1. Gör Blad3 till det aktiva bladet genom att klicka på det i Excel. Blad3 innehåller tabellen Geografi som du importerade förut.

  2. Klicka på Power Pivot > Lägg till i datamodell. Nu läggs tabellen Geografi till i modellen och Power Pivot-tilläggsprogrammet öppnas, som du ska använda för de resterande stegen i den här uppgiften.

  3. Observera att alla tabeller i modellen visas i Power Pivot-fönstret, även Geografi. Klicka igenom ett par tabeller. I tilläggsprogrammet kan du visa alla data som modellen innehåller.

  4. I avsnittet Visa i Power Pivot-fönstret klickar du på Diagramvy.

  5. Använd skjutreglaget och ändra storlek på diagrammet så att du ser alla objekt i diagrammet. Observera att två tabeller är orelaterade till resten av diagrammet: DimEntity och Geography.

  6. Högerklicka på NedtonadEnhet och klicka på Ta bort. Den här tabellen är en rest från den ursprungliga databasen och behövs inte i modellen.

  7. Zooma in Geography så att alla fälten visas. Använd skjutreglaget om du vill göra tabelldiagrammet större.

  8. Observera att Geografi innehåller GeografiNyckel. Kolumnen innehåller unika värden som identifierar varje rad i tabellen Geografi. Nu ska vi se om andra tabeller i modellen använder samma nyckel. I så fall kan vi skapa en relation som kopplar ihop Geografi med resten av modellen.

  9. Klicka på Sök.

  10. Skriv GeographyKey i Sök metadata.

  11. Klicka flera gånger på Sök nästa. Som du ser visas GeographyKey i tabellen Geography och i tabellen Stores.

  12. Flytta tabellen Geografi så att den hamnar bredvid Butiker.

  13. Dra kolumnen GeographyKey i Stores till kolumnen GeographyKey i Geography. Power Pivot ritar en linje mellan de två kolumnerna som representerar relationen.

I den här uppgiften lärde du dig en ny teknik för att lägga till tabeller och skapa relationer. Nu har du en helt integrerad modell, där alla tabeller är kopplade och tillgängliga i pivottabellen i Blad1.

Tips:  I diagramvyn är flera tabelldiagram helt utvecklade och kolumner som ETLHämtaID, HämtaDatum och UppdateraDatum visas. Just de här fälten är rester från det ursprungliga Contoso-datalagret som lades till för att stödja extrahering och läsning av data. De behövs inte i modellen. Du tar bort dem genom att markera och högerklicka på fältet och klicka på Ta bort .

Skapa en beräknad kolumn

I Power Pivot kan du lägga till beräkningar med hjälp av DAX (Data Analysis Expressions). I den här uppgiften ska du beräkna total vinst och lägga till en beräknad kolumn som refererar datavärden från andra tabeller. Senare kommer du att lära dig att använda refererade kolumner för att förenkla modellen.

  1. Växla tillbaka till datavyn i Power Pivot-fönstret.

  2. Byt namn på tabellen Tabell_Produktkategorier accdb till något enklare. Du kommer att referera tabellen i de nästkommande stegen och ett kortare namn gör beräkningarna lättare att läsa. Högerklicka på tabellnamnet, klicka på Byt namn, skriv Produktkategorier och tryck på Retur.

  3. Markera tabellen Försäljningsinfo.

  4. Klicka på Design > Kolumner > Lägg till.

  5. Skriv följande formel i formelfältet ovanför tabellen. Funktionen Komplettera automatiskt hjälper till att skriva in hela kvalificerade namn för kolumner och tabeller och listar funktionerna som finns tillgängliga. Det går också bra att klicka på en kolumn så läggs kolumnnamnet till i formeln med Power Pivot.

    = [Försäljningsbelopp] - [TotalKostnad] - [Returbelopp]

  6. Tryck på Retur när du är färdig och vill godkänna den formel du har skapat.

    Värden fylls i för alla rader i den beräknade kolumnen. Om du bläddrar ned i tabellen ser du att rader kan ha olika värden för den här kolumnen, baserat på de data som finns på varje rad.

  7. Byt namn på kolumnen genom att högerklicka på BeräknadKolumn1 och markera Byt namn på kolumn. Skriv Vinst och tryck på Retur.

  8. Markera tabellen DimProduct.

  9. Klicka på Design > Kolumner > Lägg till.

  10. Skriv följande formel i formelfältet ovanför tabellen.

    = RELATED(ProduktKategorier[ProduktkategoriNamn])

    Funktionen RELATED returnerar ett värde från en relaterad tabell. I det här fallet innehåller tabellen Produktkategorier namnen på produktkategorier, som kan vara bra att ha i tabellen NedtonadProdukt när du ska bygga en hierarki som innehåller kategoriinformation. Mer information om funktionen finns i Funktionen RELATED (DAX).

  11. Tryck på retur när du är färdig och vill godkänna den formel du har skapat.

    Värden fylls i för alla rader i den beräknade kolumnen. Om du bläddrar ned i tabellen ser du att varje rad nu har ett produktkategorinamn.

  12. Byt namn på kolumnen genom att högerklicka på BeräknadKolumn1 och markera Byt namn på kolumn. Skriv Produktkategori och tryck på Retur.

  13. Klicka på Design > Kolumner > Lägg till.

  14. Skriv följande formel i formelfältet ovanför tabellen och tryck på Retur när du vill godkänna formeln.

    = RELATED(NedtonadUnderkategoriProdukt[UnderkategorinamnProdukt])

  15. Byt namn på kolumnen genom att högerklicka på BeräknadKolumn1 och markera Byt namn på kolumn. Skriv UnderkategoriProdukt och tryck på Retur.

Skapa en hierarki

De flesta modeller innehåller data som är hierarkiska. Vanliga exempel är kalenderdata, geografiska data och produktkategorier. Det är praktiskt att skapa hierarkier eftersom du drar ett objekt (hierarkin) till en rapport i stället för att behöva sammanställa och ordna samma fält om och om igen.

  1. Växla till diagramvyn i Power Pivot. Expandera tabellen DimDate så att det blir lättare att se alla fälten.

  2. Håll ned Ctrl och klicka på kolumnerna CalendarYear, CalendarQuarter och CalendarMonth (du måste rulla ned i tabellen).

  3. Högerklicka på någon av de tre markerade kolumnerna och klicka på Skapa hierarki. En överordnad hierarkinod, Hierarki 1, skapas längst ned i tabellen, och de markerade kolumnerna kopieras och placeras under hierarkin som underordnade noder.

  4. Skriv Dates som namn på den nya hierarkin.

  5. Lägg till kolumnen FullständigtDatum i hierarkin. Högerklicka på FullständigtDatum och markera Lägg till i hierarki. Välj Datum. FullständigtDatum innehåller ett fullständigt datum med år, månad och dag. Kontrollera att FullständigtDatum visas längst ned i hierarkin. Nu har du en hierarki i flera nivåer som innehåller år, kvartal, månad och enskilda kalenderdagar.

  6. Peka på tabellen DimProduct i diagramvyn och klicka på knappen Create Hierarchy i tabellrubriken. En tom överordnad nivå visas längst ned i tabellen.

  7. Skriv Product Categories som namn på den nya hierarkin.

  8. Skapa hierarkiska underordnade noder genom att dra Produktkategori och UnderkategoriProdukt till hierarkin.

  9. Högerklicka på ProductName och välj Lägg till i hierarki. Välj Product Categories.

Nu när du har lärt dig hur du skapar en hierarki på ett par olika sätt är det dags att använda dem i pivottabellen.

  1. Gå tillbaka till Excel.

  2. Ta bort fälten i området Rader i Blad1 (bladet som innehåller pivottabellen).

  3. Ersätt dem med den nya Product Categories-hierarkin i DimProduct.

  4. Ersätt också Kalenderår i området Kolumner med Datums-hierarkin i NedtonatDatum.

När du nu utforskar dina data är det lätt att se fördelarna med hierarkierna. Du kan styra hur det tillgängliga utrymmet används genom att expandera och stänga olika områden i pivottabellen oberoende av varandra. Genom att lägga till en enskild hierarki i både Rader och Kolumner får du dessutom åtkomst till en praktisk detaljvy, utan att du behöver stapla flera fält för att åstadkomma ett liknande resultat.

Dölja kolumner

Nu när du har skapat en hierarki med produktkategorier och lagt till den i DimProduct behöver du inte längre DimProductCategory eller DimProductSubcategory i fältlistan för pivottabellen. I den här uppgiften lär du dig hur du döljer onödiga tabeller och kolumner som tar upp plats i pivottabellens fältlista. Genom att dölja tabellerna och kolumnerna kan du förbättra rapportmiljön utan att påverka modellen som hanterar datarelationerna och databeräkningarna.

Din webbläsare har inte stöd för video. Installera Microsoft Silverlight, Adobe Flash Player eller Internet Explorer 9.

Du kan dölja enskilda kolumner, ett intervall av kolumner eller en hel tabell. Tabell- och kolumnnamn tonas ned för att indikera att de är dolda för rapportklienter som använder modellen. Dolda kolumner är nedtonade i modellen, vilket anger deras status, men de är fortfarande synliga i datavyn så att du kan fortsätta arbeta med dem.

  1. Kontrollera att datavyn är vald i Power Pivot.

  2. Högerklicka på DimProductSubcategory och välj Dölj för klientverktyg på flikarna längst ned.

  3. Gör samma sak med ProductCategories.

  4. Öppna DimProduct.

  5. Högerklicka på följande kolumner och klicka på Dölj för klientverktyg:

    • ProductKey

    • ProductLabel

    • ProductSubcategory

  6. Markera flera intilliggande kolumner. Börja med KlassID och fortsätt till UnderkategoriProdukt sist. Högerklicka och dölj dem.

  7. Upprepa samma steg för andra tabeller och ta bort ID:n, nycklar eller annan information som inte behövs i rapporten.

Växla tillbaka till Excel och Blad 1 med fältlistan för pivottabellen och granska resultatet. Antalet tabeller minskas och NedtonadProdukt innehåller bara de objekt som det är mer sannolikt att du kommer att använda när du analyserar försäljningsuppgifterna.

Skapa en Power View-rapport

Pivottabellrapporter är inte den enda rapporttyp som kan dra fördel av en datamodell. Du kan använda samma modell som du nyss skapat och lägga till ett Power View-blad för att prova några av de tillgängliga layouterna.

  1. Klicka på Infoga > Power View i Excel.

    Obs!:  Om det är första gången du använder Power View på den här datorn uppmanas du att aktivera tilläggsprogrammet och installera Silverlight först.

  2. Klicka på pilen bredvid tabellen Försäljningsinfo i Power View-fälten och klicka på Försäljningsbelopp.

  3. Expandera Geografi-tabellen och klicka på RegionLandNamn.

  4. Klicka på Karta i menyfliksområdet.

  5. En kartrapport visas. Ändra rapportens storlek genom att dra ett hörn. Blå cirklar i olika storlekar på kartan representerar försäljningsresultat för olika länder eller regioner.

Optimera för Power View-rapportering

Genom att göra ett par små förändringar i modellen kan du få mer intuitiva svar när du skapar en Power View-rapport. I den här uppgiften lägger du till webbadresser till flera tillverkare och kategoriserar informationen som en URL så att adressen visas som en länk.

Först ska du lägga till URL-adresser i arbetsboken.

  1. Öppna ett nytt blad i Excel och kopiera följande värden:

URLTillverkare

IDTillverkare

http://www.contoso.com

Contoso, LTD

http://www.adventure-works.com

Adventure Works

http://www.fabrikam.com

Fabrikam, Inc.

  1. Formatera cellerna som en tabell och ge tabellen namnet URL.

  2. Skapa en relation mellan URL och tabellen med tillverkarnamn, NedtonadProdukt:

    1. Klicka på Data > Relationer. Dialogrutan Skapa relation visas.

    2. Klicka på Ny.

    3. Välj NedtonadProdukt i Tabell.

    4. Välj Tillverkare i Kolumn.

    5. Välj URL i Relaterad tabell.

    6. Välj IDTillverkare i Relaterad kolumn (primär).

Jämför resultaten före och efter genom att starta en ny Power View-rapport och lägga till Försäljningsinfo | Försäljningsbelopp, NedtonadProdukt | Tillverkare, och URL | URLTillverkare i en rapport. Lägg märke till att URL-adresserna visas som statisk text.

För att en URL ska visas som en aktiv länk krävs kategorisering. Du använder Power Pivot för att kategorisera kolumner.

  1. Öppna URL i .Power Pivot

  2. Välj URLTillverkare.

  3. Klicka på Avancerat > Rapportegenskaper > Datakategori: Ej kategoriserat.

  4. Klicka på nedpilen.

  5. Välj Webb-URL.

  6. Klicka på Infoga > Power View i Excel.

  7. Välj Försäljningsinfo | Försäljningsbelopp, NedtonadProdukt | Tillverkare och URL | URLTillverkare i Power View-fälten. Nu visas webbadresserna som riktiga länkar.

Du kan också optimera Power View genom att definiera en standardfältuppsättning för varje tabell och ange egenskaper som bestämmer om rader med upprepade data aggregeras eller visas separat. Mer information finns i Konfigurera en standardfältuppsättning för Power View-rapporter och Konfigurera tabellbeteendeegenskaper för Power View-rapporter.

Skapa beräknade fält

I den andra uppgiften, Utforska data med en pivottabell, klickade du på fältet Försäljningsbelopp i fältlistan i pivottabellen. Eftersom Försäljningsbelopp är en numerisk kolumn placerades den automatiskt i området Värden i pivottabellen. Sedan kunde summan av Försäljningsbelopp beräknas för försäljningsmängder för vilket filter som helst. I det här exemplet fanns det till en början inget filter, men sedan lades Kalenderår, UnderkategorinamnProdukt och Företagsnamn till.

Det du egentligen gjorde var att skapa ett implicit beräknat fält, som gjorde det enkelt att analysera och jämföra försäljningsmängder från tabellen Försäljningsinfo med andra fält som t. ex. produktkategori, region och datum. Implicita beräknade fält skapas i Excel när du drar ett fält till området Värden eller klickar på ett numeriskt fält, som du gjorde med Försäljningsbelopp. Implicita beräknade fält är formler som skapas automatiskt och använder standardmängdfunktioner som SUM, COUNT och AVERAGE.

Det finns fler typer av beräknade fält. I Power Pivot kan du skapa explicita beräknade fält. Till skillnad från ett implicit beräknat fält som bara kan användas i den pivottabell där de skapas, kan ett explicit beräknat fält användas i alla pivottabeller i arbetsboken eller alla rapporter som bygger på datamodellen. Med explicita beräknade fält som skapas i Power Pivot kan du använda autosummeringsfunktionen för att automatiskt skapa beräknade fält med standardmängder, eller skapa egna med hjälp av en formel som skapas med DAX (Data Analysis Expressions).

Som du kan förstå kan du analysera data på mycket kraftfulla sätt med hjälp av beräknade fält, så nu är det dags att du lär dig hur du skapar dem.

Det är enkelt att skapa beräknade fält i Power Pivot med autosummeringsfunktionen.

  1. Klicka på kolumnen Vinst i tabellen Försäljningsinfo.

  2. Klicka på Beräkningar > Autosummering. Nu visas ett nytt beräknat fält, Summa av vinst, som skapades automatiskt i cellen i beräkningsområdet under kolumnen Vinst.

  3. Klicka på Summa av vinst i Försäljningsinfo i Blad1 i Excel.

Nu är det klart! Det var allt som behövdes för att skapa ett beräknat fält med hjälp av en standardmängd i Power Pivot. Du har på bara ett par minuter skapat ett beräknat fält med SUM, Summa av vinst, och lagt till det i pivottabellen så att du enkelt kan analysera vinster beroende på vilka filter som används. I det här fallet ser du Summa av vinst filtrerad genom hierarkierna Produktkategori och Datum.

Men vad händer om du behöver göra en mer detaljerad analys, t. ex. antalet försäljningar för en viss kanal, produkt eller kategori? I så fall behöver du skapa ett annat beräknat fält som räknar antalet rader, en för varje försäljning i tabellen Försäljningsinfo, beroende på vilka filter som används.

  1. Klicka på kolumnen Försäljningsnyckel i tabellen Försäljningsinfo.

  2. Klicka på nedpilen vid Autosummering > Antal i Beräkningar.

  3. Byt namn på det nya beräknade fältet genom att högerklicka på Antal Försäljningsnyckel i beräkningsområdet och sedan klicka på Byt namn. Skriv Antal och tryck på Retur.

  4. Klicka på Antal i Försäljningsinfo, i fältlistan på Blad1 i Excel.

Lägg märke till att en ny kolumn, Antal, har lagts till i pivottabellen och visar antal försäljningar beroende på vilka filter som används. Precis som för det beräknade fältet Summan av vinst, visas Antal filtrerat genom hierarkierna Produktkategori och Datum.

Nu skapar vi ett nytt fält. Den här gången ska du skapa ett beräknat fält som beräknar procentandelen av den totala försäljningen för ett visst sammanhang eller filter. Men i stället för att som tidigare använda autosummeringsfunktionen ska du ange en formel manuellt.

  1. Klicka på en tom cell i beräkningsområdet i tabellen Försäljningsinfo. Tips: cellen längst upp till vänster är ett bra ställe att placera beräknade fält på. Där är de lätta att hitta. Du kan flytta runt beräknade fält i beräkningsområdet.

  2. Skapa följande formel i formelfältet genom att skriva och använda IntelliSense: Percentage of All Products:=[Count]/CALCULATE([Count], ALL(DimProduct))

  3. Godkänn formeln genom att trycka på RETUR.

  4. Klicka på Procent av alla produkter i Försäljningsinfo i Blad1 i Excel.

  5. Markera kolumnerna Procent av alla produkter i pivottabellen.

  6. Klicka på Tal > Procent på fliken Start. Formatera varje ny kolumn med två decimaler.

Det nya beräknade fältet beräknar procentandelen av den totala försäljningen för ett visst filtersammanhang. I det här fallet är filtersammanhanget fortfarande hierarkierna Produktkategori och Datum. Till exempel kan du se att procentandelen för datorer av den totala produktförsäljningen har ökat genom åren.

Om du känner till hur du skapar Excel-formler, är det relativt enkelt att skapa formler för både beräknade kolumner och fält. Vare sig du är bekant med Excel-formler eller inte, kan du lära dig grunderna i DAX-formler genom att gå igenom uppgifterna i Kom igång: Lär dig grundläggande DAX på 30 minuter.

Spara arbetet

Spara arbetsboken så att du kan använda den med andra guider eller om du vill fortsätta att öva.

Fortsättning

Även om det är enkelt att importera data från Excel är det oftast snabbare och mer effektivt att importera med hjälp av Power Pivot-tilläggsprogrammet. Du kan filtrera de data som du importerar, utesluta kolumner du inte behöver och välja att hämta data med ett frågeverktyg eller ett frågekommando. I nästa steg får du lära dig mer om dessa alternativa metoder: Hämta data från en datafeed i Power Pivot och Importera data från Analysis Services eller Power Pivot.

Power View-rapporteringen har utformats för att fungera med datamodeller liknande den som du nyss skapat. Läs vidare och lär dig mer om de avancerade datavisualiseringarna som är tillgängliga i Power View i Excel: Starta Power View i Excel 2013 och Power View: Utforska, visualisera och presentera data.

Prova att utöka datamodellen så att dina Power View-rapporter blir ännu bättre med hjälp av Självstudiekurs: Optimera datamodeller för Power View-rapporter

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×