Sammanfattning av metoder för att addera och räkna Excel-data

Sammanfattning av metoder för att addera och räkna Excel-data

Skillnaden mellan att räkna och summera
Att summera (addera värden) är en viktig del av en dataanalys, oavsett om du beräknar delsummor för försäljningen i region Nordväst eller om du gör en löpande summering av veckans kvitton. Du kan summera data på flera sätt i Excel.

Den här artikeln innehåller en fullständig sammanfattning av de olika metoderna, stödinformation som hjälper dig att snabbt välja vilken teknik du ska använda, samt länkar till ingående artiklar.

Summera ska inte förväxlas med att räkna. Mer information om hur du räknar antalet celler, kolumner eller rader med data finns i avsnittet Räkna celler, rader eller kolumner.

I den här artikeln

Enkel addition och subtraktion

Du kan addera och subtrahera tal med hjälp av en enkel formel, genom att klicka på en knapp eller med hjälp av en kalkylbladsfunktion.

Summera värdena i en cell med hjälp av en enkel formel

Om du bara behöver ett snabbt resultat kan du använda Excel som en miniräknare. Det gör du genom att använda den aritmetiska operatorn + (plustecken). Om du exempelvis anger formeln =5+10 i en cell visar Excel 15 som resultat.

Mer information om hur du använder aritmetiska operatorer i en formel finns i artikeln Använda Excel som kalkylator.

Överst på sidan

Subtrahera värdena i en cell med hjälp av en enkel formel

Det gör du genom att använda den aritmetiska operatorn - (minustecken). Till exempel visar formeln =12-9 resultatet 3.

Mer information om hur du använder aritmetiska operatorer i en formel finns i artikeln Använda Excel som kalkylator.

Överst på sidan

Summera värdena i en kolumn eller rad med hjälp av en knapp

Du kan använda Autosumma för att snabbt summera ett område med tal i en kolumn eller rad. Klicka på en tom cell nedanför en kolumn med tal eller till höger om en rad med tal och klicka sedan på Autosumma. Excel markerar det som verkar det mest troliga dataområdet. Klicka på Autosumma igen för att acceptera det område som Excel markerar, eller markera ett eget område och klicka sedan på Autosumma.

Använda Autosumma för att lägga till en rad med data

Mer information om hur du använder Autosumma finns i artikeln Använda Excel som kalkylator.

Överst på sidan

Summera värdena i ett område med hjälp av en funktion

Funktionen SUMMA är användbar om du vill addera eller subtrahera värdena från olika områden eller kombinera numeriska värden med områden med tal. Använd funktionen SUMMA när du vill lägga till alla argument som du anger inom inledande och avslutande parenteser. Ett argument kan vara ett område, en cellreferens eller ett positivt eller negativt numeriskt värde.

Du skapar en enkel formel genom att skriva =SUMMA i en cell, följt av en inledande parentes. Skriv ett eller flera tal, cellreferenser eller cellområden, avgränsade med kommatecken. Skriv sedan en avslutande parentes och visa resultatet genom att trycka på RETUR. Du kan också använda musen för att markera celler som innehåller data som du vill summera.

1

2

3

A

Närvaro

4823

12335

Om vi utgår från informationen i föregående tabell använder alla formler nedan funktionen SUMMA för att returnera samma värde (17158):

  • =SUMMA(4823;12335)

  • =SUMMA(A2,A3)

  • =SUMMA(A2:A3)

  • =SUMMA(A2;12335)

Följande bild illustrerar formeln som använder funktionen SUMMA för att addera värdet i cell A2 med 12335. Under formeln visas ett skärmtips som förklarar hur du använder funktionen SUMMA.

Addera en cell och ett värde med funktionen SUMMA

Meddelanden: 

  • Excel har ingen funktion för SUBTRAHERA. För att subtrahera värden med hjälp av en funktion använder du negativa numeriska värden med funktionen SUMMA. Exempel: Formeln =SUMMA(30;A3;-15;-B6) adderar 30 och värdet i cell A3, subtraherar 15 och subtraherar även värdet i cell B6.

  • Du kan lägga till upp till 255 numeriska värden eller referenser till celler eller cellområden, i valfri kombination, som argument i funktionen SUMMA.

Mer information finns i artikeln om funktionen SUMMA.

Överst på sidan

Subtrahera värdena i ett område med hjälp av en funktion

Använd funktionen SUMMA om du vill subtrahera tal genom att skriva talen som ska subtraheras som negativa tal i formeln.

1

2

3

A

Närvaro

29072

12335

Om vi utgår från informationen i föregående tabell använder alla formler nedan funktionen SUMMA för att returnera samma värde (16737):

  • =SUMMA(29072;-12335)

  • =SUMMA(A2;-A3)

  • =SUMMA(A2;-12335)

  • =SUMMA(A2;(-1*(A3)))

Överst på sidan

Summera data genom att gruppera och pivotera

Du kan använda en disposition eller en pivottabellrapport om du vill gruppera och summera data.

Summera värdena i en kolumn med hjälp av en disposition

Om dina data är ordnade i en lista och om de kan grupperas logiskt efter kolumnvärden, kan du gruppera och sammanfatta dem genom att skapa en disposition. Med en disposition kan du sammanfatta data genom att infoga delsummor och totalsummor. Anta att du har följande försäljningssiffror, ordnade efter region och månad.

1

2

3

4

5

6

7

A

B

C

Region

Månad

Försäljning

Öst

jan

18 000 kr

Öst

feb

23 000 kr

Öst

mar

19 000 kr

Väst

jan

17 000 kr

Väst

feb

27 000 kr

Väst

mar

21 000 kr

Följande bild illustrerar en disposition med delsummor, grupperade efter region och en totalsumma.

Disposition med delsummor och totalsumma

Använd kommandot Delsumma (fliken Data, gruppen Disposition) om du vill skapa en disposition, delsummor och en totalsumma.

Våra ursprungliga data innehåller tre rader med data för region Öst och tre rader med data för region Väst (rad 2 till och med 7). Observera att kommandot Delsumma infogade totalsumman för Öst på rad 5 mellan den sista raden med data för Öst och den första raden med data för Väst.

Om du klickar på cell A4 och sedan på kommandot Delsumma skapar Excel en disposition och infogar rader för Summa Öst, Summa Väst och Totalsumma och fyller cellerna i kolumnen Försäljning med dessa summor.

Mer information finns i följande artiklar:

Skapa en disposition för en lista med data i ett kalkylblad

Infoga delsummor i en lista med data i ett kalkylblad

Överst på sidan

Summera värdena i en lista eller i en Excel-tabellkolumn med hjälp av en funktion

Ett mer flexibelt alternativ till kommandot Delsumma är funktionen DELSUMMA som du kan använda för att beräkna delsummor och totalsummor i listor eller Excel-tabeller som innehåller dolda rader eller kolumner. I funktionen DELSUMMA anger du ett argument som antingen tar med eller utelämnar dolda värden.

Obs!: Funktionen DELSUMMA kan styra huruvida dolda rader tas med i resultatet och ignorerar alltid rader som har filtrerats.

Anta till exempel att du vill beräkna delsummor och en totalsumma för data i cell C2 till och med C7, men att du vill ignorera dolda data på rad 3 och rad 6. Funktionen som du använder ser ut så här:

= DELSUMMA( 109;C2:C7)

Det första argumentet (109) anger att du vill summera värdena i området och ignorera dolda värden. Om du vill ta med de dolda värdena använder du i stället 9 som det första argumentet.

Mer detaljerad information finns i artiklarna funktionen DELSUMMA och Summera data i en Excel-tabell.

Överst på sidan

Summera data och titta på dem från olika perspektiv

Om ett kalkylblad innehåller flera hundra eller till och med flera tusen rader med liknande data kan det vara svårt att dra slutsatser från talen. Du kan skapa en pivottabellrapport i Excel från dessa data som visar delsummor och totalsummor och som kan sammanfatta data utifrån kategorier som du anger.

Du kan snabbt skapa en pivottabell genom att markera en cell i ett område med data eller en Excel-tabell och sedan klicka på Pivottabell i gruppen Tabeller på fliken Infoga.

Följande exempel med många rader försäljningsdata (det finns egentligen 40 rader, men endast några av dem visas i bilden) illustrerar vad en pivottabell kan göra. Observera att dessa data inte är sammanfattade och att de inte har delsummor eller någon totalsumma.

Data som används i en pivottabellrapport

En pivottabellrapport baserad på samma data med delsummor, totalsummor och en lättöverskådlig sammanfattning.

Summerade data i en pivottabellrapport

Du kan behöva förbereda dina data och känna till vissa begrepp innan du skapar och arbetar med pivottabeller.

Detaljerad information som hjälper dig att komma igång finns i följande artiklar:

Beräkna värden i en pivottabellrapport

Fält för del- och totalsummor i en pivottabellrapport

Överst på sidan

Summera data baserat på ett eller flera villkor

Genom att använda kalkylbladsfunktioner kan du tillämpa villkor (även kallade kriterier) så att endast de data som uppfyller de villkor du angett summeras.

Summera värdena i ett område baserat på ett enstaka villkor med hjälp av en enskild funktion eller en kombination av funktioner

Använd funktionen SUMMA.OM eller kapsla funktionen SUMMA inuti funktionen OM.

Du kan summera tal baserat på ett enstaka villkor med hjälp av funktionen SUMMA.OM eller med en kombination av funktionen SUMMA och funktionen OM.

Formeln =SUMMA.OM(A2:A6,">20") summerar exempelvis bara talen i området från A2 till och med A6 som är större än 20.

Obs!: Följande information är en aning teknisk, men väl värd att lära sig.

Om funktionen SUMMA.OM inte fanns skulle du ändå kunna få samma resultat genom att kombinera funktionen OM och SUMMA. Att kombinera funktioner på det här sättet kallas ofta för att "kapsla" eftersom en funktion används i en annan funktion.

Om du vill skapa en formel som efterliknar funktionen SUMMA.OM anger du en formel som behandlar dataområdet A2 till och med A6 som en matris, vilket innebär att området betraktas som en enda enhet med fem celler.

Formeln ser ut så här: {=SUMMA(OM(A2:A6>20;A2:A6))}. Klammerparenteserna som omger formeln anger att det är en matrisformel. En matrisformel kräver speciell behandling: I stället för att skriva in klammerparenteserna själv måste du trycka på CTRL+SKIFT+RETUR. När du gör det infogas klammerparenteserna runt formeln =SUMMA(OM(A2:A6>20;A2:A6)). Om du skriver klammerparenteserna själv skapas ingen matrisformel.

Prova själv!    

Kopiera alla data i följande tabell till ett kalkylblad i cell A1. När du har klistrat in alla data ser du att cell A10 innehåller ett #VÄRDEFEL!-fel. Det betyder att du måste konvertera cell A10 till en matrisformel. Det gör du genom att trycka på F2 och sedan på CTRL+SKIFT+RETUR. Excel visar resultatet (65) i cell A8 och A10.

Kopiera exempeldata från kalkylblad

  • Skapa en tom arbetsbok eller ett tomt kalkylblad.

  • Markera exemplet i hjälpavsnittet.

    Obs!: Markera inte rad- eller kolumnrubrikerna.

    Markera ett exempel i hjälpen
    Markera ett exempel i hjälpen
  • Tryck på Ctrl+C.

  • Markera cell A1 i kalkylbladet och tryck på Ctrl+V.

  • Tryck på CTRL+` (grav accent) för att växla mellan att visa resultaten och formlerna som ger resultaten.

1

2

3

4

5

6

7

8

9

10

A

Vikt

18

29

36

11

16

Använda funktionen SUMMA.OM

=SUMMA.OM(A2:A6;">20")

Använda funktionerna SUMMA och OM

=SUMMA(OM(A2:A6>20;A2:A6))

I Knowledge Base-artikeln XL: When to Use SUM(IF()) instead of CountBlank() (När ska jag använda SUMMA(OM)) i stället för ANTAL.TOMMA()?) beskriver mer utförligt när du bör använda funktionen SUMMA.OM.

Överst på sidan

Summera värdena i en kolumn baserat på ett eller flera villkor med hjälp av en funktion

Använd funktionen DSUMMA om du vill summera alla tal i ett fält (kolumn) med poster i en lista eller databas som matchar de villkor (även kallade kriterier) som du anger.

Du kan också använda funktionen DSUMMA om du har en kolumnlista och du tycker att det är lättare att definiera villkor i ett separat cellområde i stället för att använda en kapslad funktion.

Mer information finns i artikeln om funktionen DSUMMA.

Överst på sidan

Summera värdena i ett område baserat på flera villkor med hjälp av en guide (endast för Excel 2007)

Du kan använda Villkorssummeringsguiden (Formler > Lösningar > Villkorlig summering) för att summera värden som baseras på flera olika villkor.

Viktigt!: Villkorssummeringsguiden är endast tillgänglig i Excel 2007 och tidigare versioner. Mer information finns i Vad har hänt med tillägget Villkorssummeringsguiden?.

Om detta kommando inte är tillgängligt (gruppen Lösningar kanske inte heller visas), installerar och aktiverar du tilläggsmakrot Analysis ToolPak.

Läsa in Analysis Toolpak

Klicka på Microsoft Office-knappen Bild av Office-knappen , klicka på Excel-alternativ och klicka sedan på kategorin Tilläggsmakron.

  1. Klicka på Excel-tillägg i listan Hantera och klicka på OK.

  2. Markera rutan Analysis ToolPak i listan Tillgängliga tilläggsmakron, och klicka sedan på OK.

  3. Om guiden visas i listan Inaktiva programtillägg, väljer du guiden och klickar sedan på Kör för att göra den aktiv.

  4. Om det behövs följer du anvisningarna i installationsprogrammet.

För att använda Villkorssummeringsguiden väljer du dataområdet och klickar på kommandot Villkorlig summering (gruppen Lösningar på fliken Formler). Följ steg 1 till 4 för att slutföra guiden. Följande illustration visar steg 2 i guiden där det finns ett villkor: De värden som ska summeras måste vara över 100.

Villkorssummeringsguiden: Steg 2 av 4

Överst på sidan

Summera värdena i ett område baserat på flera villkor med hjälp av en enskild funktion eller en kombination av funktioner

Använd funktionen SUMMA.OMF. Ange det område som du vill summera, ett område som innehåller villkor, och villkoren som tillämpas på villkorsområdet. Alternativt kan du kapsla funktionerna SUMMA och OM.

Mer information finns i artikeln om funktionen SUMMA.OMF.

Se även följande Knowledge Base-artiklar för ytterligare information:

Överst på sidan

Summera kvadrat- och matrisvärden

Du kan använda kalkylbladsfunktioner för att summera värden i två eller fler kolumner som relaterar till varandra. Den här typen av åtgärder kan vara så enkel som att fastställa ett viktat medelvärde (se exemplet nedan som beräknar ett medelbetyg) eller involvera komplexa statistiska och tekniska beräkningar.

Summera produkten av motsvarande värden i en eller flera matriser

Använd funktionen PRODUKTSUMMA. Du kan till exempel beräkna en elevs medelbetyg med hjälp av funktionen PRODUKTSUMMA och dividera resultatet med antalet poäng, som du ser i följande bild.

Multiplikation av motsvarande värden i två matriser

Formeln =PRODUKTSUMMA(A2:A6;B2:B6)/SUMMA(B2:B6) multiplicerar betygen för varje klass med antalet poäng, summerar dessa produkter (61.3), dividerar summan med totalt antal poäng (18) och fastställer medelbetyget (3,41). Den här typen av beräkning kallas också för ett viktat medelvärde.

Du kan också använda funktionen PRODUKTSUMMA i mer avancerade matematiska operationer genom att multiplicera flera matriser.

Funktionen PRODUKTSUMMA är enkel att använda med matriser som har samma dimensioner, men du kan också använda funktionen SUMMA i en matrisformel om du behöver mer flexibilitet.

Mer detaljerad information finns i artikeln om funktionen PRODUKTSUMMA.

De följande fyra funktionerna används vanligtvis endast i avancerade statistiska program eller komplexa matematiska program. Därför ges bara en kort beskrivning. Om du vill ha mer information klickar du på namnet på funktionen så kommer du direkt till referensavsnittet.

  • Funktionen KVADRATSUMMA  Returnerar summan av kvadraterna för en lista med tal eller värden i ett område. Till exempel returnerar KVADRATSUMMA(2;3) 13.

  • Funktionen SUMMAX2PY2  Adderar summan av kvadraterna för motsvarande värden i två matriser.

  • Funktionen SUMMAX2MY2  Returnerar summan av differensen mellan kvadraterna för motsvarande värden i två matriser.

  • Funktionen SUMMAXMY2  Returnerar summan av kvadraten av skillnaden mellan motsvarande värden i två matriser.

Överst på sidan

Specialfall (löpande summa, unika värden)

Du kan använda kalkylbladsfunktioner för att skapa summor som uppdateras automatiskt när du lägger till mer data i ett område eller en tabell, eller för att bara addera unika värden i ett område eller en tabell.

Skapa en löpande summa med hjälp av en funktion

Använd funktionen SUMMA. Skapa exempelvis kolumnrubriker i ett kalkylblad med namnen Insättningar, Uttag och Saldo.

  1. I den första cellen, under kolumnen Saldo, anger du ditt ingående saldo.

  2. I cellen direkt nedanför ditt saldo (i vårt exempel C3) anger du en formel som summerar värdet från kolumnen Insättningar på samma rad och subtraherar värdet från kolumnen Uttag (=SUMMA(C2;A3;-B3).

  3. Dra formeln nedåt till nya rader som du lägger till. I följande exempel dras den till rad 4.

    Detta blir enklare att förstå om du kopierar exemplet till ett kalkylblad.

    Så här kopierar du ett exempel

    • Skapa en tom arbetsbok eller ett tomt kalkylblad.

    • Markera exemplet i hjälpavsnittet.

      Obs!: Markera inte rad- eller kolumnrubrikerna.

      Markera ett exempel i hjälpen

      Markera ett exempel i hjälpen

    • Tryck på Ctrl+C.

    • Markera cell A1 i kalkylbladet och tryck på Ctrl+V.

    • Om du vill växla mellan att visa resultatet och de formler som returnerar resultatet trycker du på Ctrl+§. Du kan också gå till fliken Formler och klicka på Visa formler i gruppen Formelgranskning.

1

2

3

4

A

B

C

Insättningar

Uttag

Saldo

500

1000

625

=SUMMA(C2;A3;-B3)

1000

740

=SUMMA(C3;A4;-B4)

Du kan använda en löpande balans på samma sätt som ett checkregister för att se hur värdena för poster i celler ökar eller minskar i takt med att du lägger till nya poster och värden över tid.

Mer information finns i artikeln Beräkna en löpande balans.

Överst på sidan

Summera de unika värdena i ett område med hjälp av en sammansatt formel

Lägg till en lista med värden som innehåller dubbletter i en kolumn och använd sedan en kombination av funktionerna SUMMA, OM och FREKVENS om du bara vill addera unika värden i intervallet.

Överst på sidan

Ta med värden från andra kalkylblad eller arbetsböcker i en formel

Du kan addera och subtrahera celler eller områden med data från andra kalkylblad eller arbetsböcker i en formel genom att lägga till en referens till dem. Om du vill referera till en cell eller ett område i ett annat kalkylblad eller en annan arbetsbok följer du instruktionerna i följande tabell.

Om du vill referera till:

Skriver du:

Exempel:

En cell eller ett område i ett annat kalkylblad i samma arbetsbok

Namnet på kalkylbladet följt av ett utropstecken, följt av cellreferensen eller områdesnamnet.

Blad2!B2:B4
Blad3!Försäljningssiffror

En cell eller ett område i en annan arbetsbok som är öppen

Namnet på arbetsboken inom hakparenteser ([]) och namnet på kalkylbladet följt av ett utropstecken, följt av cellreferensen eller områdesnamnet.

[MinArbetsbok.xlsx]Blad1!A7

En cell eller ett område i en annan arbetsbok som inte är öppen

Arbetsbokens fullständiga sökväg inom hakparenteser ([]) och namnet på kalkylbladet följt av ett utropstecken, följt av cellreferensen eller områdesnamnet. Om den fullständiga sökvägen innehåller blanksteg omger du början av sökvägen och slutet av kalkylbladsnamnet med enkla citattecken (se exemplet).

['C:\Mina dokument\[MinArbetsbok.xlsx]Blad1'!A2:A5

Överst på sidan

Summera och subtrahera datum- och tidsvärden

Du kan använda datum- och tidsfunktioner och även enkel addition eller subtraktion för att beräkna förfluten tid, uppskattat slutdatum för projekt och mycket mer. Följande tabell innehåller några formler som beräknar förfluten tid och antal förflutna dagar. Observera att om du subtraherar ett datum eller klockslag som resulterar i ett negativt värde så visas ###-tecken i cellen som innehåller formeln.

Detta blir enklare att förstå om du kopierar exemplet till ett kalkylblad.

Så här kopierar du ett exempel

  • Skapa en tom arbetsbok eller ett tomt kalkylblad.

  • Markera exemplet i hjälpavsnittet.

    Obs!: Markera inte rad- eller kolumnrubrikerna.

    Markera ett exempel i hjälpen

    Markera ett exempel i hjälpen

  • Tryck på Ctrl+C.

  • Markera cell A1 i kalkylbladet och tryck på Ctrl+V.

  • Om du vill växla mellan att visa resultatet och de formler som returnerar resultatet trycker du på Ctrl+§. Du kan också gå till fliken Formler och klicka på Visa formler i gruppen Formelgranskning.

1

2

3

4

5

A

B

C

Starttid

Sluttid

Formel för förfluten tid

Beskrivning (resultat)

11:55:24 AM

2:48:13 PM

=B2-A2

Visar förfluten tid i timmar, minuter och sekunder. I det här fallet visar Excel resultatet (2:52:49 AM) i "AM"-format eftersom skillnaden är mindre än 12 timmar. Om skillnaden är 12 timmar eller mer visas "PM"-format.

Startdatum

Slutdatum

Formel för antal förflutna dagar

Beskrivning (resultat)

2008-05-28

2008-06-03

=B5-A5

Visar antal förflutna dagar som ett tal (6).

Var försiktig eftersom beräkningar med datum- och tidsvärden kan ge oväntade resultat.

Överst på sidan

Visa beräkningar i statusfältet i Excel

Du kan snabbt se summorna i celler som är markerade i ett kalkylblad genom att titta i statusfältet i Excel (statusfältet är placerat längst ned i dokumentfönstret).

När en eller flera celler är markerade visas information om data i cellerna i statusfältet i Excel. Om till exempel fyra celler i kalkylbladet är markerade, och de innehåller värdena 2, 3, en textsträng (till exempel "moln") och 4, kan samtliga av följande värden visas i statusfältet samtidigt: Medelvärde, Antal, Numeriskt antal, Min, Max och Summa. Högerklicka i statusfältet om du vill visa eller dölja något eller samtliga av dessa värden. Dessa värden visas i bilden nedan.

Statusfält med beräknade värden och antal markerade celler

Överst på sidan

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×