SUMMA.OMF (funktionen SUMMA.OMF)

SUMMA.OMF (funktionen SUMMA.OMF)

Funktionen SUMMA.OMF, en matematisk och trigonometrisk funktion, adderar alla argument som uppfyller flera villkor. Du kan till exempel använda SUMMA.OMF för att summera antalet återförsäljare i landet som (1) ligger i ett och samma postnummerområde och (2) vars vinster överskrider ett visst värde.

Din webbläsare har inte stöd för video. Installera Microsoft Silverlight, Adobe Flash Player eller Internet Explorer 9.

Det här videoklippet ingår i kursen Avancerade OM-funktioner.

Syntax

SUMMA.OMF(summaområde, villkorsområde1, villkor1, [villkorsområde2, villkor2], ...)

  • =SUMMA.OMF(A2:A9,B2:B9,"=A*",C2:C9,"Tom")

  • =SUMMA.OMF(A2:A9,B2:B9,"<>Bananer",C2:C9,"Tom")

Argumentnamn

Beskrivning

Summaområde    (obligatoriskt)

Det cellintervall som ska summeras.

Villkorsområde1    (obligatoriskt)

Det intervall som testas med Villkor1.

Villkorsområde1 och Villkor1 bilder ett sökpar där intervallet söks igenom efter specifika villkor. När poster har hittats i intervallet läggs motsvarande värden i Summaområde till.

Villkor1    (obligatoriskt)

Det villkor som anger vilka celler i Villkorsområde1 som ska adderas. Villkor kan till exempel anges som 32, ">32", B4, "äpplen" eller "32".

Villkorsområde2, villkor2, …    (valfritt)

Ytterligare områden och associerade villkor. Du kan ange upp till 127 områdes- och villkorspar.

Exempel

Om du vill använda dessa exempel i Excel kan du dra för att välja data i tabellen, högerklicka på markeringen och välja Kopiera. I ett nytt kalkylblad högerklickar du på cell A1 och väljer Matcha målformatering under Inklistringsalternativ.

Såld mängd

Produkt

Säljare

5

Äpplen

Tom

4

Äpplen

Sarah

15

Kronärtskockor

Tom

3

Kronärtskockor

Sarah

22

Bananer

Tom

12

Bananer

Sarah

10

Morötter

Tom

33

Morötter

Sarah

Formel

Beskrivning

=SUMMA.OMF(A2:A9, B2:B9, "=A*", C2:C9, "Tom")

Lägger till antalet produkter som börjar med A och såldes av Tom. Använder jokertecknet * i Villkor1, "=A*" för att söka efter matchande produktnamn i Villkorsområde1 B2:B9, och söker efter namnet "Tom" i Villkorsområde2 C2:C9. Sedan adderas talen i Summaområde A2:A9 som uppfyller båda villkoren. Resultatet är 20.

=SUMMA.OMF(A2:A9, B2:B9, "<>Bananer", C2:C9, "Tom")

Lägger till antalet produkter som inte är bananer och som säljs av Tom. Bananer utesluts med &lt;&gt; i Villkor1, " &lt; &gt;Bananer", och funktionen söker efter namnet "Tom" i Villkorsområde2 C2:C9. Sedan adderas talen i Summaområde A2:A9 som uppfyller båda villkoren. Resultatet är 30.

Vanliga problem

Problem

Beskrivning

0 (Noll) visas i stället för det förväntade resultatet.

Kontrollera att Villkor1,2 är inom citattecken om du testar för textvärden, t.ex. en persons namn.

Resultatet blir felaktigt om Summaområde har SANT eller FALSKT-värden.

SANT- och FALSKT-värden för Summaområde utvärderas på olika sätt, vilket kan ge oväntade resultat om de läggs till.

De celler i Summaområde som innehåller värdet SANT utvärderas till 1, och de som innehåller värdet FALSKT utvärderas till 0 (noll).

Metodtips

Gör du så här

Beskrivning

Använda jokertecken

Att använda jokertecken som frågetecken ( ?) och asterisk ( * ) i criteria1,2 kan hjälpa dig att hitta liknande matchningar men är inte exakt.

Ett frågetecken motsvarar valfritt enstaka tecken. En asterisk matchar en obestämd teckensekvens. Om du vill söka efter ett frågetecken eller en asterisk skriver du ett tilde ( ~) framför frågetecknet eller asterisken.

Exempel: =SUMMA.OMF(A2:A9, B2:B9, "=A*", C2:C9, "To?") lägger till alla instanser med namn som börjar med "To" och avslutas med en sista bokstav som kan variera.

Förstå skillnaden mellan SUMMA.OM och SUMMA.OMF.

Argumentens ordning är inte samma för SUMMA.OMF och SUMMA.OM. Detta gäller i synnerhet argumentet summaområde som är det första argumentet i SUMMA.OMF men det tredje argumentet i SUMMA.OM. Detta är en vanlig orsak till problem när de här funktionerna används.

Om du kopierar och redigerar de här funktionerna som liknar varandra måste du se till att placera argumenten i rätt ordning.

Använd samma antal rader och kolumner för områdesargument.

Argumentet Villkorsområde måste innehålla samma antal rader och kolumner som argumentet Summaområde.

Överst på sidan

Har du en specifik fråga om funktioner?

Ställ en fråga i Excel-communityforumet

Hjälp oss att göra Excel bättre

Har du förslag på hur vi kan förbättra nästa version av Excel? Titta i så fall på avsnitten i Excel User Voice.

Mer information finns i

Titta på en video om hur du använder avancerade OM-funktioner, som SUMMA.OMF

SUMMA.OM-funktionen lägger endast till de värden som uppfyller ett enda villkor

Funktionen KVADRATSUMMA summerar flera värden när de enskilda värdena har kvadrerats

Funktionen ANTAL.OM räknar endast de värden som uppfyller ett enda villkor

Funktionen ANTAL.OMF räknar endast de värden som uppfyller flera villkor

IFS-funktionen (Office 365, Excel 2016 och senare)

Översikt över formler i Excel

Så här undviker du felaktiga formler

Använd felkontroll om du vill hitta fel i formler

Matematiska och trigonometriska funktioner

Excel-funktioner (alfabetisk ordning)

Excel-funktioner (efter kategori)

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×