Så här korrigerar du felvärdet #VÄRDEFEL! i funktionen SUMMA.OM/SUMMA.OMF

Det här avsnittet innehåller vanliga orsaker till felvärdet #VÄRDEFEL! i funktionerna SUMMA.OM och SUMMA.OMF och hur du löser dem.

Problem: Formeln refererar till celler i en stängd arbetsbok

Om funktionerna SUMMA.OM/SUMMA.OMF refererar till en cell eller ett område i en stängd arbetsbok resulterar det i felvärdet #VÄRDEFEL!.

Obs! Det här är ett känt problem hos flera andra Excel-funktioner, till exempel ANTAL.OM, ANTAL.OMF, ANTAL.TOMMA för att nämna några. Se artikeln Funktionerna SUMMA.OM, SUMMA.OMF och ANTAL.TOMMA returnerar felvärdet #VÄRDEFEL! för mer information.

Lösning: Öppna arbetsboken som angetts i formeln och tryck på F9 för att uppdatera formeln.

Du kan också kringgå problemet genom att använda funktionerna SUMMA och OM tillsammans i en matrisformel. Se artikeln Funktionerna SUMMA.OMF, ANTAL.OMF och ANTAL.TOMMA returnerar felvärdet #VÄRDEFEL! för mer information.

Problem: Kriteriesträngen är längre än 255 tecken

Funktionerna SUMMA.OM/SUMMA.OMF returnerar felaktiga resultat om du försöker att matcha strängar som är längre än 255 tecken.

Lösning: Förkorta strängen om möjligt. Om du inte kan korta ned den använder du funktionen SAMMANFOGA eller et-tecknet (&) för att dela upp värdet i flera strängar. Till exempel:

=SUMMA.OM(B2:B12;"lång sträng"&"annan lång sträng")

Problem: I SUMMA.OMF är inte argumentet villkorsområde konsekvent med argumentet summaområde.

Områdesargumenten måste alltid vara desamma i SUMMA.OMF. Det betyder att argumenten villkorsområde och summaområde måste innehålla samma antal rader och kolumner.

I exemplet nedan ska formeln returnera summan av den dagliga försäljningen av äpplen i Bellevue. Argumentet summaområde (C2:C10) motsvarar dock inte samma antal rader och kolumner i argumenten villkorsområde (A2:A12 och B2:B12). Om du använder syntax =SUMMA.OMF (C2:C10;A2:A12; A14;B2:B12; B14) resulterar det i felvärdet #VÄRDEFEL!.

Felaktig formel är =SUMMA.OM(C2:C10;A2:A12;A14;B2:B12;B14) där C2:C10 måste vara C2:C12
I funktionen SUMMA.OMF måste villkorsområde stämma överens med summaområde

Lösning: Följ det här exemplet och ändra summaområde till C2:C12 och prova formeln igen.

Obs!:  SUMMA.OMF kan använda olika storleksområden.

Har du en specifik fråga om funktioner?

Ställ en fråga i Excel-communityforumet

Hjälp oss att göra Excel bättre

Har du förslag på hur vi kan förbättra nästa version av Excel? Titta i så fall på avsnitten i Excel User Voice.

Mer information finns i

Korrigera felvärdet #VÄRDEFEL!

Funktionen SUMMA.OM

Funktionen SUMMA.OMF

Videor om den avancerade OM-funktionen

Översikt över formler i Excel

Hur du undviker felaktiga formler

Använd felkontroll om du vill hitta fel i formler

Alla Excel-funktioner (alfabetisk ordning)

Alla Excel-funktioner (efter kategori)

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×