Så här korrigerar du felvärdet #VÄRDEFEL! i funktionen MEDEL eller SUMMA

Om MEDEL eller SUMMA refererar till celler som innehåller felvärdet #VÄRDEFEL! resulterar formlerna i felvärdet #VÄRDEFEL!.

Felvärdet #VÄRDEFEL! i MEDEL

För att förbise felvärdena skapar vi en formel som ignorerar fel i referensområdet när du beräknar medelvärdet med de återstående ”normala” värdena.

För att lösa det här problemet använder vi en kombination av MEDEL tillsammans med OM och ÄRFEL för att avgöra om det finns ett fel i det angivna området. Just detta scenario kräver en matrisformel:

=MEDEL(OM(ÄRFEL(B2:D2));"";B2:D2))

Obs!: Det här är en matrisformel som måste anges med CTRL+SKIFT+RETUR. Excel omges automatiskt av klammerparenteser {}. Om du försöker ange dem själv visar Excel formeln som text.

Matrisfunktion i MEDEL för att lösa felvärdet #VÄRDEFEL!

Obs!: Funktionen ovan fungerar inte bara för #VÄRDEFEL!, utan även för #SAKNAS!, #NULL, #DIVISION/0! och andra felvärden.

Du kan också använda SUMMA på samma sätt:

=SUMMA(OM(ÄRFEL(B2:D2);"";B2:D2))

Har du en specifik fråga om funktioner?

Ställ en fråga i Excel-communityforumet

Hjälp oss att göra Excel bättre

Har du förslag på hur vi kan förbättra nästa version av Excel? Titta i så fall på avsnitten i Excel User Voice.

Mer information finns i

Korrigera felvärdet #VÄRDEFEL!

Funktionen MEDEL

Funktionen SUMMA

Översikt över formler i Excel

Hur du undviker felaktiga formler

Använd felkontroll om du vill hitta fel i formler

Alla Excel-funktioner (alfabetisk ordning)

Alla Excel-funktioner (efter kategori)

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×