Så här korrigerar du felvärdet #VÄRDEFEL! i funktionen ANTAL.OM/ANTAL.OMF

Det här avsnittet innehåller vanliga orsaker till felvärdet #VÄRDEFEL! i funktionerna ANTAL.OM och ANTAL.OMF.

Problem: Formeln refererar till celler i en stängd arbetsbok

Om funktionerna ANTAL.OM/ANTAL.OMF refererar till en cell eller ett område i en stängd arbetsbok resulterar det i felvärdet #VÄRDEFEL!.

Obs! Det här är ett känt problem med flera andra Excel-funktioner, till exempel SUMMA.OM, SUMMA.OMF, ANTAL.TOMMA för att nämna några. Se Funktionerna SUMMA.OM, ANTAL.OM och ANTAL.TOMMA returnerar felvärdet #VÄRDEFEL! för mer information.

Lösning: Öppna den länkade arbetsboken som angetts i formeln och tryck på F9 för att uppdatera formeln.

Du kan också kringgå problemet genom att använda funktionerna SUMMA och OM tillsammans i en matrisformel. Se Funktionerna SUMMA.OM, ANTAL.OM och ANTAL.TOMMA returnerar felvärdet #VÄRDEFEL! för mer information.

Problem: Strängen är längre än 255 tecken

Lösning: Förkorta strängen om möjligt. Om du inte kan korta ned den använder du funktionen SAMMANFOGA eller et-tecknet (&) för att dela upp värdet i flera strängar. Exempel:

  • =ANTAL.OM(B2:B12;"lång sträng"&"annan lång sträng")

Har du en specifik fråga om funktioner?

Ställ en fråga i Excel-communityforumet

Hjälp oss att göra Excel bättre

Har du förslag på hur vi kan förbättra nästa version av Excel? Titta i så fall på avsnitten i Excel User Voice.

Mer information finns i

Korrigera felvärdet #VÄRDEFEL!

Funktionen ANTAL.OM

Funktionen ANTAL.OMF

Funktionen OM – kapslade formler och hur du undviker fallgropar

Titta på en video om avancerade OM-funktioner

Översikt över formler i Excel

Hur du undviker felaktiga formler

Använd felkontroll om du vill hitta fel i formler

Alla Excel-funktioner (alfabetisk ordning)

Alla Excel-funktioner (efter kategori)

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×