Så här korrigerar du felvärdet #VÄRDEFEL! fel i funktionen sammanfoga

Viktigt!: I Excel 2016, Excel Mobile och Excel på webben har SAMMANFOGNINGen ersatts av funktionen samman. SAMMANFOGA-funktionen är fortfarande tillgänglig för bakåtkompatibilitet, men du bör överväga att använda SAMMAN eftersom det är en mer robust funktion.

En av de vanligaste scenarierna där du stöter på #VÄRDEFEL! med SAMMANFOGA är när du försöker skapa en sträng som innehåller en cellreferens som innehåller ett fel, till exempel #VÄRDEFEL!.

I följande exempel vill vi sammanfoga D2, E2 och F2 där E2 har en #VALUE! #REF!.

Felvärdet #VÄRDEFEL! fel i sammanfoga

Felet i E2 gör att funktionen visar #VALUE! #REF!. För att det ska fungera måste du ersätta felet med ett annat värde än felet. Du kan skapa en formel för att kontrol lera om det finns ett fel i cell referensen, och om det gör det visar du text strängen där en 0 visas i stället för felet (eller så kan du ersätta texten med citat tecken – "texten").

Den här formeln fungerar:

=OM(ÄRFEL(E2);SAMMANFOGA(D2;” ”;0;” ”;F2))

OM-och ÄRFEL-funktioner används som en lösning för att sammanfoga en sträng med #VALUE! med OM

Hur fungerar det? Med funktionen OMFEL kan du avgöra om det finns ett fel i E2 och funktionen sammanfoga kombinerar värdena i D2, E2 och F2 (funktionen ersätter felet med 0) och visar den resulterande text strängen. Obs! i formeln används blank steg ("") för att skilja värdena åt.

Åtgärda #VÄRDEFEL! med SAMMANFOGA i Excel 2003 och tidigare versioner

Om du får #VÄRDEFEL! i Office Excel 2003 eller äldre versioner måste du avmarkera alternativet Alternativ uttrycksvärdering i Excel. Följ stegen som beskrivs i #VALUE! när du sammanfogar celler för att lösa problemet.

Har du en specifik fråga om funktioner?

Ställ en fråga i Excel-communityforumet

Hjälp oss att göra Excel bättre

Har du förslag på hur vi kan förbättra nästa version av Excel? Titta i så fall på avsnitten i Excel User Voice.

Se även

Korrigera felet #VÄRDE! med OM

Funktionen SAMMANFOGA

Funktionen SAMMAN

Översikt över formler i Excel

Hur du undviker felaktiga formler

Upptäck fel i formler

Alla Excel-funktioner (alfabetisk ordning)

Alla Excel-funktioner (efter kategori)

Obs!:  Den här sidan har översatts automatiskt och kan innehålla grammatiska fel och andra felaktigheter. Vår avsikt är att innehållet ska vara användbart för dig. Skulle du vilja svara på om informationen var till hjälp? Här är den engelska artikeln som en referens.

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×