Fel
Så här korrigerar du #REFERENS!-fel

Så här korrigerar du #REFERENS!-fel

Obs!:  Vi vill kunna erbjuda dig bästa möjliga supportinnehåll så fort som möjligt och på ditt språk. Den här sidan har översatts med hjälp av automatiserad översättning och kan innehålla grammatiska fel eller andra felaktigheter. Vår avsikt är att den här informationen ska vara användbar för dig. Vill du berätta för oss om informationen är till hjälp längst ned på sidan? Här är artikeln på engelska som referens.

Den #referens! fel visas när en formel refererar till en cell som inte är giltigt. Detta händer oftast när celler som har referenser till formler få bort eller klistrats över.

Exempel på #REFERENS!-fel som orsakas genom att en kolumn har tagits bort

I följande exempel används formeln =SUMMA(B2,C2,D2) i kolumnen E.

En formel som använder uttryckliga cellreferenser, t.ex. =SUMMA(B2,C2,D2) kan orsaka ett #REFERENS!-fel om en kolumn tas bort.

Om du vill ta bort kolumn B, C eller D det skulle orsaka felet #referens! fel. I det här fallet ska vi ta bort kolumn C (2007 Sales), och formeln nu lyder =SUM(B2,#REF!,C2). När du använder explicita cellreferenser sådan (när du refererar till varje cell individuellt, avgränsade med semikolon) och ta bort en refererade rad eller kolumn, Excel inte kan lösa det, så att den returnerar #referens! fel. Det här är den primära skäl Varför använda uttryckliga cellreferenser i funktioner inte rekommenderas.

Exempel på #REFERENS!-fel som orsakas genom att en kolumn har tagits bort.

Lösning

  • Om du tar bort rader eller kolumner av misstag kan du återställa dem direkt genom att klicka på knappen Ångra i verktygsfältet Snabbåtkomst (eller trycka på CTRL+Z).

  • Ändra formeln så att den använder en områdesreferens i stället för enskilda celler, som =SUM(B2:D2). Nu kan du ta bort en kolumn i området summa och Excel justeras automatiskt formeln. Du kan också använda =SUM(B2:B5) för en summa av rader.

Exempel – LETARAD med felaktiga områdesreferenser

I exemplet nedan returnerar =LETARAD(A8,A2:D5,5,FALSKT) ett #REFERENS!-fel eftersom formeln söker efter ett värde som ska returneras från kolumn 5, men referensområdet är A:D, dvs. bara 4 kolumner.

Exempel på en LETARAD-formel med ett felaktigt område.  Formeln är = LETARAD(A8,A2:D5,5,FALSKT).  Det finns ingen femte kolumn i LETARAD-området och därför orsakar 5 #REFERENS!-felet.

Lösning

Justera område om du vill vara större eller minska uppslagsvärdet kolumn så att det matchar området referens. =VLOOKUP(a8,a2:E5,5,FALSE) ska vara en giltig referens område, som skulle ha gjort = VLOOKUP(A8,A2:D5,4,FALSE).

Exempel – INDEX med felaktig referens för rad eller kolumn

I det här exemplet returnerar formeln =INDEX(B2:E5,5,5) ett #REFERENS!-fel eftersom INDEX-området är 4 rader och 4 kolumner, men formeln försöker hämta värdet i rad 5 och kolumn 5.

Exempel på en INDEX-formel med en ogiltig områdesreferens.  Formeln är =INDEX(B2:E5,5,5), men området består endast av 4 rader och 4 kolumner.

Lösning

Justera referenserna raden eller kolumnen så att de passar i uppslagscellområdet INDEX. =Index(B2:E5,4,4) returnerar ett giltigt resultat.

Exempel – refererar till en stängd arbetsbok med INDIREKT

I följande exempel försöker en INDIREKT-funktion referera till en arbetsbok som är stängd, och orsakar därigenom ett #REFERENS!-fel.

Exempel på #REFERENS!-fel som orsakas av en INDIREKT-referens till en stängd arbetsbok.

Lösning

Öppna den refererade arbetsboken

OLE-problem

Om du har använt en OLE-länk som returnerar ett #REFERENS!-fel startar du programmet som länken refererar till.

Obs! OLE är en teknik som du kan använda för att dela information mellan program.

DDE-problem

Om du har använt ett ämne som Dynamic Data Exchange (DDE) som returnerar felet #referens! fel, första Kontrollera att du refererar till rätt avsnitt. Om du fortfarande får felet #referens! fel och kontrollera dina Inställningar för Säkerhetscenter för externt innehåll som beskrivs i Blockera eller häva blockering av externt innehåll i Office-dokument.

Anteckning: Dynamic Data Exchange (DDE)är ett protokoll för att flytta data mellan Microsoft Windows-baserade program.

Makro-problem

Om ett makro anger en funktion i kalkylbladet som refererar till en cell ovanför funktionen, och cellen som innehåller funktionen finns i rad 1, returnerar funktionen #referens! eftersom det inte finns några celler ovanför rad 1. Kontrollera funktionen för att se om ett argument refererar till en cell eller ett område med celler som inte är giltigt. Du kan behöva redigera makrot i Visual Basic Editor (VBE) hinner situationen till konto.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community, få support i Answers-communityn eller föreslå en ny funktion eller förbättringar på Excel User Voice.

Mer information finns i

Översikt över formler i Excel

Hur du undviker felaktiga formler

Använd felkontroll om du vill hitta fel i formler

Excel-funktioner (alfabetisk ordning)

Excel-funktioner (efter kategori)

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×