Fel
Så här korrigerar du #REFERENS!-fel

Så här korrigerar du #REFERENS!-fel

#REFERENS!-felet visas när en formel refererar till en cell som inte är giltig. Det här händer oftast när celler som formler refererar till tas bort eller klistras över.

Exempel på #REFERENS!-fel som orsakas genom att en kolumn har tagits bort

I följande exempel används formeln =SUMMA(B2,C2,D2) i kolumnen E.

En formel som använder uttryckliga cellreferenser, t.ex. =SUMMA(B2,C2,D2) kan orsaka ett #REFERENS!-fel om en kolumn tas bort.

Om du tar bort kolumn B, C eller D orsakas ett #REFERENS!-fel. I det här fallet ska vi ta bort kolumnen C (Försäljning 2007) och formeln blir då =SUMMA(B2,#REFERENS!,C2). När du använder sådana uttryckliga cellreferenser (där du refererar till respektive cell individuellt, avgränsade med semikolon) och tar bort en refererad rad eller kolumn kan Excel inte lösa det och returnerar ett #REFERENS!-fel. Det här är det primära skälet till varför vi inte rekommenderar användning av uttryckliga cellreferenser i funktioner.

Exempel på #REFERENS!-fel som orsakas genom att en kolumn har tagits bort.

Lösning

  • Om du tar bort rader eller kolumner av misstag kan du återställa dem direkt genom att klicka på knappen Ångra i verktygsfältet Snabbåtkomst (eller trycka på CTRL+Z).

  • Ändra formeln så att den använder en områdesreferens i stället för enskilda celler, t.ex. =SUMMA(B2:D2). Om du tar bort en kolumn i området så justeras formeln automatiskt i Excel. Du kan även använda =SUMMA(B2:B5) för att summera rader.

Exempel – LETARAD med felaktiga områdesreferenser

I exemplet nedan returnerar =LETARAD(A8,A2:D5,5,FALSKT) ett #REFERENS!-fel eftersom formeln söker efter ett värde som ska returneras från kolumn 5, men referensområdet är A:D, dvs. bara 4 kolumner.

Exempel på en LETARAD-formel med ett felaktigt område.  Formeln är = LETARAD(A8,A2:D5,5,FALSKT).  Det finns ingen femte kolumn i LETARAD-området och därför orsakar 5 #REFERENS!-felet.

Lösning

Gör området större eller minska kolumnvärdet så att det matchar referensområdet. =LETARAD(A8,A2:E5,5,FALSKT) skulle vara ett giltigt referensområde, liksom = LETARAD(A8,A2:D5,4,FALSKT).

Exempel – INDEX med felaktig referens för rad eller kolumn

I det här exemplet returnerar formeln =INDEX(B2:E5,5,5) ett #REFERENS!-fel eftersom INDEX-området är 4 rader och 4 kolumner, men formeln försöker hämta värdet i rad 5 och kolumn 5.

Exempel på en INDEX-formel med en ogiltig områdesreferens.  Formeln är =INDEX(B2:E5,5,5), men området består endast av 4 rader och 4 kolumner.

Lösning

Justera rad- eller kolumnreferenserna så att de är inom INDEX-uppslagsområdet. =INDEX(B2:E5,4,4) returnerar ett giltigt resultat.

Exempel – refererar till en stängd arbetsbok med INDIREKT

I följande exempel försöker en INDIREKT-funktion referera till en arbetsbok som är stängd, och orsakar därigenom ett #REFERENS!-fel.

Exempel på #REFERENS!-fel som orsakas av en INDIREKT-referens till en stängd arbetsbok.

Lösning

Öppna den refererade arbetsboken

OLE-/DDE-problem

Om du har använt en OLE-länk som returnerar ett #REFERENS!-fel startar du programmet som länken refererar till.

Obs! OLE är en teknik som du kan använda för att dela information mellan program.

Kontrollera att du refererar till rätt avsnitt om du har använt ett DDE-avsnitt som returnerar ett #REFERENS!-fel.

Obs! DDE är ett protokoll för att utbyta data mellan Microsoft Windows-program.

Makro-problem

Om ett makro anger en funktion som refererar till en cell ovanför funktionen, och cellen som innehåller funktionen finns på rad 1, returnerar funktionen ett #REFERENS!-fel eftersom det inte finns några celler ovanför rad 1. Kontrollera funktionen för att se om ett argument refererar till en cell som inte är giltig eller ett cellområde som inte är giltigt. Du kan behöva redigera makrot i VBE (Visual Basic Editor) för att ta hänsyn till den situationen.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community, få support i Answers-communityn eller föreslå en ny funktion eller förbättringar på Excel User Voice.

Mer information finns i

Översikt över formler i Excel

Hur du undviker felaktiga formler

Använd felkontroll om du vill hitta fel i formler

Excel-funktioner (alfabetisk ordning)

Excel-funktioner (efter kategori)

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×