Räkna unika värden bland dubbletter

Viktigt!: Den här artikeln är maskinöversatt, se ansvarsfriskrivningen. Den engelska versionen av den här artikeln finns här för din referens.

Anta att du vill ta reda på hur många unika text eller numeriska värden som finns i ett område. Till exempel om en kolumn innehåller texten med ett belopp som Bradley, Doyle, Doyle, Doyle, det finns två unika värden – Bradley och Doyle. Om cellområdet inte innehåller talen 5, 6, 7, 6, är de unika värdena 5, 6 och 7.

För att endast räkna unika värden använder du en kombination av följande funktioner, så som visas i exempelkalkylbladet nedan:

  • Använd funktionen OM för att tilldela värdet 1 för varje villkor som är SANT.

  • Använd funktionen SUMMA för att lägga till alla unika värden.

  • Använd funktionen FREKVENS för att räkna antalet unika värden. Med den här funktionen ignoreras textvärden och nollvärden. För den första förekomsten av ett specifikt värde returnerar den ett tal som motsvarar antalet förekomster av värdet. För varje förekomst av samma värde efter den första förekomsten returneras värdet 0.

  • Använd funktionen PASSA för att returnera ett textvärdes läge i ett område. Funktionen FREKVENS använder det resulterande värdet för att beräkna motsvarande textvärden.

  • Använd funktionen LÄNGD för att hitta tomma celler. Tomma celler har längden (antal tecken) 0.

Exempel

Kopiera tabellen till cell A1 på ett tomt kalkylblad i Excel om du vill arbeta med de här exemplen på formler som använder funktioner.

Data

Data

986

Bradley

Doyle

563

67

789

235

Bradley

Doyle

689

789

Doyle

143

56

237

67

235

Formel

Beskrivning (Resultat)

=SUMMA(OM(FREKVENS(A2:A10;A2:A10)>0;1))

Räknar antalet unika talvärden i cellerna A2:A10, men räknar inte tomma celler eller textvärden (4)

=SUMMA(OM(FREKVENS(PASSA(B2:B10;B2:B10;0);PASSA(B2:B10;B2:B10;0))>0;1))

Räknar antalet unika text- och talvärden i cellerna B2:B10 (som inte får innehålla några tomma celler) (7)

=SUMMA(OM(FREKVENS(OM(LÄNGD(A2:A10)>0;PASSA(A2:A10;A2:A10;0);""); OM(LÄNGD(A2:A10)>0;PASSA(A2:A10;A2:A10;0);""))>0;1))

Räknar antalet unika text- och talvärden i cellerna A2:A10, men räknar inte tomma celler eller textvärden (6)

Meddelanden: 

  • Formlerna i det här exemplet måste matas in som matrisformler. Markera varje cell som innehåller en formel, tryck på F2 och tryck sedan på Ctrl + Skift + Retur.

  • Om du vill se hur funktionen beräknas steg för steg markerar du den cell som innehåller formeln och klickar på pilen bredvid Utvärdera formel i gruppen Formelgranskning på fliken Formler.

Obs!: Ansvarsfriskrivning för maskinöversättning: Den här artikeln har översatts av ett datorsystem utan mänsklig inblandning. Microsoft erbjuder dessa maskinöversättningar för att hjälpa icke engelskspråkiga användare att ta del av information om Microsofts produkter, tjänster och tekniker. Eftersom artikeln är maskinöversatt kan den innehålla fel i ordval, syntax och grammatik.

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×