Räkna tecken i celler med Excel 2016 för Mac

När du behöver räkna tecknen i celler använder du funktionen LÄNGD. Funktionen räknar bokstäver, siffror, tecken och alla blanksteg. Längden för "Det är 37 grader idag, så jag går och badar" (exklusive citattecknen) är exempelvis 44 tecken, 32 bokstäver, 2 siffror, 10 blanksteg och ett kommatecken.

  • Du använder funktionen genom att ange =LÄNGD(cell) i formelfältet och trycka på Retur. I de här exemplen är cellen du vill räkna en cellreferens, till exempel B1.

  • Du räknar tecknen i fler än en cell genom att först ange formeln och sedan kopiera och klistra in den i övriga celler.

  • Om du vill räkna ett totalt antal tecken i flera celler använder du SUMMA-funktioner tillsammans med LÄNGD, till exempel =SUMMA((LÄNGD(cell1);LÄNGD(cell2);(LÄNGD(cell3)))). I det här exemplet räknar LÄNGD-funktionen tecknen i varje cell och SUMMA-funktionen lägger ihop antalen.

  • Om du vill räkna vissa speciella tecken i celler använder du funktionen LÄNGD med funktionen BYT.UT. Om du till exempel vill veta hur många små z som finns i en cell använder du den här formeln: =LÄNGD(cell1) -LÄNGD(BYT.UT(cell1;"z";""))

Testa själv

Ange följande uppgifter i ett nytt Excel-kalkylblad. Börja i cell A1.

Textsträngar

Formler

Flygande bäckasiner söka

Flygande bäckasiner söka hwila på

Flygande bäckasiner söka hwila på mjuka tuvor

Räkna tecken i en cell

  1. Klicka på cell B2.

  2. Ange =LÄNGD(A2) i cellen och tryck på Retur.

Formeln räknar tecknen i cell A2. Där finns 19 tecken. Det antalet omfattar alla blanksteg. Om du har blanksteg efter den sista punkten räknas de också.

Räkna tecken i flera celler

  1. Tryck på CTRL+C för att kopiera cell B2.

  2. Tryck på CTRL+V för att klistra in dess formel i cellerna B3:B4.

Då kopieras formeln till cell B3 och cell B4, och tecknen i respektive cell räknas (26 och 44).

Räkna ett totalt antal tecken

  1. Klicka i cell B6.

  2. I cellen anger du =SUMMA(LÄNGD(A2);LÄNGD(A3);LÄNGD(A4)) och trycker på Retur.

Då räknas antalet tecken i alla tre celler och den sammanlagda summan (89).

Så här räknar du vissa speciella tecken i celler

  1. Klicka i cell C4.

  2. I cellen anger du =LÄNGD(A4)-LÄNGD(BYT.UT(A4; "z";"")) och trycker på Retur.

I korthet: då räknas alla små z i cell A4. De är 1 till antalet.

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×