Räkna tecken i celler

När du behöver räkna tecknen i celler använder du funktionen LÄNGD. Funktionen räknar bokstäver, siffror, tecken och alla blanksteg. Längden för "Det är 37 grader idag, så jag går och badar" (exklusive citattecknen) är exempelvis 44 tecken, 32 bokstäver, 2 siffror, 10 blanksteg och ett kommatecken.

  • Du använder funktionen genom att ange =LÄNGD(cell) i formelfältet och trycka på Retur. I de här exemplen är cellen du vill räkna en cellreferens, till exempel B1.

  • Du räknar tecknen i fler än en cell genom att ange formeln och sedan dra fyllningshandtaget över det område med celler som du vill använda.

Ange flera LÄNGD-funktioner på ett kalkylblad

  • Om du vill räkna ett totalt antal tecken i flera celler använder du SUMMA-funktioner tillsammans med LÄNGD, till exempel =SUMMA((LÄNGD(cell1);LÄNGD(cell2);(LÄNGD(cell3)))). I det här exemplet räknar LÄNGD-funktionen tecknen i varje cell och SUMMA-funktionen lägger ihop antalen.

Testa själv

Ta reda på hur du använder funktionen LÄNGD genom att använda exemplen i arbetsboken nedan.

Kopiera tabellen nedan och klistra in den i cell A1 i ett Excel-kalkylblad. Ta reda på hur lång celltexten i kolumn A är genom att dra formeln från B2 till B3:B4.

Textsträngar

Formler

Flygande bäckasiner söka

=LÄNGD(A2)

Flygande bäckasiner söka hwila på

Flygande bäckasiner söka hwila på mjuka tuvor

Räkna tecken i en cell

  1. På Blad1 i exempelarbetsboken klickar du på cell B1.

  2. Ange =LÄNGD(A2) i cellen och tryck på Retur.

Formeln räknar tecknen i cell A1, 45, och det antalet omfattar alla blanksteg. Om du har blanksteg efter den sista punkten räknas de också.

Räkna tecken i flera celler

  1. I exempelarbetsboken klickar du på cell B2.

  2. Ange =LÄNGD(A2) i cellen.

  3. Tryck på Ctrl+C om du vill kopiera cell B2, och klistra in dess formel i cellerna B3:B4 genom att trycka på Ctrl+V.

Då kopieras formeln till cell B3 och B4, och funktionen räknar tecknen i varje cell (19, 26 och 45).

Räkna ett totalt antal tecken

  1. I exempelarbetsboken klickar du på cell B6.

  2. I cellen anger du =SUMMA(LÄNGD(A2);LÄNGD(A3);LÄNGD(A4)) och trycker på Retur.

Då räknas antalet tecken i alla tre celler och den sammanlagda summan (90).

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×