Office
Logga in

Räkna tal eller datum baserat på ett villkor

Obs!:  Vi vill kunna erbjuda dig bästa möjliga supportinnehåll så fort som möjligt och på ditt språk. Den här sidan har översatts med hjälp av automatiserad översättning och kan innehålla grammatiska fel eller andra felaktigheter. Vår avsikt är att den här informationen ska vara användbar för dig. Vill du berätta för oss om informationen är till hjälp längst ned på sidan? Här är artikeln på engelska som referens.

Om du vill räkna tal eller datum som uppfyller ett enda villkor (till exempel lika med, större än, mindre än större än eller lika med eller mindre än eller lika med) använder du funktionen antal.Om . Om du vill räkna tal eller datum som faller inom ett område (till exempel större än mindre än 22500 9000 och på samma gång), kan du använda funktionen antal.OMF . Alternativt kan använda du PRODUKTSUMMA för.

Exempel

1

2

3

4

5

6

7

8 %

9

10

11

12

13

14

15

16

17

A

B

Säljare

Faktura

Buchwald

15 000

Buchwald

9 000

Suyama

8 000

Suyama

20 000

Buchwald

5 000

Damiani

22 500

Formel

Beskrivning (resultat)

=ANTAL.OM(B2:B7;">9000")

Funktionen ANTAL.OM räknar antalet celler i området B2:B7 som innehåller tal som är större än 9 000 (4)

=ANTAL.OM(B2:B7;"<=9000")

Funktionen ANTAL.OM räknar antalet celler i området B2:B7 som innehåller tal som är mindre än 9 000 (4)

=ANTAL.OMF(B2:B7;">=9000";B2:B7;"<=22500")

Funktionen ANTAL.OMF (tillgänglig i Excel 2007 och senare) räknar antalet celler i området B2:B7 som är större än eller lika med 9 000 och mindre än eller lika med 22 500 (4)

=PRODUKTSUMMA((B2:B7>=9000)*(B2:B7<=22500))

Funktionen PRODUKTSUMMA räknar antalet celler i området B2:B7 som innehåller tal som är större än eller lika med 9 000 och mindre än eller lika med 22 500 (4). Du kan använda den här funktionen i Excel 2003 och tidigare versioner, där funktionen ANTAL.OMF inte är tillgänglig.

Datum

2011-03-11

2010-01-01

2010-12-31

2010-06-30

Formel

Beskrivning (resultat)

=ANTAL.OM(B14:B17;">2010-03-01")

Räknar antalet celler i området B14:B17 som innehåller ett datum som är större än 2010-03-01 (3)

=ANTAL.OM(B14:B17;"2010-12-31")

Räknar antalet celler i området B14:B17 som är lika med 2010-12-31 (1). Inget likhetstecken har angetts här eftersom det inte behövs i villkoret (formeln fungerar med ett likhetstecken om du väljer att använda det ("=2010-12-31")).

=ANTAL.OMF(B14:B17;">=2010-01-01";B14:B17;"<=2010-12-31")

Räknar antalet celler i området B14:B17 som innehåller datum mellan (inklusive) 2010-01-01 och 2010-12-31 (3).

=PRODUKTSUMMA((B14:B17>=DATUMVÄRDE("2010-01-01"))*(B14:B17<=DATUMVÄRDE("2010-12-31")))

Räknar antalet celler i området B14:B17 som innehåller datum mellan (inklusive) 2010-01-01 och 2010-12-31 (3). Det här exemplet illustrerar hur du gör om du inte kan använda funktionen ANTAL.OMF, som introducerades i Excel 2007. Funktionen DATUMVÄRDE konverterar datum till ett numeriskt värde, som funktionen PRODUKTSUMMA sedan kan arbeta med.

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×