Räkna hur ofta ett värde förekommer i Excel

Viktigt!: Den här artikeln är maskinöversatt, se ansvarsfriskrivningen. Den engelska versionen av den här artikeln finns här för din referens.

Anta att du vill veta antalet förekomster av ett visst textvärde eller numeriskt värde i ett cellområde. Till exempel:

  • Om ett område, som A2:D20, innehåller talen 5, 6, 7 och 6, innehåller området två förekomster av talet 6.

  • Om en kolumn innehåller "Buchanan", "Damiani", "Damiani" och "Damiani", innehåller kolumnen tre förekomster av "Damiani".

Du kan räkna antalet förekomster av ett värde på flera olika sätt.

Vad vill du göra?

Räkna antalet förekomster av ett enskilt värde med hjälp av en funktion

Räkna antalet förekomster utifrån flera villkor med hjälp av funktionen ANTAL.OMF

Räkna antalet förekomster utifrån villkor med hjälp av funktionerna ANTAL och OM tillsammans

Räkna antalet förekomster av flera textvärden eller numeriska värden med hjälp av funktionerna SUMMA och OM i kombination

Räkna antalet förekomster av flera värden med hjälp av en pivottabellrapport

Räkna antalet förekomster av ett enskilt värde med hjälp av en funktion

Använd funktionen ANTAL.OM för att utföra denna åtgärd.

Exempel

Kopiera exempeldata i följande tabell och klistra in dem i cell A1 i ett nytt Excel-kalkylblad. När du vill att formlerna ska visa resultat markerar du dem, trycker på F2 och sedan på Retur. Om det behövs kan du justera kolumnbredderna så att alla data visas.

Säljare

Faktura

Buchwald

150 000

Buchwald

9 000

Suyama

8 000

Suyama

20 000

Buchwald

5 000

Damiani

225 000

Formel

Beskrivning

Resultat

=ANTAL.OM(A2:A7;"Buchwald")

Antal förekomster av Buchwald (3)

=ANTAL.OM(A2:A7;"Buchwald")

=ANTAL.OM(A2:A7;A4)

Antal förekomster av Suyama (2)

=ANTAL.OM(A2:A7;A4)

=ANTAL.OM(B2:B7;"< 200000")

Antal fakturor med ett belopp som är mindre än 200 000 (4)

=ANTAL.OM(B2:B7;"< 200000")

=ANTAL.OM(B2:B7;">="&B5)

Antal fakturor med ett belopp som är större än eller lika med 200 000 (2)

=ANTAL.OM(B2:B7;">="&B5)

Mer information om hur du använder den här funktionen finns i funktionen ANTAL.OM.

Överst på sidan

Räkna antalet förekomster utifrån flera villkor med hjälp av funktionen ANTAL.OMF

Funktionen ANTAL.OMF introducerades i Excel 2007 och liknar funktionen ANTAL.OM med ett viktigt undantag: Med ANTAL.OMF kan du använda villkor på celler över flera områden och räkna antalet gånger ett villkor uppfylls. Du kan använda upp till 127 områdes- och villkorspar med funktionen ANTAL.OMF. Syntaxen för funktionen ser ut så här:

ANTAL.OMF(villkorsområde1, villkor1, [villkorsområde2, villkor2], …)

Exempel

Anställningsnr

Regionsnr

Avdelning

20552

2

Försäljning

21268

2

Ekonomi

23949

1

Administration

24522

4

Administration

28010

3

IT

29546

4

Försäljning

31634

3

IT

32131

1

IT

35106

4

Ekonomi

40499

1

HR

42051

1

Försäljning

43068

2

HR

45382

2

Ekonomi

47971

1

IT

Hur många anställda finns det i Region 2 och på Ekonomiavdelningen?

'=ANTAL.OM(B2:B15;"2";C2:C15;"Ekonomi")

=ANTAL.OM(B2:B15;"2";C2:C15;"Ekonomi")

Det första villkorsområdet är regionsnumren och det andra villkorsområdet är avdelningsnamnet. Villkoret som tillämpas på det första villkorsområdet är "2," och villkoret som tillämpas på det andra området är "Ekonomi." ANTAL.OM kontrollerar för att se om båda villkoren är uppfyllda.

Mer information om hur du använder funktionen för att beräkna flera områden och villkor finns i Funktionen ANTAL.OMF.

Överst på sidan

Räkna antal förekomster utifrån villkor med hjälp av funktionerna ANTAL och OM tillsammans

Anta att du vill veta hur många säljare som har sålt en viss artikel i en viss region eller att du vill veta antalet försäljningar över ett visst belopp som gjorts av en viss säljare. Du kan använda funktionerna OM och ANTAL tillsammans, det vill säga att du först använder funktionen OM för att testa ett villkor och sedan, om resultatet av funktionen OM är Sant, använder du funktionen ANTAL för att räkna celler.

Exempel

Område

Säljare

Typ

Försäljning

Söder

Buchwald

Drycker

3571

Väst

Gustavsson

Mejeri

3338

Öst

Suyama

Drycker

5122

Norr

Suyama

Mejeri

6239

Söder

Damiani

Spannmål

8677

Söder

Gustavsson

Kött

450

Söder

Gustavsson

Kött

7673

Öst

Suyama

Spannmål

664

Norr

Gustavsson

Spannmål

1 500

Söder

Damiani

Kött

6596

Formel

Beskrivning

Resultat

=ANTAL(OM((A2:A11="Syd")*(C2:C11="Kött");D2:D11))

Antal försäljningar av kött i regionen Syd. (3)

=ANTAL(OM((A2:A11="Syd")*(C2:C11="Kött");D2:D11))

=ANTAL(OM((B2:B11="Suyama")*(D2:D11>=10000);D2:D11))

Antal order på belopp över 10 000 kronor som gjorts av Suyama. (2)

=ANTAL(OM((B2:B11="Suyama")*(D2:D11>=10000);D2:D11))

Obs!: 

  • Formlerna i det här exemplet måste anges som matrisformler. Om du har öppnat arbetsboken i Excel-skrivbordsprogrammet och vill ändra formeln eller skapa en liknande formel trycker du på F2 och trycker sedan på Ctrl+Skift+Retur för att formeln ska returnera det resultat du förväntar dig.

  • För att de här formlerna ska fungera måste det andra argumentet i funktionen OM vara ett tal.

Med funktionen ANTAL räknas antalet celler som innehåller tal och talen inom listan med argument. Med funktionen OM räknas antalet celler som innehåller tal och talen inom listan med argument.

Mer information om funktionerna finns i Funktionen ANTAL och Funktionen OM.

Överst på sidan

Räkna antalet förekomster av flera textvärden eller numeriska värden med hjälp av funktionerna SUMMA och OM i kombination

I följande exempel använder vi funktionerna OM och SUMMA tillsammans. Funktionen OM testar först värdena i några celler och sedan, om resultatet av testet är Sant, summerar SUMMA de värden som klarade testet.

Exempel

Säljare

Faktura

Buchwald

15000

Buchwald

9000

Suyama

8000

Suyama

20000

Buchwald

5000

Damiani

22500

Formel

Beskrivning

Resultat

=SUMMA(OM((A2:A7="Buchanan")+(A2:A7="Damiani");1;0))

Antal fakturor för Buchanan eller Damiani.

=SUMMA(OM((A2:A7="Buchanan")+(A2:A7="Damiani");1;0))

=SUMMA(OM((B2:B7<90000)+(B2:B7>190000);1;0))

Antal fakturor med värden mindre än 90 000 kronor eller större än 190 000 kronor.

=SUMMA(OM((B2:B7<90000)+(B2:B7>190000);1;0))

=SUMMA(OM(A2:A7="Buchanan";IF(B2:B7<90000;1;0)))

Antalet fakturor för Buchanan med ett värde som är mindre än 90 000 kr.

=SUMMA(OM(A2:A7="Buchanan";IF(B2:B7<90000;1;0)))

Obs!: Formlerna i det här exemplet måste anges som matrisformler. Om du har öppnat arbetsboken i Excel-skrivbordsprogrammet och vill ändra formeln eller skapa en liknande formel trycker du på F2 och trycker sedan på Ctrl+Skift+Retur för att formeln ska returnera det resultat du förväntar dig.

Överst på sidan

Räkna antalet förekomster av flera värden med hjälp av en pivottabellrapport

Du kan använda en pivottabellrapport för att visa summor och räkna antalet förekomster av unika värden. En pivottabell är ett interaktivt sätt att snabbt summera stora mängder data. Du kan använda en pivottabell om du vill utöka och dölja datanivåer för att fokusera dina resultat och visa information från sammanfattningsdata i detalj för de områden som är intressanta för dig. Du kan dessutom flytta rader till kolumner eller kolumner till rader ("pivotera") för att se olika sammanfattningar av källdata.

Exempel på källdata och den resulterande pivottabellen

1   Källdata, i det här fallet från ett kalkylblad

2   Källvärdena för sammanfattningen av Golf, Kv3 i pivottabellrapporten

3   Hela pivottabellrapporten

4   Sammanfattning av källvärdena i C2 och C8 från källdata

Skapa en pivottabellrapport

  1. Markera den kolumn som innehåller informationen.
    Kontrollera att kolumnen har en rubrik.

  2. På fliken Infoga, i gruppen Tabeller, klickar du på Pivottabell.
    Dialogrutan Skapa pivottabell visas.

  3. Klicka på Markera en tabell eller ett område.

  4. Placera pivottabellrapporten i ett nytt kalkylblad med början i cell A1 genom att klicka på Nytt kalkylblad.

  5. Klicka på OK.
    En tom pivottabellrapport läggs till på den plats du angav och fältlistan för pivottabell visas.

  6. Placera musen i fältområdet överst i fältlistan för pivottabellen, klicka på och håll ned fältnamnet och dra sedan fältet till rutan Radetiketter i layoutområdet längst ned i fältlistan för pivottabellen.

  7. Placera musen i fältområdet överst i fältlistan för pivottabellen, klicka på och håll ned samma fältnamn och dra sedan fältet igen till rutan Värden i layoutområdet längst ned i fältlistan för pivottabellen.

Obs!: Om informationen innehåller tal kommer posterna att summeras i pivottabellrapporten i stället för att räknas. Du kan byta från summeringsfunktionen Summa till summeringsfunktionen Antal. Markera en cell i kolumnen, gå till gruppen Aktivt fält på fliken Analysera, klicka på Fältinställningar, gå till fliken Sammanfatta med, klicka på Antal och sedan på OK.

Överst på sidan

Obs!: Ansvarsfriskrivning för maskinöversättning: Den här artikeln har översatts av ett datorsystem utan mänsklig inblandning. Microsoft erbjuder dessa maskinöversättningar för att hjälpa icke engelskspråkiga användare att ta del av information om Microsofts produkter, tjänster och tekniker. Eftersom artikeln är maskinöversatt kan den innehålla fel i ordval, syntax och grammatik.

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×