Räkna antalet förekomster av ett värde

Med hjälp av ett antal kalkylbladsfunktioner kan du räkna hur många gånger en viss text eller numeriskt värde förekommer i ett cellområde. Du kan till exempel använda funktionen ANTAL.OMför att räkna antalet förekomster av ett enskilt värde, som du ser i exemplet nedan.

Exempel

Säljare

Faktura

Buchwald

15 000

Buchwald

9 000

Suyama

8 000

Suyama

20 000

Buchwald

5 000

Damiani

22 500

Formel

Beskrivning

Resultat

=ANTAL.OM(A2:A7;"Buchwald")

Antal förekomster av Buchwald (3)

3

=ANTAL.OM(A2:A7;A4)

Antal förekomster av Suyama (2)

2

=ANTAL.OM(B2:B7;"< 200000")

Antal fakturor med ett belopp som är mindre än 200 000 (4)

4

=ANTAL.OM(B2:B7;">="&B5)

Antal fakturor med ett belopp som är större än eller lika med 200 000 (2)

2

Använda ANTAL.OMF för att räkna värden baserat på flera villkor

Funktionen ANTAL.OMF liknar funktionen ANTAL.OM med ett viktigt undantag: Med ANTAL.OMF kan du använda kriterier på celler över flera områden och antalet gånger alla kriterier uppfylls beräknas. Du kan använda upp till 127 områdes- och villkorspar med funktionen ANTAL.OMF. Syntaxen för funktionen ser ut så här:

ANTAL.OMF(villkorsområde1, villkor1, [villkorsområde2, villkor2],…)

Exempel

Anställningsnr

Regionsnummer

Avdelning

20552

2

Försäljning

21268

2

Ekonomi

23949

1

Administration

24522

4

Administration

28010

3

IT

29546

4

Försäljning

31634

3

IT

32131

1

IT

35106

4

Ekonomi

40499

1

HR

42051

1

Försäljning

43068

2

HR

45382

2

Ekonomi

47971

1

IT

Formel

Beskrivning

Resultat

=ANTAL.OM(B2:B15;"2";C2:C15;"Ekonomi")

Antalet anställda i region 2 och på ekonomiavdelningen

2

Det första villkorsområdet omfattar alla regionsnummer och det andra villkorsområdet omfattar alla avdelningsnamn. Villkoret som används på det första villkorsområdet är "2" och villkoret som används på det andra området är "Ekonomi." Med ANTAL.OMF kontrolleras om båda villkoren uppfylls.

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×