Olika sätt att summera värden i ett kalkylblad

Skillnaden mellan att räkna och summera

Att summera (addera värden) är en central del i dataanalys, till exempel om du tittar på försäljningen i en viss region eller gör en veckosammanställning av kvitton. I Excel finns flera olika sätt att summera data.

I den här artikeln finns en sammanfattning av de olika summeringsmetoderna samt länkar till mer detaljerade artiklar, och du kan använda informationen som ett hjälpmedel när du ska välja en summeringsmetod.

Det är en viktig skillnad mellan att summera värden och räkna antalet celler. Mer information om hur du räknar antalet celler, kolumner eller rader med data finns i avsnittet Funktionen RÄKNA.OM.

I den här artikeln

Enkel addition och subtraktion

Addera värden i en cell med en enkel formel

Subtrahera värden i en cell med en enkel formel

Addera värden i en kolumn eller rad med en knapp

Addera värden i ett cellområde med en funktion

Subtrahera värden i ett cellområde med en funktion

Summera data genom att gruppera och pivotera

Addera värden i en kolumn med en disposition

Addera värden i en lista eller Excel-tabellkolumn med en funktion

Summera data och analysera dem ur olika synvinklar

Summera data baserat på ett eller flera villkor

Addera värden i ett cellområde baserat på ett enstaka villkor genom att använda en funktion eller en kombination av funktioner

Addera värden i en kolumn baserat på ett eller flera villkor genom att använda en funktion

Addera värden i ett cellområde baserat på flera villkor genom att använda en enstaka funktion eller en kombination av funktioner

Summera kvadrerade värden och matriser

Summera motsvarande värden i en eller flera matriser

Specialfall (löpande saldon, unika värden)

Skapa ett löpande saldo med en funktion

Addera de unika värdena i ett cellområde med en sammansatt formel

Inkludera värden från andra kalkylblad eller arbetsböcker i en formel

Summera och subtrahera tids- och datumvärden

Visa beräkningar i statusfältet i Excel

Enkel addition och subtraktion

Du kan addera och subtrahera värden genom att använda en enkel formel, genom att klicka på en knapp eller genom att använda en kalkylbladsfunktion.

Addera värden i en cell med en enkel formel

Om du bara vill beräkna summan av två värden kan du använda Excel som en miniräknare. Addera talen genom att använda ett plustecken (+) som aritmetisk operator.

Formel

Beskrivning

Resultat

=5+10

Använd operatorn + (plustecken) för att summera två eller flera värden.

15

=A2+B2

Adderar värden i två eller flera celler. I det här fallet antar vi att A2 = 5 och att B2 = 10.

15

=A2+B2+20

Adderar värdet i två celler och ett värde du anger direkt i formeln. I det här fallet antar vi att A2 = 5 och att B2 = 10.

35

Överst på sidan

Subtrahera värden i en cell med en enkel formel

Subtrahera talen genom att använda ett minustecken (-) som aritmetisk operator. Formeln =12-9 ger till exempel resultatet 3.

Mer information om hur du använder aritmetiska operatorer i en formel finns i artikeln Använda Excel som miniräknare.

Överst på sidan

Addera värden i en kolumn eller rad med en knapp

Du kan använda Autosumma om du snabbt behöver summer flera värden i en kolumn eller en rad. Klicka på en tom cell under en kolumn med tal eller till höger om en rad med tal, och klicka sedan på Autosumma. Klicka på Autosumma igen för att godkänna det cellområde som Excel föreslår, eller markera ett eget cellområde och klicka sedan på Autosumma.

Använda Autosumma för att lägga till en rad med data

Mer information om hur du använder Autosumma i en formel finns i artikeln Använda Excel som miniräknare.

Överst på sidan

Addera värden i ett cellområde med en funktion

Funktionen SUMMA är praktisk när du behöver lägga ihop eller dra ifrån värden från olika cellområden eller kombinera numeriska värden med cellområden med tal. Använd funktionen SUMMA för att summera samtliga argument som du anger inom inledande och avslutande parentes. Argumenten kan vara ett cellområde, en cellreferens eller ett positivt eller negativt numeriskt värde.

Om du vill ange en enkel formel skriver du =SUMMA i en cell, följt av en inledande parentes. Skriv sedan ett eller flera tal, cellreferenser eller cellområden avgränsade med semikolon. Skriv därefter en avslutande parentes och tryck på RETUR för att visa resultatet. Du kan också välja celler med musen när du ska ange vilka celler som ska summeras.

1

2

3

A

Närvaro

4823

12335

Med informationen i föregående exempel använder alla formler funktionen SUMMA för att returnera samma värde (17158):

  • =SUMMA(4823;12335)

  • =SUMMA(A2;A3)

  • =SUMMA(A2:A3)

  • =SUMMA(A2;12335)

I illustrationen nedan visas den formel som använder funktionen SUMMA för att addera värdet i cell A2 och 12335. Under formeln visas ett skärmtips med information om hur du använder funktionen SUMMA.

Addera en cell och ett värde med funktionen SUMMA


Meddelanden  

  • Det finns ingen funktion som heter DIFFERENS i Excel. Om du vill subtrahera värden med en funktion använder du negativa värden som argument till funktionen SUMMA. Formeln =SUMMA(30;A3;-15;-B6) summerar 30 och värdet i cell A3, subtraherar 15 från resultatet och subtraherar sedan värdet i cell B6.

  • Du kan ange upp till 255 numeriska värden eller cell- eller områdesreferenser i valfri kombination som argument till funktionen SUMMA.

Mer information finns i artikeln Funktionen SUMMA.

Överst på sidan

Subtrahera värden i ett cellområde med en funktion

Använd funktionen SUMMA för att subtrahera värden genom att skriva in ett minustecken framför de värden du vill använda i formeln.

1

2

3

A

Närvaro

29072

12335

Med informationen i föregående exempel använder alla formler funktionen SUMMA för att returnera samma värde (16737):

  • =SUMMA(29072;-12335)

  • =SUMMA(A2;-A3)

  • =SUMMA(A2;-12335)

  • =SUMMA(A2;(-1*(A3)))

Överst på sidan

Summera data genom att gruppera och pivotera

Du kan använda en disposition eller en pivottabellrapport för att gruppera och summera dina data.

Addera värden i en kolumn med en disposition

Om dina data är organiserade på det vanliga sättet (det vill säga i rader och kolumner) och du kan gruppera informationen efter värden i kolumnerna, kan du gruppera och summera data genom att skapa en disposition. Om du skapar en disposition kan du sammanfatta dina data genom att infoga delsummor och totalsummor. Anta att du har följande försäljningsstatistik, ordnat efter region och månad.

1

2

3

4

5

6

7

A

B

C

Region

Månad

Försäljning

Öst

Jan

18 000

Öst

Feb

23 000

Öst

Mar

19 000

Väst

Jan

17 000

Väst

Feb

27 000

Väst

Mar

21 000

I följande illustration visas en disposition med delsummor, grupperade efter region, samt en totalsumma.

Disposition med delsummor och totalsumma

Använd kommandot Delsumma (fliken Data, gruppen Disposition) för att skapa en disposition, delsummor och en totalsumma.

Den ursprungliga informationen innehöll tre datarader för region Öst och tre datarader för region Väst (raderna 2 till 7). Observera att delsummeringen infogade Öst Summa på rad 5 mellan den sista raden för Öst och den första raden för Väst.

Om du klickar på cell A4 och sedan på kommandot Delsumma skapas en disposition med rader för Öst Summa, Väst Summa och Totalsumma. Cellerna i kolumnen Försäljning fylls med dessa summor.

Mer information finns i följande artiklar:

Överst på sidan

Addera värden i en lista eller Excel-tabellkolumn med en funktion

Ett mer flexibelt alternativ till kommandot Delsumma är att använda funktionen DELSUMMA för att beräkna delsummor och totalsummor i listor eller Excel-tabeller som innehåller dolda rader eller kolumner. Med funktionen DELSUMMA anger du ett argument som inkluderar eller inte inkluderar dolda värden.

Obs!   Funktionen DELSUMMA kan styra om dolda rader ska tas med i beräkningen eller inte, men rader som har filtrerats bort ignoreras alltid.

Anta till exempel att du ska beräkna delsummor och totalsumma av värdena i cellerna C2 till C7, men att du vill ignorera data i de dolda raderna 3 och 6. Den funktion du använder ser då ut så här:

=DELSUMMA(109;C2:C7)

Det första argumentet (109) anger att du vill summera värdena i cellområdet och att dolda värden ska ignoreras. Om du vill ha med dolda värden i summa använder du i stället 9 som det första argumentet.

Mer detaljerad information finns i artikeln Funktionen DELSUMMA.

Överst på sidan

Summera data och analysera dem ur olika synvinklar

Om ett kalkylblad innehåller hundratals eller tusentals rader med liknande data, kan det vara svårt att få en överblick över informationen. Du kan skapa en pivottabellrapport i Excel med de här värdena som visar delsummor och totalsummor, och som kan sammanfatta data baserat på kategorier som du anger.

Du kan snabbt skapa en pivottabell genom att markera en cell i ett dataintervall eller en Excel-tabell och sedan klicka på Pivottabell i gruppen Tabeller på fliken Infoga.

Ett exempel på hur effektiv en pivottabell kan vara framgår av följande exempel, där det finns många rader med försäljningsstatistik (i själva verket är det 40 rader, men i bilden visas bara några av dem). Dessutom är värdena inte summerade, och det finns inga delsummor eller en totalsumma.

Data som används i en pivottabellrapport

En pivottabellrapport som baseras på samma data visar delsummor, totalsummor och ger en effektiv sammanfattning direkt.

Summerade data i en pivottabellrapport

När du skapar och arbetar med pivottabeller kan det behövas vissa förberedande åtgärder, och du kan behöva bekanta dig med några viktiga begrepp. Mer detaljerade information om hur du kommer igång finns i följande artiklar:


Överst på sidan

Summera data baserat på ett eller flera villkor

Med kalkylbladsfunktioner kan du tillämpa villkor (kallas även kriterier) så att du bara summerar data som uppfyller de villkor du anger.

Addera värden i ett cellområde baserat på ett enstaka villkor genom att använda en funktion eller en kombination av funktioner

Använd funktionen SUMMA.OM eller använd funktionen SUMMA inne i funktionen OM.

Du kan summera tal efter ett villkor genom att använda funktionen SUMMA.OM eller genom att kombinera funktionen SUMMA och funktionen OM.

Formeln =SUMMA.OM(A2:A6;">20") summerar endast värden i cellområdet A2 till A6 som är större än 20.

Obs!   Följande information är ganska teknisk, men den är definitivt användbar.

Om funktionen SUMMA.OM inte fanns, skulle det ändå gå att få samma resultat genom att kombinera funktionerna OM och SUMMA. Att kombinera funktioner på det här sättet kallas även "kapsling", eftersom den ena funktionen används inne i den andra funktionen.

Du kan skapa en formel som ger samma resultat som funktionen SUMMA.OM genom att skriva in en formel som behandlar området A2 till A6 som en matris, vilket betyder att hela området hanteras som ett enda objekt som innehåller fem element.

Formeln ser ut så här: {=SUMMA(OM(A2:A6>20;A2:A6))}. Klammerparenteserna som omger formeln visar att det är en matrisformel. En matrisformel kräver vissa särskilda åtgärer: I stället för att skriva parenteserna själv, måste du trycka på CTRL+SKIFT+RETUR – formeln =SUMMA(OM(A2:A6>20;A2:A6)) omges då med parenteserna. Om du skriver parenteserna själv skapas ingen matrisformel.

Försök själv!    

Kopiera värdena från följande tabell till ett kalkylblad vid cell A1. När du har klistrat in värdena märker du att cell A10 innehåller felet #VÄRDEFEL!. Det betyder att du måste konvertera cell A10 till en matrisformel. Gör detta genom att trycka på F2 och sedan trycka på CTRL+SKIFT+RETUR. Resultatet (65) visas i cellerna A8 och A10.

1

2

3

4

5

6

7

8

9

10

A

Vikt

18

29

36

11

16

Använda funktionen SUMMA.OM

=SUMMA.OM(A2:A6;">20")

Använda funktionerna SUMMA och OM

=SUMMA(OM(A2:A6>20;A2:A6))

Mer information finns i artikeln Funktionen SUMMA.OM och avsnittet "Addera tal baserat på ett villkor" i artikeln Addera tal.

Dessutom innehåller Knowledge Base-artikeln När du kan använda SUMMA(OM()) i stället för ANTAL.TOMMA() ytterligare information om när du kan använda funktionen SUMMA.OM.

Överst på sidan

Addera värden i en kolumn baserat på ett eller flera villkor genom att använda en funktion

Du kan använda funktionen DSUMMA för att addera tal i ett fält (en kolumn) i poster i en lista eller databas som uppfyller villkor (kallas även kriterier) som du anger.

Du kan också använda funktionen DSUMMA om du har en kolumnlista och tycker det är enklare att definiera dina villkor i ett separat cellområde i stället för med en kapslad funktion.

Mer information finns i artikeln Funktionen DSUMMA.

Du kan också läsa avsnittet "Addera tal baserade på förutsättningar i ett område" i artikeln Addera tal.

Överst på sidan

Addera värden i ett cellområde baserat på flera villkor genom att använda en enstaka funktion eller en kombination av funktioner

Använd funktionen SUMMA.OMF. Ange det område som ska summeras, ett område som innehåller villkor samt de villkor som ska tillämpas på villkorsområdet. Ett annat sätt är att kapsla funktionerna SUMMA och OM.

Mer information finns i artikeln Funktionen SUMMA.OMF.

Se avsnittet "Addera tal baserat på flera villkor" i artikeln Addera tal för mer information om hur du kombinerar funktionerna SUMMA och OM.

Dessutom finns ytterligare information i följande Knowledge Base-artiklar:

Överst på sidan

Summera kvadrerade värden och matriser

Du kan använda kalkylbladsfunktioner för att addera värden i två eller flera kolumner som hör ihop. Den här typen av beräkning kan något enkelt som att bestämma ett viktat medelvärde (se följande exempel som beräknar ett medelbetyg) eller en mer avancerad statistisk eller teknisk beräkning.

Summera motsvarande värden i en eller flera matriser

Använd funktionen PRODUKTSUMMA. Du kan till exempel beräkna ett medelbetyg genom att använda funktionen PRODUKTSUMMA och sedan dela resultatet med antalet poäng, enligt vad som visas i illustrationen.

Multiplikation av motsvarande värden i två matriser

Formeln =PRODUKTSUMMA(A2:A6;B2:B6)/SUMMA(B2:B6) beräknar ett medelbetyg genom att betyget i varje kurs multipliceras med antalet poäng. Sedan summeras produkterna (61,3) och divideras med antalet poäng (18) vilket ger medelbetyget (3,41). Den här typen av beräkning kallas även viktat genomsnitt.

Du kan också använda funktionen PRODUKTSUMMA i mer avancerade matematiska beräkningar genom att multiplicera flera matris med varandra.

Funktionen PRODUKTSUMMA är enkel att använda med matriser som har samma dimensioner, men du kan också använda funktionen SUMMA i en matrisformel om du behöver större flexibilitet.

Mer detaljerad information finns i artikeln Funktionen PRODUKTSUMMA.

Följande fyra funktioner används oftast bara i avancerade statistiska beräkningar eller komplexa matematiska modeller, så här ges endast en kortfattad beskrivning. Om du vill ha mer detaljerad information klickar du på funktionsnamnet för att gå direkt till motsvarande referensavsnitt.

  • Funktionen KVADRATSUMMA Returnerar summan av kvadraterna på en lista med tal eller värden i ett område. Till exempel returnerar KVADRATSUMMA(2;3) 13.

  • Funktionen SUMMAX2PY2 Adderar summan av kvadraterna av motsvarande värden i två matriser.

  • Funktionen SUMMAX2MY2  Returnerar summan av differenserna mellan kvadraterna av motsvarande värden i två matriser.

  • Funktionen SUMMAXMY2 Returnerar summan av kvadraterna av differenser mellan motsvarande värden i två matriser.

Överst på sidan

Specialfall (löpande saldon, unika värden)

Du kan använda kalkylbladsfunktioner för att skapa summor som uppdateras automatiskt när du lägger till data i ett område eller en tabell, eller för att bara summera unika värden som förekommer i ett område eller en tabell.

Skapa ett löpande saldo med en funktion

Använd funktionen SUMMA. Skapa till exempel kolumnrubriker i ett kalkylblad med namnen Insättningar, Uttag och Saldo.

  1. Skriv det ingående saldot i den första cellen under Saldo.

  2. I cellen direkt under saldot (i det här exempel cell C3) skriver du en formel som adderar värdet i kolumnen Insättningar på samma rad och subtraherar värdet i kolumnen Uttag()=SUMMA(C2;A3;-B3).

  3. Dra den här formeln nedåt till alla nya rader som du lägger till. I följande exempel dras formeln till rad 4.

1

2

3

4

A

B

C

Insättningar

Uttag

Saldo

500

1000

625

=SUMMA(C2;A3;-B3)

1000

740

=SUMMA(C3;A4;-B4)

Du kan använda ett löpande saldo på samma sätt som i ett checkhäfte, så att värdet ökar eller minskar automatiskt när du skriver in nya element och värden över tiden.

Mer information finns i artikeln Beräkna en löpande balans.

Överst på sidan

Addera de unika värdena i ett cellområde med en sammansatt formel

Skriv in värden i en kolumn så att kolumnen innehåller dubbletter, och använd sedan en kombination av funktionerna SUMMA, OM och FREKVENS för att endast summera de unika värden som finns i cellområdet.

Mer detaljerad information om hur du utför den här beräkningen finns i avsnittet "Addera unika värden" i artikeln Addera tal.

Överst på sidan

Inkludera värden från andra kalkylblad eller arbetsböcker i en formel

Du kan addera eller subtrahera celler eller dataområden från andra kalkylblad eller arbetsböcker i en formel genom att ange en referens till värdena. I följande tabell finns information om hur du refererar till en cell eller till ett cellområde i en annan arbetsbok eller i ett annat kalkylblad.

Om du vill referera till:

Skriver du så här

Exempel

En cell eller ett område i ett annat kalkylblad i samma arbetsbok

Namnet på kalkylbladet följt av ett utropstecken, följt av cellreferensen eller namnet.

Blad2!B2:B4
Blad3!Säljstatistik

En cell eller ett område en annan arbetsbok som är öppen

Arbetsbokens filnamn inom hakparenteser ([]) och kalkylbladets namn, följt av ett utropstecken, följt av cellreferensen eller namnet.

[Arbetsbok.xlsx]Blad1!A7

En cell eller ett område en annan arbetsbok som inte är öppen

Arbetsbokens fullständiga filnamn och sökväg inom hakparenteser ([]) och kalkylbladets namn, följt av ett utropstecken, följt av cellreferensen eller namnet. Om den fullständiga sökvägen innehåller blanktecken omger du sökvägen och filnamnet med enkla citattecken (se exemplet).

['C:\Mina dokument\[Arbetsbok.xlsx]Blad1'!A2:A5


Överst på sidan

Summera och subtrahera tids- och datumvärden

Om du behöver beräkna tidsintervall, uppskatta slutförandedatum eller liknande kan du använda tids- och datumfunktioner, eller bara enkel addition och subtraktion. I följande tabell visas några formler som beräknar tidsintervall och dagar. Observera att om resultatet blir negativt när du subtraherar från ett datum eller ett klockslag visas tecknen ### i den cell som innehåller formeln.

1

2

3

4

5

A

B

C

Starttid

Sluttid

Formel för tidsintervall

Beskrivning (resultat)

11:55:24

14:48:13

=B2-A2

Visar skillnaden i timmar, minuter och sekunder (02:52:49). Om du använder amerikanskt datumformat visas resultatet som "2:52:49 AM" eftersom tidsdifferensen är mindre än 12 timmar. Om differensen vore större än 12 timmar skulle värdet visas med "PM".

Startdatum

Slutdatum

Formel för tidsintervall

Beskrivning (resultat)

2008-05-28

2008-06-03

=B5-A5

Visar skillnaden i antal dygn som ett heltal (6)

När du arbetar med klockslag och datumvärden kan beräkningarna ge oväntade resultat, så var noggrann när du anger värdena.

Överst på sidan

Visa beräkningar i statusfältet i Excel

Ett snabbt sätt att visa summan av de celler som är markerade i ett kalkylblad är att titta på statusfältet i Excel (statusfältet finns längst ned i dokumentfönstret). I statusfältet visas summan av två eller flera markerade celler som innehåller numeriska data. Summavärdet i statusfältet uppdateras omedelbart när du markerar fler celler eller avmarkerar celler.

Statusfältet i Excel

Statusfältet i Excel

Beräknad summa i statusfältet i Excel

Om du har markerat en eller flera celler visas information om cellerna i statusfältet i Excel. Om du till exempel har markerat fyra celler i kalkylbladet, och om dessa celler innehåller värdena 2, 3, en textsträng (t.ex. "moln") och 4, kan följande beräknade värden visas i statusfältet samtidigt: medelvärde, antal, antal numeriska värden, minimivärde, maximivärde och summa. Du kan visa eller dölja värdena genom att högerklicka på statusfältet. Dessa värden visas i illustrationen nedan.

Statusfält med beräknade värden och antal markerade celler

Obs!    I tidigare versioner av Excel än Excel 2007 kan endast ett av dessa värden visas åt gången i statusfältet.

Överst på sidan

Gäller för: Excel 2007, Excel 2010



Hade du nytta av den här informationen?

Ja Nej

Hur kan vi förbättra den?

255 återstående tecken

För att skydda din integritet bör du inte ange någon kontaktinformation i feedbacken. Granska våra sekretesspolicy.

Tack för din feedback!

Supportresurser

Ändra språk