Korrigera brutna länkar till data

Om arbetsboken innehåller en länk till data i en arbetsbok eller annan fil som har flyttats till en annan plats, kan du korrigera länken genom att uppdatera sökvägen till denna källfil. Om du inte hittar eller inte har tillgång till dokumentet som du ursprungligen länkade till, kan du förhindra att Excel försöker att uppdatera länken genom att inaktivera automatisk uppdatering eller ta bort länken.

Viktigt!: länkat objekt är inte detsamma som hyperlänkar. I följande procedur korrigeras inte brutna hyperlänkar. Mer information om hyperlänkar finns i Skapa, redigera eller ta bort en hyperlänk

Gör något av följande:

Korrigera en bruten länk

Varning!: Den här åtgärden kan inte ångras. Du bör spara en säkerhetskopia av arbetsboken innan du börjar med proceduren.

  1. Öppna arbetsboken som innehåller den brutna länken.

  2. Klicka på LänkarRedigera-menyn.

    Kommandot Länkar är inte tillgängligt om arbetsboken inte innehåller några länkar.

  3. Klicka på den brutna länk som du vill reparera i rutan Källfil.

    Obs!: Om du vill reparera flera länkar håller du ned KOMMANDO och klickar på länkarna.

  4. Klicka på Ändra källa.

  5. Gör något av följande:

Om du vill

Gör du så här

Korrigera en bruten länk till ett blad i en annan arbetsbok

Leta reda på arbetsboken i dialogrutan Öppna och klicka på Ändra.

Korrigera en bruten länk till en arbetsbok i ett annat Office-dokument

Skriv namnet eller platsen för dokumentet i textrutan Ändra länkar till och klicka på OK.

Inaktivera automatisk uppdatering av länkade data

  1. Öppna arbetsboken som innehåller den brutna länken.

  2. Klicka på LänkarRedigera-menyn.

    Kommandot Länkar är inte tillgängligt om arbetsboken inte innehåller några länkar.

  3. Klicka på den brutna länk som du vill reparera i rutan Källfil.

    Obs!: Om du vill reparera flera länkar håller du ned KOMMANDO och klickar på länkarna.

  4. Klicka på Manuellt.

Ta bort en bruten länk

När du bryter en länk konverteras alla formler som refererar till källfilen till deras aktuella värde. Om till exempel formeln =SUMMA([Budget.xls]Årlig!C10:C25) resulterar i 45, konverteras formeln till 45 när länken bryts.

  1. Öppna arbetsboken som innehåller den brutna länken.

  2. Klicka på LänkarRedigera-menyn.

    Kommandot Länkar är inte tillgängligt om arbetsboken inte innehåller några länkar.

  3. Klicka på den brutna länken som du vill ta bort i rutan Källfil.

    Obs!: Om du vill ta bort flera länkar håller du ned KOMMANDO och klickar på respektive länk.

  4. Klicka på Bryt länk.

Se även

Importera data från en CSV-, HTML- eller textfil

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×