Korrigera #VÄRDEFEL!-fel i funktionen SAMMANFOGA

Viktigt!: I Excel 2016, Excel Mobile, och Excel Online har SAMMANFOGA ersatts av funktionen SAMMAN. SAMMANFOGA-funktionen är fortfarande tillgänglig för bakåtkompatibilitet, men du bör överväga att använda SAMMAN eftersom det är en mer robust funktion.

En av de vanligaste scenarierna där du stöter på #VÄRDEFEL! med SAMMANFOGA är när du försöker skapa en sträng som innehåller en cellreferens som innehåller ett fel, till exempel #VÄRDEFEL!.

I följande exempel vill vi sammanfoga D2, E2 och F2, och E2 har ett #VÄRDEFEL!.

#VÄRDEFEL!-fel i SAMMANFOGA

Felet i E2 gör att funktionen visar felet #VÄRDEFEL!. För att det ska fungera måste du ersätta felet med ett annat värde än felet. Du kan skapa en formel som söker efter fel i cellreferensen, och i så fall visa en textsträng där 0 visas i stället för felet (eller du kan ersätta 0 med någon annan text, men du måste innesluta texten inom citattecken – ”Din text”).

Den här formeln fungerar:

=OM(ÄRFEL(E2);SAMMANFOGA(D2;” ”;0;” ”;F2))

Funktionerna OM och ÄRFEL funktioner används som en lösning för att sammanfoga en sträng med felet #VÄRDEFEL!

Hur fungerar det här? Funktionen OM funktionen OMFEL för att fastställa om det finns ett fel i E2. Om det finns det kombinerar funktionen SAMMANFOGA värdena i D2, E2 och F2 (funktionen ersätter felet med 0), och visar den resulterande textsträngen. Observera att formeln också använder blanksteg (” ”) för att skilja värden åt.

Åtgärda #VÄRDEFEL! med SAMMANFOGA i Excel 2003 och tidigare versioner

Om du får #VÄRDEFEL! i Office Excel 2003 eller äldre versioner måste du avmarkera alternativet Alternativ uttrycksvärdering i Excel. Följ de steg som beskrivs i #VÄRDEFEL! vid sammanfogning av celler för att lösa problemet.

Har du en specifik fråga om funktioner?

Ställ en fråga i Excel-communityforumet

Hjälp oss att göra Excel bättre

Har du förslag på hur vi kan förbättra nästa version av Excel? Titta i så fall på avsnitten i Excel User Voice.

Mer information finns i

Korrigera ett #VÄRDEFEL!

Funktionen SAMMANFOGA

Funktionen SAMMAN

Översikt över formler i Excel

Hur du undviker felaktiga formler

Använd felkontroll om du vill hitta fel i formler

Alla Excel-funktioner (alfabetisk ordning)

Alla Excel-funktioner (efter kategori)

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×