Fel
Korrigera #SAKNAS!-fel

Korrigera #SAKNAS!-fel

#SAKNAS!-felet betyder vanligtvis att en formel inte kan hitta vad den har blivit ombedd att leta efter.

Bästa lösning

Den vanligaste orsaken till #SAKNAS!-felet är om en av funktionerna LETARAD, LETAKOLUMN, LETAUPP eller PASSA i en formel inte kan hitta värdet en referens pekar på. Uppslagsvärdet kanske inte förekommer i källdata t.ex.

Uppslagsvärdet finns inte.  Formeln i cell E2 är =LETARAD(D2,$D$6:$E$8,2,FALSKT).  Det går inte att hitta värdet Banana. Formeln returnerar därför ett #SAKNAS!-fel.
Objektet hittades inte i källdata

I det här fallet finns det ingen "Banana" i uppslagstabellen och LETARAD returnerar därför ett #SAKNAS!-fel.

Lösning: Se antingen till att uppslagsvärdet finns i källdata eller använd en felhanteringsfunktion, t.ex. OMFEL, i formeln. Exempelvis =OMFEL(FORMEL(),0), vilket innebär:

  • = OM(0 returneras om formeln utvärderas till ett fel. I annat fall visas formelns resultat)

Du kan använda "" till att visas ingenting eller ersätta med en egen text: =OMFEL(FORMEL(); "Ange felmeddelandet här")

Om du inte vet vad du ska göra nu, eller vilken typ av hjälp du behöver, kan du söka efter liknande frågor i Excel Community-forumet eller skapa en egen fråga.

Länk till Excel Community-forumet

Om du vill gå vidare finns felsökningsanvisningar i den följande checklistan som kan hjälpa dig ta reda på vad som kan ha blivit fel i dina formler.

Uppslagsvärdet och källdata är olika datatyper. Om du t.ex. försöker få LETARAD att referera till ett tal samtidigt som källdata är lagrade som text.

Felaktiga värdetyper.  I exemplet visas en LETARAD-formel som returnerar #SAKNAS!-felet eftersom uppslagsobjektet är formaterat som ett tal medan uppslagstabellen är formaterad som text.
#SAKNAS!-fel som orsakas av olika datatyper

Lösning: Se till att datatyperna är desamma. Du kan kontrollera cellformat genom att markera en cell eller ett cellområde, högerklicka, välja Formatera celler > Tal (eller trycka på Ctrl+1) och ändra talformatet om det behövs.

Dialogrutan Formatera celler med fliken Tal och alternativet Text markerat

Tips: Om du vill genomföra en formatändring på en hel kolumn använder du först önskat format och använder sedan Data > Text till kolumner > Slutför.

Du kan använda funktionen RENSA till att ta bort alla inledande eller avslutande blanksteg. I följande exempel används RENSA inkapslad i funktionen LETARAD för att ta bort inledande blanksteg från namnen i A2:A7 och returnera avdelningsnamnet.

Använda LETARAD med RENSA i en matrisformel för att ta bort inledande/avslutande blanksteg.  Formeln i cell E3 är {=LETARAD(D2,RENSA(A2:B7),2,FALSKT)} och måste anges med Ctrl+Skift+Retur.

{=LETARAD(D2,RENSA(A2:B7),2,FALSKT)}

Obs!: Det här är en matrisformel som måste anges med Ctrl+Skift+Retur. Formeln omges automatiskt av klammerparenteser {} i Excel. Om du försöker ange dem själv visas formeln som text i Excel.

Som standard måste funktioner som söker efter information i tabeller sorteras i stigande ordning. Men kalkylbladsfunktionerna LETARAD och LETAKOLUMN innehåller ett ungefärlig-argument som instruerar funktionen att söka efter en exakt matchning även om tabellen inte är sorterad. Om du vill söka efter en exakt matchning anger du argumentet ungefärlig till FALSKT. Observera att om SANT används, d.v.s. att funktionen instrueras att söka efter en ungefärlig matchning, inte bara kan resultera i ett #SAKNAS!-fel utan kan också returnera felaktiga resultat som i exemplet nedan.

Exempel på hur användning av LETARAD med SANT som värde på argumentet ungefärlig kan orsaka felaktiga resultat.
LETARAD misslyckas p.g.a. att ungefärlig matchning användes i en osorterad tabell

I det här exemplet returnerar inte bara "Banana" ett #SAKNAS!-fel. "Pear" returnerar dessutom fel pris. Det beror på att SANT används för argumentet, vilket instruerar LETARAD att söka efter en ungefärlig matchning i stället för en exakt matchning. Det finns ingen nära matchning för "Banana" och "Pear" kommer före "Peach" i alfabetisk ordning. I det här fallet skulle LETARAD med argumentvärdet FALSKT returnera rätt pris för "Pear" medan "Banana" fortfarande skulle resultera i ett #SAKNAS!-fel eftersom "Banana" inte finns i uppslagslistan.

Om du använder funktionen PASSA kan du ändra värdet i argumentet typ och ange tabellens sorteringsordning. Om du vill hitta en exakt matchning anger du värdet 0 (noll) för argumentet typ.

Det här kan du lösa genom att först kontrollera att området som refereraras av matrisformeln har samma antal rader och kolumner som det cellområde där matrisformlen angavs. Du kan också ange matrisformeln i färre eller fler celler och på så vis matcha områdesreferensen i formeln.

I det här exemplet refererar cell E2 till områden som inte matchar:

Exempel på matrisform med områdesreferenser som inte matchar och orsakar ett #SAKNAS!-fel.  Formeln i cell E2 är {=SUMMA(OM(A2:A11=D2,B2:B5))} och måste anges med Ctrl+Skift+Retur.

{=SUMMA(OM(A2:A11=D2,B2:B5))}

Den måste ändras så att båda områden speglar raderna 2 till 11 för att formeln ska kunna beräknas korrekt.

{=SUMMA(OM(A2:A11=D2,B2:B11))}

Obs!: Det här är en matrisformel som måste anges med Ctrl+Skift+Retur. Formeln omges automatiskt av klammerparenteser {} i Excel. Om du försöker ange dem själv visas formeln som text i Excel.

Exempel på förekomsten av #SAKNAS! i celler och hur det förhindrar en SUMMA-formel från att beräknas korrekt.

I det här fallet har May-December #SAKNAS-värden. Total kan därför inte beräknas och i stället returneras ett #SAKNAS!-fel.

Det här kan du lösa genom att kontrollera formelsyntaxen för den formel du använder och ange alla obligatoriska argument i formeln som returnerar felet. Det kan kräva att du kontrollerar funktionen i Visual Basic Editor (VBE). Du kan öppna VBE från fliken Utvecklare eller med ALT+F11.

Det löser du genom att kontrollera att den användardefinierade funktionen är öppen och fungerar.

Det löser du genom att kontrollera att argumenten i funktionen stämmer och att de är rätt placerade.

Du löser det genom att trycka på Ctr+Alt+F9 så beräknas kalkylbladet på nytt

Du kan använda funktionsguiden som hjälpa om du är osäker på rätt argument. Markera cellen med formeln i fråga, gå sedan till fliken Formel i menyfliksområdet och tryck på Infoga funktion.

Knappen Infoga funktion.

Excel laddar automatiskt guiden åt dig:

Exempel på dialogrutan Formelguiden.

När du klickar på ett argument visas relaterad information om det i Excel.

#SAKNAS! kan vara användbart! Det är vanligt att använda #SAKNAS! när du använder data som i följande exempel för diagram eftersom #SAKNAS!-värden inte ritas i diagram. Här följer exempel på hur diagram ser ut med nollvärden jämfört med #SAKNAS!-värden.

Exempel på ett linjediagram som visar nollvärden.

I exemplet ovan ser du att nollvärden har ritats och visas som en platt linje längst ned i diagrammet som sedan skjuter i höjden för att visa summan. I följande exempel visas hur det ser ut när nollvärden ersätts med #SAKNAS!.

Exempel på ett linjediagram som inte visar #SAKNAS!-värden.

Mer information om ett #SAKNAS!-fel som visas i en viss funktion finns i avsnitten nedan:

Överst på sidan

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community, få support i Answers-communityn eller föreslå en ny funktion eller förbättringar på Excel User Voice.

Mer information finns i

Konvertera tal som är sparade som text till tal

Funktionen LETARAD

Funktionen LETAKOLUMN

Funktionen LETAUPP

Funktionen PASSA

Översikt över formler i Excel

Hur du undviker felaktiga formler

Använd felkontroll om du vill hitta fel i formler

Kortkommandon i Excel för Windows

Kortkommandon i Excel för Mac

Alla Excel-funktioner (alfabetisk ordning)

Alla Excel-funktioner (efter kategori)

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×