Korrigera #DIVISION/0!-fel

Felet #DIVISION/0! visas i Microsoft Excel om ett tal delas med noll (0). Det händer när du anger en enkel formel som =5/0 eller när en formel refererar till en cell som innehåller 0 eller är tom, som i följande bild.

Exempel på formler som orsakar #DIVISION/0!-fel.

Åtgärda felet genom att göra något av följande:

  • Kontrollera att nämnaren i funktionen eller formeln inte är noll eller en tom cell.

  • Ändra cellreferensen i formeln till en annan cell som inte innehåller en nolla (0) eller ett tomt värde.

  • Ange #SAKNAS! i cellen som refereras som nämnaren i formeln. Då ändras formelresultatet till #SAKNAS! vilket innebär att nämnarvärdet inte finns tillgängligt.

Felet #DIVISION/0! går många gånger inte att undvika eftersom dina formler väntar på indata från dig eller någon annan. Vid sådana tillfällen vill du inte att felmeddelandet ska visas alls. Det finns därför några felhanteringsmetoder som du kan använda för att dölja felet när du väntar på indata.

Utvärdera nämnaren för 0 eller inget värde

Det enklaste sättet att dölja #DIVISION/0!-felet är att använda funktionen OM till att utvärdera om det finns en nämnare. Om nämnaren är 0 eller saknar ett värde visa då 0 eller inget värde som formelresultatet i stället för #DIVISION/0!-felvärdet. Beräkna formeln i annat fall.

Exempel: Om formeln som returnerar felet är =A2/A3 använder du =OM(A3,A2/A3,0) för att returnera 0 eller =OM(A3,A2/A3,"") för att returnera en tom sträng. Du kan också visa ett anpassat meddelande så här: =OM(A3,A2/A3;"Indata krävs"). Med funktionen KVOT från det första exemplet skulle du använda =OM(A3,KVOT(A2,A3),0). Det innebär följande: OM(A3 finns, returnera resultatet av formeln, ignorera det annars).

Exempel på sätt att åtgärda #DIVISION/0!-fel.

Använd OMFEL för att dölja #DIVISION/0!-fel

Du kan också dölja det här felet genom att kapsla in divisionen i funktionen OMFEL. Igen, för A2/A3 kan du använda =OMFEL(A2/A3,0). Det innebär att om formeln utvärderas till ett fel returneras 0. Annars returneras resultatet av formeln.

För tidigare versioner av Excel än Excel 2007 kan du använda OM(ÄRFEL())-metoden: =OM(ÄRFEL(A2/A3),0,A2/A3) (se ÄR-funktioner).

Obs! Både OMFEL- och OM(ÄRFEL())-metoderna är generella felhanterare på så sätt att de döljer alla fel, inte bara #DIVISION/0!. Du måste se till att formeln fungerar korrekt innan du använder någon felhantering. Om du inte gör det kan det hända att formeln inte fungerar som väntat utan att du ser det.

Tips:  Om du har aktiverat felkontroll i Excel kan du klicka på Bild av knapp bredvid den cell som visar felet. Klicka på Visa beräkningssteg, om det alternativet finns tillgängligt, och välj den lösning som fungerar för dina data.

Har du en specifik fråga om funktioner?

Ställ en fråga i Excel-communityforumet

Hjälp oss att göra Excel bättre

Har du förslag på hur vi kan förbättra nästa version av Excel? Titta i så fall på avsnitten i Excel User Voice.

Mer information finns i

Funktionen OM

Funktionen OMFEL

ÄR-funktioner

Översikt över formler i Excel

Hur du undviker felaktiga formler

Använd felkontroll om du vill hitta fel i formler

Excel-funktioner (alfabetisk ordning)

Excel-funktioner (efter kategori)

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×