Kapsla in en funktion i en funktion

Viktigt!: Den här artikeln är maskinöversatt, se ansvarsfriskrivningen. Den engelska versionen av den här artikeln finns här för din referens.

När du skapar en formel med hjälp av en funktion kan du kapsla funktioner inuti andra funktioner. När du gör du använder resultatet från funktionerna kapslad som argumentets– element funktionen första ska kunna köras korrekt. Du kan alltid se när en funktion är kapslat eftersom det är inom parentes.

Här är ett exempel. Funktionen OM använder de inkapslade funktionerna MEDEL och SUMMA som argument.

=OM(MEDEL(F2:F5)>50,SUMMA(G2:G5);0)

Du kan läsa den här formeln från vänster till höger. OM medelvärdet av cellerna F2 till F5 är högre än 50 SUMMERAS värdena i cellerna G2 till G5. Annars returneras 0.

Du kan kapsla in 64 nivåer av funktioner och du anger dem som andra funktioner:

  1. Klicka på cellen som innehåller formeln.

  2. Ange formeln i formelfältet och tryck på Retur.

Här är ett annat exempel. Funktionen OM kapslas in i en annan OM-funktion för att beräkna avdrag baserat på inkomstnivå.

=OM(A5<31500,A5*15%,OM(A5<72500,A5*25%,A5*28%))

Du kan läsa även det här exemplet från vänster till höger. OM värdet i cellen A5 är mindre än 31 500 multiplicerar du värdet med 15 %. OM det inte är det kontrollerar du om värdet är mindre än 72 500. OM det är det multiplicerar du det med 25 % och om det inte är det multiplicerar du det med 28 %.

Observera att inkomstnivån inte använder komman. Om den hade gjort det hade funktionen OM försökt använda den som argument och formeln hade slutat fungera.

Överst på sidan

Obs!: Ansvarsfriskrivning för maskinöversättning: Den här artikeln har översatts av ett datorsystem utan mänsklig inblandning. Microsoft erbjuder dessa maskinöversättningar för att hjälpa icke engelskspråkiga användare att ta del av information om Microsofts produkter, tjänster och tekniker. Eftersom artikeln är maskinöversatt kan den innehålla fel i ordval, syntax och grammatik.

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×