Importera XML-data

Om du tidigare skapade en XML-mappning kan du använda den för att importera XML-data till celler som har mappats, men det finns även flera metoder och kommandon för att importera XML-data utan en XML-mappning.

Om du har en XML-mappning gör du så här för att importera XML-data till mappade celler:

  1. Välj en av de mappade cellerna i XML-mappningen.

  2. Klicka på Utvecklare > Importera.

    Om du inte ser fliken Utvecklare läser du Visa fliken Utvecklare.

  3. Leta rätt på och markera den XML-datafil (.xml) du vill importera i dialogrutan Importera XML. Klicka sedan på Importera.

Andra sätt att importera XML-data

Mer information om problem finns i Vanliga problem med att importera XML-data i slutet av den här artikeln.

Importera en XML-datafil som en XML-tabell

  1. Klicka på Utvecklare > Importera.

    Om du inte ser fliken Utvecklare läser du Visa fliken Utvecklare.

  2. Leta rätt på och markera den XML-datafil (.xml) du vill importera i dialogrutan Importera XML. Klicka sedan på Importera.

    Om XML-datafilen inte refererar till ett schema härleds schemat i Excel från XML-datafilen.

  3. Gör något av följande i dialogrutan Importera data:

    1. Markera XML-tabell i befintligt kalkylblad för att importera innehållet i XML-datafilen till en XML-tabell i kalkylbladet på den angivna cellplatsen.

    2. Markera XML-tabell i nytt kalkylblad för att importera innehållet i filen till en XML-tabell i ett nytt kalkylblad med början i cell A1. Schemat för XML-datafilen visas i åtgärdsfönstret XML-källa.

  4. Om XML-datafilen inte refererar till ett schema härleds schemat i Excel från XML-datafilen.

  5. Klicka på Egenskaper om du vill visa dialogrutan Egenskaper för XML-mappning där du kan konfigurera XML-dataegenskaper (t.ex. databindning, format och layout). Till exempel är standardinställningen att befintliga data i ett mappat område skrivs över när du importerar data. Det kan du dock ändra.

Importera flera XML-datafiler

  1. Markera en mappad cell om du vill importera flera XML-filer till en enda uppsättning mappade celler.

    Klicka på en cell i kalkylbladet som inte är mappad om du vill importera flera XML-datafiler till flera uppsättningar mappade celler.

  2. Klicka på Utvecklare > Importera.

    Om du inte ser fliken Utvecklare läser du Visa fliken Utvecklare.

  3. Leta rätt på och markera den XML-datafil (.xml) du vill importera i dialogrutan Importera XML.

    • Om filerna är angränsande trycker du på Skift-tangenten och klickar på den första och sista filen i listan. Alla data från XML-filerna importeras och läggs till i de mappade cellerna.

    • Om filerna inte är angränsande håller du ned Ctrl-tangenten och klicka på varje fil du vill importera i listan.

  4. Klicka på Importera.

    Dialogrutan Importerar <filnamn>.xml visas om du har markerat filer som inte är angränsande. För varje fil markerar du den XML-mappning som motsvarar den XML-datafil du importerar.

    Välj Använd XML-mappningen för samtliga markerade filer i schemat om du vill använda en enda karta för alla markerade filer som inte har importerats än.

Importera flera XML-datafiler som externa data

Du kan använda kommandot Från XML-dataimport om du vill importera flera XML-filer som använder samma namnområde men olika XML-scheman. I Excel skapas en unik XML-mappning för varje XML-datafil du importerar.

Obs!: Om du importerar flera XML-filer som inte definierar ett namnområde behandlas de här XML-filerna som om de använder samma namnområde.

  1. Om du använder Excel med en Office 365-prenumeration klickar du på Data > Hämta data > Från fil > Från XML.

    Om du använder Excel 2016 eller tidigare klickar du på Data > Från andra källor > Från XML-dataimport.

  2. Gå till den enhet, mapp eller Internetplats där XML-datafilen (.xml) du vill importera finns.

  3. Markera filen och klicka på Öppna.

  4. Gör något av följande i dialogrutan Importera data:

    • XML-tabell i befintligt kalkylblad    Innehållet i filen importeras till en ny XML-tabell i ett nytt kalkylblad. Om XML-datafilen inte refererar till ett schema härleds schemat i Excel från XML-datafilen.

    • Befintligt kalkylblad    XML-data importeras till en tvådimensionell tabell med rader och kolumner. I tabellen visas XML-taggar som kolumnrubriker medan data visas i raderna under kolumnrubrikerna. Det första elementet (rotnoden) används som en rubrik och visas i den angivna cellplatsen. Resten av taggarna sorteras i alfabetisk ordning längs den andra raden. I det här fallet härleds inget schema i Excel och du kan heller inte använda en XML-mappning.

    • Nytt kalkylblad    Ett nytt kalkylblad läggs till i arbetsboken i Excel. XML-data placeras automatiskt i det övre vänstra hörnet i det nya kalkylbladet. Om XML-datafilen inte refererar till ett schema härleds schemat i Excel från XML-datafilen.

  5. Klicka på Egenskaper om du vill visa dialogrutan Egenskaper för XML-mappning där du kan konfigurera XML-dataegenskaper, t.ex. databindning, format och layout. Till exempel är standardinställningen att befintliga data i ett mappat område skrivs över när du importerar data. Det kan du dock ändra.

Öppna en XML-datafil för att importera data i den

  1. Klicka på Arkiv > Öppna.

    Klicka på Microsoft Office-knappen Bild av Office-knappen > Öppna om du använder Excel 2007.

  2. I dialogrutan Öppna klickar du på den enhet, mapp eller Internetplats där filen du vill öppna finns.  

  3. Markera filen och klicka på Öppna.

  4. Om dialogrutan Importera XML visas refererar den fil du öppnade till en eller XSLT-formatmallar (Extensible Stylesheet Language Transformation). Du kan då klicka på ett av följande alternativ:

    • Öppna filen utan att använda en formatmall    XML-data importeras till en tvådimensionell tabell med rader och kolumner. I tabellen visas XML-taggar som kolumnrubriker medan data visas i raderna under kolumnrubrikerna. Det första elementet (rotnoden) används som en rubrik och visas i den angivna cellplatsen. Resten av taggarna sorteras i alfabetisk ordning längs den andra raden. I det här fallet härleds inget schema i Excel och du kan heller inte använda en XML-mappning.

    • Öppna filen med följande formatmall (välj en)    Välj den formatmall som du vill använda och klicka sedan på OK. XML-data formateras i enlighet med formatmallen du valde.

      Obs!: XML-data öppnas som skrivskyddade i Excel så att du inte oavsiktligt sparar den ursprungliga källfilen i filformatet Makroaktiverad Excel-arbetsbok (.xlsm). I det här fallet härleds inget schema i Excel och du kan heller inte använda en XML-mappning.

  5. Om dialogrutan Öppna XML visas har XML-filen inga XSLT-formatmallreferenser. Öppna filen genom att klicka på ett av följande alternativ:

    • Klicka på Som en XML-tabell för att skapa en XML-tabell i en ny arbetsbok.

      Innehållet i filen importeras till XML-tabellen. Om XML-datafilen inte refererar till ett schema härleds schemat i Excel från XML-datafilen.

    • Klicka på Som en skrivskyddad arbetsbok.

      XML-data importeras till en tvådimensionell tabell med rader och kolumner. I tabellen visas XML-taggar som kolumnrubriker medan data visas i raderna under kolumnrubrikerna. Det första elementet (rotnoden) används som en rubrik och visas i den angivna cellplatsen. Resten av taggarna sorteras i alfabetisk ordning längs den andra raden. I det här fallet härleds inget schema i Excel och du kan heller inte använda en XML-mappning.

      XML-data öppnas som skrivskyddade i Excel så att du inte oavsiktligt sparar den ursprungliga källfilen i filformatet Makroaktiverad Excel-arbetsbok (.xlsm). I det här fallet härleds inget schema i Excel och du kan heller inte använda en XML-mappning.

    • Klicka på Använd åtgärdsfönstret XML-källa.

      Schemat för XML-datafilen visas i åtgärdsfönstret XML-källa. Du kan då dra element i schemat till kalkylbladet för att mappa elementen till kalkylbladet.

      Om XML-datafilen inte refererar till ett schema härleds schemat i Excel från XML-datafilen.

Vanliga problem med att importera XML-data

Dialogrutan XML-importfel visas i Excel om det inte går att verifiera data enligt XML-mappningen. Klicka på Information i den här dialogrutan för ytterligare information om varje fel. Följande tabell innehåller några vanliga importfel:

Fel

Vad hände

Schemaverifieringen misslyckades

Data importerades när du klickade på Verifiera data mot schema för import och export i dialogrutan Egenskaper för XML-mappning, men data verifierades inte mot den angivna XML-mappning.

Vissa data importerades som text

Vissa eller alla data som du importerade har konverterats från sina deklarerade datatyper till text. Du måste konvertera dessa data från text till tal eller datum om du vill använda dem i en beräkning. Till exempel så fungerar inte ett datumvärde som har konverterats till text som det ska i funktionen År förrän du konverterar det till datatypen Datum. I Excel omvandlas data till text när:

  • Data är i ett format som Excel inte stöder.

  • Data är inkompatibla med Excels interna representation av datatypen XSD. Lös problemet genom att kontrollera varje datatypdeklaration för att säkerställa att dina XML-data är giltiga enligt XML-schemat.

XML-tolkningsfel

XML-tolkaren kan inte öppna den angivna XML-filen. Kontrollera att XML-filen inte innehåller syntaxfel och att XML-koden är korrekt.

Det går inte att hitta en XML-mappning som motsvarar data

Det här problemet kan uppstå när du markerar mer än en XML-datafil att importera och Excel inte kan hitta en matchande XML-mappning för en av filerna. Importera först ett lämpligt schema för den fil som namnges på namnlisten i dialogrutan och försök sedan importera filen igen.

Storleken på en XML-tabell kan inte ändras så att data får plats

Du försöker lägga till rader genom att importera eller lägga till data till XML-tabellen, men det finns inget utrymme för tabellen att expandera. En XML-tabell kan bara expandera från nederkanten och nedåt. Det kan finnas ett objekt, t.ex. en bild eller en annan tabell, direkt under XML-tabellen som hindrar XML-tabellen från att expandera. Det kan också vara så att om XML-tabellen expanderar så överskrider den radbegränsningen i Excel på 1 048 576. Åtgärda det här problemet genom att ordna om tabellerna och objekten i kalkylbladet så att XML-tabellen kan expandera från nederkanten och nedåt.

Den angivna XML-filen refererar inte till ett schema

XML-filen du försöker öppna refererar inte till ett XML-schema. För arbete med de XML-data som finns i filen i Excel krävs ett schema baserat på innehållet i XML-filen. Om det schemat är felaktigt eller otillräckligt tar du bort det från arbetsboken. Skapa sedan en XML-schemafil och redigera XML-datafilen så att den refererar till schemat. Mer information finns i Mappa XML-element till celler i en XML-mappning.

Obs!: Du kan inte exportera det Excel-härledda schemat som en separat XML-schemadatafil (.xsd). Även om det finns XML-schemaredigerare och andra metoder för att skapa XML-schemafiler kanske du inte har tillgång till dem eller vet hur de ska användas.

Följ anvisningarna nedan för att ta bort det schema som skapades av Excel från arbetsboken:

  1. Klicka på Utvecklare > Källa.

    XML-kommandon på fliken Utvecklare

    Om du inte ser fliken Utvecklare läser du Visa fliken Utvecklare.

  2. Klicka på XML-mappningar i åtgärdsfönstret XML-källa.

  3. I dialogrutan XML-mappningar klickar du på den XML-mappning som skapades av Excel och klickar sedan på Ta bort.

Flera XML-filer som använder samma namnområde importerades men olika scheman fungerar inte som väntat

När du arbetar med flera XML-datafiler och XML-scheman kan du vanligtvis skapa en XML-mappning för varje schema, mappa de element du vill använda och sedan importera varje XML-datafil till lämplig XML-mappning. Du kan bara använda ett XML-schema om du använder kommandot Importera för att öppna flera XML-filer med samma namnområde. Du kan få oväntade resultat om du använder det här kommandot för att öppna flera XML-filer som använder samma namnområde men olika scheman. Data kan t.ex. skrivas över eller så kanske det inte går att öppna filer.

Använd kommandot Från XML-dataimport (klicka på Data > Från andra källor) om du vill importera flera XML-filer som använder samma namnområde men olika XML-scheman. Med det här kommandot kan flera XML-filer med samma namnområde använda olika XML-scheman. I Excel skapas en unik XML-mappning för varje XML-datafil du importerar.

Obs!: Om du importerar flera XML-filer som inte definierar ett namnområde behandlas de här XML-filerna som om de använder samma namnområde.

Visa fliken Utvecklare

Om fliken Utvecklare inte visas tar du fram den på följande sätt:

  • I Excel 2013 och Excel 2010:

    1. Klicka på Arkiv > Alternativ.

    2. Klicka på kategorin Anpassa menyfliksområdet.

    3. Markera rutan Utvecklare under Primära flikar och klicka på OK.

  • I Excel 2007:

    1. Klicka på Microsoft Office-knappen Bild av Office-knappen > Excel-alternativ.

    2. Klicka på kategorin Populära.

    3. Markera rutan Visa fliken Utvecklare i menyfliksområdet under De vanligaste alternativen när du arbetar i Excel och klicka på OK.

Mer information finns i

Översikt över XML i Excel

Mappa XML-element till celler i en XML-mappning

Exportera XML-data

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×