Hur du undviker felaktiga formler

Viktigt!: Den här artikeln är maskinöversatt, se ansvarsfriskrivningen. Den engelska versionen av den här artikeln finns här för din referens.

Det kan vara mycket frustrerande när formler visar oväntade resultat eller fel, särskilt om du inte vet vad du ska göra härnäst.

Det kan finnas många orsaker till att det blir fel. Det kan till exempel finnas parenteser som inte matchar varandra, skrivfel och referenser till data i områden som inte finns. Följande rekommendationer kan hjälpa dig att förhindra eller lösa vanliga misstag när du bygger upp eller korrigerar formler.

Använd den här metoden:

För att undvika vanliga misstag:

Börja varje funktion med ett likhetstecken (=)

Om din inmatning inte börjar med ett likhetstecken är det inte en formel och den kommer inte att beräknas. Detta är ett vanligt misstag som är lätt att göra.

Om du till exempel skriver någonting som SUMMA(A1:A10), visar Excel Online textsträngen SUMMA(A1:A10) i stället för resultatet. Om du skriver in 11/2 visas ett datum, till exempel 2-nov eller 2009-02-11, i stället för 11 delat med 2.

Du undviker dessa oväntade resultat genom att alltid börja med ett likhetstecken. Skriv till exempel: =SUMMA(A1:A10) och =11/2

Matcha alla inledande och avslutande parenteser

Kontrollera att alla parenteser ingår i ett parentespar. I en formel som använder en funktion ska varje vänsterparentes ha en avslutande högerparentes för att funktionen ska fungera korrekt.

Formeln =OM(B5<0);"Ogiltig";B5*1,05) fungerar till exempel inte eftersom den innehåller två avslutande högerparenteser och endast en inledande vänsterparentes.

Den korrekta formeln ser ut så här: =OM(B5<0;"Inte giltig";B5*1,05 ).

Ange alla argument som behövs

De flesta funktioner har obligatoriska argument, värden som du måste ange för att funktionen ska fungera. Endast ett fåtal funktioner (t.ex. PI eller IDAG) saknar argument. Kontrollera formelsyntaxen, som visas när du skriver ett likhetstecken följt av en funktion, och se till att ange alla argument som behövs, varken fler eller färre.

Till exempel accepterar funktionen VERSALER bara en textsträng eller en cellreferens som argument: =VERSALER("hej") eller =VERSALER(C2)

För vissa funktioner, som SUMMA, krävs endast numeriska argument, medan andra funktioner, som ERSÄTT, kräver ett textvärde för minst ett av argumenten. Om du använder fel datatyp kan vissa funktioner ge oväntade resultat eller visa felmeddelandet #VÄRDE!.

Använd oformaterade tal i formler

Ange inte tal formaterade med dollartecken ($) eller kommatecken (,) i formler eftersom dollartecken används för absoluta referenser och kommatecken som argumentavgränsare. Formaterade tal används inte i formelberäkningen. I stället för att ange 10 000 kr ska du ange 10000 i formeln.

Om du använder formaterade tal i argument kommer du att få oväntade beräkningsresultatet, men du kan också se felmeddelandet #NUM! Till exempel, om du anger formeln =ABS(-2,134) för att hitta det absoluta värdet -2134, visas #NUM! i Excel Online eftersom funktionen ABS endast accepterar ett argument.

Genom att tillämpa talformat kan du formatera resultatet med decimalavgränsare och valutasymboler sedan du skrivit formeln.

Använd rätt celldatatyp

Formeln kan inte returnera förväntade resultat om cellens datatyp inte kan användas i beräkningar.

Om du till exempel anger en enkel formel som = 2+3 i en cell som är formaterad som text, kan informationen som du angav inte beräknas i Excel Online. Allt som visas i cellen är =2+3.

Du korrigerar detta genom att ändra cellens datatyp från Text till Allmänt. Gör så här:

  1. Markera cellen.

  2. Klicka på Start > pilen Talformat och välj sedan Allmänt.

  3. Aktivera redigeringsläget för cellen genom att trycka på F2 och godkänn formeln genom att trycka på Retur.

Ett datum som du anger i en cell med datatypen Tal kanske visas som ett numeriskt värde i stället för ett datum. För att visa numret som ett datum väljer du ett datumformat i galleriet Talformat.

Använd symbolen * för att multiplicera tal

Du kanske vill använda x som multiplikationsoperator i en formel, men det fungerar inte eftersom du måste använda en asterisk (*).

När du använder ett x i en formel kan resultatet inte beräknas i Excel Online. I stället visas formeln i cellen och en prickad röd ram placeras runt cellen så att du vet att det finns ett fel i formeln.

Använd citattecken runt text i formler

Om du skapar en formel som innehåller text ska du omge texten med citattecken.

I exempelvis formeln ="I dag är det " & TEXT(IDAG();"dddd MM DD") kombineras texten "i dag är det" med resultatet från funktionerna TEXT och IDAG och returnerar I dag är det måndag 05 30 i cellen.

Observera blanksteget i formeln före det avslutande citattecknet i "I dag är det ". Det är blanksteget som visas mellan orden I dag är det och måndag den 30 maj. Utan citattecken runt texten kan formeln visa felmeddelandet #NAMN?.

Kapsla inte in mer än 64 funktioner i en formel

Du kan kombinera, eller kapsla, upp till 64 funktionsnivåer i en funktion.

Formeln =OM(ROT(PI())<2,"Mindre än två!","Större än två!") innehåller till exempel tre (3) funktioner, där funktionen PI är kapslad i funktionen ROT, som i sin tur är kapslad i funktionen OM.

Du kan inte dela numeriska värden med noll

Om du delar en cell med en annan cell som har noll (0) eller inget värde kommer felmeddelandet #DIVISION/0! att visas

Du undviker detta fel genom att kapsla in divisionsoperationen i funktionen OMFEL. Ange exempelvis följande två formler i cellerna på ett kalkylblad:

=OMFEL(3/0,0)

=OMFEL(3/7,0)

Med den första formeln returneras värdet 0 eftersom i OMFEL-funktionen tolkas divisioner med noll som ett fel. Den andra formeln returnerar värdet för 3/7 och inget fel uppstår eftersom du inte dividerar med noll.

Om du vill göra det lättare att skapa formler kanske du också vill veta mer om dessa formeltips.

Obs!: Ansvarsfriskrivning för maskinöversättning: Den här artikeln har översatts av ett datorsystem utan mänsklig inblandning. Microsoft erbjuder dessa maskinöversättningar för att hjälpa icke engelskspråkiga användare att ta del av information om Microsofts produkter, tjänster och tekniker. Eftersom artikeln är maskinöversatt kan den innehålla fel i ordval, syntax och grammatik.

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×