Hur du kan åtgärda fel i formler i Excel 2016 för Mac

Viktigt!: Den här artikeln är maskinöversatt, se ansvarsfriskrivningen. Den engelska versionen av den här artikeln finns här för din referens.

Oavsett om är #VÄRDEFEL!, #NAMN! eller ett problem med LETARAD kan följande information hjälpa dig att åtgärda felet.

LETARAD

Om du får fel eller oväntade resultat med LETARAD hämtar du snabbreferens för felsökningstips för LETARAD.

#VÄRDEFEL!-fel

Källan till det här problemet är vanligtvis relaterat till en blandning av numeriska värden och textvärden. Mer information finns i Korrigera ett #VÄRDEFEL! fel-.

#NAMN?-fel

Kontrollera att du skriver namn korrekt, omge text inom citattecken, eller omge bladnamn med enkla citattecken ('). För andra orsaker och lösningar, se #NAMN? fel-.

#NUM!-fel

Det här kan inträffa om du skrev in extra tecken i en formel. Om ska till exempel inte skriva 1 000 kr i en formel. Skriv istället 1000. För andra orsaker och lösningar, se Korrigera ett #NUM! fel-.

#SAKNAS!-fel

Om en formel inte kan hitta ett refererat värde returneras felet #SAKNAS!. Mer information finns i Korrigera ett #SAKNAS!-fel.

#REFERENS!-fel

Det här felmeddelandet visas när en formel innehåller en cellreferens som är inte giltig. Mer information finns i Korrigera ett #REFERENS! fel-.

#DIVISION/0!-fel

Det här händer när ett tal har dividerats med noll (0), eller när en formel refererar till en cell som har 0 eller är tom. Mer information finns i #DIVISION/ 0! fel-.

Referera till andra blad och arbetsböcker

Om du refererar till ett annat kalkylblads- namn skriver du ! efter namnet, och skriv sedan en cell eller ett område. Om namnet innehåller blanksteg omger du namnet med enkla citattecken. Till exempel: =SUMMA('Försäljningsrapport'!A1:A8).

När du refererar till en annan extern arbetsbok:

  • Omge arbetsbokens namn med hakparenteser [ ].

  • Skriv den fullständiga sökvägen till filen.

  • Omge sökvägen med enkla citattecken (i början av sökvägen och efter namnet på kalkylbladet, före utropstecknet).

    Exempel: =SUMMA('/Användare/dittnamn/Desktop/[Verksamhet Q2.xlsx]Försäljning'!A1:A8)

Andra snabblösningar som kan hjälpa

  • Inled alla formler med ett likhetstecken (=). Exempel: =SUM(A1:A8)

  • Använd symbolen * för att multiplicera tal, inte X. Exempel: =A1*A8

  • Matcha alla inledande och avslutande parenteser så att de står i par. Det här exemplet har 2 par: =IF(40>50,SUM(G2:G5),0)

  • Ange alla argument som behövs. Formelverktyget kan hjälpa dig med detta. Börja skriva en formel med ett funktionsnamn och tryck sedan på CONTROL + A för att se visa formelverktyget.

  • Använd citattecken runt text i formler. Exempel: =IF(A2>B2,”Over Budget”,”OK”)

  • Ändra datatypen för en refererad cell. Tryck på KOMMANDO + 1, och välj sedan Nummer.

Obs!: Ansvarsfriskrivning för maskinöversättning: Den här artikeln har översatts av ett datorsystem utan mänsklig inblandning. Microsoft erbjuder dessa maskinöversättningar för att hjälpa icke engelskspråkiga användare att ta del av information om Microsofts produkter, tjänster och tekniker. Eftersom artikeln är maskinöversatt kan den innehålla fel i ordval, syntax och grammatik.

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×