Funktionen OMFEL

I den här artikeln beskrivs formelsyntaxen för och användningen av funktionen OMFEL i Microsoft Excel.

Beskrivning

Returnerar ett värde som du anger om en formel utvärderas till ett fel. Annars returneras formelresultatet. Använd funktionen OMFEL för att identifiera och hantera fel i en formel.

Syntax

OMFEL(värde; värde_om_fel)

Syntaxen för funktionen OMFEL har följande argument:

  • Värde    Obligatoriskt. Detta är det argument som genomsöks efter fel.

  • Värde_om_fel    Obligatoriskt. Detta är det värde som returneras om formeln utvärderas till ett fel. Följande feltyper utvärderas: #SAKNAS!, #VÄRDEFEL!, #REFERENS!, #DIVISION/0!, #OGILTIGT!, #NAMN? och #SKÄRNING!.

Kommentarer

  • Om värde eller värde_om_fel är en tom cell behandlar OMFEL argumentet som ett tomt strängvärde ("").

  • Om värde är en matrisformel returnerar OMFEL en matris med resultat för varje cell i det område som anges i värde. Se det andra exemplet nedan.

Exempel

Kopiera exempeldata i följande tabell och klistra in dem i cell A1 i ett nytt Excel-kalkylblad. Om du vill visa formelresultaten markerar du formlerna, trycker på F2 och sedan på Retur. Om det behövs kan du ändra kolumnbredden så att alla data visas.

Kvot

Antal sålda enheter

02:10

3,5

5:5

{0}

2, 3

Formel

Beskrivning

Resultat

=OMFEL(A2/B2; "Fel i beräkningen")

Söker efter fel i formeln i det första argumentet (dividera 210 med 35), hittar inga fel och returnerar formelresultatet.

6.

=OMFEL(A3/B3; "Fel i beräkningen")

Söker efter fel i formeln i det första argumentet (dividera 55 med 0), hittar en division med 0-fel och returnerar värde_om_fel.

Fel i beräkningen

=OMFEL(A4/B4; "Fel i beräkningen")

Söker efter fel i formeln i det första argumentet (dividera "" med 23), hittar inga fel och returnerar formelresultatet.

{0}

Exempel 2

Kvot

Antal sålda enheter

Proportioner

02:10

3,5

6.

5:5

{0}

Fel i beräkningen

2, 3

{0}

Formel

Beskrivning

Resultat

=C2

Söker efter fel i formeln i det första argumentet i det första elementet av matrisen (A2/B2 eller dividera 210 med 35), hittar inga fel och returnerar formelresultatet.

6.

=C3

Söker efter fel i formeln i det första argumentet i det andra elementet i matrisen (A3/B3 eller dividera 55 med 0), hittar en division med 0-fel och returnerar värde_om_fel.

Fel i beräkningen

=C4

Söker efter fel i formeln i det första argumentet i det tredje elementet av matrisen (A4/B4 eller dividera "" med 23), hittar inga fel och returnerar formelresultatet.

{0}

Obs! Formeln i exemplet måste skrivas som en matrisformel. När du har kopierat exemplet till ett tomt kalkylblad markerar du cellområdet C2:C4, trycker på F2 och sedan på CTRL+SKIFT+RETUR.

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×