Funktionen OM

OM-funktionen är en av de funktioner som används mest i Excel. Med den kan du göra logiska jämförelser mellan ett värde och en förväntning. I sin enklaste form anger OM-uttrycket det här:

  • OM(Någonting är Sant gör du så här, annars gör du så här)

Därför kan ett OM-uttryck ha två resultat Det första resultatet är för om jämförelsen är sann och det andra är för om jämförelsen är falsk.

Om du vill gå vidare och arbeta med flera OM-uttryck kan du läsa: Avancerade OM-funktioner – Arbeta med kapslade funktioner och undvika fallgropar.

Använd funktionen OM, en av de logiska funktionerna, för att returnera ett värde om ett villkor är sant och ett annat värde om det är falskt.

Syntax

OM(logisk_test; värde_om_sant; [värde_om_falskt])

Till exempel:

  • =OM(A2>B2;"Över budget";"OK")

  • =OM(A2=B2,B4-A4,””)

Argumentnamn

Beskrivning

logisk_test    (krävs)

Det villkor du vill testa.

värde_om_sant    (krävs)

Det värde som ska returneras om resultatet av logisk_test är SANT.

värde_om_falskt    (valfritt)

Det värde som ska returneras om resultatet av logisk_test är FALSKT.

Enkla exempel med OM

Cell D2 innehåller formeln =OM(C2="Ja";1;2)
  • =OM(C2=”Ja”,1,2)

I exemplet ovan anger cell D2: OM(C2 = Ja, returnera 1, annars, returnera 2)

Cell D2 innehåller formeln =OM(C2=1,"JA","NEJ")
  • =OM(C2=1,”Ja”,”Nej”)

I det här exemplet anger formeln i cell D2: OM(C2 = 1, returnera Ja, annars, returnera Nej)

Som du ser kan OM-funktionen användas för att utvärdera både text och värden. Den kan också användas för att utvärdera fel. Du kan inte bara kontrollera om något är lika med något annat och returnera ett enskilt resultat, du kan också använda matematiska operatorer och utföra ytterligare beräkningar utifrån dina villkor. Du kan även kapsla flera OM-funktioner och utföra flera jämförelser.

Obs!: Om du ska använda text i formler måste du skriva texten inom citattecken (t.ex. ”Text”). Det enda undantaget till detta är om du använder SANT eller FALSKT, vilket Excel förstår automatiskt.

Komma igång

Det bästa sättet att börja skriva ett OM-uttryck är att fundera över vad det är du vill uppnå. Vilken jämförelse vill du göra? När du skriver ett OM-uttryck är det ofta inte svårare än att tänka igenom logiken: ”Vad ska hända om villkoret uppfylls och vad ska hända om det inte gör det?” Du bör alltid kontrollera att stegen följer logiskt på varandra annars kommer formeln inte att göra det du hade avsett. Det här är särskilt viktigt när du skapar komplexa (kapslade) OM-uttryck.

Fler OM-exempel

Formeln i cell D2 är =OM(C2>B2; "Över Budget", "Inom Budget")
  • = OM(C2>B2,”Över budget”,”Inom budget”)

I exemplet ovan anger OM-funktionen i D2 OM(C2 är större än B2, returnera ”Över Budget”, annars, returnera ”Inom Budget”)

Formeln i cell E2 är =OM(C2>B2;C2-B2;"")
  • =OM(C2>B2;C2-B2;0)

I exemplet ska vi returnera en matematisk beräkning i stället för ett textresultat. Formeln i E2 säger alltså OM(Faktiskt är större än Budgeterat, subtrahera Budgeterat belopp från Faktiskt belopp, annars returnera ingenting).

Formeln i Cell F7 är OM(E7="Ja";F5*0,0825;0)
  • =OM(E7=”Ja”;F5*0,0825;0)

I det här exemplet säger formeln i F7 OM(E7 = ”Ja”, beräkna totalbeloppet i F5 * 8,25 %, annars krävs ingen moms så returnera 0)

Bästa praxis - konstanter

I det sista exemplet ser du att både ”Ja” och momssatsen (0,0825) anges direkt i formeln. Normalt rekommenderar vi inte att teckensträngskonstanter (värden som kan behöva ändras emellanåt) anges direkt i formler eftersom de kan vara svåra att hitta och ändra i framtiden. Det är mycket bättre att placera konstanterna i sina egna celler där de syns tydligt och enkelt går att hitta och ändra. I det här fallet är det okej eftersom det bara finns en OM-funktion och momssatsen sällan ändras. Även om den skulle det kan den enkelt ändras i formeln.

Beräkningsoperatorer

Läs den här artikeln om du vill veta mer om de olika beräkningsoperatorer som du kan använda i formler (< mindre än > större än, = lika med, <> inte lika med osv.): Beräkningsoperatorer och prioritet.

Använda OM för att kontrollera om en cell är tom

Ibland behöver du kontrollera om en cell är tom, oftast eftersom du kanske inte vill att en formel ska visa ett resultat utan indata.

Formeln i cell E2 är =OM(D2=1,"Ja",OM(D2=2,"Nej","Kanske"))

I det här fallet använder vi OM med funktionen ÄRTOM:

  • =OM(ÄRTOM(D2);"Tom";"Inte tom")

Som säger att OM(D2 är tom, returnera "Tom", annars "Inte tom"). Det är lika enkelt att använda en egen formel för villkoret "Inte tom". I nästa exempel använder vi "" i stället för ÄRTOM. "" betyder i princip "inget".

Kontrollera om en cell är tom – formeln i cell E2 är =OM(ÄRTOM(D2);"Tom";"Inte tom")
  • =OM(D3="","Tom","Inte tom")

Den här formeln säger OM(D3 är inget, returnera "Tom", annars "Inte tom"). Här är ett exempel på ett mycket vanligt sätt att använda "" för att förhindra att en formel beräknas om en cell är tom:

  • =OM(D3="";"";DinFormel())

    OM(D3 är inget, returnera inget; om inte beräkna formeln).

Exempel med kapslat OM

Om en enkel OM-funktionen bara ger två resultat (Sant eller Falskt), ger kapslade OM-funktioner från 3 till 64 resultat.

Använda "" för att söka efter en tom cell – formeln i cell E3 är =OM(D3="";"Tom";"Inte tom")
  • =OM(D2=1,”JA”,OM(D2=2,”Nej”,”Kanske”))

I exemplet ovan säger formeln i E2: OM(D2 är lika med 1, returnera ”Ja”, annars OM(D2 är lika med 2, returnera ”Nej”, annars returnera ”Kanske”)). Obs! Det finns två avslutande parenteser i slutet av formeln. De krävs för att slutföra bägge OM-funktionerna – om du försöker ange formeln utan de båda avslutande parenteserna försöker Excel korrigera felet åt dig.

En liten varning

Även om du kan kapsla upp till 64 olika OM-funktioner i Excel är det inget vi rekommenderar. Varför?

  • Det krävs mycket tankearbete för att skapa flera OM-uttryck som är korrekta och se till att deras logik ger korrekta beräkningar genom alla villkor ända till slutet. Om du inte kapslar OM-satserna 100 % rätt kanske formeln fungerar i 75 % av fallen, men returnerar oväntade resultat till 25%. Tyvärr är chansen liten att du ska lyckas upptäcka de 25 %.

  • Flera OM-uttryck kan bli mycket svåra att hantera, särskilt när du går tillbaka senare och försöker ta reda på vad det var du eller någon annan ville uppnå.

  • Om du använder flera OM-satser krävs flera inledande och avslutande parenteser (), något som beroende på hur komplex formeln blir kan vara svårt att hantera.

Vanliga problem

Problem

Något gick fel

0 (noll) i cell

Det fanns inget argument för vare sig värde_om_sant eller värde_om_falskt. För att få rätt värde returnerat ska du lägga till argumenttext för de två argumenten, eller lägga till SANT eller FALSKT för argumentet.

#NAMN? i cell

Det här betyder vanligtvis att formeln är felstavad.

Har du en specifik fråga om funktioner?

Ställ en fråga i Excel-communityforumet

Hjälp oss att göra Excel bättre

Har du förslag på hur vi kan förbättra nästa version av Excel? Titta i så fall på avsnitten i Excel User Voice.

Mer information finns i

Se en video om hur du använder OM-funktionen

IFS-funktionen (Office 365, Excel 2016 och senare)

Avancerade funktioner – Arbeta med kapslade formler och undvika fallgropar

Utbildningsvideor: Avancerade OM-funktioner

Funktionen ANTAL.OM beräknar värden baserat på ett enda villkor

Funktionen ANTAL.OMF beräknar värden baserat på flera villkor

Funktionen SUMMA.OM summerar värden baserat på ett enda villkor

Funktionen SUMMA.OMF summerar värden baserat på flera villkor

OCH-funktion

ELLER-funktion

Funktionen LETARAD

Översikt över formler i Excel

Så här undviker du felaktiga formler

Använd felkontroll om du vill hitta fel i formler

Logiska funktioner

Excel-funktioner (alfabetisk ordning)

Excel-funktioner (efter kategori)

Logiska OM-tester (kostnadsfritt smakprov)

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×