Funktionen OCH

Använd funktionen OCH, en av de logiska funktionerna till att utvärdera om alla villkor i ett test är sanna.

Exempel

Exempel på funktionen OCH

Funktionen OCH returnerar SANT om alla dess argument utvärderas som sanna och returnerar FALSKT om ett eller flera argument utvärderas som falska.

Ett vanligt användningsområde för funktionen OCH är att öka användbarheten för andra funktioner som utför logiska tester. Om exempelvis funktionen OM utför ett logiskt test, returneras sedan ett värde om testet utvärderas som SANT och ett annat värde om testet utvärderas som FALSKT. Genom att använda funktionen OCH som logisk_test-argument för funktionen OM kan du testa flera olika villkor istället för bara ett.

Syntax

OCH(logisk1, [logisk2], ...)

Syntaxen för funktionen OCH har följande argument:

Argument

Beskrivning

logisk1

Obligatoriskt. Det första villkoret som du vill testa och som kan utvärderas som antingen SANT eller FALSKT.

logisk2, ...

Valfritt. Ytterligare villkor som du vill testa som kan utvärderas som antingen SANT eller FALSKT, upp till högst 255 villkor.

Anmärkningar

  • Argumenten måste utvärderas som logiska värden, till exempel SANT och FALSKT, eller så måste argumenten vara matriser eller referenser som innehåller logiska värden.

  • Om ett matris- eller referensargument innehåller text eller tomma celler ignoreras dessa värden.

  • Om det angivna området inte innehåller några logiska värden returnerar funktionen OCH #VÄRDEFEL!-felvärdet.

Exempel

Här är några generella exempel för hur du använder OCH för sig själv och tillsammans med funktionen OM.

Exempel på användning av OM-funktioner med OCH

Formel

Beskrivning

=OCH(A2>1,A2<100)

SANT visas om A2 är större än 1 OCH mindre än 100. Annars visas FALSKT.

=OM(OCH(A2<A3,A2<100),A2,"Värdet ligger utanför giltigt intervall")

Visar värdet i cell A2 om det är mindre än A3 OCH mindre än 100. Annars visas meddelandet "Värdet ligger utanför giltigt intervall".

=OM(OCH(A3>1,A3<100),A3,"Värdet ligger utanför giltigt intervall")

Visar värdet i cell A3 om det är större än 1 OCH mindre än 100. Annars visas ett meddelande. Du kan använda valfritt meddelande.

Beräkning av bonus

Här är ett relativt vanligt scenario där vi behöver beräkna om säljare är berättigade till bonus med OM och OCH.

Exempel på beräkning av försäljningsbonus med funktionerna OM och OCH funktioner.  Formeln i cell E14 är =OM(OCH(B14>=$B$7,C14>=$B$5),B14*$B$8,0)
  • =OM(OCH(B14>=$B$7,C14>=$B$5),B14*$B$8,0)OM totalförsäljningen är större än eller lika med (>=) försäljningsmålet OCH om kontona är större än eller lika med (>=) kontomålet, multiplicera totalförsäljningen med procentsatsen för bonus. Returnera 0 i annat fall.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community, få support i Answers-communityn eller föreslå en ny funktion eller förbättringar på Excel User Voice.

Närliggande avsnitt

Video: Avancerade OM-funktioner
Läs mer om att använda kapslade funktioner i en formel
Funktionen OM
Funktionen ELLER
Funktionen INTE
Översikt över formler i Excel
Hur du undviker felaktiga formler
Använd felkontroll om du vill hitta fel i formler
Kortkommandon i Excel 2016 för Windows
Kortkommandon i Excel 2016 för Mac
Logiska funktioner (referens)
Excel-funktioner (alfabetisk ordning)
Excel-funktioner (efter kategori)

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×