Funktionen ELLER

Använd ELLER-funktionen, en av de logiska funktionerna för att avgöra om något villkor i ett test är SANT.

Exempel

Exempel på användning av funktionen ELLER.

Funktionen ELLER returnerar SANT om något av dess argument utvärderas som sant och returnerar FALSKT om alla argument utvärderas till falska.

En vanlig användning för funktionen ELLER är att utöka användbarheten för andra funktioner som utför logiska test. Funktionen OM t.ex. utför ett logiskt test och returnerar sedan ett värde som testet utvärderas till SANT och ett annat värde om testet utvärderas till FALSKT. Genom att använda funktionen ELLER som argumentet logiskt_test i funktionen OM kan du testa många olika villkor i stället för bara ett.

Syntax

ELLER(logisk1, [logisk2], ...)

Syntaxen för funktionen ELLER har följande argument:

Argument

Beskrivning

logisk1

Obligatoriskt. Det första villkoret som du vill testa och som kan utvärderas som antingen SANT eller FALSKT.

logisk2, ...

Valfritt. Ytterligare villkor som du vill testa som kan utvärderas som antingen SANT eller FALSKT, upp till högst 255 villkor.

Anmärkningar

  • Argumenten måste utvärderas till logiska värden som SANT och FALSKT, eller till matriser eller referenser som innehåller logiska värden.

  • Om ett matris- eller referensargument innehåller text eller tomma celler ignoreras dessa värden.

  • Om det angivna området inte innehåller några logiska värden returnerar ELLER #VÄRDEFEL!-felvärdet.

  • Du kan använda en ELLER-matrisformel för att se om ett värde uppstår i en matris. Om du vill ange en matrisformel trycker du på Ctrl+Skift+Retur.

Exempel

Här är några generella exempel för hur du använder ELLER för sig själv och tillsammans med OM.

Exempel på användning av funktionen ELLER med funktionen OM.


Formel

Beskrivning

=ELLER(A2>1,A2<100)

SANT visas om A2 är större än 1 ELLER mindre än 100. Annars visas FALSKT.

=OM(ELLER(A2>1,A2<100),A3,"Värdet ligger utanför giltigt intervall")

Visar värdet i cell A3 om det är större än 1 ELLER mindre än 100. Annars visas meddelandet "Värdet ligger utanför giltigt intervall".

=OM(ELLER(A2<0,A2>50),A2,"Värdet ligger utanför giltigt intervall")

Visar värdet i cell A2 om det är mindre än 0 ELLER större än 50. Annars visas ett meddelande.

Beräkning av försäljningsprovision

Här är ett relativt vanligt scenario där vi behöver beräkna om säljare är berättigade till provision med OM och ELLER.

Exempel på användning av OM och ELLER för beräkning av försäljningsprovision.
  • =OM(ELLER(B14>=$B$4,C14>=$B$5),B14*$B$6,0) - OM totalförsäljningen är större än eller lika med (>=) försäljningsmålet ELLER om kontona är större än eller lika med (>=) kontomålet multiplicera totalförsäljningen med procentsatsen för provision. Returnera 0 i annat fall.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community, få support i Answers-communityn eller föreslå en ny funktion eller förbättringar på Excel User Voice.

Mer information finns i

Titta på en video om hur du använder funktionen OM

Läs mer om att använda kapslade funktioner i en formel

Funktionen OM

Funktionen OCH

Funktionen INTE

Översikt över formler i Excel

Hur du undviker felaktiga formler

Använd felkontroll om du vill hitta fel i formler

Kortkommandon i Excel 2016 för Windows

Kortkommandon i Excel 2016 för Mac

Logiska funktioner (referens)

Excel-funktioner (alfabetisk ordning)

Excel-funktioner (efter kategori)

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×