FIELDVALUE-funktionen

Obs!: Vi vill kunna erbjuda dig bästa möjliga supportinnehåll så fort som möjligt och på ditt språk. Den här sidan har översatts med hjälp av automatiserad översättning och kan innehålla grammatiska fel eller andra felaktigheter. Vår avsikt är att den här informationen ska vara användbar för dig. Vill du berätta för oss om informationen är till hjälp längst ned på sidan? Här är artikeln på engelska som referens.

Du kan använda funktionen FIELDVALUE för att hämta fältdata från länkade datatyper som Aktier eller Geografi. Det finns enklare metoder för att skriva formler som refererar till datatyper, så funktionen FIELDVALUE bör i huvudsak användas för att skapa villkorsstyrda beräkningar baserade på länkade datatyper.

Obs!: Den 28 mars 2019: data typer har frisläppts till alla Windows Office 365-prenumeranter. Om du har en prenumeration på Office 365 bör du kontrollera att du har den senaste versionen av Office.

Teknisk information

Syntax

=FIELDVALUE(value, field_name)

Syntaxen för funktionen FIELDVALUE har följande argument:

argument

Beskrivning

värde

Funktionen returnerar alla matchande fält från den länkade datatypen som anges i värdeargumentet.

field_name

Namnet eller namnen på de fält som du vill extrahera från den länkade datatypen.

Beskrivning

Exempel

I följande grundläggande exempel extraherar formeln =FIELDVALUE(A2;"Pris") fältet Pris från aktiedatatypen för JM Smucker Co.

Hämta ett företags aktiepris med =FIELDVALUE(A2;"Pris")

Nästa exempel är ett mer typiskt exempel för funktionen FIELDVALUE. Här använder vi funktionen OMFEL för att söka efter fel. Om det inte finns något företagsnamn i cell A2, returnerar formeln FIELDVALUE ett fel, och i så fall vill vi visa ingenting (””). Men om det finns ett företagsnamn vill vi hämta priset från datatypen i A2 med =OMFEL(FIELDVALUE($A2;B$1);"").

Hämta ett företags aktiepris och ignorera fel med =OMFEL(FIELDVALUE($A2;B$1);"")

Observera att du med funktionen FIELDVALUE kan referera till kalkylbladsceller för argumentet field_name, så ovanstående formel refererar till cell B1 för priset i stället för att du manuellt anger ”Pris” i formeln. 

Kommentarer

Om du försöker hämta data från ett data typ fält som inte finns returnerar funktionen FIELDVALUE#FIELD!-fel. Du kan till exempel ha angett "priser", när fältet datatyp för data typen "Price". Dubbelkolla formeln för att kontrol lera att du använder ett giltigt fält namn. Om du vill visa en lista med fält namn för en post markerar du cellen för posten och trycker på Alt + Skift + F10.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community, få support i Answers-communityn eller föreslå en ny funktion eller förbättringar på Excel User Voice.

Se även

Datatyperna Aktier och Geografi

Så här skriver du formler som refererar till datatyper

Felet #FIELD!

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×