FEL.TYP (Funktionen FEL.TYP)

I den här artikeln beskrivs formelsyntaxen för och användningen av FEL.TYP i Microsoft Excel.

Beskrivning

Returnerar ett värde som motsvarar något av felvärdena i Microsoft Excel eller returnerar felet #Saknas! om det inte finns något fel. Du kan använda FEL.TYP i en OM-funktion för att söka efter ett felvärde och returnera en textsträng, t ex ett meddelande, i stället för felvärdet.

Syntax

FEL.TYP(felvärde)

Syntaxen för funktionen FEL.TYP har följande argument:

  • Felvärde    Obligatoriskt. Det felvärde vars feltyp du vill ha. Även om felvärde kan vara det faktiska felvärdet är det oftast en referens till den cell som innehåller en formel som du vill undersöka.

Om felvärde är

Returnerar FEL.TYP

#Skärning!

1.

#Division/0!

2.

#Värdefel!

3.

#Referens!

4.

#Namn?

5.

#Ogiltigt!

6.

#Saknas!

7

#HÄMTAR_DATA

8

Något annat

#Saknas!

Exempel

Kopiera exempeldata i följande tabell och klistra in dem i cell A1 i ett nytt Excel-kalkylblad. När du vill att formlerna ska visa resultat markerar du dem, trycker på F2 och sedan på Retur. Om det behövs kan du justera kolumnbredderna så att alla data visas.

Data

#SKÄRNING!

#DIVISION/0!

Formel

Beskrivning

Resultat

=FEL.TYP(A2)

Numret på felet #SKÄRNING! (1).

1.

=OM(FEL.TYP(A3)<3;VÄLJ(FEL.TYP(A3);"Områdena skär inte varandra";"Nämnaren är noll"))

Kontrollerar om cell A3 innehåller felvärdet #SKÄRNING! eller #DIVISION/0!. Om så är fallet används felvärdets nummer i kalkylbladsfunktionen VÄLJ för att visa ett av två meddelanden. Annars returneras felvärdet #SAKNAS!.

Nämnaren är noll

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×