Enhetlig Hämta och transformera

Excel 2016 introducerade en mycket användbar uppsättning verktyg som kallas Hämta och transformera. Verktygen, som baseras på Power Query-tekniken, ger dig möjlighet att enkelt ansluta, kombinera och forma data som kommer från en rad olika källor. I följande självstudie om Hämta och transformera får du lära dig grunderna.

Vi är stolta över att kunna presentera nästa stora uppdatering av funktionerna för dataimport och datautformning i Excel: den enhetliga Hämta och transformera-upplevelsen. Med Office 365-uppdateringen i mars 2017 utökade vi Excels funktioner för dataimport och flyttade om knapparna på fliken Data så att det blivit enklare än någonsin tidigare att utnyttja Hämta och transformera-funktionerna till fullo.

Alternativ för Hämta och transformera på fliken Data

Med den enhetliga Hämta och transformera-upplevelsen drar du nytta av fördelarna i den välintegrerade och moderna uppsättningen dataimport-/datautformningsfunktioner i Excel. Du kan enkelt ansluta och hämta data från en mängd olika vanliga datakällor, som filer, databaser, Azure- och onlinetjänster med mera. Du kan också forma data på ett effektivt sätt genom att sortera, ändra datatyper, dela upp kolumner, aggregera data och så vidare. Det ständigt växande utbudet med nya anslutningar och de användarvänliga transformeringarna är det som gör Hämta och transformera ett ovärderligt och tidssparande verktyg i ditt dagliga arbete.

Observera att den nya versionen ersätter gamla, inaktuella dataimportguider som var tillgängliga under Data > Hämta externa data. Du kan dock fortfarande komma åt dem om du vill. Se: Hur återställer jag den gamla Hämta externa data-upplevelsen?

Obs!: Den här funktionen är endast tillgänglig i Excel om du har en Office 365-prenumeration. Om du har en prenumeration på Office 365 behöver du kontrollera att du har den senaste versionen av Office.

Hur hämtar jag data från vanliga källor som CSV-filer eller Internet?

Vi vet att användare som importerar data gärna vill ha de vanligaste anslutningarna nära till hands i menyfliksområdet. I den här uppdateringen har vi försökt att följa den principen och vi har bevarat det gränssnitt som du är van vid. Nu hittar du följande tre populära anslutningar under avsnittet Hämta och transformera data på fliken Data: Från text/CSV, Från Internet och Från tabell/område.

Från text/CSV

Med den här anslutningen kan du enkelt importera data från en textfil (*.txt), kommaavgränsade värden (*.csv) eller formaterade textfiler (*.prn). Den här moderna anslutningen baseras på Power Query-teknik och ersätter den äldre Från text-guiden.

För att börja importera data med den nya anslutningen klickar du på Data > Från text/CSV, väljer källfilen och klickar sedan på OK. Den nya och förbättrade anslutningen Från text/CSV analyserar sedan strukturen för indatafilen, och tillämpar automatiskt de relevanta importinställningarna. Den kan dela upp kolumnerna med hjälp av avgränsare, flytta upp den första raden så att den används som kolumnrubrik och mycket annat.

Alternativ för Från text för Hämta och transformera

Om förhandsgranskningen inte är som du vill kan du konfigurera de grundläggande importinställningarna som filursprung, avgränsare och logik för datatypsidentifiering direkt. När du gjort dina val uppdateras förhandsgranskningen av datan automatiskt.

Du kan sedan klicka på Läs in för att läsa in kalkylbladet direkt, eller klicka på pilen bredvid Läs in för att läsa in data i din datamodell. Om du vill använda ytterligare datatransformeringar i frågeredigeraren klickar du på Redigera.

Från Internet

Med den här anslutningen kan du samla in data från HTML-sidor. Det här är ytterligare en modern anslutning som också baseras på Power Query-tekniken och ersätter den äldre Från Internet-guiden.

Om du vill börja använda den klickar du på Data > Från Internet, anger webbadressen för målsidan och klickar sedan på OK. En lista över alla tabeller på sidan visas i dialogrutan Navigatör. Du har möjlighet att interagera med webbsidan, antingen i tabellvy eller webbvy. Om du använder tabellvyn klickar du först på ett tabellnamn till vänster, så visas data från den tabellen till höger. Om du använder webbvyn kan du antingen klicka på en tabell från listan Navigatör eller från förhandsgranskningsfönstret Webbvy. Du kan markera flera tabeller i båda vyer.

Alternativ för Från Internet för Hämta och transformera

Från tabell/område

Med den här anslutningen kan du skapa en ny fråga som är kopplad till en tabell eller ett namngivet område i ett Excel-kalkylblad. Du kan sedan förfina dina data och tillämpa flera transformationer på dem i fönstret för frågeredigeraren.

Alternativ för Från tabell för Hämta och transformera

Hur hämtar jag data från flera källor som XML-filer eller Microsoft SQL Server?

Du kan skapa en ny fråga om du vill importera data från en enda datakälla, som en Microsoft Access-databas eller en OData-feed, eller så kan du importera data från flera textfiler i en mapp på en gång.

När du klickar på Data > Hämta data kan du se de tillgängliga datakällorna i en nedrullningsbar meny. Källalternativen är ordnade i kategorier, inklusive filer som Excel-arbetsböcker, XML-filer eller hela mappen, databaser som SQL Server eller Oracle, Azure-tjänster till exempel HDInsight eller Blob-lagring, onlinetjänster som SharePoint Online-lista eller Salesforce, och en mängd andra datakällor som OData eller ODBC.

Listan över tillgängliga anslutningar växer hela tiden.

Alternativ för Från databas för Hämta och transformera

I den här uppdateringen har vi också tagit bort följande inaktuella guider som tidigare var tillgängliga under avsnittet Hämta externa data på fliken Data: Från Access, Från Internet, Från text, Från SQLServer, Från OData-datafeed, Från XML-dataimport och Från guiden Dataanslutning. Om du av någon anledning behöver använda någon av de inaktuella guiderna kan du se: Hur återställer jag den gamla Hämta externa data-upplevelsen?

Det finns dock två populära och ganska unika guider från den gamla funktionsuppsättningen för Hämta externa data som finns kvar i den nya versionen: Från Analysis Services och Från Microsoft Query. De finns under respektive kategorier Data > Från databas och Data > Från andra källor i den nya upplevelsen.

Hur använder jag funktionerna i Hämta och transformera för att rensa och forma mina data?

I Hämta och transformera är rensning och formning av dina data ett nödvändigt steg för en optimal dataanalys. Du kan ta bort kolumner, filtrera rader, ändra kolumndatatyper, ersätta värden och mycket mer. Detta görs i det dedikerade fönstret för frågeredigeraren som underlättar och visar alla datatransformeringar.

Växla till fliken Data i menyfliksområdet, klicka på Hämta data, anslut till önskad datakälla (t.ex. en fil eller databas) med hjälp av någon av de tillgängliga anslutningarna och förhandsgranska dina data i fönstret Navigatör.

Navigatör för Hämta och transformera

Markera sedan de tabeller som du vill importera och klicka på Redigera att öppna fönstret för frågeredigeraren.

Frågeredigeraren för Hämta och transformera

Använd den stora samlingen med kommandon som är tillgängliga i menyfliksområdet i fönstret för frågeredigeraren. Du kan tillämpa effektiva transformeringar genom att sortera och filtrera data, konvertera datatyper, dela eller sammanfoga kolumner, samla dina data och mycket mer.

Alla transformeringssteg som du tillämpar på dina data registreras och sparas som en del av frågan. De registrerade transformeringarna kan visas och hanteras via avsnittet ANVÄNDA STEG i fönstret för frågeredigeraren. De tillämpas på dina data igen varje gång frågan uppdateras.

Hur hämtar jag data från nyligen använda källor, ODC-filer (Office-databasanslutningar), andra arbetsboksanslutningar eller tabeller?

En av de vanligaste åtgärderna i dataimportsområdet är att ansluta och hämta data från dina senast använda källor. Användare skapar ofta en uppsättning vanliga källor som de ansluter till för att importera data.

Om du vill ansluta och skapa en fråga från en av dina senast använda datakällor klickar du på Data > Senaste källor. Du kan sedan bläddra igenom nyligen anslutna källor, välja en och klicka på Anslut för att fortsätta med importflödet.

Sida med senast använda källor för Hämta och transformera

En annan vanlig åtgärd är att importera data från befintliga anslutningar eller tabeller i arbetsboken. Du kanske vill skapa en ny pivottabell baserat på en tidigare skapad arbetsboksanslutning. Eller så kanske du vill länka och importera från en datakälla med hjälp av en ODC-fil (Office-databasanslutning) som definierats av någon i din organisation.

Med den här uppdateringen kommer du att kunna exportera definitioner för dina frågor i en ODC-fil och sedan dela den i dina arbetsböcker eller med dina medarbetare. Om du vill exportera en frågedefinition till en ODC-fil (Office-databasanslutning) högerklickar du på en fråga i sidofönstret Frågor och anslutningar och väljer Exportera anslutningsfil. Den skapade ODC-filen innehåller definitionen för frågan med alla beroenden, inklusive anslutningsinstruktioner till datakällan, och transformeringsstegen tillämpas på dina data. Ett annat sätt att exportera en frågedefinition är via dialogrutan Frågeegenskaper som kan öppnas genom att du väljer Egenskaper från frågans snabbmeny.

När du får en ODC-fil kan du använda den och importera frågedefinitionen till arbetsboken. Om du vill importera data via ODC-mekanismen klickar du på Data > Befintliga anslutningar. Dialogrutan Befintliga anslutningar visas och sedan kan du importera de tillgängliga ODC-filerna, befintliga arbetsboksanslutningar eller tabeller.

Välja bland befintliga anslutningar eller frågor

Om du behöver skapa en ODC-fil som ska användas av ett annat program som Visio eller Excel 2013 och tidigare, kan du göra det med hjälp av följande anslutningar: Från SQL Server-databas, Från Microsoft Access-databas, Från OData-feed, Från Analysis Services, Från Microsoft Query eller den gamlaFrån guiden Dataanslutning. När du använder ODC-filer från ett annat program är det viktigt att känna till att programmet endast återanvänder anslutningsinstruktionerna från ODC-filen, och att de inte innehåller eventuella transformeringssteg som den ursprungliga frågan kanske innehöll. Om du behöver återställa de gamla anslutningarna Från Access, Från SQL Server, Från OData-feed, se: Hur återställer jag den gamla Hämta externa data-upplevelsen?

Hur hanterar jag befintliga arbetsboksfrågor och anslutningar?

När vi introducerade Hämta och transformera i Excel 2016 införde vi också två dataimportsmetoder: Den första var den nya Hämta och transformera-upplevelsen som använder frågor (och också bygger på arbetsboksanslutningar i bakgrunden för att uppdatera och läsa in arbetsbokselement). Den andra var en äldre upplevelse som använde arbetsboksanslutningar. Hanteringen av arbetsboksfrågor och anslutningar skedde också separat. Arbetsboksfrågor hanterades via det dedikerade fönstret Frågor, medan anslutningar hanterades via dialogrutan Arbetsboksanslutningar. Detta ledde till förvirring hos många användare.

I den här uppdateringen har vi åtgärdat det här problemet. Nu får du åtkomst till och kan hantera dina arbetsboksfrågor och anslutningar från det dedikerade sidofönstret Frågor och anslutning. Öppna sidofönstret och klicka på Data > knappen Frågor och anslutningar.

Fönstret Hämta och transformera Frågor och anslutningar

När du klickar på fliken Frågor högst upp i fönstret kan du bläddra bland och hantera frågor som är tillgängliga i arbetsboken. Högerklicka på en fråga för att få åtkomst till den frågans snabbmeny, där du kan utföra ytterligare åtgärder. Du kan till exempel uppdatera frågedata från den underliggande källan, kopiera och klistra in frågan, redigera frågetransformeringar med frågeredigeraren och mycket annat.

Vi har även förenklat hanteringen av frågan och dess underliggande anslutning via den nya dialogrutan Frågeegenskaper. När du i dag skapar en ny fråga i arbetsboken skapas en ny underliggande anslutningsentitet automatiskt i bakgrunden och den är kopplad till den här frågan. Syftet med frågan är att ansluta till datakällan och dessutom tillämpa nödvändiga datatransformeringar på den, medan den underliggande anslutningen kontrollerar var data läses in (t.ex. arbetsboken eller Datamodell) samt uppdateringsinställningarna för frågedata, som uppdateringsfrekvensen. Med den nya dialogrutan Frågeegenskaper kan du enkelt kontrollera alla frågeegenskaper, till exempel dess namn eller transformationsinstruktioner och de underliggande anslutningsegenskaperna, som uppdateringsinställningar, på ett centraliserat sätt. Öppna den nya dialogrutan Frågeegenskaper genom att klicka på kommandot Egenskaper från frågans snabbmeny i sidofönstret Frågor och anslutning.

Om du klickar på fliken Anslutningar högst upp i sidofönstret kan du bläddra bland och hantera tillgängliga, äldre anslutningar i arbetsboken som är kopplade till någon av de inaktuella guiderna som Från Text, Från Analysis Services eller Från Microsoft Query. Högerklicka på en anslutning för att komma åt på snabbmenyn. Därifrån kan du utföra ytterligare åtgärder som att uppdatera anslutningsdata från källan, ta bort anslutningen eller hantera anslutningsegenskaper via den välbekanta dialogrutan Anslutningsegenskaper.

Hur återställer jag den gamla Hämta externa data-upplevelsen?

I jämförelse med de äldre guiderna är den nya Hämta och transformera-upplevelsen överlägsen när det gäller anslutningsutbudet och transformeringsfunktionerna. Det finns dock fortfarande tillfällen då du kanske vill använda någon av de gamla guiderna för att importera dina data. Till exempel när du vill spara inloggningsuppgifterna till datakällan som en del av arbetsboken. (Observera att den här metoden inte uppfyller moderna säkerhetsstandarder och stöds därför inte i den nya Hämta och transformera-upplevelsen).

Du kan komma åt äldre anslutningar genom att anpassa menyfliksområdet eller så kan du flytta tillbaka och visa dina gamla dataimportsguider direkt på den nedrullningsbara menyn Data > Hämta data via de nya och enkla konfigurationsinställningarna från dialogrutan Excel-alternativ.

Öppna Arkiv > Alternativ > Data > Visa äldre guider för dataimport, och välj de guider som du vill använda:

Alternativ för återställning av äldre Hämta och transformera

Öppna den nedrullningsbara menyn Data > Hämta data och starta en av de äldre, redan markerade, guiderna för import av data från den dedikerade kategorin Äldre guider:

Äldre menyalternativ för Hämta och transformera

Ytterligare information om Hämta och transformera

Om du vill veta mer om funktionerna i Hämta och transformera är hjälpen för Microsoft Power Query för Excel en bra början.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community, få support i Answers-communityn eller föreslå en ny funktion eller förbättringar på Excel User Voice.

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×