Bakåtkompilera källkod för Microsoft Visual C++ 6.0

Viktigt!: Den här artikeln är maskinöversatt, se ansvarsfriskrivningen. Den engelska versionen av den här artikeln finns här för din referens.

  1. Anpassa Visual C++.

    hur

    1. Arbeta i Visual C++. Gå till Verktyg-menyn och klicka på Anpassa.

    2. Dialogrutan Anpassa öppnas. Klicka på fliken Tillägg och Makron.

    3. Markera UML-tillägg för Visio i listan Tillägg och Makron.

      UML-tillägg för Visio visas markerat.

    4. Klicka på Stäng.

      Verktygsfältet UML-tillägg för Visio med fem knappar visas.

    5. Om du vill att verktygsfältet ska visas varje gång du öppnar Visual C++ kan du docka verktygsfältet genom att dra det till verktygsfältområdet.

      Tips: Du kan ange tangentbordsgenvägar för alla knapparna i verktygsfältet UML-tillägg för Visio. Gå till Verktyg-menyn, klicka på Anpassa, klicka på fliken Tangentbord och välj kategorin Tilläggsprogram.

      Om du vill ange ytterligare systemet filer du vill bakåtkompilera (MFC, ATL eller inkludera) klickar du på Alternativ för Visio UML knappen Knappbild för UML-alternativ .

  2. Generera en Browse-informationsfil.

    hur

    1. Öppna Visual C++. Gå till Project-menyn och klicka på Settings.

    2. Dialogrutan Project Settings öppnas. Välj önskad typ av byggkonfiguration, klicka på fliken C/C++ och markera sedan Generate Browse Info.

    3. Klicka på fliken Browse Info och ange namn och plats för Browse-informationsfilen. Klicka på Build Browse Info File och klicka sedan på OK.

  3. Bygga projektet i Visual C++.

    Obs!: Om du gör ändringar i ett Visual C++-projekt efter att du har bakåtkompilerat det måste du återskapa projektet och sedan bakåtkompilera projektet till Visio-programmet för att se ändringarna.

  4. Klicka på Bakåtkompilera UML-modell verktygsfält knappen Knappbild för UML-bakåtkompilera i verktygsfältet Visio UML-tillägget i Visual C++.

    Om mer än ett projekt finns i arbetsytan i Visual C++ väljer du projektet som du vill bakåtkompilera (i dialogrutan Välj projekt) och klickar därefter på OK.

    Om det finns fler än en browse-fil i projekthierarkin väljer du filen (i dialogrutan Välj Browse-fil) och klickar därefter på OK.

    Det kan ta flera sekunder att ta fram klassinformationen från Browse-informationsfilen. När allt är framtaget öppnas Visio UML-modelldiagram med en tom ritningssida i ett statiskt strukturdiagram samt en trädvy i Modellutforskaren, där det finns ikoner som visar klassdefinitionerna i källkoden.

  5. I Visio UML-modelldiagram kan du dra ikoner från trädvyn till ritningssidan om du vill skapa ett statiskt strukturdiagram som representerar en bild av modellen.

Obs!: Ansvarsfriskrivning för maskinöversättning: Den här artikeln har översatts av ett datorsystem utan mänsklig inblandning. Microsoft erbjuder dessa maskinöversättningar för att hjälpa icke engelskspråkiga användare att ta del av information om Microsofts produkter, tjänster och tekniker. Eftersom artikeln är maskinöversatt kan den innehålla fel i ordval, syntax och grammatik.

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×