Avrunda ett tal till önskat antal decimaler

Avrunda ett tal till önskat antal decimaler

Om du inte vill ha onödiga decimaler i celler, eftersom de gör att symbolerna ###### visas, eller om du inte behöver mikroskopisk noggrannhet, kan du ändra cellformatet så att du får önskat antal decimaler.

Om du vill avrunda till närmaste huvudenhet, till exempel tusental, hundratal, tiotal eller ental, använder du en funktion i en formel.

Genom att använda en knapp:

  1. Markera de celler som du vill formatera.

  2. Klicka på Öka decimal eller Minska decimal på fliken Start om du vill visa fler eller färre siffror efter decimaltecknet.

Genom att använda ett inbyggt talformat:

  1. Klicka på pilen bredvid listan över talformat i gruppen Tal på fliken Start och sedan på Fler talformat.

Gruppen Tal på fliken Start

  1. Gå till listan Kategori och beroende på vilken typ av data du använder klickar du på Valuta, Redovisning, Procent eller Vetenskapligt.

  2. Ange antalet decimaler som ska visas i rutan Decimaler.

Genom att använda en funktion i en formel:

Avrunda ett tal till önskat antal decimaler genom att använda funktionen AVRUNDA. Den här funktionen har bara två argument (argument är data som behövs för att köra formeln).

  • Det första argumentet är talet som du vill avrunda, som kan kallas en cellreferens eller ett tal.

  • Det andra argumentet är antalet siffror som du vill avrunda talet till.

Anta att cell A1 innehåller 823,7825. Om du vill avrunda det här talet till närmaste:

  • Tusental

    • Skriv = AVRUNDA(A1,-3) vilket motsvarar 1 000

    • 823,7825 är närmare 1 000 än 0 (0 är en multipel av 1 000 )

    • Använd ett negativt tal här eftersom du vill att avrundningen ska göras till vänster om decimaltecknet. Samma sak gäller för de två följande formlerna som avrundas till hundratal och tiotal.

  • Hundratal

    • Skriv =AVRUNDA(A1,-2) vilket motsvarar 800

    • 823,7825 är närmare 800 än 900. Vi tror att du har förstått principen nu.

  • Tiotal

    • Skriv =AVRUNDA(A1,-1) vilket motsvarar 820

  • Ental

    • Skriv =AVRUNDA(A1,0) vilket motsvarar 824

    • Använd en nolla för att avrunda talet till närmaste ental.

  • Tiondelar

    • Skriv =AVRUNDA(A1,1) vilket motsvarar 823,8

    • Använd ett positivt tal här för att avrunda talet till det antal decimaler du anger. Samma sak gäller för de två följande formlerna som avrundas till hundradelar och tusendelar.

  • Hundradelar

    • Skriv =AVRUNDA(A1,2) vilket motsvarar 823,78

  • Tusendelar

    • Skriv = AVRUNDA(A1,3) vilket motsvarar 823,783

Avrunda ett tal uppåt genom att använda funktionen AVRUNDA.UPPÅT. Funktionen fungerar på samma sätt som AVRUNDA, förutom att avrundningen alltid görs uppåt. Exempel: Om du vill avrunda 3,2 till noll decimaler:

  • =AVRUNDA.UPPÅT(3,2,0) vilket motsvarar 4

Avrunda ett tal nedåt genom att använda funktionen AVRUNDA.NEDÅT. Funktionen fungerar på samma sätt som AVRUNDA, förutom att den alltid avrundar nedåt. Exempel: Om du vill avrunda 3,14159 till tre decimaler:

  • =AVRUNDA.NEDÅT(3,14159,3) vilket motsvarar 3,141

Tips: Om du vill se fler exempel och experimentera med exempeldata i en Excel Online-arbetsbok går du till artiklarna AVRUNDA, AVRUNDA.UPPÅT och AVRUNDA.NEDÅT.

Du kan ange en standarddecimal för talen i Excel-alternativen.

  1. Klicka på Alternativ (Excel 2010 till Excel 2016) eller Microsoft Office-knappen Bild av Office-knappen > Excel-alternativ (Excel 2007).

  2. Klicka på kategorin Avancerat och markera kryssrutan Infoga decimaltecken automatiskt under Redigeringsalternativ.

  3. I rutan Antal skriver du ett positivt tal för siffror till höger om decimaltecknet eller ett negativt tal för siffror till vänster om decimaltecknet.

    Obs!: Om du exempelvis skriver 3 i rutan Antal och sedan skriver 2834 i en cell så visas värdet som 2,834. Om du skriver -3 i rutan Antal och sedan skriver 283 i en cell så blir värdet 283000.

  4. Klicka på OK.

    Indikatorn Fast decimaler visas i statusfältet.

  5. Klicka på en cell i kalkylbladet och skriv ett tal.

    Obs!: Data som du skrev innan du markerade Fast decimaler påverkas inte.

  • Om du tillfälligt vill åsidosätta Fasta decimaler skriver du ett decimaltecken när du skriver talet.

  • Så här tar du bort decimaltecknen från där du redan har angett fast decimaltal:

    1. Klicka på Alternativ (Excel 2010 till Excel 2016) eller Microsoft Office-knappen Bild av Office-knappen > Excel-alternativ (Excel 2007).

    2. Klicka på Avancerat och avmarkera kryssrutan Infoga decimaltecken automatiskt under Redigeringsalternativ.

    3. Skriv ett tal som 10, 100, eller 1 000 i en tom cell, beroende på hur många decimaler du vill ta bort.

      Skriv till exempel 100 i cellen om talen innehåller två decimaler och du vill konvertera dem till heltal.

    4. Klicka på Kopiera Knappbild i gruppen Urklipp på fliken Start, eller tryck på Ctrl+C.

    5. Markera de celler som innehåller talen med decimaler som du vill ändra i kalkylbladet.

    6. Klicka på pilen under Klistra in på fliken Start i gruppen Urklipp. Klicka sedan på Klistra in special.

    7. Klicka på Multiplicera i dialogrutan Klistra in special, under Operation.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community, få support i Answers-communityn eller föreslå en ny funktion eller förbättringar på Excel User Voice.

Mer information finns i

Avrunda ett nummer

Varför visas ett nummer som avrundat?

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×