Arbeta sömlöst med Office för webb-och Office-datorprogram

Office på webben-kommandot för att öppna eller redigera dokumentet i Word, Excel och PowerPoint fungerar bäst med den senaste versionen av Office. Om du har en äldre version av Office fungerar det bäst med den senaste versionen av webbläsaren Internet Explorer.

När du använder det här kommandot öppnas dokumentet normalt sett med rätt Office-program och du kan utnyttja alla funktioner i programmen. När du sparar dokumentet sparas det på den plats från vilken du öppnade det i Office på webben.

Om du stöter på problem när du försöker öppna dokumentet i skrivbordsprogrammet fortsätter du att arbeta med det i Office på webben. Du kan också prova med den senaste Office-versionen. Du kan prova den kostnadsfritt i en månad om du inte är redo att göra ett inköp.

Om du redan har den senaste versionen av Office kan problemet ligga i webbläsaren du använder. Nu går vi igenom hur du kan lösa problemet

Använd en annan webbläsare

Tillägget som öppnar dokument fungerar bara i 32-bitars Internet Explorer, Chrome, Firefox eller Safari (Mac). Om du använder en annan webbläsare, till exempel om du använder 64-bitars Internet Explorer, måste du ladda ned och ladda upp dokumentet manuellt eller fortsätta använda Office på webben. I Windows 8 kan du också använda Internet Explorer som körs på Skriv bordet, inte på det program som du kör på Start skärmen.

Om det har visats ett meddelande om webbläsartillägget för Office på webben kan du gå vidare och hämta och installera tillägget.

Köra tillägget

Om du har rätt typ av webbläsare och en ny version av Office kan dina säkerhetsinställningar vara för stränga. Eller så har tillägget inaktiverats. Här finns anvisningar för hur du rättar till de här problemen:

Ändra säkerhetsinställningar i Internet Explorer

  1. Gå till Verktyg > Internetalternativ och klicka på Betrodda platser på fliken Säkerhet.

  2. Om skjutreglaget står på Hög flyttar du det till Medelhög.

Ge behörighet i Chrome

Om du ser ett meddelande om begäran om externt protokoll (External Protocol Request) i Chrome markerar du kryssrutan Kom ihåg mitt val för alla länkar av den här typen och klickar på Starta program. Nästa gång du använder Office på webben-kommandot när du vill öppna eller redigera ett dokument i programmet ska det fungera utan problem.

Aktivera tillägget igen

I Internet Explorer:

  1. Gå till Verktyg > Hantera tillägg.

  2. Det finns en nedrullningsbar lista med etiketten bild. Öppna det och klicka på alla tillägg.

  3. Rulla genom tilläggen tills du ser de som kommer från Microsoft och klicka på OpenDocument-klass för SharePoint .

  4. Klicka på Aktivera i dialogrutans nedre del och stäng sedan dialogrutan.

I Firefox:

  1. Gå till Firefox-listrutan och klicka på Tillägg och gå sedan till Insticksmoduler.

  2. Leta efter Microsoft Office 2010-modulen. Det står (inaktiverad) efter namnet.

  3. Klicka på Aktivera.

Kör OS X Lion i 32-bitars läge

Om du använder Safari eller Firefox och din Mac kör OS X Lion växlar du till 32-bitars läge:

  1. Stäng webbläsaren.

  2. I Finder går du till Program och markerar Safari- eller Firefox-ikonen.

  3. I webbläsaren går du till Arkiv > Få information och markera Öppna i 32-bitars läge.

  4. Stäng webbläsaren och öppna den igen.

Om du fortfarande behöver hjälp med att få dokument att öppna på din Mac kan du gå till forumet Office för Mac på https://answers.Microsoft.com/en-US/Mac.

Obs!:  Den här sidan har översatts automatiskt och kan innehålla grammatiska fel och andra felaktigheter. Vår avsikt är att innehållet ska vara användbart för dig. Skulle du vilja svara på om informationen var till hjälp? Här är den engelska artikeln som en referens.

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×