Använda kapslade funktioner i en formel

Viktigt!: Den här artikeln är maskinöversatt, se ansvarsfriskrivningen. Den engelska versionen av den här artikeln finns här för din referens.

Med hjälp av en funktion som argument i en formel som använder en funktion som kallas kapsling, och vi ska referera till som fungerar som en kapslad funktion. Till exempel genom att kapsla funktionen medel och summa i argumenten för funktionen om summerar följande formel en uppsättning tal (G2:G5) om medelvärdet för en annan uppsättning tal (F2: F5) är större än 50. Annars returneras 0.

Kapslade funktioner

Funktionerna medel och summa är kapslade om-funktionen.

Du kan kapsla upp till 64 funktionsnivåer i en formel.

  1. Klicka på den cell som du vill skriva in formeln i.

  2. Om du vill inleda formeln med funktionen klickar du på Infoga funktion Bild av knapp i formelfältet Bild av knapp .

    Likhetstecknet (=) infogas automatiskt av Excel.

  3. Markera Alla i rutan Eller välj en kategori.

    Om du känner till funktionskategorierna kan du också markera en kategori.

    Om du är osäker på vilken funktion du ska använda kan du skriva in en fråga som beskriver vad du vill göra i rutan Sök efter funktion (till exempel returneras funktionen SUMMA om du skriver in "lägga till tal").

  4. Om du vill ange en annan funktion som argument skriver du in den i den aktuella argumentrutan.

    De delar av formeln som visas i dialogrutan Funktionsargument speglar den funktion som du valde i föregående steg.

    Om du till exempel klickade på OM visar dialogrutan Funktionsargument argumenten för funktionen OM. Vill du kapsla ytterligare en funktion kan du ange den i argumentrutan. Exempelvis kan du skriva inSUMMA(G2:G5) i rutan Värde_om_sant för funktionen OM.

  5. Ange alla argument som behövs för att formeln ska bli komplett.

    I stället för att skriva in cellreferenser kan du markera de celler som du vill referera till. Klicka på Bild av knapp för att minimera dialogrutan, markera de celler som du vill referera till och klicka sedan på Knappbild för att expandera dialogrutan igen.

    Tips: Om du vill ha mer information om en funktion och tillhörande argument kan du klicka på Hjälp om funktionen.

  6. När du är färdig med att ange argument för formeln klickar du på OK.

  1. Klicka på den cell som du vill skriva in formeln i.

  2. Om du vill inleda formeln med funktionen klickar du på Infoga funktion Bild av knapp i formelfältet Bild av knapp .

  3. Markera alla i dialogrutan Infoga funktion i rutan Välj en kategori.

    Om du känner till funktionskategorierna kan du också markera en kategori.

  4. Om du vill ange en annan funktion som argument skriver du in den i den aktuella argumentrutan i Formelverktyget eller direkt i cellen.

  5. Ange alla argument som behövs för att formeln ska bli komplett.

  6. När du har slutfört argumenten för formeln trycker du på RETUR.

Exempel

Här visas exempel på hur du använder kapslade funktioner av typen OM för att betygsätta ett provresultat med bokstäver.

Kopiera exempeldata i följande tabell och klistra in dem i cell A1 i ett nytt Excel-kalkylblad. När du vill att formlerna ska visa resultat markerar du dem, trycker på F2 och sedan på Retur. Om det behövs kan du justera kolumnbredderna så att alla data visas.

Poäng

45

90

78

Formel

Beskrivning

Resultat

'=OM(A2>89;"A";OM(A2>79;"B"; OM(A2>69;"C";OM(A2>59;"D";"F"))))

Tilldelar ett bokstavsbetyg till poängen i cell A2 med kapslade OM-villkor.

=OM(A2>89;"A";OM(A2>79;"B"; OM(A2>69;"C";OM(A2>59;"D";"F"))))

'=OM(A3>89;"A";OM(A3>79;"B"; OM(A3>69;"C";OM(A3>59;"D";"F"))))

Tilldelar ett bokstavsbetyg till poängen i cell A3 med kapslade OM-villkor.

=OM(A3>89;"A";OM(A3>79;"B";OM(A3>69;"C";OM(A3>59;"D";"F"))))

'=OM(A4>89;"A";OM(A4>79;"B"; OM(A4>69;"C";OM(A4>59;"D";"F"))))

Tilldelar ett bokstavsbetyg till poängen i cell A4 med kapslade OM-villkor.

=OM(A4>89;"A";OM(A4>79;"B";OM(A4>69;"C";OM(A4>59;"D";"F"))))

Tips!: 

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community, få support i Answers-communityn eller föreslå en ny funktion eller förbättringar på Excel User Voice.

Obs!: Ansvarsfriskrivning för maskinöversättning: Den här artikeln har översatts av ett datorsystem utan mänsklig inblandning. Microsoft erbjuder dessa maskinöversättningar för att hjälpa icke engelskspråkiga användare att ta del av information om Microsofts produkter, tjänster och tekniker. Eftersom artikeln är maskinöversatt kan den innehålla fel i ordval, syntax och grammatik.

Mer information finns i

Video: Kapslade om-funktioner

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×