Använda PRODUKTSUMMA när du vill summera produkten av motsvarande värden i en eller flera matriser

Viktigt!: Den här artikeln är maskinöversatt, se ansvarsfriskrivningen. Den engelska versionen av den här artikeln finns här för din referens.

PRODUKTSUMMA använder cellområden (eller matriser) som argument (de delar av formeln som får den att fungera). Objekten i matriserna multipliceras och sedan adderas resultaten.

Det här exemplet är en inköpslista, där en matris innehåller kostnaden för varje objekt och den andra matrisen anger hur många objekt som ska köpas.

Priser och kvantiteter som ska multipliceras och sedan summeras

  1. Skapa formeln genom att ange =PRODUKTSUMMA(B3:B6;C3:C6) och sedan trycka på Retur.

Varje cell i kolumn B multipliceras med motsvarande cell på samma rad i kolumn C, och resultaten adderas sedan. Det totala beloppet för varorna är 129,60 kr.

  1. För att använda en längre formel som ger samma resultat, typ = B3 * C3 + B4 * C4 + B5 * C5 + B6 * C6 och tryck på RETUR.

När du trycker på Retur blir resultatet detsamma: 129,60 kr. Cell B3 multipliceras med C3, och resultatet adderas med resultatet av cell B4 gånger cell C4 och så vidare. Du kan tänka dig hur mycket enklare det är att använda PRODUKTSUMMA om du har tusentals (eller bara hundratals) rader.

Meddelanden: 

  • Kolumnerna eller raderna (matriserna) måste vara lika långa.

  • Om en cell innehåller text i stället för ett tal behandlas det som noll.

Exempel

Om du vill leka lite med PRODUKTSUMMA och matriser kan du använda den här Excel Online-arbetsboken med andra data än de vi använder i den här artikeln.

Kopiera exempeldata i följande tabell och klistra in dem i cell A1 i ett nytt Excel-kalkylblad. När du vill att formlerna ska visa resultat markerar du dem, trycker på F2 och sedan på Retur. Om det behövs kan du justera kolumnbredderna så att alla data visas.

En

B

:d

R

3

4

2

7

8

6

6

7

1

9

5

3

Formel

Resultat

'=PRODUKTSUMMA(A2:B4;D2:E4)

=PRODUKTSUMMA(A2:B4;D2:E4)

Multiplicerar de två matrisernas alla komponenter (A2:B4 och D2:E4) och lägger sedan till produkterna – d.v.s 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156).

Du kan även öppna den här arbetsboken i Excel. Klicka bara på Excel-ikonen i det nedre högra hörnet i arbetsboken  Excel-ikon i Excel Online , spara filen på en praktisk plats på datorn och öppna den sedan.

Överst på sidan

Obs!: Ansvarsfriskrivning för maskinöversättning: Den här artikeln har översatts av ett datorsystem utan mänsklig inblandning. Microsoft erbjuder dessa maskinöversättningar för att hjälpa icke engelskspråkiga användare att ta del av information om Microsofts produkter, tjänster och tekniker. Eftersom artikeln är maskinöversatt kan den innehålla fel i ordval, syntax och grammatik.

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×