Använda Excel som miniräknare

Använda Excel som miniräknare

Använd Microsoft Excel istället för miniräknaren när du ska göra en beräkning!

På ett kalkylblad kan du ange enkla formler och addera, dividera, multiplicera eller subtrahera två eller flera numeriska värden. Du kan även använda funktionen Autosumma om du snabbt vill summera en serie värden utan att behöva ange manuella värden i en formel. När du har skapat en formel kan du dra den till angränsande celler så att du slipper skapa samma formel om och om igen.

När du har lärt dig att behärska enkla formler kan du också lära dig hur du skapar mer komplexa formler genom att prova några av de många funktionerna som är tillgängliga i Excel. Mer information finns i Översikt över formler och Lista över kalkylbladsfunktioner (efter kategori).

Obs!: Skärmbilderna i den här artikeln har tagits i Excel 2016. Vyn kan variera beroende på Excel-versionen du använder.

Läs mer om hur du kapar enkla formler.

Alla formelinmatningar börjar med ett likhetstecken (=). För enkla formler anger du bara ett likhetstecken följt av de numeriska värdena som du vill beräkna samt de matematiska operatorerna som du vill använda – plustecken (+) om du vill addera, minustecken (-) om du vill subtrahera, asterisk (*) om du vill multiplicera och snedstreck (/) om du vill dividera. Tryck på Retur så beräknar Excel omedelbart och visar resultatet av formeln.

Om du till exempel skriver = 12,99 + 16,99 i cell C5 och trycker på Retur, beräknar Excel resultatet och visar 29,98 i cellen.

Exempel på en enkel formel

Formeln du anger i en cell förblir synlig i formelfältet och du kan se den när cellen markeras.

Viktigt!: Det finns en SUMMA-funktion, men ingen SUBTRAHERA-funktion. Använd i stället minustecknet (-) som operator i en formel. Till exempel: = 8-3 + 2 – 4 + 12. Du kan också använda ett minustecken till att konvertera ett tal till dess negativa värde i SUMMA-funktionen. Exempel: I formeln =SUM(12,5,-3,8,-4), används SUMMA-funktionen för att addera 12, 5, subtrahera 3, addera 8 och subtrahera 4, i den ordningen.

Använda Autosumma

Det enklaste sättet att addera en SUMMA-formel i kalkylbladet är att använda Autosumma-funktionen. Markera en tom cell direkt ovanför eller nedanför det område som du vill summera. På fliken Start eller Formel i menyfliksområdet trycker du på Autosumma > Summa. Autosumma känner automatiskt av det område som ska summeras formeln skapas. Det fungerar även vågrätt om du markerar en cell åt vänster eller höger i området som ska summeras.

Obs!: Autosumma fungerar inte för icke-angränsande områden.

Du kan använda guiden Autosumma för att automatiskt skapa en Summa-formel.  Välj ett område ovanför/nedanför eller till vänster/höger om området som ska summeras och gå till fliken Formel i menyfliksområdet och markera Autosumma och SUMMA.

Autosumma lodrätt

Cell D6 visar summaformeln för Autosumma: =SUMMA(B2:B5)

Guiden Autosumma har automatiskt upptäckt att cellerna B2:B5 är området som ska summeras. Du behöver bara trycka på Retur för att bekräfta. Om du behöver lägga till/utelämna fler celler kan du hålla ned Skift > valfri piltangent tills ditt val matchar det du önskar och trycka på Retur när du är klar.

IntelliSense-funktionsguide: SUMMANS (tal1, [tal2], ...) flytande tagg under den här funktionen är dess Intellisense-guide. Om du klickar på SUMMA eller namnet på funktionen ändras den till en blå hyperlänk som tar dig till hjälpavsnittet för funktionen. Om du klickar på de enskilda funktionselement markeras deras representativa delar i formeln. I det här fallet skulle endast B2:B5 markeras eftersom det finns bara en talreferens i den här formeln. Intellisense-taggen visas för vilken funktion som helst.

Autosumma vågrätt

Cell D2 visar summaformeln för Autosumma: =SUMMA(B2:C2)

Vänta, det finns mer att summera. Ta en titt på SUMMA-funktionen!

Sluta skriva samma formel om och om igen

När du har skapat en formel kan du dra den till angränsande celler – utan att behöva skapa samma formel om och om igen. Du kan antingen kopiera formeln eller använda fyllningshandtaget Fyllningshandtag för att kopiera formeln till angränsande celler.

När du till exempel kopierar formeln i cell B6 till C6 ändras formeln i cellen automatiskt och uppdateras enligt cellreferenserna i kolumn C.

När du kopierar en formel uppdateras cellreferenser automatiskt

Kontrollera att cellreferenserna är korrekta när du kopierar formeln. Cellreferenser kan ändras utifrån absoluta eller relativa referenser. Mer information finns i Kopiera och klistra in en formel till en annan cell eller ett annat kalkylblad.

Vad kan jag använda i en formel för att efterlikna kalkylatortangenterna?

Kalkylatortangent

Excel-metod

Beskrivning, exempel

Resultat

+ (plustangent)

+ (plustecken)

Använd i en formel för att addera tal. Exempel: =4+6+2

12

- (minustangent)

- (minustecken)

Använd i en formel för att subtrahera tal eller för att beteckna ett negativt tal.

Exempel: =18-12

Exempel: =24*-5 (24 gånger minus 5)


6

-120

x (multiplikationstangent)

* (asterisk, även kallad "stjärna")

Använd i en formel för att multiplicera tal. Exempel: =8*3

24

÷ (divisionstangent)

/ (snedstreck)

Använd i en formel för att dividera ett tal med ett annat. Exempel: =45/5

9

% (procenttangent)

% (procent)

Använd i en formel med * för att multiplicera med en procent. Exempel: =15%*20

3

(kvadratroten)

SQRT (funktion)

Använd ROT-funktionen i en formel för att hitta kvadratroten av ett tal. Exempel: =SQRT(64)

8

1/x (motsvarigheten)

= 1/n

Använd = 1 /n i en formel där n är talet som du vill dividera med 1.

Exempel: =1/8

0,125

Har du en specifik Excel-fråga?

Ställ en fråga i Excel-communityforumet

Hjälp oss att göra Excel bättre

Har du förslag på hur vi kan förbättra nästa version av Excel? Titta i så fall på avsnitten i Excel User Voice

Mer information finns i

Beräkningsoperatorer och prioritet i Excel

Översikt över formler i Excel

Hur du undviker felaktiga formler

Hitta och korrigera fel i formler

Kortkommandon och funktionstangenter i Excel

Excel-funktioner (alfabetisk ordning)

Excel-funktioner (efter kategori)

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×