#NAMN? visas i stället för innehållet i vissa celler

Orsak: Formeln använder en anpassad funktion som inte är tillgänglig.

Lösning:    Kontrollera att arbetsboken som innehåller den anpassade funktionen är öppen och att den fungerar korrekt.

  1. Markera cellen.

  2. På fliken Formler klickar du på Formelverktyget under Funktion.

    Fliken Formler, gruppen Funktion

  3. Redigera formeln i fältet Argument i fönstret för formelverktyget.

    Obs!: Vissa inbyggda funktioner som är tillgängliga i Excel för Windows är inte tillgängliga i Excel för Mac. Mer information finns i Funktionen fungerar inte.

Orsak: Formeln innehåller en referens till en namngiven cell eller ett namngivet område som inte är definierat.

Lösning:    Kontrollera att den namngivna cellen eller det namngivna området är definierat.

  1. Peka på NamnInfoga-menyn och klicka sedan på Definiera.

  2. Om den namngivna cellen eller det namngivna området inte visas lägger du till det genom att klicka på Definiera.

Orsak: Formeln innehåller ett funktionsnamn, en namngiven cell eller ett namngivet område som är felstavat.

Lösning:    Redigera formeln och rätta stavningen.

  1. Markera cellen.

  2. På fliken Formler klickar du på Formelverktyget under Funktion.

    Fliken Formler, gruppen Funktion

  3. Redigera formeln i fältet Argument i fönstret för formelverktyget.

    Obs!: Vissa inbyggda funktioner som är tillgängliga i Excel för Windows är inte tillgängliga i Excel för Mac. Mer information finns i Funktionen fungerar inte.

Orsak: Formeln innehåller text som inte har matats in på rätt sätt.

Lösning:    Redigera formeln så att texten omsluts med citattecken ( " ).

  1. Markera cellen.

  2. På fliken Formler klickar du på Formelverktyget under Funktion.

    Fliken Formler, gruppen Funktion

  3. Redigera formeln i fältet Argument i fönstret för formelverktyget.

Orsak: Ett kolon ( : ) saknas i en områdesreferens.

Lösning:    Kontrollera att alla områdesreferenser i formeln använder kolon ( : ).

Till exempel =SUMMA(A1:C10).

Orsak: Formeln innehåller en referens till en annan arbetsbok eller annat kalkylblad med ett icke alfabetiskt tecken eller ett blanksteg i namnet, men referensen omsluts inte med enkla citattecken ( ' ).

Lösning:    Redigera formeln och omslut namnet på arbetsboken eller bladet med enkla citattecken ( ' ).

  1. Markera cellen.

  2. På fliken Formler klickar du på Formelverktyget under Funktion.

    Fliken Formler, gruppen Funktion

  3. Redigera formeln i fältet Argument i fönstret för formelverktyget.

Orsak: Formeln innehåller en referens till en rad- eller kolumnrubrik (etiketter) som inte stöds i Excel 2008 för Mac och Excel 2007 för Windows.

Lösning:    Tillåt att etikettreferenser ändras till vanliga cellreferenser i Excel.

När du öppnar en arbetsbok som innehåller formler med etiketter kan du ändra etikettreferenserna till de vanliga cellreferenserna i Excel. Om till exempel en arbetsbok innehåller en kolumn med data med rubriken "Försäljning" som sträcker sig från cell A2 till cell A10, och arbetsboken innehåller formeln =SUMMA(Försäljning), byts etikettreferensen "Försäljning" ut mot den vanliga cellreferensen "A2:A10" och sedan räknas formeln om. Om du tillåter att dessa ändringar görs i Excel blir ändringarna av formeln permanenta när du sparar arbetsboken, och de kan inte ångras.

Du kan också använda namn om du vill skapa formler som är enklare att förstå. Mer information om hur du skapar namn och formler som använder namn finns i Använda namn i formler.

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×