Priprava Excelovega vira podatkov za Wordovo spajanje dokumentov

Ustvarili ste seznam stikov in drugih podatkov, ki jih želite uporabiti za spajanje dokumentov v Word. Če je vaš vir podatkov obstoječa preglednica Excel, morate le pripraviti podatke za spajanje dokumentov. Če pa je vaš vir podatkov zavihek, ločen (. txt) ali datoteka z vrednostmi, ločenimi z vejico (. csv), morate najprej uvoziti podatke v Excel in jo nato pripraviti na spajanje dokumentov.

1. korak: Nastavitev vira podatkov v Excel

Če uporabljate Excel preglednico kot vir podatkov za spajanje dokumentov v Word, preskočite ta korak. Če je vir podatkov datoteka. txt ali a . csv, uporabite čarovnika za uvoz besedila, da nastavite podatke v Excel.

Ko ste uspešno uvozili datoteko .txt ali .csv, nadaljujte z 2. korakom.

  1. Odprite Excel.

  2. Pojdite na > podatkov iz besedila/CSV.

    Izbiranje besedila/CSV na zavihku» podatki «

  3. Izberite želeno datoteko. txt ali. csv in nato izberite Uvozi.

  4. V oknu predogleda izberite preoblikuj podatke.

  5. Izberite ZIP, poštno številko ali drug stolpec, ki ga želite oblikovati.

  6. Pojdite na Transform > podatkovni tip: in izberite besedilo.

    Okno dodatka Power Query z izbranim besedilom

  7. Izberite Zamenjaj trenutno.

  8. Po potrebi ponovite korake 5-7.

  9. Izberite zapri & nalaganje.

  10. Pojdite v razdelek datoteka > Shrani kot in Shrani kot z drugim imenom.

  1. Odprite Excel.

  2. Excel 2016    Pojdite na podatki > pridobite zunanje podatke > iz besedila.

    Na zavihku »Podatki« je označena možnost »Iz besedila«.

  3. Izberite želeno datoteko. txt ali. csv in nato izberite Uvozi.

  4. V čarovniku za uvoz besedila v podoknu Izvirna vrsta podatkov izberite Ločeno.

    Excelova funkcija »Pridobi zunanje podatke iz besedila«, Čarovnik za uvoz besedila, korak 1 od 3

  5. Izberite moji podatki imajo glave nad podoknom predogleda, če ima datoteka glave, nato pa izberite naprej.

  6. V podoknu ločila potrdite potrditveno polje, ki se ujema z ločilom (kot je na primer zavihek ali vejica), ki ga uporabljajo podatki, nato pa izberite naprej.

    V čarovniku za uvoz besedila so označene možnosti za ločila.

  7. V razdelku Predogled podatkov izberite stolpec s poštnimi številkami, nato pa v razdelku Oblika zapisa podatkov v stolpcih izberite Besedilo.

    V čarovniku za uvoz besedila je označena možnost »Besedilo« za obliko podatkov v stolpcih.

    Opomba: Vsakič ko uporabite obliko podatkov – splošno, besedilo ali datum – za stolpec, se ime oblike zapisa prikaže v glavi tabele za ta stolpec.

  8. Po potrebi ponovite 7. korak in izberite stolpec, ki ga želite spremeniti, in obliko zapisa podatkov, ki jo želite uporabiti.

  9. Izberite Dokončaj.

  10. V pogovornem oknu Uvoz podatkov sprejmite privzete nastavitve za Obstoječi delovni list in naslov celice, nato pa kliknite V redu.

    V pogovornem oknu »Uvoz podatkov« izberite vstavljanje podatkov v obstoječi delovni list, privzeto nastavitev ali vstavljanje v nov delovni list

    Pozor: V naslovu celice v pogovornem oknu Uvoz podatkov je prikazana trenutno izbrana celica. Podatki se uvozijo tako, da se najprej uvozi celica z naslovom.

  11. Shranite preglednico z novim imenom datoteke.

2. korak: Priprava vira podatkov

V viru podatkov za Excel, ki ga boste uporabili za poštni seznam v spajanju dokumentov Word, preverite, ali ste pravilno oblikovali stolpce s številskimi podatki. Oblikujte stolpec s števili, na primer tako, da se ujema z določeno kategorijo, kot je valuta.

Če izberete kot kategorijo odstotek, ne pozabite, da se bo zaradi oblike zapisa odstotka vrednost v celici pomnožila z 100. Če se želite izogniti dejavniku množenja, oblikujte stolpec z odstotki kot besedilo.

Kode ZIP ali poštne številke morajo biti oblikovane kot besedilo, če želite ohraniti podatke med spajanjem dokumentov. Če ga ne izvedete pri uvozu, ga oblikujte zdaj. Vodilne ničle – na primer 00399 – v kodah se med spajanjem izpustijo, če niso oblikovane kot besedilo.

  1. Izberite stolpec, ki vsebuje kode ZIP, poštne številke ali druge podatke, ki jih želite oblikovati.

  2. Pojdite na osnovnoin v skupini število izberite puščico navzdol polje oblika zapisa števil in nato izberite možnost na seznamu (na primer besedilo).

    V Excelovem zavihku »Osnovno«, skupina »Število«  izberite puščico navzdol v skupini »Splošno«, če želite izbrati uporabljeno obliko zapisa števil.

Preverite, ali ste pred ali za spojno polje dodali ustrezen simbol. Tukaj si lahko na primer ogledate, kako so videti vrednosti za valuto in odstotek, če izpustite simbole.

V dokumentu z rezultati spajanja dokumentov je napisano »vaš prispevek 50,00 EUR« in »ponudba za 20-odstotni popust«.

Če vključite simbole, so številke bolj smiselne.

Rezultat spajanja je dokument »vaš prispevek 50,00 EUR« in »ponudba za 20-odstotni popust«.

V dokumentu za spajanje dokumentov dodajte simbole pred ali za polja za spajanje tako:

V vzorčnem spojenem dokumentu je dolarski znak pred poljem »Donacija« in znak za odstotke pred poljem »Odstotek«.

Glejte tudi

Bistven korak v procesu spajanja dokumentov Word je nastavitev in priprava vira podatkov. Uporabite lahko obstoječe Excel viru podatkov ali ustvarite novega tako, da uvozite zavihek (. txt) ali datoteko z vrednostmi, ločenimi z vejico (. csv). Ko nastavite in pripravite svoj vir podatkov, lahko izvedete spajanje dokumentov s DDE (dinamična izmenjava podatkov) čarovnikom za spajanje dokumentov po korakih ali z načinom ročnega spajanja dokumentov.

Če ne uporabljate obstoječega vira podatkov Excel za spajanje dokumentov, lahko uporabite seznam stikov ali adresar v datoteki. txt ali . csv. Čarovnik za uvoz besedila vas vodi skozi navodila za pridobivanje podatkov, ki so v datoteki. txt ali. CSV v Excel.

  1. Odprite Excel.

  2. Na zavihku podatki izberite iz besedila/CSV.

  3. Izberite želeno datoteko. txt ali. csv in nato izberite Uvozi.

  4. V čarovniku za uvoz besedila v podoknu Izvirna vrsta podatkov izberite Ločeno.

    Excelova funkcija »Pridobi zunanje podatke iz besedila«, Čarovnik za uvoz besedila, korak 1 od 3

  5. Potrdite potrditveno polje Moji podatki imajo glave nad podoknom Predogled, če uvažate datoteko z glavami, nato pa izberite Naprej.

  6. V podoknu Ločila potrdite potrditveno polje, ki se ujema z ločilom (na primer tabulatorka ali vejica) za vaše podatke, in nato kliknite Naprej.

    V čarovniku za uvoz besedila so označene možnosti za ločila.

    Namig: V podoknu Predogled podatkov se prikaže predogled rezultatov v obliki tabele.

  7. V razdelku Predogled podatkov izberite stolpec s poštnimi številkami, nato pa v razdelku Oblika zapisa podatkov v stolpcih izberite Besedilo.

    V čarovniku za uvoz besedila je označena možnost »Besedilo« za obliko podatkov v stolpcih.

    Opombe: 

    • Oblike zapisa, ki so na voljo, so Splošno, Besedilo in Datum. Vsakič ko uporabite obliko zapisa podatkov v stolpcu, se ime oblike zapisa prikaže v glavi tabele za ta stolpec.

    • Stolpec, ki vsebuje številske podatke, kot sta na primer odstotek ali vrednost valute, je mogoče oblikovati samo po uvozu datoteke. Za več informacij si oglejte podrazdelek »Oblikuj številske podatke v Excel«, ki sledi.

  8. Po potrebi ponovite 7. korak in izberite stolpec, ki ga želite spremeniti, in obliko zapisa podatkov, ki jo želite uporabiti.

  9. Izberite Dokončaj.

  10. V pogovornem oknu Uvoz podatkov sprejmite privzete nastavitve za Obstoječi delovni list in naslov celice, nato pa kliknite V redu.

    V pogovornem oknu »Uvoz podatkov« izberite vstavljanje podatkov v obstoječi delovni list, privzeto nastavitev ali vstavljanje v nov delovni list

    Pozor: V naslovu celice v pogovornem oknu Uvoz podatkov je prikazana trenutno izbrana celica. Podatki se uvozijo tako, da se najprej uvozi celica z naslovom.

  11. Ko končate, shranite svoj vir podatkov z novim imenom datoteke.

Oblikovanje številskih podatkov vExcel

Oblikujte poljubne številske podatke, kot so odstotki ali vrednosti valut, v katerem koli novem ali obstoječem viru podatkov v Excel, ki ga nameravate uporabiti v Word spajanju dokumentov. Če želite ohraniti številske podatke, ki ste jih oblikovali kot odstotek ali kot valuto med spajanjem dokumentov, upoštevajte navodila v razdelku» korak 2: uporaba dinamične izmenjave podatkov (DDE) za spajanje dokumentov «.

V viru podatkov za Excel, ki ga boste uporabili za poštni seznam v spajanju dokumentov Word, preverite, ali ste pravilno oblikovali stolpce s številskimi podatki. Oblikujte stolpec s števili, na primer tako, da se ujema z določeno kategorijo, kot je valuta.

  1. Odprite svoj Excel vir podatkov.

  2. Izberite stolpec, ki ga želite oblikovati.

  3. Na zavihku Osnovno v skupini Število kliknite puščico dol v polju Oblika zapisa številke (splošno) in nato izberite možnost na seznamu.

    V Excelovem zavihku »Osnovno«, skupina »Število«  izberite puščico navzdol v skupini »Splošno«, če želite izbrati uporabljeno obliko zapisa števil.

  4. Po potrebi ponovite 2. in 3. korak.

  5. Ko končate, izberite možnost Shrani.

Če imate Excel vir podatkov, ki vsebuje oblikovane številke, kot so odstotki in vrednosti valute, nekateri številski podatki morda ne bodo ohranili svojega oblikovanja med spajanjem dokumentov. Dobili boste želene rezultate spajanja dokumentov in lahko ohranili obliko številskih podatkov v Excel s funkcijo DDE.

Excelova oblika zapisa podatkov v primerjavi s spajanjem polj za delo s pomočjo dinamične izmenjave podatkov ali brez nje

Opomba: Če se odločite, da ne boste uporabljali DDE, upoštevajte navodila v razdelku Uporaba spajanja dokumentov za pošiljanje množičnih e-poštnih sporočil.

  1. Odprite Word, izberite Datoteka > Možnosti > Napredno.

  2. V razdelku splošnopotrdite potrditveno polje ob odpiranju potrdite pretvorbo oblike datoteke .

    Pri možnosti odpiranja potrdite pretvorbo oblike datoteke

  3. Izberite V redu.

  4. Na zavihku pošiljanje izberite začni spajanje dokumentov > čarovnik za Spajanje dokumentov po korakih.

    Na zavihku »Pošiljanje« v Wordu izberite možnost »Začni spajanje dokumentov« in nato izberite čarovnika za spajanje dokumentov po korakih.

  5. V podoknu Spajanje dokumentov v razdelku Izbiranje prejemnikov izberite možnost Uporabi obstoječ seznam.

    Podokno opravil za spajanje dokumentov v Wordu, ki se odpre, ko izberete čarovnika za spajanje dokumentov po korakih v skupini za spajanje dokumentov

  6. V razdelku Uporabi obstoječ seznam izberite možnost Prebrskaj in nato odprite svoje oblikovane preglednice.

  7. V pogovornem oknu potrdi vir podatkov izberite potrditveno polje Pokaži vse in nato kliknite delovni listi MS Excela prek DDE (*. xls) > v redu.

    Pogovorno okno »Potrdite vir podatkov«

  8. V pogovornem oknu Microsoft Excel izberite možnost Celotna preglednica > V redu.

    Pogovorno okno »Microsoft Excel« v Wordu

  9. Ko se odpre pogovorno okno Prejemniki spajanja dokumentov, izberite možnost V redu.

    Pogovorno okno »Prejemniki spajanja dokumentov«, ki prikazuje vsebino Excelove preglednice, ki se uporablja kot vir podatkov za poštni seznam

  10. Nadaljujte s spajanjem pisma, e-poštnega sporočila, oznake ali ovojnice.

Namig: Lahko preprečite, da vas ob vsakem odpiranju podatkovne datoteke pozove Word. Ko vzpostavite povezavo s svojim poštnim seznamom, pojdite na Datoteka > Možnosti > Napredno. V razdelku Splošno počistite potrditveno polje Ob odpiranju potrdite pretvorbo oblike datoteke.

Če ste v preglednici Excel ustvarili seznam stikov, je pomembno, da v besedilu oblikujete kakršne koli poštne kode ali poštne številke, da ne bi izgubili podatkov. Če uvažate stike v novo preglednico iz besedila (. txt) ali datoteke z vrednostmi, ločenimi z vejico (. csv), vam čarovnik za uvoz besedila lahko pomaga uvoziti in oblikovati podatke.

1. korak: nastavitev vira podatkov v Excelu

Če že uporabljate Excelovo preglednico kot vir podatkov za spajanje dokumentov v Wordu, pojdite na korak 2 v tej temi. Če je vir podatkov datoteka. txt ali. csv, ki vsebuje vaše stike iz storitve Gmail, na primer uporabite čarovnika za uvoz besedila za nastavitev podatkov vExcel.

  1. Odprite Excel in na zavihku podatki izberite iz besedila.

    On the Data tab, select From Text

  2. Izberite želeno datoteko. csv ali. txt in nato izberite pridobi podatke.

  3. V čarovniku za uvoz besedilaizberite naprej.

  4. V razdelku ločila potrdite polje, ki se ujema z ločilom, ki ločuje vsak element podatkov (na primer tabulator ali vejica). Nato izberite Naprej.

    Namig: Predogled izbranega podatkovnega podokna prikazuje, kako bodo rezultati videti kot v obliki tabele.


    Step 2 of the Text Import Wizard
     

  5. V predogledu izbranih podatkovizberite stolpec, ki vsebuje poštne številke ali poštne številke. Nato vobliki zapisa podatkovCtolpca izberite besedilo.

    Text Import Wizard step 3
     

  6. Po potrebi ponovite korak 5, izberite stolpec, ki ga želite spremeniti, in obliko zapisa podatkov, ki jo želite uporabiti.

    Opomba: Vsakič ko uporabite obliko zapisa podatkov v stolpcu, se ime oblike zapisa prikaže v glavi tabele za ta stolpec.

  7. Kliknite Dokončaj.

  8. V pogovornem oknu Uvozi podatke izberite mesto, kamor želite Excel postaviti podatke, nato pa kliknite v redu.

    Opomba: Shranite preglednico z novim imenom datoteke.

2. korak: oblikovanje številskih podatkov v Excelovi preglednici

Če želite zagotoviti, da poštna številka ali poštna številka poteka prek spajanja dokumentov, ne da bi izgubili nobene ničle, oblikujte stolpec, ki vsebuje te kode kot besedilo.

  1. Odprite preglednico in izberite stolpec, ki vsebuje poštne številke ali poštne številke.

  2. Na zavihku osnovno v polju oblika izberite besedilo.

    On the Home tab, in the Format box, select Text

Zdaj lahko uporabite te podatke za Spajanje dokumentov.

Opomba:  Ta stran je bila prevedena z avtomatizacijo in lahko vsebuje slovnične napake ali nepravilnosti. Želimo, da bi bila ta vsebina za vas uporabna. Ali nam lahko sporočite, če so bile te informacije uporabne? Tukaj je referenčni članek v angleščini.

Razširite poznavanje Officea
Oglejte si izobraževanje
Prvi dobite nove funkcije
Pridružite se programu Office Insider

Vam je bila informacija v pomoč?

Zahvaljujemo se vam za povratne informacije.

Zahvaljujemo se vam za povratne informacije. Videti je, da bi vam prišla prav pomoč enega od naših Officeovih agentov za podporo.

×