Office
Prihlásenie

Excelový súbor zamkol na úpravy iný používateľ

Pokúšate sa otvoriť excelový súbor a zobrazí sa nasledujúce hlásenie: Súbor sa používa: Iný používateľ zamkol súbor na úpravy. Niekedy súbor zamkol iný používateľ a inokedy ste „iným používateľom“ v skutočnosti vy. Ak ste súbor zamkli vy, mohlo to byť spôsobené tým, že ho máte otvorený v inom zariadení alebo sa predchádzajúca inštancia súboru nezavrela správne.

Uistite sa, že súbor je zavretý vo všetkých vašich zariadeniach. Ak sa chyba zobrazuje aj naďalej, počkajte niekoľko minút, kým server uvoľní uzamknutie súboru. (Niekedy si server myslí, že máte súbor otvorený, a potrebuje chvíľu na to, aby zistil aktuálny stav.)

Ak ste súbor nezamkli vy, môžete počkať, kým iný používateľ dokončí zmeny a súbor zavrie. Súbor tiež môžete zobraziť v režime iba na čítanie. Rovnako môžete používateľa upravujúceho súbor požiadať, aby ho zavrel, vrátil alebo aby vám povolil úpravy.

Ak chcete na súbore pracovať súčasne s inými ľuďmi, uistite sa, že každý používa verziu Excelu, ktorá podporuje spolutvorbu. Pri spolutvorbe môžu súbor otvoriť viacerí ľudia a zmeny vykonané ostatnými používateľmi uvidíte v priebehu niekoľkých sekúnd.

Verzie Excelu, ktoré podporujú spolutvorbu:

  • Excel 2016 pre Windows*

  • Excel 2016 pre Mac*

  • Excel Online

  • Excel pre Android

  • Excel pre iOS

  • Excel Mobile

* Spolutvorba v tejto verzii vyžaduje inštaláciu najnovšej verzie Excelu a tiež prihlásenie do balíka Office pomocou konta predplatného na Office 365. Upozorňujeme, že ak máte pracovné alebo školské konto, pravdepodobne ešte nemáte verziu balíka Office, ktorá podporuje spolutvorbu. Môže to byť preto, že váš správca ešte neposkytol najnovšiu verziu k inštalácii. Ak používate Excel 2016 pre Windows, tak to môže byť spôsobené tým, že má vaša spoločnosť alebo škola aktivovaný polročný kanál aktualizácií. Ak chcete zistiť, či máte aktivovaný tento kanál, vyberte položky Súbor > Konto. Ak je vedľa položky O programe Excel napísané Polročný kanál, tak spolutvorbu ešte nemáte k dispozícii.

Ak čo len jedna osoba používa verziu Excelu, ktorá spolutvorbu nepodporuje, ostatným používateľom sa zobrazí chyba Zamknuté, a to aj napriek tomu, že všetci ostatní používajú verziu Excelu, ktorá spolutvorbu podporuje.

Ak si ľudia nie sú istí, ktorú verziu aplikácie používajú, vyzvite všetkých, aby používali Excel Online a spolupracovali na súbore vo webovom prehliadači.

Ak sa pri spolutvorbe chcete vyhnúť problémom, uložte súbor vo OneDrive, OneDrive for Business alebo v SharePointe. Ak súbor uložíte v inom umiestnení, ktoré nepodporuje spolutvorbu, ostatným používateľom sa bude zobrazovať chybové hlásenie o uzamknutí. Spolutvorba nie je podporovaná v týchto nasledujúcich umiestneniach:

  • Cesty k serveru, ako napríklad \\server\folder a smb://server/folder

  • Cloudové umiestnenia, ako napríklad DropBox, Box alebo Google Drive

  • Lokálne priečinky v počítači s Windowsom alebo v Macu

  • Knižnice na lokálnych lokalitách SharePointu. Ak používate lokálnu lokalitu a Excel 2016, skúste na spolutvorbu namiesto toho použiť Excel Online.

Pre Windows: Ak využívate spolutvorbu, skontrolujte názov súboru a uistite sa, že je vo formáte .xlsx, .xlsm alebo .xlsb. Ak je súbor v inom formáte, prejdite na položky Súbor > Uložiť ako > Prehľadávať > Uložiť vo formáte a vyberte formát .xlsx, .xlsm alebo .xlsb.

Pre Mac: Ak využívate spolutvorbu, skontrolujte názov súboru a uistite sa, že je vo formáte .xlsx, .xlsm alebo .xlsb. Ak je súbor v inom formáte, prejdite na položky Súbor > Uložiť ako... a vyberte formát .xlsx, .xlsm alebo .xlsb.

Ak používate synchronizačného klienta pre OneDrive pre Windows, skontrolujte, či používate najnovšiu verziu. Skontrolujte tiež, či synchronizačný klient nie je pozastavený.

Ak pri spolutvorbe použije súbor funkciu, ktorú spolutvorba nepodporuje, môže sa zobraziť chybové hlásenie o uzamknutí. Požiadajte osobu, ktorá má súbor otvorený, o vykonanie jedného alebo viacerých z týchto krokov: Najprv skúste vypnúť funkciu Zdieľaný zošit. Ak otvárate snímku v SharePointe, otvorte namiesto toho samotný zošit. Ak tieto dve riešenia váš problém nevyriešili, vyskúšajte niektorý z týchto krokov.

Windows:

  • Ak je to možné, odstráňte zo súboru šifrovanie heslom alebo obmedzený prístup. Prejdite na položky Súbor > Informácie > Zabezpečiť zošit a odstráňte všetky heslá a nastavenia obmedzeného prístupu.

  • Vo všetkých tabuľkách a kontingenčných tabuľkách v súbore vypnite nastavenie Obnoviť údaje pri otváraní súboru. Vyberte tabuľku alebo kontingenčnú tabuľku a potom prejdite na položky Nástroje tabuliek – Návrh > Obnoviť > Vlastnosti pripojenia. Potom zrušte začiarknutie políčka Obnoviť údaje pri otváraní súboru.

  • Deaktivujte doplnok, ktorý uzamknutie spôsobuje. Vyberte možnosti Súbor > Možnosti > Doplnky > Doplnky Excelu > Spustiť... a zrušte začiarknutie políčka doplnku.

Mac:

  • Ak je to možné, odstráňte zo súboru šifrovanie heslom. Ak to chcete urobiť, prejdite na kartu Revízia. Ak je položka Zabezpečiť zošit zvýraznená, kliknutím na ňu zabezpečenie vypnite. Ak sa zobrazí výzva, zadajte heslo.

  • Ak je to možné, odstráňte obmedzený prístup. Prejdite na položky Súbor > Obmedziť povolenia > Bez obmedzení.

  • Vo všetkých tabuľkách a kontingenčných tabuľkách v súbore vypnite nastavenie Obnoviť údaje pri otváraní súboru. Vyberte tabuľku alebo kontingenčnú tabuľku a potom prejdite na kartu Tabuľka a položky > Obnoviť > Vlastnosti pripojenia. Potom zrušte začiarknutie políčka Obnoviť údaje pri otváraní súboru.

  • Deaktivujte doplnok, ktorý uzamknutie spôsobuje. Vyberte položky Nástroje > Doplnky Excelu a zrušte začiarknutie políčka doplnku.

Rozšírte svoje zručnosti práce s balíkom Office
Preskúmať školenie
Buďte medzi prvými, ktorí získajú nové funkcie
Pridajte sa k insiderom pre Office

Boli tieto informácie užitočné?

Ďakujeme za vaše pripomienky!

Ďakujeme vám za pripomienky. Pravdepodobne vám pomôže, ak vás spojíme s pracovníkom podpory pre Office.

×