Vytvorenie diagramu pomocou nástroja Vizualizér údajov

Vytvorenie diagramu pomocou nástroja Vizualizér údajov

Poznámka:  Radi by sme vám čo najrýchlejšie poskytovali najaktuálnejší obsah Pomocníka vo vašom vlastnom jazyku. Táto stránka bola preložená automaticky a môže obsahovať gramatické chyby alebo nepresnosti. Naším cieľom je, aby bol tento obsah pre vás užitočný. Dali by ste nám v dolnej časti tejto stránky vedieť, či boli pre vás tieto informácie užitočné? Tu nájdete anglický článok pre jednoduchú referenciu.

Radi by ste z excelového zošita automaticky vytvárali podrobné a dokonalé vývojové diagramy Visia? Môžete tak urobiť pomocou šablón nástroja Vizualizér údajov. Každá šablóna má priradený excelový zošit, ktorý slúži na konverziu údajov procesu na vývojový diagram vo Visiu. Môžete použiť aj vlastné excelové šablóny, priradiť excelové údaje k tvarom v sprievodcovi Vytvorenie diagramu z údajov a automaticky vytvoriť diagram. V Exceli dokonca môžete pridať ďalšie stĺpce s údajmi, ktoré sa skonvertujú na vlastnosti tvaru Visia.

Visio podporuje aj obojsmernú synchronizáciu medzi diagramom Visia a  excelovým zošitom. Okrem toho, že môžete vytvoriť vývojový diagram úpravou údajov v Exceli a obnovením diagramu z Visia, môžete tiež vykonať zmeny v diagrame Visia a potom aktualizovať excelové údaje z diagramu. 

Vizualizér údajov – prehľad

Šablóny nástroja Vizualizér údajov je možné použiť iba s Visiom Online (plán 2) v kanáli aktuálneho vydania. Ak si nie ste istí, akú verziu Visia používate, vyberte položky Súbor > Konto > Informácie o programe Visio. Ďalšie informácie o predplatenej verzii Visia nájdete v téme Visio Online (plán 2).

Ak sa vám nezobrazujú šablóny Vizualizéra údajov alebo ak začínate používať tento program a máte ďalšie otázky, pozrite si stránku Najčastejšie otázky o nástroji Vizualizér údajov.

Poznámka: Ak chcete používať túto funkciu, musíte mať predplatné služieb Office 365. Ak ste predplatiteľom služieb Office 365, uistite sa, že používate najnovšiu verziu balíka Office. Ak ste IT profesionálom zodpovedným za spravovanie procesu aktualizácie služieb Office 365, pozrite si stránku vydaní pre rôzne kanály s informáciami o aktualizáciách, ktoré sú poskytované pre každý kanál.

Obsah tohto článku

Vytvorenie diagramu pomocou nástroja Vizualizér údajov

Skôr než začnete

Dajte dokopy nápady a spracujte ich koncept na papieri alebo pomocou funkcie písania rukou. Pomocou tohto konceptu budete môcť jednoduchšie pracovať a zabezpečíte plynulosť ďalších krokov.

Pri vytváraní diagramu pomocou nástroja Vizualizér údajov môžete pracovať súčasne v Exceli a Visiu. Možno pre vás bude jednoduchšie pracovať v dvoch oknách v zariadení s Windowsom alebo v prostredí s viacerými monitormi. Vizuálnym porovnaním práce medzi Excelom a Visiom si môžete potvrdiť, že naozaj robíte to, čo ste chceli.

Odporúčané    Pozrite si toto video o Microsoft Office a jeho fungovaní: Vizualizér údajov: ukážka.

Fáza 1: Výber šablóny nástroja Vizualizér údajov

  1. Ak upravujete diagram, otvorte Visio alebo vyberte položky Súbor > Nové.

  2. Vyberte položku ŠABLÓNY.

    Príkaz ŠABLÓNY
  3. Vyberte položku Vývojový diagram.

    Príkaz Vývojový diagram
  4. Vyberte Základný vývojový diagram - Vizualizácia údajov, vývojový diagram krížového procesu - Vizualizácia údajov alebo Diagram auditu - Vizualizácia údajov.

    Vizualizér údajov – šablóny

    V hornom ľavom rohu šablóny nástroja Vizualizér údajov sa nachádza ikona Excelu.

Ďalšie informácie o vývojových diagramoch a ich tvaroch nájdete v téme Vytvorenie základného vývojového diagramuVytvorenie vývojového diagramu krížového procesu.

Fáza 2: Vytvorenie excelového zošita

  1. V ukážke šablóny vyberte položku Excelová šablóna údajov.

    Výber prepojenia excelovej šablóny údajov

    Poznámka    Ak chcete použiť rovnaké vzorové excelové šablóny, na ktoré sa odkazuje v tomto článku, môžete si ich stiahnuť po prechode na nasledujúce prepojenia:

  2. Vyberte položky Súbor > Uložiť, zadefinujte počítač, sieťový server alebo knižnicu dokumentov SharePointu, zadajte názov súboru a potom vyberte položku Uložiť.

  3. Ak chcete pridať nový hárok, v dolnej časti zošita vyberte položku Nový hárok Tlačidlo Nový hárok .

  4. Vytvorte excelovú tabuľku. Ďalšie informácie o používaní excelových tabuliek nájdete v téme Prehľad excelových tabuliek, Vytvorenie alebo odstránenie excelovej tabuľkyZmena veľkosti tabuľky pridaním alebo odstránením riadkov a stĺpcov.

  5. Pridanie stĺpcov a riadkov do tabuľky, ktoré sa používajú na vytvorenie diagramu programu Visio. Existuje špecifické požiadavky na hlavičky stĺpcov tabuľky programu Excel a hodnoty. Pomocou sekcie, ako Excel stĺpce interakciu s súčasti vývojového diagramu programu Visio ako vizuálnu príručku.

Fáza 3: Pridanie ďalších vlastností tvaru do excelovej tabuľky (voliteľné)

  1. V excelovej šablóne si pozrite kartu Mapa procesu. Stĺpce v excelovej tabuľke sú zobrazené modrou a zelenou farbou. Farba poskytuje akúsi vizuálnu pomôcku, pomocou ktorej môžete stĺpce rozlišovať.

    Modré stĺpce sa používajú na vytvorenie vývojového diagramu v diagrame Visia. Všetky stĺpce sa tiež pridajú ako vlastnosti tvaru.

  2. Ak chcete pridať ďalšie vlastnosti tvaru, pridajte do excelovej tabuľky jeden alebo viacero stĺpcov.

    Zelené stĺpce predstavujú ďalšie vlastnosti tvaru, ktoré môžete do jednotlivých tvarov pridať. Pridať môžete ľubovoľný počet stĺpcov. Kým nepridáte údajovú grafiku, predvolene tieto údaje nie sú v diagrame viditeľné. Ak chcete zobraziť vlastnosti tvaru v diagrame Visia, vyberte položky Údaje > Okno Údaje tvaru. Ďalšie informácie o vlastnostiach tvaru a údajovej grafike nájdete v téme Pridanie údajov do tvarov a Údajová grafika, prehľad.

Fáza 4: Vytvorenie diagramu Visia pomocou Sprievodcu

  1. Prepnite späť do Visia, v ukážke šablóny vyberte svoju mernú jednotku a potom vyberte položku Vytvoriť.

  2. Na prvej strane sprievodcu Vytvorenie diagramu z údajov postupujte takto:

    1. V časti Aký diagram chcete vytvoriť z údajov vyberte šablónu: Základný vývojový diagram, Vývojový diagram krížového procesu (vodorovný) alebo Vývojový diagram krížového procesu (zvislý).

    2. V časti Vyberte excelový zošit vyberte zošit zo zoznamu naposledy použitých zošitov alebo vyberte položku Prehľadávať a vyhľadajte zošit, ktorý ste vytvorili vo fáze 2.

    3. V časti Vyberte tabuľku alebo vlastný rozsah v zošite vyberte tabuľku, v ktorej sa nachádzajú excelové údaje procesu.

    4. Vyberte tlačidlo Dokončiť. Týmto sa prijmú všetky predvolené hodnoty, ktoré Visio vyplní na ďalších stranách sprievodcu.

Výsledkom je diagram, ktorý sa automaticky vytvorí v rámci kontajnera. Ďalšie strany Visia sa pridajú v závislosti od veľkosti vývojového diagramu.

Fáza 5: Uloženie diagramu Visia

  • Vyberte položky Súbor > Uložiť, vyhľadajte umiestnenie, zadajte názov súboru a potom vyberte položku Uložiť.

Keďže súbory Excelu a Visia spolupracujú, je vhodné, aby sa nachádzali v tom istom umiestnení.

Fáza 6: Synchronizácia údajov a diagramu

Po vytvorení diagramu pomocou nástroja Vizualizér údajov v ňom možno budete chcieť vykonať zmeny. Visio podporuje obojsmernú synchronizáciu medzi zdrojovými údajmi a diagramom.

Tip    Po ukončení práce so súbormi udržiavajte oba súbory synchronizované a aktualizované. Po zmene excelových údajov obnovte diagram. Po zmene obsahu diagramu aktualizujte excelové údaje.

Úprava údajov v Exceli a následné obnovenie diagramu

  1. Vykonajte zmeny zdrojových údajov v excelovej tabuľke. Môžete pridať, aktualizovať alebo odstrániť riadky.

  2. Uložte excelový zošit.

  3. Vo Visiu kliknutím na kontajner diagramu aktivujte kartu Nástroje pre údaje, Návrh na páse s nástrojmi a potom vyberte položku Obnoviť diagram.

V dôsledku toho sa zmeny vykonané v excelovom zošite zobrazia v diagrame Visia. Majte na pamäti:

  • Ak ste v diagrame vykonali zmeny, ktoré sa môžu po obnovení stratiť, Visio zobrazí dialógové okno Konflikt obnovenia diagramu.

  • Obnovením sa vykonajú len zmeny v tvaroch a pripojeniach v rámci kontajnera.

  • Všetky vykonané zmeny formátovania v tvaroch a spojniciach v rámci kontajnera sa zachovajú.

  • Umiestnite všetky tvary a spojnice diagramov do kontajnera. Všetky objekty na strane nachádzajúce sa mimo kontajnera zostanú nezmenené. Ďalšie informácie o kontajneroch nájdete v téme Objasnenie štruktúry diagramov pomocou kontajnerov a zoznamov

Úprava obsahu diagramu a následná aktualizácia údajov v Exceli

  1. Vykonajte zmeny v diagrame Visia. Môžete pridať, aktualizovať alebo odstrániť tvary a spojnice.

  2. Ak sa excelový zošit nachádza v stolnom počítači alebo na sieťovom súborovom serveri, uistite sa, že je uložený a zatvorený.

  3. Kliknutím na kontajner diagramu aktivujte kartu Nástroje pre údaje, Návrh na páse s nástrojmi a potom vyberte položku Aktualizovať zdrojové údaje.

V dôsledku toho sa zmeny vykonané v diagrame Visia aktualizujú v excelovom zošite. Ak sa údaje v Exceli môžu stratiť, vo Visiu sa zobrazí dialógové okno Konflikt aktualizácie zdrojových údajov. Ak sa chcete vyhnúť problémom, používajte tieto osvedčené postupy:

  • Skôr než prepíšete zmeny, uložte zálohu excelových údajov.

  • V excelovom zošite použite ako zdroj údajov excelovú tabuľku, nie vlastný rozsah. Keď v dialógovom okne Aktualizácia zdrojových údajov vyberiete položku Prepísať, Visio vlastný rozsah skonvertuje na excelovú tabuľku.

  • V zdroji excelových údajov nepoužívajte vzorce. Keď v dialógovom okne Aktualizácia zdrojových údajov vyberiete položku Prepísať, Visio vzorec skonvertuje na výsledok vzorca.

  • Diagram ste vytvorili pomocou nasledujúcej možnosti v sprievodcovi Vytvorenie diagramu z údajov, kde sú stĺpce údajov priradené k funkciám a fázam: Priradenie > Ďalšie možnosti > Zachovajte poradie hodnôt stĺpcov z údajov a vytvorte > Vyberte funkciu alebo dráhu alebo Vyberte fázu alebo časovú os. V tomto prípade Visio vyžaduje ďalší stĺpec v údajoch, ktorý bude predstavovať prepojenie medzi tvarmi. Keď v dialógovom okne Aktualizácia zdrojových údajov vyberiete položku Prepísať, pridá sa ďalší stĺpec.

  • Vytvorili ste vývojový diagram krížového procesu s dráhami aj fázami na základe poradia hodnôt údajov v Exceli. Diagram ste vytvorili pomocou nasledujúcej možnosti v sprievodcovi Vytvorenie diagramu z údajov, vďaka čomu sa stĺpce údajov prepojili s krokmi procesu a aktivitami: Priradenie > Zadajte, ako sa majú prepojiť kroky procesu alebo aktivity > Prepojiť sekvenčne. V tomto prípade Visio vyžaduje ďalší stĺpec v údajoch, ktorý bude predstavovať prepojenie medzi tvarmi. Ak zmeníte poradie dráh alebo fáz v diagrame, zmení sa aj poradie v zdroji údajov. Keď v dialógovom okne Aktualizácia zdrojových údajov vyberiete položku Prepísať, dráhy a fázy v diagrame už nebudú zoradené podľa poradia údajov v excelovom zošite.

Fáza 7: Prispôsobenie interakcie medzi excelovou tabuľkou a diagramom Visia (voliteľné)

Môže sa stať, že budete chcieť prispôsobiť vytváranie diagramov pomocou nástroja Vizualizér údajov. Možno budete napríklad chcieť používať rôzne tvary v súlade s normami vašej organizácie a priradiť ich k iným názvom stĺpcov v excelovej tabuľke.

  1. Keď vyberiete položku Vytvoriť, otvorí sa sprievodca Vytvorenie diagramu z údajov a potom zadáte hodnoty na prvej strane (pozrite fázu 4), výberom položky Ďalej alebo Späť môžete zobraziť každú stranu sprievodcu.

  2. Vyberte položku Pomocník (?) a získajte ďalšie informácie o prispôsobení jednotlivých možností na strane. Ďalšie informácie nájdete v téme Použitie sprievodcu Vytvorenie diagramu z údajov.

Na začiatok stránky

Interakcia excelových stĺpcov s komponentmi vývojového diagramu Visia

Pomocou nasledujúceho obrázkovému návodu porozumiete tomu, ako sa jednotlivé excelové stĺpce používajú na vytváranie vývojového diagramu Visia.

ID kroku procesu   Číslo, ktoré identifikuje každý tvar vo vývojovom diagrame. Tento stĺpec je povinný. Každá hodnota v excelovej tabuľke musí byť jedinečná a nemôže byť prázdna. Táto hodnota sa vo vývojovom diagrame nezobrazí.

Interakcia mapy procesu Excelu s vývojovým diagramom Visia: ID kroku procesu

Popis kroku procesu   Text pridaný do každého tvaru vo vývojovom diagrame.

Interakcia mapy procesu Excelu s vývojovým diagramom Visia: Popis kroku procesu

ID ďalšieho kroku   ID kroku procesu ďalšieho tvaru v poradí. Tvar vetvenia zahŕňa ďalšie dva kroky a je vyjadrený číslami oddelenými čiarkou, napríklad 4,5. Môže to byť aj viac ako dva ďalšie kroky.

Interakcia mapy procesu Excelu s vývojovým diagramom Visia: ID ďalšieho kroku

Označenie spojnice    Pri tvaroch vetvenia je označenie spojnice vyjadrené ako text oddelený čiarkou, napríklad Áno,Nie. V tomto príklade Áno zodpovedá číslu 4 a Nie číslu 5.

Interakcia mapy procesu Excelu s vývojovým diagramom Visia: Označenie spojnice

Typ tvaru    Typ tvaru, ktorý chcete použiť v diagrame Visia, napríklad Proces alebo Rozhodnutie. Spoločnosť Microsoft odporúča použiť rozbaľovacie zoznamy ako pomoc pri overovaní výberov

Interakcia mapy procesu Excelu s vývojovým diagramom Visia: Typ tvaru

Funkcia a fáza    Funkcia (alebo dráha) a fáza (alebo časová os), do ktorej patrí každý tvar. Tento stĺpec sa vzťahuje len na vývojový diagram krížového procesu. Základný vývojový diagram ho ignoruje.

Interakcia mapy procesu Excelu s vývojovým diagramom Visia: Funkcia a fáza

Na začiatok stránky

Použitie iných vzorkovníc na vytvorenie diagramu pomocou nástroja Vizualizér údajov

Okrem používania šablón Vizualizácia údajov, môžete použiť aj vzorkovnice z iných šablón pri vytváraní diagramu Vizualizácia údajov. Napríklad vytváranie diagramov procesov pre finančné transakcie alebo riadenie zásob. Existujú iné orientovanom vzorkovníc vrátane BPMN základné a práce toku objektov šablón. Môžete dokonca pridať vlastné tvary pomocou vzorkovnice Moje tvary. Ďalšie informácie nájdete v téme Vytvorenie, uloženie, a zdieľanie vlastných vzorkovníc.

  1. Otvorte diagram nástroja Vizualizér údajov (základný vývojový diagram alebo vývojový diagram krížového procesu), ktorý ste už vytvorili.

  2. Vybratím položky Vytvoriť otvorte sprievodcu Vytvorenie diagramu z údajov a keď zadáte hodnoty na prvej strane, vyberajte položku Ďalej, kým sa v sprievodcovi nezobrazí strana Priradenie tvarov.

  3. Pridajte jednu alebo viacero vzorkovníc pomocou možnosti Ďalšie tvary.

  4. Vyberte ľubovoľný tvar a presunutím myšou ho priraďte k hodnotám údajov stĺpca Typ tvaru.

Na začiatok stránky

Použitie údajovej grafiky v diagrame

Diagram môžete vylepšiť pridaním údajovej grafiky, ktoré pomáha vizualizovať vlastnosti tvaru v diagrame. V podstate môžete diagram zmeniť na tabuľu procesu, v ktorej údajová grafika zobrazí informácie o kľúčovom ukazovateli výkonu (KPI) v ikon údajovej grafiky založených na vlastnostiach tvaru.

  1. Otvorte diagram pomocou nástroja Vizualizér údajov.

    Vyberte kontajner, pre ktorý chcete použiť údajovú grafiku.

  2. Vyberte položky Údaje > Polia údajovej grafiky.

  3. Vyberte polia údajovej grafiky, ktoré chcete pridať do diagramu.

    Použitie údajovej grafiky v diagrame nástroja Vizualizér údajov vo Visiu

    Údajové grafiky a použijú na celý diagram. Ak chcete skryť údajové grafiky niektorých tvarov, vyprázdnite hodnoty v údajových stĺpcoch, ktoré zodpovedajú riadkom v excelovom zošite.

  4. Ak chcete, na karte Údaje môžete nastaviť ďalšie možnosti. Ďalšie informácie nájdete v téme Údajová grafika, prehľad.

Na začiatok stránky

Ďalšie kroky

Tu je niekoľko úloh, ktoré možno budete chcieť vykonať po vytvorení diagramu pomocou nástroja Vizualizér údajov.

  • Motívy    Motív vo Visiu je sústavou farieb a efektov, ktoré môžete použiť v kresbe jediným kliknutím. Motívy predstavujú rýchly spôsob, ako dať kresbám profesionálny vzhľad. Ďalšie informácie nájdete v téme Použitie profesionálneho vzhľadu na kresby s motívmi.

  • Rozloženie    Visio má manuálne vodiace čiary a automatické nástroje, pomocou ktorých zaistíte správne zarovnanie a rozloženie tvarov v diagrame. Vďaka tomu bude vaša kresba čo možno najprehľadnejšia a bude pôsobiť usporiadane. Ďalšie informácie nájdete v téme Zarovnanie a umiestnenie tvarov v diagrame.

  • Export    Diagram vytvorený pomocou nástroja Vizualizér údajov a priradený excelový zošiť možno exportovať do balíka šablóny Visia (.vtpx). Balík šablóny Visia ukladá nastavenia diagramov, vzorkovnice a údaje, ktoré môžu ostatní použiť, aby mohli rýchlo začať vytvárať vlastný diagram pomocou Vizualizéra údajov. Ostatní používatelia si balík šablóny môžu nainštalovať do svojich počítačov. Ďalšie informácie nájdete v téme Export a inštalácia balíka šablóny Vizualizéra údajov.

Na začiatok stránky

Rozšírte svoje zručnosti práce s balíkom Office
Preskúmať školenie
Buďte medzi prvými, ktorí získajú nové funkcie
Pridajte sa k insiderom pre Office

Boli tieto informácie užitočné?

Ďakujeme za vaše pripomienky!

Ďakujeme vám za pripomienky. Pravdepodobne vám pomôže, ak vás spojíme s pracovníkom podpory pre Office.

×