Vytvorenie a zdieľanie tabule pomocou Excelu a Skupín od Microsoftu

Tabuľa je vizuálnym znázornením kľúčových metrík, ktoré umožňujú rýchlo zobrazovať a analyzovať údaje na jednom mieste. Tabule poskytujú nielen konsolidované zobrazenia údajov, ale aj príležitosť samostatne používať analytické nástroje, kedy používatelia môžu filtrovať údaje tak, aby sa im zobrazilo len to, čo je pre nich dôležité. V minulosti bolo pri vytváraní zostáv v Exceli často potrebné generovať viacero zostáv podľa potrieb rôznych ľudí alebo oddelení.

Príklad excelovej tabule s rýchlymi filtrami a časovou osou

Prehľad

V tomto článku budeme hovoriť o tom, ako vytvoriť dynamickú tabuľu s pomocou viacerých kontingenčných tabuliek, kontingenčných grafov a nástrojov kontingenčných tabuliek. Potom poskytneme používateľom možnosť rýchleho filtrovania údajov podľa vlastných potrieb prostredníctvom rýchlych filtrov a časovej osi, ktoré umožňujú automatické rozbalenie alebo zúženie kontingenčných tabuliek tak, aby sa používateľom zobrazili len údaje, ktoré potrebujú. Okrem toho môžete po pridaní alebo aktualizácii údajov tabuľu rýchlo obnoviť. Vďaka tomu je veľmi praktická, pretože zostavu tabule je potrebné vytvoriť iba raz.

V tomto príklade vytvoríme z jedného zdroja údajov štyri kontingenčné tabuľky a grafy.

Po vytvorení tabule si ukážeme, ako ju zdieľať s ľuďmi vytvorením skupiny Microsoft. K dispozícii je tiež interaktívny excelový zošit, ktorý si môžete stiahnuť a postupovať podľa týchto krokov samostatne.

Stiahnuť excelový zošit s kurzom o tabuli.

Získanie údajov

  1. Môžete skopírovať a prilepiť údaje priamo do Excelu alebo môžete nastaviť dotaz zo zdroja údajov. V tomto článku sme použili dotaz Analýza predaja zo šablóny Northwind Traders pre Microsoft Access. Ak ju chcete použiť, otvorte Access, prejdite na položky Súbor > Nové a vyhľadajte výraz Northwind a vytvorte šablónu databázy. Potom budete môcť pristupovať k ľubovolnému dotazu, ktorý je zahrnutý v šablóne. Do excelového zošita sme už vložili tieto údaje za vás, preto ak nemáte Access, nie je to prekážka.

  2. Overte, či sú údaje správne štruktúrované a nechýbajú žiadne riadky ani stĺpce. Každý riadok by mal predstavovať samostatný záznam alebo položku. Ak potrebujete pomoc pri nastavení dotazu, alebo ak je potrebné vaše údaje upraviť, pozrite si tému Získať a transformovať v Exceli.

    Vzorové údaje v excelovej tabuľke, ktoré sa použijú ako zdroj údajov kontingenčnej tabuľky
  3. Ak údaje nie sú naformátované ako excelová tabuľka, naformátujte ich. Pri importe údajov z Accessu sa údaje automaticky importujú do tabuľky.

Vytvorenie kontingenčných tabuliek

  1. Vyberte ľubovoľnú bunku v rozsahu údajov a prejdite na položky Vložiť > Kontingenčná tabuľka > Nový hárok. Ďalšie podrobnosti nájdete v téme Vytvorenie kontingenčnej tabuľky na analýzu údajov z hárkov.

  2. Pridajte do kontingenčnej tabuľky potrebné polia a požadované formátovanie. Táto kontingenčná tabuľka bude základom pre ostatné, preto by ste mali vykonať potrebné úpravy štýlu, rozloženia zostavy a všeobecného formátovania, aby ste to nemuseli robiť viackrát. Ďalšie informácie získate tu: Zmena rozloženia a formátu zostavy kontingenčnej tabuľky

    V tomto prípade sme vytvorili súhrn predaja na najvyššej úrovni podľa kategórií produktov a zoradili ho podľa oblasti predaja v zostupnom poradí.

    Vzorová kontingenčná tabuľka so stĺpcami Kategória, Predaj a % z celku

    Ďalšie podrobnosti nájdete v téme Zoradenie údajov v zostave kontingenčnej tabuľky alebo kontingenčného grafu.

  3. Po vytvorení predlohy kontingenčnej tabuľky ju vyberte a skopírujte a prilepte do prázdnych oblastí hárka toľkokrát, koľkokrát je to potrebné. V našom príklade môžu kontingenčné tabuľky meniť riadky, ale nie stĺpce, preto sme ich umiestnili do rovnakého riadka a každú oddelili prázdnym stĺpcom. Vo vašom prípade však môže byť potrebné umiestniť kontingenčné tabuľky pod seba, ak majú možnosť rozbaľovania stĺpcov.

    Dôležité : Kontingenčné tabuľky sa nemôžu navzájom prekrývať, preto sa presvedčte, že je medzi nimi dostatok miesta na rozbaľovanie alebo zužovanie pri filtrovaní, pridávaní alebo odstraňovaní hodnôt.

    V tomto bode je vhodné kontingenčné tabuľky zmysluplne pomenovať, aby ste vedeli, na čo slúžia. V opačnom prípade im Excel zadá názvy Kontingenčná tabuľka1, Kontingenčná tabuľka2 atď. Vyberte každú z nich, prejdite na položky Nástroje pre kontingenčné tabuľky > Analyzovať a zadajte nový názov do poľa Názov kontingenčnej tabuľky. Bude to dôležité, keď sa kontingenčné tabuľky pripoja k ovládacím prvkom rýchlych filtrov a časovej osi.

    Premenovanie kontingenčnej tabuľky pomocou položiek Nástroje pre kontingenčné tabuľky > Analyzovať > pole Názov kontingenčnej tabuľky

Vytvorenie kontingenčných grafov

  1. Kliknite na ľubovoľné miesto v prvej kontingenčnej tabuľke, prejdite na položky Nástroje pre kontingenčné tabuľky > Analyzovať > Kontingenčný graf a vyberte typ grafu. Vybrali sme kombinovaný graf s predajom vyjadreným pomocou skupinového stĺpcového grafu a % celkového súčtu vyjadreným vo forme čiarového grafu vyobrazeného na vedľajšej osi.

    Dialógové okno Výber grafu pre kombinovaný graf so skupinovým stĺpcovým grafom a čiarovým grafom
  2. Vyberte graf a pomocou karty Nástroje pre kontingenčné grafy upravte podľa potreby jeho veľkosť a formát. Ďalšie podrobnosti nájdete v sérii článkov o formátovaní grafov.

  3. Postup zopakujte vo všetkých zvyšných kontingenčných tabuľkách.

  4. Teraz nastala vhodná chvíľa aj na premenovanie kontingenčných grafov. Prejdite na položky Nástroje pre kontingenčné grafy > Analyzovať a zadajte nový názov do poľa Názov grafu.

Pridanie rýchlych filtrov a časovej osi

Rýchle filtre a časové osi umožňujú rýchlo filtrovať kontingenčné tabuľky a kontingenčné grafy, aby ste mohli zobrazovať len dôležité informácie.

Rozložené zobrazenie rýchlych filtrov a časovej osi na tabuli
  1. Vyberte ľubovolnú kontingenčnú tabuľku, prejdite na položky Nástroje pre kontingenčné tabuľky > Analyzovať > Filter > Vložiť rýchly filter a potom začiarknite každú položku, ktorú chcete v rýchlom filtri použiť. Na tejto tabuli sme vybrali položky Kategória, Názov produktu, Meno zamestnanca a Meno zákazníka. Po kliknutí na tlačidlo OK sa rýchle filtre pridajú do stredu obrazovky navrstvené na seba, preto je následne potrebné ich usporiadať a prípadne zmeniť ich veľkosť.

    Možnosť Vložiť rýchly filter, na ktorú prejdete pomocou položiek Nástroje pre kontingenčné tabuľky > Analyzovať > Filtrovať
  2. Možnosti rýchleho filtra – Ak kliknete na ľubovolný rýchly filter, môžete prejsť na položky Nástroje rýchleho filtra > Možnosti a vybrať rôzne možnosti, ako napríklad Štýl alebo počet zobrazovaných stĺpcov. Môžete zarovnať viaceré rýchle filtre tak, že ich vyberiete stlačením klávesu Ctrl a kliknutím ľavým tlačidlom myši a potom použijete nástroje Zarovnať umiestnené na karte Nástroje rýchleho filtra.

  3. Pripojenia rýchleho filtra – Rýchle filtre sú pripojené iba ku kontingenčnej tabuľke, ktorú ste použili na ich vytvorenie. Preto vyberte jednotlivé rýchle filtre, prejdite na položky Nástroje rýchleho filtra > Možnosti > Pripojenia zostáv a začiarknite kontingenčné tabuľky, ku ktorým ich chcete pripojiť. Rýchle filtre a časové osi môžu ovládať kontingenčné tabuľky v ktoromkoľvek hárku, dokonca aj vtedy, ak je hárok skrytý.

    Možnosť Pripojenia zostáv k rýchlym filtrom, na ktorú prejdete pomocou položiek Nástroje rýchleho filtra > Možnosti
  4. Pridanie časovej osi – Vyberte ľubovolnú kontingenčnú tabuľku, prejdite na položky Nástroje pre kontingenčné tabuľky > Analyzovať > Filter > Vložiť časovú os a potom začiarknite každú položku, ktorú chcete použiť. Na tejto tabuli sme vybrali položku Dátum objednávky.

  5. Možnosti časovej osi – Kliknite na časovú os, prejdite na položky Nástroje časovej osi > Možnosti a vyberte možnosti, ako napríklad Štýl, Hlavička a Popis. Vyberte položku Pripojenia zostáv a prepojte časovú os s ľubovoľnými kontingenčnými tabuľkami.

Prečítajte si ďalšie informácie o ovládacích prvkoch rýchlych filtrov a časovej osi.

Ďalší postup

Tabuľa je teraz funkčne úplná, pravdepodobne ju však ešte bude potrebné usporiadať podľa vlastných predstáv a vykonať posledné úpravy. Je možné, že budete chcieť napríklad pridať názov zostavy alebo pozadie. Na našej tabuli sme pridali okolo kontingenčných tabuliek tvary a na karte Zobraziť vypli nadpisy a mriežky.

Nezabudnite otestovať všetky rýchle filtre a časové osi a presvedčte sa, že všetky kontingenčné tabuľky a kontingenčné grafy fungujú správne. Môžu sa vyskytnúť situácie, kedy konkrétny výber možností spôsobí problémy. Napríklad kontingenčná tabuľka sa môže pokúsiť upraviť a prekryť inú, čo nie je možné a výsledkom bude chybové hlásenie. Tieto problémy je potrebné odstrániť ešte pred distribúciou tabule.

Po dokončení nastavovania tabule môžete kliknúť na kartu Zdieľanie tabule v hornej časti tejto témy a zistiť, ako tabuľu distribuovať.

Gratulujeme k vytvoreniu tabule. V tomto kroku vám ukážeme, ako nastaviť zdieľanie tabule so skupinou Microsoft. Urobíme to tak, že tabuľu pripneme do hornej časti knižnice s dokumentami skupiny v SharePointe, aby k nej mali používatelia kedykoľvek jednoduchý prístup.

Poznámka : Ak ešte nemáte nastavenú skupinu, prečítajte si tému Vytvorenie skupiny v Outlooku

Uloženie tabule v skupine

Ak ste ešte neuložili zošit s tabuľou v skupine, je ho potrebné presunúť do skupiny. Ak je už v knižnici súborov skupiny, môžete tento krok vynechať.

  1. Prejdite na skupinu v programe Outlook 2016 alebo aplikácii Outlook na webe.

  2. Na páse s nástrojmi kliknite na položku Súbory, čím získate prístup ku knižnici dokumentov skupiny.

  3. Na páse s nástrojmi kliknite na tlačidlo Nahrať a nahrajte zošit s tabuľou do knižnice dokumentov.

Pridanie do tímovej lokality skupiny v SharePointe Online

  1. Ak ste získali prístup do knižnice dokumentov z programu Outlook 2016, kliknite na navigačnej table v ľavej časti na položku Domov. Ak ste získali prístup do knižnice dokumentov z aplikácie Outlook na webe, kliknite na položky Ďalšie > Lokalita na pravej strane pása s nástrojmi.

  2. Na navigačnej table v ľavej časti kliknite na položku Dokumenty.

  3. Vyhľadajte zošit s tabuľou a kliknite na kruh s výberom umiestnený naľavo od názvu.

  4. Po vybratí zošita s tabuľou vyberte na páse s nástrojmi položku Pripnúť na začiatok.

Výberom súboru a kliknutím na položku Pripnúť na začiatok ho urobíte ľahko dostupným z knižnice dokumentov

Odteraz vždy, keď používatelia prídu na stránku s dokumentmi na tímovej lokalite SharePointu Online, zošit s tabuľou bude v hornej časti stránky. Môžu na naň kliknúť a získať jednoduchý prístup k aktuálnej verzii tabule.

Tip : Používatelia môžu získať prístup do knižnice dokumentov skupiny vrátane zošita s tabuľou taktiež prostredníctvom mobilnej aplikácie Outlook Groups. Ďalšie informácie nájdete v téme Mobilná aplikácia Outlook Groups.

Pozrite tiež

Máte otázky, na ktoré sme tu neodpovedali?

Navštívte komunitu odpovedí spoločnosti Microsoft.

Váš názor nás zaujíma.

Tento článok naposledy revidoval Ben a Chris 16. marca 2017 na základe vašej spätnej väzby. Ak bol pre vás užitočný, no najmä ak nebol, použite nižšie uvedené ovládacie prvky spätnej väzby a posielajte nám konštruktívne pripomienky, aby sme ho mohli naďalej zlepšovať. Ďakujeme.

Rozšírte svoje zručnosti
Preskúmať školenie
Buďte medzi prvými, ktorí získajú nové funkcie
Pridajte sa k insiderom pre Office

Boli tieto informácie užitočné?

Ďakujeme za vaše pripomienky!

Ďakujeme vám za pripomienky. Pravdepodobne vám pomôže, ak vás spojíme s pracovníkom podpory pre Office.

×