Vytvorenie a spustenie odstraňovacieho dotazu

Vytvorenie a spustenie odstraňovacieho dotazu

Dôležité : Tento článok je strojovo preložený, prečítajte si vyhlásenie. Anglickú verziu tohto článku nájdete tu a môžete ju použiť ako referenciu.

Ak chcete rýchlo odstrániť veľké množstvo údajov alebo odstránenie množiny údajov v pravidelných intervaloch v počítačovej databáze programu Access, odstrániť alebo aktualizačný dotaz môže byť výhodné pretože dotazy, aby bolo možné zadať kritériá môžete rýchlo vyhľadať a odstrániť údaje. Použitie dotazu môže byť tiež dobrá rada lebo ju môžete znova použiť uložený dotaz.

Poznámka : Pred odstránením akýchkoľvek údajov alebo spustením odstraňovacieho dotazu, skontrolujte, či máte vytvorenú zálohu počítačovej databázy programu Access.

Ak chcete len odstrániť niekoľko záznamov, nepotrebujete dotaz. Stačí iba otvoriť tabuľku v údajovom zobrazení, vybrať polia (stĺpce) alebo záznamy (riadky), ktoré chcete odstrániť, a potom stlačiť kláves DELETE.

Dôležité : Informácie v tomto článku sú určené na použitie len pri počítačových databázach. Nie je možné použiť odstrániť alebo aktualizácia dotazov vo webových aplikáciách ACCESSu.

Obsah tohto článku

Výber typu dotazu

Použitie odstraňovacieho dotazu

Použitie aktualizačného dotazu

Ďalšie informácie

Tipy na riešenie problémov

Výber typu dotazu

Na odstránenie údajov z databázy môžete použiť aktualizačný dotaz alebo odstraňovací dotaz. Vyberte si dotaz na základe podrobností v nasledujúcej tabuľke:

Typ dotazu

Použitie

Výsledky

Odstraňovací dotaz

Na odstránenie celých záznamov (riadkov) z tabuľky alebo z dvoch súvisiacich tabuliek súčasne.

Poznámka : Ak sú záznamy umiestnené na strane „one“ vzťahu one-to-many, pred spustením odstraňovacieho dotazu môže byť potrebné tento vzťah zmeniť. Pozrite si časť o odstraňovaní údajov zo súvisiacich tabuliek.

Odstraňovacie dotazy odstránia všetky údaje v každom poli vrátane hodnoty kľúča, ktorá robí záznam jedinečným.

Aktualizačný dotaz

Na odstránenie jednotlivých hodnôt polí z tabuľky.

Uľahčuje odstraňovanie hodnôt aktualizovaním existujúcich hodnôt na hodnotu null (čiže žiadne údaje) alebo na reťazec s nulovou dĺžkou (dvojica dvojitých úvodzoviek bez medzery medzi nimi).

Na začiatok stránky

Čo treba overiť pred odstránením údajov pomocou dotazu

  • Skontrolujte, či súbor nie je určený iba na čítanie:

    1. Kliknite pravým tlačidlom myši na tlačidlo Štart a potom kliknite na položku Otvoriť program Windows Prieskumník.

    2. Kliknite pravým tlačidlom myši na databázový súbor a potom kliknite na položku Vlastnosti.

    3. Skontrolujte, či je vybratý atribút Iba na čítanie.

  • Overte, či máte potrebné povolenia na odstránenie záznamov z databázy. Ak ste si nie istí, informujte sa u správcu systému alebo návrhára databázy.

  • Skontrolujte, či ste povolili obsah v databáze. Program Access v predvolenom nastavení blokuje všetky akčné dotazy (odstraňovací, aktualizačný a vytvárajúci), pokiaľ ste databázu najskôr neoznačili za dôveryhodnú. Informácie o zmene databázy na dôveryhodnú nájdete v časti Ukončenie režimu vypnutia blokujúceho dotaz.

  • Požiadajte ostatných používateľov databázy, aby zatvorili všetky tabuľky, formuláre, dotazy a zostavy, ktoré používajú údaje vybraté na odstránenie. Tým sa predíde porušeniam zámku.

  • Pred úpravou alebo odstránením záznamov je vhodné vytvoriť záložnú kópiu databázy pre prípad, že sa rozhodnete vrátiť vykonané zmeny.

Tip : Ak veľký počet používateľov pripojiť k databáze, budete musieť databázu zavrieť a znovu otvoriť v režime s výhradným prístupom.

Otvorenie databázy vo výhradnom režime

  1. Kliknite na kartu Súbor > Otvoriť.

  2. Prejdite na databázu a ukázaním na ňu ju vyberte, kliknite na šípku vedľa tlačidla Otvoriť a potom kliknite na položku Výhradný prístup.

    Otvorenie súboru vo výhradnom režime

Zálohovanie databázy

  1. Kliknite na kartu Súbor a ukážte na položku Uložiť ako.

  2. Kliknite na položku Uložiť databázu ako a na položku Zálohovať databázu. Access zatvorí pôvodný súbor, vytvorí záložnú kópiu a potom znova otvorí pôvodný súbor.

  3. Kliknite na položku Uložiť ako a zadajte názov a umiestnenie záložnej kópie a potom kliknite na tlačidlo Uložiť.

Poznámka :  Pri použití databázy určenej iba na čítanie alebo vytvorenej v predchádzajúcej verzii programu Access sa môže zobraziť hlásenie, že záložnú kópiu databázy nie je možné vytvoriť.

Ak sa chcete vrátiť k zálohe, zavrite a zmeňte názov pôvodného súboru, takže záložná kópia môže použiť názov pôvodnej verzie. Priraďte názov pôvodnej verzie záložnej kópii a v programe Access otvorte premenovanú záložnú kópiu.

Použitie odstraňovacieho dotazu

Vytvorenie odstraňovacieho dotazu, kliknite na položku vytvoriť klávesom tab v dotazy skupiny, kliknite na položku Návrh dotazu. V dialógové okno Zobrazenie tabuľky dvakrát kliknite na každú tabuľku, z ktorého chcete odstrániť záznamy a potom kliknite na položku Zavrieť.

Tabuľka sa zobrazí ako okno v hornej časti mriežky návrhu dotazu. V zozname polí dvakrát kliknite na hviezdičku (*), čím pridáte všetky polia v tabuľke do mriežky návrhu.

Použitie konkrétnych kritérií v odstraňovacom dotaze

Dôležité : Použite kritériá na vrátenie len tých záznamov, ktoré chcete odstrániť. V opačnom prípade odstraňovací dotaz odstráni všetky záznamy v tabuľke.

Dvakrát kliknite na pole, ktoré chcete zadať ako kritériá na odstránenie, jeden zadať kritériá v riadka kritérií dotazu návrhára a potom Vymazať začiarknutie políčka Zobraziť pre každé pole, kritériá.

Príklad, kedy je vhodné použiť túto možnosť: Predpokladajme, že chcete odstrániť všetky nevybavené objednávky určitého zákazníka. Aby ste našli iba tieto záznamy, do mriežky návrhu dotazu pridáte polia Identifikácia zákazníka a Dátum objednávky a potom zadáte identifikačné číslo zákazníka a dátum, kedy sa objednávky tohto zákazníka stali neplatnými.

  1. Na karte návrh kliknite na položky Zobraziť > Údajové zobrazenie.

  2. Overte, či dotaz vracia záznamy, ktoré chcete odstrániť, a potom stlačením kombinácie klávesov CTRL+S dotaz uložte.

  3. Dotaz spustíte dvoma kliknutiami na dotaz v navigačnej table.

Na začiatok stránky

Použitie aktualizačného dotazu

Poznámka : Možnosť aktualizačného dotazu nemožno použiť vo webovej aplikácii ACCESSu.

Táto časť vysvetľuje použitie aktualizačného dotazu na odstránenie jednotlivých polí z tabuliek. Nezabudnite, že spustením aktualizačného dotazu na odstránenie údajov sa zmenia existujúce hodnoty v závislosti od zadaných kritérií buď na hodnotu NULL, alebo reťazec s nulovou dĺžkou (dvojica dvojitých úvodzoviek bez medzery medzi nimi).

  1. Kliknite na kartu Vytvoriť a v skupine Dotazy kliknite na položku Návrh dotazu.

  2. Vyberte tabuľku obsahujúcu údaje, ktoré chcete odstrániť (ak je tabuľka súvisiaca, vyberte tabuľku na strane vzťahu „one“), kliknite na položku Pridať a potom kliknite na tlačidlo Zavrieť.

    Tabuľka sa zobrazí ako okno v hornej časti mriežky návrhu dotazu. Okno obsahuje všetky polia vybratej tabuľky.

  3. Dvakrát kliknite na hviezdičku (*), čím pridáte všetky polia v tabuľke do mriežky návrhu. Pridanie všetkých polí umožňuje odstraňovaciemu dotazu odstrániť z tabuľky celé záznamy (riadky).

    V prípade potreby môžete pre jedno alebo viaceré polia zadať kritériá do riadku Kritériá v návrhárovi a potom zrušiť začiarknutie políčka Zobraziť pre každé pole s kritériom. Ďalšie informácie o používaní kritérií nájdete v tabuľke Ukážkové kritériá pre výberové dotazy.

    Poznámka : Kritériá sa používajú na vrátenie len tých záznamov, ktoré chcete zmeniť. V opačnom prípade aktualizačný dotaz nastaví každý záznam v každom poli dotazu na hodnotu NULL.

  4. Prejdite na kartu Návrh a v skupine Výsledky kliknite na položku Zobraziť a potom na položku Údajové zobrazenie.

  5. Overte, či dotaz vracia záznamy, ktoré chcete nastaviť na hodnotu NULL alebo reťazec s nulovou dĺžkou (dvojica dvojitých úvodzoviek bez medzery medzi nimi ("").

  6. Podľa potreby zopakujte kroky 3 až 5 a zmeňte polia alebo kritériá, kým dotaz vráti iba údaje, ktoré chcete odstrániť, a potom stlačte kombináciu klávesov CTRL + S uložte dotaz.

  7. Dotaz spustíte dvoma kliknutiami na dotaz v navigačnej table.

Na začiatok stránky

Ďalšie informácie

Odstránenie údajov zo súvisiacich tabuliek

Ak chcete odstrániť údaje z viacerých súvisiacich tabuliek, je potrebné pre každý vzťah zapnúť možnosti Referenčná integrita a Kaskádové odstránenie súvisiacich záznamov. Tým sa umožní dotazu odstrániť údaje z tabuliek na stranách vzťahu „one“ a „many“. Pri príprave na odstránenie súvisiacich údajov je potrebné overiť nasledujúce skutočnosti:

  • Určite, ktoré záznamy sú umiestnené na strane „one“ vzťahu a ktoré sú na strane „many“.

  • Ak musíte odstrániť záznamy na strane vzťahu „one“ a súvisiace záznamy na strane „many“, zapnite množinu pravidiel nazvanú referenčná integrita a umožnite kaskádové odstránenia. Kroky v tejto sekcii približujú referenčnú integritu a vykonanie oboch úloh.

  • Ak chcete odstrániť záznamy len na strane vzťahu „one“, najskôr odstráňte vzťah a potom údaje.

Ak chcete odstrániť údaje len zo strany vzťahu „many“, vytvorte a spustite odstraňovací dotaz bez nutnosti zmeniť vzťah.

Ak chcete zistiť, ktoré záznamy sú umiestnené na strane vzťahu „one“ a ktoré na strane „many“, na karte Nástroje databázy kliknite v skupine Vzťahy na položku Vzťahy. Na karte Vzťahy sa zobrazia tabuľky v databáze a vzťahy. Každý vzťah je znázornený ako čiara spájajúca tabuľky medzi poľami.

Nasledujúci obrázok znázorňuje typický vzťah. Väčšina vzťahov v databáze má strany vzťahu „one“ a „many“. Diagram vzťahov označuje stranu „one“ číslicou jeden (1) a stranu „many“ symbolom nekonečno ().

Vzťah medzi dvoma tabuľkami

Ak odstránite záznamy na strane vzťahu „one“, odstránite tiež všetky súvisiace záznamy na strane vzťahu „many“. Ak však odstránite záznamy na strane vzťahu „many“, zvyčajne neodstránite záznamy na strane „one“.

Program Access automaticky používa množinu pravidiel nazvanú referenčná integrita. Tieto pravidlá zabezpečujú, že cudzie kľúče v databáze obsahujú správne hodnoty. Cudzí kľúč je stĺpec, ktorého hodnoty sa zhodujú s hodnotami v stĺpci hlavného kľúča inej tabuľky.

Úprava vzťahu

Podľa týchto krokov postupujte, len ak chcete odstrániť údaje na stranách vzťahu „one“ a „many“.

  1. Na karte Databázové nástroje v skupine Vzťahy kliknite na položku Vzťahy.

  2. Pravým tlačidlom myši kliknite na vzťah (čiaru) spájajúci tabuľky, ktorých sa týka odstránenie, a potom v kontextovej ponuke kliknite na položku Upraviť vzťah.

  3. V dialógovom okne Úprava vzťahov skontrolujte, či je začiarknuté políčko Zabezpečiť referenčnú integritu.

  4. Začiarknite políčko Kaskádové odstránenie súvisiacich záznamov.

    Poznámka : Pokiaľ túto vlastnosť znova nezakážete, odstránenie záznamu na strane vzťahu „one“ odstráni všetky súvisiace záznamy na strane vzťahu „many“.

  5. Kliknite na tlačidlo OK, zavrite tablu Vzťahy a potom prejdite na ďalšiu množinu krokov.

Odstránenie vzťahu

  1. Ak ešte nie je otvorená tabla Vzťahy, otvorte ju.

  2. Na karte Databázové nástroje v skupine Vzťahy kliknite na položku Vzťahy.

    Poznačte si polia zapojené do vzťahu, aby ste po odstránení údajov mohli vzťah obnoviť.

  3. Kliknite pravým tlačidlom myši na vzťah (čiaru) spájajúci tabuľky, ktorých odstránenie, a potom kliknite na položku odstrániť v kontextovej ponuke.

Poznámka : Ak chcete obnoviť vzťah, podľa predchádzajúcich krokov otvorte tablu Vzťahy a potom pomocou myši presuňte pole hlavného kľúča z tabuľky „one“ do poľa cudzieho kľúča tabuľky „many“. Zobrazí sa dialógové okno Úprava vzťahu. Ak pôvodný vzťah zabezpečil referenčnú integritu vyberte položku Zabezpečiť referenčnú integritu a potom kliknite na položku Vytvoriť. Ak nie, kliknite iba na položku Vytvoriť.

Na začiatok stránky

Ukážkové kritériá pre výberové dotazy

Nasledujúca tabuľka obsahuje zoznam niektorých ukážkových kritérií, ktoré možno použiť vo výberových dotazoch s cieľom zabezpečiť, aby sa odstránili iba požadované údaje. Niektoré príklady používajú zástupné znaky.

Kritériá

Vplyv

> 234

Vráti všetky čísla väčšie ako 234. Ak chcete nájsť všetky čísla menšie ako 234, použite kritérium < 234.

>="Cajhen"

Vráti všetky záznamy od položky Cajhen po koniec abecedy.

Od #2/2/2010# do #12/1//2010#

Vráti dátumy od 2. februára 2010 do 1. decembra 2010 (ANSI-89). Ak databáza používa zástupné znaky ANSI-92, namiesto znakov mriežky (#) použite jednoduché úvodzovky. Príklad: Between '2/2/2010' And '12/1/2010'.

Not "Nemecko"

Vyhľadá všetky záznamy poľa, ktoré neobsahujú presne hodnotu Nemecko. Kritérium vráti záznamy, ktoré okrem reťazca Nemecko obsahujú aj ďalšie znaky, ako napríklad záznam "Nemecko (euro)" alebo záznam "Európa (Nemecko)".

Not "T*"

Vyhľadá všetky záznamy, ktoré nezačínajú na písmeno „T“. Ak sa v databáze používa skupina zástupných znakov ANSI-92, použite namiesto hviezdičky (*) znak percenta (%) .

Not "*t"

Vyhľadá všetky záznamy, ktoré sa nekončia písmenom „t“. Ak databáza používa množinu zástupných znakov ANSI-92, namiesto hviezdičky (*) použite znak percenta (%).

In(Kanada,UK)

Vyhľadá v zozname všetky záznamy obsahujúce slovo Kanada alebo UK.

Like "[A-D]*"

V poli typu Text vyhľadá všetky záznamy, ktoré sa začínajú na písmená A až D. Ak sa v databáze používa skupina zástupných znakov ANSI-92, použite namiesto hviezdičky (*) znak percenta (%).

Like "*ar*"

Vyhľadá všetky záznamy, ktoré obsahujú skupinu znakov „ar“. Ak databáza používa množinu zástupných znakov ANSI-92, namiesto hviezdičky (*) použite znak percenta (%).

Like "Maison Dewe?"

Vyhľadá všetky záznamy, ktoré začínajú slovom „Maison“ a obsahujú druhý reťazec pozostávajúci z piatich písmen, z ktorých prvé štyri písmená sú „Dewe“ a posledné písmeno je neznáme. Ak databáza používa množinu zástupných znakov ANSI-92, namiesto otáznika (?) použite podčiarknutie (_).

#02.02.2010#

Vyhľadá všetky záznamy pre 02.02.10.Ak databáza používa zástupné znaky ANSI-92, ohraničte dátum jednoduchými úvodzovkami namiesto znakov mriežky ('02.02.2010').

< Date() - 30

Používa funkciu Date na vrátenie všetkých dátumov starších ako 30 dní.

Date()

Používa funkciu Date na vrátenie všetkých záznamov s dnešným dátumom.

Between Date() And DateAdd("M"; 3; Date())

Používa funkcie Date a DateAdd na vrátenie všetkých záznamov medzi dnešným dátumom a tromi mesiacmi od dnešného dátumu.

Is Null

Vráti všetky záznamy obsahujúce nezadanú (prázdnu alebo nedefinovanú) hodnotu.

Is Not Null

Vráti všetky záznamy, ktoré obsahujú akúkoľvek hodnotu (ktoré nemajú hodnotu null).

""

Vráti všetky záznamy, ktoré obsahujú reťazec s nulovou dĺžkou. Reťazce s nulovou dĺžkou sa používajú, ak je potrebné pridať hodnotu do požadovaného poľa, pričom skutočná hodnota ešte nie je známa. Pole môže napríklad obsahovať číslo faxu, ale niektorí zákazníci nemusia mať faxové prístroje. V tomto prípade sa namiesto čísla zadá pár dvojitých úvodzoviek bez medzery ("").

Na začiatok stránky

Tipy na riešenie problémov

Prečo sa zobrazuje toto chybové hlásenie a ako je možné tento problém odstrániť?

Ak zostavujete odstraňovací dotaz použitím viacerých tabuliek a vlastnosť dotazu Jedinečné záznamy je nastavená na hodnotu Nie, v Accesse sa po spustení dotazu zobrazí chybové hlásenie Nedá sa odstrániť zo zadanej tabuľky.

Ak chcete odstrániť tento problém, nastavte vlastnosť dotazu Jedinečné záznamy na hodnotu Áno.

  1. Otvorte odstraňovací dotaz v návrhovom zobrazení.

  2. Ak hárok vlastností nie je otvorený, otvorte ho stlačením klávesu F4.

  3. Kliknutím na návrhára dotazu zobrazte vlastnosti dotazu (a nie vlastnosti poľa).

  4. V hárku vlastností dotazu vyhľadajte vlastnosť Jedinečné záznamy a nastavte ju na hodnotu Áno.

Ukončenie režimu vypnutia blokujúceho dotaz

V predvolenom nastavení, ak otvoríte počítačovú databázu, ktorá nie je označená na vyjadrenie dôvery alebo ktoré sa nenachádza v dôveryhodnom umiestnení, program Access blokuje spustenie všetkých akčných dotazov.

Ak sa pokúšate spustiť akčný dotaz a zdá sa, že sa nevykonala žiadna akcia, skontrolujte stavový riadok programu Access, či sa nezobrazuje nasledovné hlásenie:

Akcia alebo udalosť boli blokované režimom vypnutia.

Keď sa zobrazí toto hlásenie, povoľte blokovaný obsah vykonaním nasledujúceho postupu:

  • Na paneli hlásení Upozornenie zabezpečenia kliknite na položku Povoliť obsah, a spustite dotaz znova.

Ďalšie informácie o režime vypnutia a zabezpečení programu Access nájdete v článku Správanie dôveryhodných a nedôveryhodných databázových objektov.

na začiatok stránky

Poznámka : Vyhlásenie týkajúce sa strojového prekladu: Tento článok bol preložený počítačovým systémom bez zásahu človeka. Poskytovaním týchto strojových prekladov umožňuje spoločnosť Microsoft aj používateľom, ktorí nehovoria po anglicky, využívať obsah o produktoch, službách a technológiách spoločnosti Microsoft. Článok bol preložený strojovo, môže preto obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky.

Rozšírte svoje zručnosti
Preskúmať školenie
Buďte medzi prvými, ktorí získajú nové funkcie
Pridajte sa k insiderom pre Office

Boli tieto informácie užitočné?

Ďakujeme za vaše pripomienky!

Ďakujeme vám za pripomienky. Pravdepodobne vám pomôže, ak vás spojíme s pracovníkom podpory pre Office.

×