Krok 4 – Zdieľanie makra s ostatnými

Dôležitá informácia o zdieľaní makier je, že sú uložené v súbore balíka Office, takže bude potrebné tento súbor zdieľať s ostatnými používateľmi. Ak ste vytvorili makro vo Worde, musíte tento súbor zdieľať ako wordovú šablónu podporujúcu makrá (.docm) alebo wordový dokument podporujúci makrá (.dotx). Ak ste vytvorili makro v Exceli, musíte tento súbor zdieľať ako zošit Excelu podporujúci makrá (.xlsm) alebo šablónu Excelu podporujúcu makrá (.xltm).

Ak ste vytvorili wordové makro, na zdieľanie makra treba vykonať ešte niekoľko krokov navyše:

Vytvorenie prázdnej wordovej šablóny

  1. Otvorte nový wordový dokument.

  2. V ponuke Súbor kliknite na príkaz Uložiť ako.

  3. Pomenujte svoj súbor ako global_macros.dotm.

  4. V rozbaľovacej ponuke Formát vyberte ako formát wordovú šablónu podporujúcu makrá (*.dotm).

  5. Vyberte vo svojej sieti miesto na uloženie tohto súboru.

  6. Kliknite na tlačidlo Uložiť a potom zavrite šablónu.

Exportovanie makra z wordového dokumentu

S makrom, ktoré ste zaznamenali v kroku 1, postupujte podľa týchto ďalších krokov a makro exportujte:

  1. Otvorte dokument alebo šablónu obsahujúcu makro, ktoré chcete exportovať.

  2. V ponuke Nástroje ukážte na položku Makro a potom kliknite na položku Makrá.

  3. Vyberte makro, ktoré chcete exportovať, a potom kliknite na položku Upraviť. Vyberte makro, ktoré chcete exportovať

  4. V editore jazyka Visual Basic kliknite na položky Súbor > Exportovať súbor.

  5. Uložte makro v tom istom priečinku ako šablónu podporujúcu makrá (súbor global_macros.dotm).

Importovanie wordového makra do novej prázdnej šablóny

  1. Otvorte súbor global_macros.dotm a potom kliknite na položky Nástroje > Makro > Editor jazyka Visual Basic.

  2. Na importovanie makra kliknite na položky Súbor > Importovať súbor, prejdite na priečinok, kde ste exportovali makro, vyberte súbor a potom kliknite na položku Otvoriť.

  3. Uložte modul, ukončite program Visual Basic Editor a potom ukončite Word.

Teraz môžete zdieľať makro s inými používateľmi a povedať im, aby postupovali podľa krokov uvedených nižšie a nainštalovali si makro vo svojich počítačoch.

Inštalácia šablóny: nastavenie Wordu na používanie makra

  1. Umiestnite súbor global_macro.dotm na tomto mieste:

    • Word pre Mac 2011: Macintosh HD: Používatelia: Meno používateľa: Knižnica: Podpora aplikácií: Microsoft: Office: Používateľské šablóny: Moje šablóny

    • Word 2003 pre Windows alebo novšia verzia: C:\Documents and Settings\Username\Application Data\Microsoft\Word\STARTUP

      Poznámka :  Meno používateľa je prihlasovacie meno používateľa.

  2. Kliknite vo Worde na položky Word > Predvoľby….

Predvoľby programu Word

  1. V časti Osobné nastavenia kliknite na položku Umiestnenia súborov

  2. Vyberte položku Po spustení zo zoznamu Umiestnenie súborov a potom kliknite na položku Upraviť....

Umiestnenie súboru

  1. Overte, či Word používa ten istý priečinok, kam ste umiestnili súbor global_macro.dotm ako priečinok Po spustení.

  2. Kliknutím na položku Vybrať zavrite dialógové okno Vybrať priečinok, potom kliknite na tlačidlo OK a zavrite dialógové okno Umiestnenie súborov.

Posledným krokom je povedať Wordu, aby po spustení používal súbor global_macros.dotm.

  1. Kliknite vo Worde na položky Nástroje > Šablóny a doplnky….

  2. Vyberte súbor global_macros.dotm zo zoznamu a kliknite na položku OK.

    Tip :  Ak sa šablóna v zozname nezobrazuje, potom súbor global_macros.dotm nie je vo wordovom priečinku Po spustení. Prejdite späť na krok 1 v tejto časti a overte, či priečinok Po spustení je ten, kde ste skopírovali súbor global_macros.dotm.

Nastavenia globálnej šablóny vo Worde

 Krok 1 – začatie so záznamom makra

Krok 2 – prečítanie a pochopenie kódu

Krok 3 – oboznámenie sa so základmi programovania

Krok 4 – zdieľanie makra s ostatnými

Krok 5 – príklady z reálneho sveta

Rozšírte svoje zručnosti
Preskúmať školenie
Buďte medzi prvými, ktorí získajú nové funkcie
Pridajte sa k insiderom pre Office

Boli tieto informácie užitočné?

Ďakujeme za vaše pripomienky!

Ďakujeme vám za pripomienky. Pravdepodobne vám pomôže, ak vás spojíme s pracovníkom podpory pre Office.

×