Konverzia databázy na formát súboru .accdb

Access 2016 a Access 2013, Access 2010 a Access 2007 vytvárajú databázy vo formáte súboru .accdb. V tomto formáte sa podporujú funkcie, ako napríklad viachodnotové polia, údajové makrá a publikovanie do služieb Access Services.

Databázy vytvorené v programoch Microsoft Office Access 2003, Access 2002, Access 2000 alebo Access 97 môžete skonvertovať na formát súboru .accdb. Databáza vo formáte súboru .accdb sa však nedá otvoriť, ani sa na ňu nedá vytvoriť prepojenie pomocou verzií programu Access, ktoré sú staršie ako program Access 2007.

Vo formáte súboru .accdb sa tiež nepodporuje replikácia ani zabezpečenie na úrovni používateľa. Ak potrebujete zdieľať databázu s osobami, ktoré používajú program Access 2003 alebo starší, alebo potrebujete vykonať replikáciu alebo zabezpečenie na úrovni používateľa, musíte použiť formát súboru .mdb.

Poznámka : Niektoré funkcie Accessu 2016, Accessu 2013 a Accessu 2010 sa nedajú použiť v Accesse 2007, aj keď zdieľajú rovnaký formát súboru. Ďalšie informácie sa nachádzajú v časti Otvorenie databázy vytvorenej alebo upravenej v Accesse 2010, Accesse 2013 alebo Accesse 2016 pomocou Accessu 2007.

Obsah tohto článku

Konverzia databázy Accessu 2000 alebo Accessu 2002 – 2003 na formát .accdb

Konverzia databázy Accessu 97 na formát .accdb

Otvorenie databázy vytvorenej alebo upravenej v Accesse 2010, Accesse 2013 alebo Accesse 2016 pomocou Accessu 2007

Konverzia databázy programov Access 2000 alebo Access 2002 – 2003 na formát .accdb

Ak chcete konvertovať databázu Accessu 2000 alebo Accessu 2002 – 2003 (.mdb) na formát súboru .accdb, musíte databázu najskôr otvoriť pomocou Accessu 2007, Accessu 2010, Accessu 2013 alebo Accessu 2016 a potom ju uložiť vo formáte súboru .accdb.

  1. Na karte Súbor kliknite na položku Otvoriť.

  2. Kliknite na databázu (.mdb) programu Access 2000 alebo Access 2002 – 2003 , ktorú chcete konvertovať.

    Poznámka : Ak sa zobrazí dialógové okno Vylepšenie databázy, databáza je vo formáte súboru staršom ako Access 2000. Ak chcete pokračovať, ďalšie informácie sa nachádzajú v sekcii Konverzia databázy programu Access 97 na formát .accdb.

  3. Na karte Súbor kliknite na položku Uložiť ako a potom na položku Uložiť databázu ako.

  4. Vyberte typ súboru programu Access a potom kliknite na položku Uložiť ako.

    Ak sú pri kliknutí na položku Uložiť ako otvorené objekty databázy, v programe Access sa zobrazí výzva na ich zatvorenie ešte pred vytvorením kópie. Ak chcete, aby sa v programe Access tieto objekty zatvorili, kliknite na tlačidlo Áno. Ak chcete, aby sa celý proces zrušil, kliknite na tlačidlo Nie. V prípade potreby sa v programe Access zobrazí výzva na uloženie zmien.

  5. V dialógovom okne Uložiť ako zadajte názov súboru do poľa Názov súboru a potom kliknite na tlačidlo Uložiť.

    Program Access vytvorí kópiu databázy a potom kópiu otvorí. Pôvodná databáza je programom Access automaticky zatvorená.

Na začiatok stránky

Konverzia databázy programu Access 97 na formát .accdb

Počnúc Accessom 2013 už nie je možné priamo konvertovať databázu Accessu 97 (.mdb) na formát súboru .accdb. Databázu Accessu 97 však môžete otvoriť v predchádzajúcej verzii Accessu a potom ju uložiť vo formáte, ktorý Access 2013 dokáže otvoriť. Tu je príklad, ako sa dá otvoriť databáza Accessu 97 v Accesse 2003 a potom skonvertovať na formát, ktorý dokáže otvoriť Access 2013:

  1. Otvorte databázu Accessu 97 v Accesse 2003.

  2. Kliknite na položky Nástroje > Pomôcky databázy > Konvertovať databázu > na formát súborov Access 2002-2003.

  3. Zadajte názov databázy a kliknite na tlačidlo Uložiť.

  4. Zatvorte Access 2003 a otvorte Access 2013.

  5. Otvorte databázu a kliknite na položky Súbor > Uložiť ako > Databáza programu Access (.accdb) > Uložiť ako > Uložiť.

Na konvertovanie databázy Accessu 97 na formát .accdb môžete použiť aj Access 2007 alebo Access 2010. Keď otvoríte databázu Accessu 97 v niektorom z týchto programov, zobrazí sa sprievodca Vylepšenie databázy, ktorý vám pomôže pri konvertovaní databázy na formát .accdb.

Na začiatok stránky

Otvorenie databázy vytvorenej alebo upravenej v Accesse 2010, Accesse 2013 alebo Accesse 2016 pomocou Accessu 2007

Keďže Access 2016, Access 2013, Access 2010 a Access 2007 používajú rovnaký formát súborov, databázu vytvorenú v programoch Access 2010, Access 2013 alebo Access 2016 môžete otvoriť pomocou Accessu 2007 bez toho, aby ste najskôr použili príkaz Uložiť ako. Access 2016, Access 2013 a Access 2010 však obsahujú niektoré funkcie, v prípade ktorých sa vyžaduje spustenie programu Access 2016, Access 2013 a Access 2010. V závislosti od funkcie môžu pri použití databázy v Accesse 2007 nastať niektoré z nasledujúcich situácií:

  • nemôžete upraviť objekt, v ktorom sa používa daná funkcia,

  • nemôžete otvoriť objekt, v ktorom sa používa daná funkcia,

  • v programe Access 2007 nemôžete otvoriť databázu vôbec.

Na začiatok stránky

Rozšírte svoje zručnosti
Preskúmať školenie
Buďte medzi prvými, ktorí získajú nové funkcie
Pridajte sa k insiderom pre Office

Boli tieto informácie užitočné?

Ďakujeme za vaše pripomienky!

Ďakujeme vám za pripomienky. Pravdepodobne vám pomôže, ak vás spojíme s pracovníkom podpory pre Office.

×