Ako zmeniť nastavenia systému Windows tak, aby bolo možné databázu nástroja Business Contact Manager zdieľať s používateľmi na iných počítačoch?

Dôležité : Tento článok je strojovo preložený, prečítajte si vyhlásenie. Anglickú verziu tohto článku nájdete tu a môžete ju použiť ako referenciu.

Príznaky

Predtým ako budete zdieľať databázu s používateľmi v iných počítačoch, vy alebo správca musíte zmeniť niektoré nastavenia Microsoft Windowsu v počítači. V opačnom prípade sa používatelia nedokážu pripojiť k zdieľanej databáze vo vašom počítači.

Poznámka :  Ak používate Windows XP Home, môžete zdieľať databázu len s používateľmi v tom istom počítači, pretože táto verzia nepodporuje zdieľanie prostredníctvom siete.

Dôležité :  Nasledujúce zmeny môže vykonať iba správca.

Príčina

Funkcie Windowsu, ako sú brána Windows Firewall a jednoduché zdieľanie súborov, sú určené na ochranu údajov v počítači. Ak chcete umožniť ostatným používateľom prístup k údajom vo svojom počítači, zmeňte nastavenia pre tieto funkcie.

Riešenie

Poznámka :  Všetky tieto zmeny môže za vás vykonať sprievodca spravovaním zdieľania. Tieto postupy budú potrebné iba výnimočne.

Prihláste sa ako správca a vykonajte nasledujúce zmeny. (Ak nie ste správca, poskytnite tieto informácie správcovi, aby za vás mohol tieto zmeny vykonať.)

Zmeny v nastaveniach Windowsu

Nasledujúce pokyny vám alebo správcovi pomôžu pochopiť vplyv zmien a preskúmať aktuálne nastavenia predtým ako manuálne vykonáte akékoľvek ďalšie zmeny.

Windows XP

  • Zmena nastavenia brány Windows Firewall

    Ak chcete povoliť používateľom prístup k svojej zdieľanej databáze zo vzdialených počítačov, musíte povoliť pripojenie (tzv. výnimku) cez Windows Firewall. Okrem toho musíte pridať do zoznamu výnimiek zdieľanie súborov a tlačiarní.

    Poznámka :  Databázu programu Business Contact Manager nemôžete zdieľať s používateľmi v inom počítači, ak je začiarknuté políčko Nepovoliť výnimky na karte Všeobecné v dialógovom okne Brána Firewall systému Windows v Centre zabezpečenia spoločnosti Microsoft. Predvolene nie sú výnimky povolené. Keď zmeníte nastavenie brány firewall, Business Contact Manager pre aplikáciu Outlook automaticky zruší začiarknutie tohto políčka, aby mali používatelia prístup k zdieľanej databáze. V zriedkavých prípadoch existujúce nastavenia Windows Firewallu zabránia automatickému zrušeniu začiarknutia tohto políčka a možno budete musieť manuálne zrušiť začiarknutie políčka Nepovoliť výnimky.

    Predvolene sú výnimky brány firewall nakonfigurované iba pre lokálnu podsieť (číslo používané s IP adresou počítača na rozdelenie veľkej siete na menšie), do ktorej patrí váš počítač. To umožňuje prístup k vašej zdieľanej databáze iba používateľom a ich počítačom, ktoré patria do vašej podsiete.

    Ak chcete povoliť prístup k zdieľanej databáze používateľovi s počítačom, ktorý nepatrí do vašej podsiete, postupujte takto:

    1. V ponuke Štart kliknite na položku Ovládací panel.

    2. V ovládacom paneli prepnite na klasické zobrazenie.

    3. Dvakrát kliknite na položku Brána Firewall systému Windows.

    4. V dialógovom okne Brána Firewall systému Windows kliknite na kartu Výnimky.

    5. Kliknite na položku Microsoft Small Business a potom na položku Upraviť.

    6. Kliknite na položku Zmeniť rozsah.

    7. Vyberte jednu z týchto možností:

      • Kliknite na položku Vlastný zoznam a potom zadajte jednu alebo viac IP adries oddelených čiarkami.

      • Vyberte položku Všetky počítače (vrátane počítačov na Internete).

    8. Kliknutím na tlačidlo OK zavrite všetky dialógové okná.

      Ďalšie informácie o bráne firewall

      Ak váš počítač používa inú bránu firewall ako tú, ktorá je súčasťou Microsoft Windowsu (napríklad bránu firewall sieťového smerovača alebo skenera vírusov), a zdieľate údaje s počítačom mimo vašej brány firewall, Business Contact Manager pre aplikáciu Outlook možno nebude môcť otvoriť port potrebný na fungovanie zdieľania databázy. Ak máte ťažkosti so zdieľaním databázy s používateľmi mimo brány firewall, musíte otvoriť TCP port 5356, ak chcete zdieľať svoju databázu. Ďalšie informácie o tom, ako otvoriť tento port, nájdete v dokumentácii k bráne firewall.

      Ak odstránite zdieľaných databáz, zmeny vykonané na vašom počítači bránu firewall a Microsoft SQL Server Native Client sieťové protokoly, keď ste si vybrali na zdieľanie databáz bude naďalej platné. Ak chcete obnoviť pôvodné nastavenia bránu firewall a sieťové protokoly SQL Server Native Client, najskôr zastavte zdieľanie jednotlivých databáz a potom odstrániť databázy. Ďalšie informácie nájdete v téme ukončiť zdieľanie databázy sekcia Zdieľanie údajov doplnku Business Contact Manager s ostatnými používateľmi a odstrániť databázy doplnku Business Contact Manager.

  • Zmena nastavenia zdieľania súborov a tlačiarní

    V zriedkavých prípadoch Business Contact Manager pre aplikáciu Outlook nemôže automaticky nakonfigurovať potrebné nastavenia Windows Firewallu. V takom prípade sa musíte manuálne uistiť, že zdieľanie súborov a tlačiarní je vybraté ako povolená výnimka.

    Začiarknite políčko Zdieľanie súborov a tlačiarní.

    1. Kliknite na tlačidlo Štart a potom kliknite na položku Ovládací panel.

    2. V ovládacom paneli kliknite na položku Brána firewall systému Windows.

    3. V dialógovom okne Brána firewall systému Windows kliknite na kartu Výnimky.

    4. Na karte Výnimky začiarknite políčko Zdieľanie súborov a tlačiarní a potom kliknite na tlačidlo OK.

  • Zmena nastavenia jednoduchého zdieľania súborov

    Pri jednoduchom zdieľaní súborov sa zaobchádza so všetkými vzdialenými používateľmi ako s hosťami. Aby ste mohli kontrolovať, kto má prístup k databáze, musíte povoliť prístup jednotlivým používateľom. Ak to chcete urobiť, zrušte začiarknutie políčka Použiť jednoduché zdieľanie súborov.

    Zrušte začiarknutie políčka Jednoduché zdieľanie súborov.

    1. Kliknite na tlačidlo Štart a potom kliknite na položku Ovládací panel.

    2. V ovládacom paneli kliknite na položku Možnosti priečinka.

    3. V dialógovom okne Možnosti priečinka kliknite na kartu Zobrazenie.

    4. Na karte Zobrazenie zrušte začiarknutie políčka Použiť jednoduché zdieľanie súborov (odporúča sa).

    5. Kliknutím na tlačidlo OK zavrite všetky dialógové okná.

Windows Vista

  • Zmena nastavenia brány Windows Firewall

    1. Kliknite na tlačidlo Štart a potom kliknite na položku Ovládací panel.

    2. V ovládacom paneli prepnite na klasické zobrazenie.

    3. Dvakrát kliknite na položku Brána Firewall systému Windows.

    4. V dialógovom okne Brána Windows Firewall vedľa položky Brána Windows Firewall je zapnutá kliknite na položku Zmeniť nastavenia.

    5. V dialógovom okne Nastavenie brány Windows Firewall kliknite na kartu Výnimky.

    6. Kliknite na položku Microsoft Small Business a potom na položku Vlastnosti.

    7. Kliknite na položku Zmeniť rozsah.

    8. Vykonajte niektorý z týchto krokov:

      • Kliknite na položku Všetky počítače (vrátane počítačov na Internete).

      • Kliknite na položku Vlastný zoznam a potom zadajte jednu alebo viac IP adries oddelených čiarkami.

    9. Kliknutím na tlačidlo OK zavrite všetky dialógové okná.

      Poznámka : Business Contact Manager pre aplikáciu Outlook nie je možné spustiť, ak je začiarknuté políčko Blokovať všetky prichádzajúce pripojenia na karte Všeobecné v dialógovom okne Nastavenie brány Windows Firewall. Predvolene nie sú výnimky povolené. Keď zmeníte nastavenie brány firewall, Business Contact Manager pre aplikáciu Outlook automaticky zruší začiarknutie tohto políčka, aby mali používatelia prístup k zdieľanej databáze. V zriedkavých prípadoch existujúce nastavenia Windows Firewallu zabránia automatickému zrušeniu začiarknutia tohto políčka a možno budete musieť manuálne zrušiť začiarknutie políčka Blokovať všetky prichádzajúce pripojenia.

  • Zmena nastavenia zdieľania súborov a tlačiarní

    V zriedkavých prípadoch Business Contact Manager pre aplikáciu Outlook nemôže automaticky nakonfigurovať potrebné nastavenia Windows Firewallu. V takom prípade sa musíte manuálne uistiť, že zdieľanie súborov a tlačiarní je vybraté ako povolená výnimka.

    Začiarknite políčko Zdieľanie súborov a tlačiarní.

    1. Kliknite na tlačidlo Štart a potom kliknite na položku Ovládací panel.

    2. V ovládacom paneli prepnite na klasické zobrazenie.

    3. Dvakrát kliknite na položku Brána Firewall systému Windows.

    4. V dialógovom okne Brána Windows Firewall kliknite na ľavej table na položku Povolenie programu v bráne Windows Firewall.

    5. Na karte Výnimky začiarknite políčko Zdieľanie súborov a tlačiarní a potom kliknite na tlačidlo OK.

Windows 7

  • Zmena nastavenia Windows Firewallu

    1. Kliknite na tlačidlo Štart a potom kliknite na položku Ovládací panel.

    2. Kliknite na položku Systém a zabezpečenie a potom na položku Windows Firewall.

    3. Na ľavej table kliknite na položku Rozšírené nastavenie.

      Poznámka :  Ak sa zobrazí správa Kontrola používateľských kont, kliknite na tlačidlo Áno.

    4. Na ľavej table okna Brána Windows Firewall s rozšíreným zabezpečením kliknite na položku Pravidlá prichádzajúcej komunikácie.

    5. Na strednej table v časti Pravidlá prichádzajúcej komunikácie dvakrát kliknite na položku Microsoft Small Business.

    6. V dialógovom okne Microsoft Small Business – vlastnosti kliknite na kartu Rozsah.

    7. Vykonajte niektorý z týchto krokov:

      • V časti Lokálna IP adresa a v časti Vzdialená IP adresa kliknite na položku Všetky IP adresy.

      • V časti Lokálna IP adresa a v časti Vzdialená IP adresa kliknite na položku Tieto IP adresy a pridajte jednu alebo viac IP adries.

    Poznámka :  Ak chcete získať ďalšie informácie o týchto nastaveniach, kliknite na položku Ďalšie informácie o nastavení rozsahu.

    1. Kliknite na tlačidlo OK.

  • Zmena nastavenia zdieľania súborov a tlačiarní

    1. Kliknite na tlačidlo Štart a potom kliknite na položku Ovládací panel.

    2. Kliknite na položku Systém a zabezpečenie a potom na položku Windows Firewall.

    3. Na ľavej table kliknite na položku Povoliť program alebo funkciu v bráne Windows Firewall.

    4. Kliknite na tlačidlo Zmeniť nastavenie.

      Poznámka :  Ak sa zobrazí správa Kontrola používateľských kont, kliknite na tlačidlo Áno.

    5. V zozname Povolené programy a funkcie začiarknite políčko vedľa položky Zdieľanie súborov a tlačiarní a potom kliknite na tlačidlo OK.

Opätovná konfigurácia Microsoft SQL Servera Express

Znova nakonfigurujte Microsoft SQL Server Express 2008, aby ste umožnili používateľom vo vzdialených počítačoch získať prístup k zdieľanej databáze.

Podľa predvoleného nastavenia, keď Business Contact Manager pre aplikáciu Outlook inštaluje SQL Server Express 2008, je nakonfigurovaný tak, aby obmedzil pripojenia iba na používateľov lokálneho počítača.

Pri zdieľaní databázy programu Business Contact Manager automaticky Business Contact Manager pre aplikáciu Outlook aktivuje podporu sietí s cieľom umožniť používateľom iných počítačov pripojiť sa k zdieľanej databáze povolením protokolu TCP/IP a protokolu pomenovaných presmerovaní.

Ak chcete manuálne aktivovať podporu sietí, aby sa mohli používatelia pripojiť k tejto databáze zo vzdialeného počítača, použite nasledujúci postup.

  1. Kliknite na tlačidlo Štart a potom ukážte na položku Všetky programy.

  2. Kliknite na položku Microsoft SQL Server 2008.

  3. Kliknite na položku Konfiguračné nástroje a potom kliknite na položku Správca konfigurácie SQL Servera.

  4. Na ľavej table okna Správca konfigurácie SQL Servera rozbaľte položku Konfigurácia siete SQL Servera a potom vyberte položku Protokoly pre MSSMLBIZ.

  5. Na pravej table kliknite pravým tlačidlom myši na položku Pomenované presmerovania a potom kliknite na položku Povoliť.

  6. Na pravej table kliknite pravým tlačidlom myši na položku TCP/IP a potom kliknite na položku Povoliť.

Zavrite okno Správca konfigurácie SQL Servera.

Na začiatok stránky

Poznámka : Vyhlásenie týkajúce sa strojového prekladu: Tento článok bol preložený počítačovým systémom bez zásahu človeka. Poskytovaním týchto strojových prekladov umožňuje spoločnosť Microsoft aj používateľom, ktorí nehovoria po anglicky, využívať obsah o produktoch, službách a technológiách spoločnosti Microsoft. Článok bol preložený strojovo, môže preto obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky.

Rozšírte svoje zručnosti
Preskúmať školenie
Buďte medzi prvými, ktorí získajú nové funkcie
Pridajte sa k insiderom pre Office

Boli tieto informácie užitočné?

Ďakujeme za vaše pripomienky!

Ďakujeme vám za pripomienky. Pravdepodobne vám pomôže, ak vás spojíme s pracovníkom podpory pre Office.

×