Функция ЕСЛИ

Функция ЕСЛИ, одна из логических функций, служит для возвращения разных значений в зависимости от того, соблюдается ли условие.

Синтаксис

ЕСЛИ(лог_выражение; значение_если_истина; [значение_если_ложь])

Например:

  • =ЕСЛИ(A2>B2;"Превышение бюджета";"ОК")

  • =ЕСЛИ(A4=500;B4-A4;""

Имя аргумента

Описание

лог_выражение    (обязательно)

Условие, которое нужно проверить.

значение_если_истина    (обязательно)

Значение, которое должно возвращаться, если лог_выражение имеет значение ИСТИНА.

значение_если_ложь    (необязательно)

Значение, которое должно возвращаться, если лог_выражение имеет значение ЛОЖЬ.

Примеры

Скопируйте данные из таблицы ниже и вставьте их в ячейку A1 нового листа Excel. Чтобы просмотреть формулу в ячейке, выделите ячейку и нажмите клавишу F2.

Фактические расходы

Предполагаемые расходы

1 500 

900 

500р.

900р.

500р.

925 

=ЕСЛИ(A2>B2;"Превышение бюджета";"ОК")

Так как фактические расходы в 1500 долл. США (A2) превышают предполагаемые расходы в 900 долл. США (B2), возвращается строка Превышение бюджета.

=ЕСЛИ(A2<B2;ИСТИНА;ЕСЛИ(A3>B3;"Превышение бюджета";"OK"))

Первая функция ЕСЛИ возвращает значение "ложь". Поэтому вычисляется второе выражение ЕСЛИ, а так как оно также имеет значение "ложь", возвращается строка ОК.

=ЕСЛИ(A4=500;B4-A4;"")

Поскольку в ячейке A4 содержится значение 500, из предполагаемых расходов в 925 долл. США вычитаются фактические расходы в размере 500 долл. США, чтобы получить сумму превышения бюджета —425. Если значение ячейки A4 не равно 500, возвращается пустая строка ("").

=ЕСЛИ(A2<B2;ИСТИНА;ЕСЛИ(A3>B3;"Превышение бюджета";"OK"))

Первая функция ЕСЛИ возвращает значение "ложь". Поэтому вычисляется второе выражение ЕСЛИ, а так как оно также имеет значение "ложь", возвращается строка ОК.

Распространенные неполадки

Проблема

Возможная причина

O (ноль) в ячейке

Не указан аргумент значение_если_истина или значение_если_ложь. Чтобы возвращать правильное значение, добавьте текст двух аргументов или значение ИСТИНА/ЛОЖЬ.

"#ИМЯ?" в ячейке

Как правило, это указывает на ошибку в формуле.

Рекомендации

Действие

Примечания

Использование вложенных функций ЕСЛИ.

Аргументы значение_если_истина и значение_если_ложь могут содержать до 64 вложенных функций ЕСЛИ, что позволяет создавать сложные проверки.

Использование функции ЕСЛИ с массивами

Если в качестве какого-либо из аргументов функции ЕСЛИ используются массив, проверяется каждый элемент массива. Узнайте, как создать формулу массива.

Дополнительные сведения

Применяется к:



Были ли сведения полезными?

Да Нет

Что мы могли бы улучшить?

255 осталось символов

Чтобы защитить вашу конфиденциальность, не указывайте контактные данные в своем отзыве. Обзор наших политика конфиденциальности.

Спасибо за ваш отзыв!

Ресурсы поддержки

Изменить язык