Войти

Применение слияния для создания и печати писем и других документов

Слияние применяется, когда нужно создать набор документов, например письма на бланках, которые рассылаются большому числу заказчиков. Каждое письмо содержит как общие, так и индивидуальные сведения. Например, в письме должно быть обращение к заказчику по фамилии. Индивидуальные сведения для каждого письма поступают из источника данных.

Процесс слияния состоит из нескольких общих действий.

  1. Настройка основного документа. Основной документ содержит текст и графику, которые являются общими для всех версий составного документа, например обратный адрес или приветствие на бланке письма.

  2. Подключение документа к источнику данных. Источником данных является файл, содержащий сведения, которые должны вставляться в документ, например, фамилии и адреса получателей письма.

  3. Уточнение списка получателей или элементов. Приложение Microsoft Office Word создает копию основного документа для каждого элемента или записи файла данных. Если файл данных — это список рассылки, то элементами, вероятно, являются получатели этой рассылки. Если нужно создать копии только для определенных элементов файла данных, элементы (записи), которые требуется включить в список, можно выбрать.

  4. Добавление в документ текстовых заполнителей (полей слияния). При слиянии поля слияния заполняются данными из файла данных.

  5. Предварительный просмотр и завершение слияния. Перед тем как печатать весь комплект копий документа, каждую из копий можно предварительно просмотреть.

Для слияния с почтой используются команды вкладки Рассылки.

Важно : Если планируется использовать настраиваемые поля контактов в списке контактов Microsoft Office Outlook, необходимо начинать слияние непосредственно из Outlook.

Совет : Слияние можно также выполнить с помощью области задач Слияние, которая позволяет шаг за шагом осуществить весь процесс. Чтобы воспользоваться областью задач, в группе Начать слияние на вкладке Рассылки выберите пункт Начать слияние, а затем пункт Пошаговый мастер слияния.

Изображение ленты Word

Настройка основного документа

  1. Запустите приложение Word.

    По умолчанию будет открыт пустой документ. Пусть он остается открытым, поскольку, если его закрыть, команды, которые нужно будет выполнить в дальнейшем, станут недоступны.

  2. На вкладке Рассылки в группе Начало слияния выберите команду Начать слияние.

    Word Ribbon Image

  3. Выберите команду Письма.

Слияние также можно использовать для создания приведенных ниже документов.

Возобновление слияния

Если необходимо прервать работу по слиянию, основной документ можно сохранить, а слияние возобновить позже. Приложение Microsoft Office Word сохраняет источник данных и данные поля. Если использовалась область задач Слияние, Word вернется к тому ее месту, где нужно возобновить слияние.

  1. Когда все будет готово для возобновления слияния, откройте документ.

    Word запросит подтверждение на открытие документа, который запустит команду SQL.

  2. Поскольку этот документ подключен к источнику данных, нажмите кнопку Да. Если открывался документ, о подключении которого к источнику данных было неизвестно, то, чтобы предотвратить потенциально опасный доступ к данным, нажмите кнопку Нет.

    Будет отображен текст документа вместе со всеми вставленными полями.

  3. Перейдите на вкладку Рассылки и возобновите свою работу.

К началу страницы

Подключение документа к источнику данных

Чтобы выполнить слияние данных в основном документе, необходимо подключить этот документ к источнику данных или файлу данных. Если файла данных еще не существует, его можно создать в процессе слияния.

Важно : При использовании существующего списка убедитесь в том, что он содержит все необходимые сведения, включая все столбцы и строки. В ходе слияния можно внести определенные изменения, однако открыть источник отдельно во время этой процедуры невозможно. Выполнить слияние проще, если источник данных подготовлен до подключения.

Выбор файла данных

  1. На вкладке Рассылки в группе Начало слияния нажмите кнопку Выбрать получателей.

    Word Ribbon Image

  2. Выполните одно из следующих действий:

    • Используйте контакты Outlook.    Если нужно использовать список "Контакты" приложения Outlook, выберите вариант Выбрать из контактов Outlook.

      Важно : Дополнительные сведения об использовании списка контактов см. в разделе Советы по работе со списком контактов Microsoft Office Outlook.

    • Используйте имеющийся файл источника данных.    При работе с электронной таблицей Microsoft Office Excel, базой данных Microsoft Office Access или файлом другого типа выберите вариант Использовать существующий список и найдите этот файл в диалоговом окне Выбор источника данных.

      В приложении Excel можно выбрать в качестве источника данных любой лист или именованный диапазон книги, в Access — любую таблицу или запрос, определенный в базе данных.

      Важно : Советы по форматированию данных на листах Excel для слияния см. в разделе Советы по форматированию данных в Office Excel.

      Чтобы использовать файл данных другого типа, выберите его в диалоговом окне Выбор источника данных. Если нужного файла нет в списке, выберите соответствующий тип либо пункт Все файлы в списке Тип файлов. При слиянии можно использовать файлы данных указанных ниже типов.

      • Файлы простых программ управления базами данных, для которых установлено соответствующее средство доступа OLE DB или драйвер ODBC. Несколько таких драйверов входят в состав Microsoft Office.

      • Файл HTML, содержащий одну таблицу. Первая строка таблицы должна содержать названия столбцов, а остальные — данные.

      • Электронные адресные книги:

        • Адресная книга Microsoft Outlook.

        • Список контактов Microsoft Schedule+ 7.0.

        • Все аналогичные списки адресов, созданные с помощью систем электронной почты, поддерживающих интерфейс MAPI, таких как Microsoft Outlook.

      • Документ Microsoft Word. Документ должен содержать одну таблицу. Первая строка таблицы должна содержать заголовки, а остальные строки — записи для слияния. В качестве источника данных можно также использовать источник заголовков.

      • Любой текстовый файл, содержащий поля данных, разделенные знаками табуляции или запятыми, и записи данных, разделенные знаками абзаца.

    • Создайте новый файл данных в Word.    Если файл данных отсутствует, выберите команду Ввести новый список и создайте список в появившейся форме. Список сохраняется в виде фала базы данных (MDB), который можно использовать многократно. Дополнительные сведения см. в разделе Создание списка.

Примечание : Если вместо приложения Microsoft Word установлен выпуск Выпуск 2007 набора Microsoft Office, можно также использовать приложение Microsoft Query для конструирования запрос и извлечения необходимых данных из внешний источник данных.

Когда все будет готово, перейдите к следующему действию.

Дополнительные сведения приведены ниже.

Советы по работе со списком контактов в Outlook

Подключение к папке "Контакты" в Outlook обычно не составляет трудностей, но время от времени могут возникать неполадки. Далее предлагается решение некоторых общих проблем, с которыми можно столкнуться:


Не удается найти в Outlook папку "Контакты"

Возможно, необходимо включить свойство Показать эту папку как адресную книгу приложения Outlook, а возможно, изменить профиль пользователя Outlook.

Включение свойства "Показать эту папку как адресную книгу"

  1. В меню Перейти приложения Microsoft Office Outlook выберите пункт Контакты.

  2. Правой кнопкой мыши щелкните папку Контакты, содержащую сведения, которые нужно использовать для слияния, а затем выберите пункт Свойства.
    Свойства контактов в Outlook

  3. На вкладке Адресная книга Outlook убедитесь, что установлен флажок Показать эту папку как адресную книгу, и нажмите кнопку OK.

К советам Outlook

Изменение профиля пользователя приложения Outlook

Профиль пользователя приложения Outlook — это группа учетных записей электронной почты и адресных книг. Обычно необходим только один профиль — однако, если данным компьютером пользуется несколько человек или, если для разных целей предназначены различные адресные книги, можно использовать дополнительные профили. Если при слиянии используется профиль, не включающий требуемую папку «Контакты», она окажется недоступной.

Чтобы переключиться на другой профиль пользователя, следует перезапустить приложение Outlook. Следуя подсказке, выберите тот профиль, который включает в себя именно ту папку «Контакты», которую нужно использовать при слиянии.

Если подсказка о выборе профиля не отображается, но точно известно, что профилей более одного, можно настроить приложение Outlook так, чтобы она отображалась. Для этого сделайте следующее.

  1. Закройте приложение Outlook.

  2. В панели управления переключитесь на классический вид и щелкните Почта.

  3. Нажмите кнопку Показать.

  4. Чтобы при каждом запуске Outlook отображалось окно выбора профиля, установите переключатель запрашивать конфигурацию и нажмите кнопку ОК.


К советам Outlook

Отображаются сообщения об ошибках в работе почтовых приложений и в таблицах

Если при попытке подключиться к папке «Контакты» во время процедуры слияния в приложении Word обнаруживается, что приложение Outlook не указано в настройках приложения Windows Internet Explorer в качестве почтового клиента по умолчанию, на экране будет отображаться сообщение об ошибке:

«Не выбран почтовый клиент по умолчанию, или текущий клиент не может выполнить запрос. Запустите Microsoft Outlook и установите клиента по умолчанию».

Чтобы избежать появления такого сообщения во время слияния, выполните следующие действия.

  1. Выйдите из приложения Word.

  2. В меню Сервис приложения Internet Explorer выберите пункт Свойства обозревателя и перейдите на вкладку Программы.

  3. В группе Электронная почта выберите пункт Microsoft Office Outlook и нажмите кнопку ОК.

Снова запустите Word, откройте документ, в котором производится слияние, и подключитесь к необходимой папке «Контакты Outlook».

К советам Outlook

Не удается подключиться к папке «Контакты» приложения Outlook через «Общие папки»

Если начать слияние в приложении Word и попытаться подключиться к папке «Контакты» приложения Outlook через Общие папки, на экране появится сообщение об ошибке:

«Не удается завершить операцию из-за ошибки окна диалога или обработчика базы данных. Повторите попытку позже.»

Попытка повторения этих действий снова приведет к получению этого же сообщения об ошибке.

Чтобы использовать папку «Контакты» через «Общие папки» в качестве файла данных для слияния, необходимо начинать слияние из Outlook.

К советам Outlook

Использование адресной книги приложения Outlook Express в качестве папки «Контакты»

Не удается во время слияния напрямую подключиться к этому типу адресной книги. Чтобы этого избежать, нужно адресную книгу приложения Outlook Express экспортировать в текстовый файл типа CSV и подключиться уже к нему.

Экспорт адресной книги приложения Outlook Express

  1. Запустите Microsoft Outlook Express.

  2. В меню Файл выберите пункт Экспорт, а затем пункт Адресная книга.

  3. В диалоговом окне Экспорт адресной книги выберите пункт Текстовый файл с разделителями-запятыми и нажмите кнопку Экспорт.

  4. В поле Сохранить экспортируемый файл как введите имя для экспортированного файла, а затем нажмите кнопку Обзор.

  5. В списке Сохранить в диалогового окна Сохранить как выберите место, где следует сохранить данный файл, и нажмите кнопку Сохранить. Удобно хранить файлы данных во внутренней папке Мои источники данных папки Мои документы. Это место, где приложение Word ищет файлы данных в первую очередь, когда требуется их просматривать во время слияния.

  6. Нажмите кнопку Далее. Установите флажки напротив полей, которые нужно экспортировать, а затем нажмите кнопку Готово.

    Примечание : Когда принимается решение, какие поля экспортировать, нужно подумать, как должны выглядеть документы на бланках, сообщения электронной почты или наклейки, которые будут создаваться с помощью слияния. Например, если в составные документы никогда не вставляются псевдонимы или адреса персональных веб-узлов, соответствующие им поля экспортировать не следует.

  7. Когда появится сообщение о том, что процедура экспорта завершена, нажмите кнопку ОК.

  8. Чтобы закрыть диалоговое окно Экспорт адресной книги, нажмите кнопку Закрыть и выйдите из приложения Outlook Express.

Чтобы подключиться к файлу данных после возвращения в приложение Word для выполнения слияния, выберите параметр Использовать существующий список и с помощью обозревателя найдите местоположение CSV-файла, который только что был экспортирован. Перед тем как открыть данный файл, возможно, потребуется ответить на вопрос приложения, каким знаком разделителя в списке адресов будет отделяться один столбец от другого. Выберите в качестве знака разделителя Запятая и нажмите кнопку .


К советам Outlook

Советы по форматированию данных в приложении Excel

Если файл данных представляет собой электронную таблицу Excel, включающую величины в процентах, в денежных единицах или почтовые индексы, можно сохранить численное форматирование этих данных с помощью динамического обмена данными, подключившись к таблице Excel из приложения Word. Например, гарантируется, что почтовый индекс 07865 из файла данных, состоящий из пяти цифр, не будет отображаться, как число 7865 (без стоящего впереди нуля).

Перед тем как подключиться к электронной таблице, выполните следующие действия в приложении Word.

  1. Нажмите кнопку Microsoft Office  Изображение кнопки Office и выберите Параметры Word.

  2. Выберите категорию Дополнительно.

  3. Перейдите к разделу Общие и установите флажокПодтверждать преобразование формата файла при открытии.

  4. Нажмите кнопку ОК.

  5. С открытым основным документом, получаемым в результате слияния, в группе Начать слияние на вкладке Рассылки выберите пункт Выбрать получателей, а затем пункт Использовать существующий список.

  6. В диалоговом окне Выбор источника данных найдите лист Excel и дважды щелкните его.

  7. В диалоговом окне Преобразование источника данных выберите пункт Листы MS Excel с помощью DDE (*.xls), а затем нажмите кнопку ОК.

    Примечание : Если файлы Книги MS Excel с помощью DDE (*.xls) не отображаются, установите флажок Показать все.

  8. В диалоговом окне Microsoft Office Excel в разделе Диапазон или имя выделите диапазон ячеек или электронную таблицу, содержащие необходимые для слияния сведения, затем нажмите кнопку ОК.

    Примечание : Чтобы предотвратить появление подсказок каждый раз, когда открывается файл данных, можно после подключения к электронной таблице отключить параметр подтверждать преобразование при открытии.

Создание списка

  1. В диалоговом окне Новый список адресов введите сведения для первого адреса или записи, которую требуется включить в слияние.

    Если требуется добавить или удалить столбцы, нажмите кнопку Настройка столбцов и внесите нужные изменения.

  2. После ввода всех данных для первой записи нажмите кнопку Создать запись и введите сведения для следующей записи. Повторяйте это действие до тех пор, пока не будут введены сведения для всех записей, которые требуется включить.

  3. Когда новый список будет готов, нажмите кнопку ОК.

  4. В диалоговом окне Сохранение списка адресов введите имя нового списка и нажмите кнопку Сохранить.

К началу страницы

Уточнение списка получателей или элементов

При подключении к определенному файлу данных, возможно, не требуется переносить данные всех записей файла данных в основной документ.

Если нужно использовать весь список, пропустите этот этап.

Чтобы ограничить список получателей или использовать подмножество элементов файла данных, выполните следующие действия.

  1. На вкладке Рассылки в группе Начало слияния выберите команду Изменить список получателей.

    Word Ribbon Image

  2. В диалоговом окне Получатели слияния выполните любое из указанных ниже действий.

    • Выделение отдельных записей.    Этот метод наиболее полезен, если список короткий. Установите флажки напротив тех получателей, которые должны быть включены в список, и снимите флажки напротив тех получателей, которые должны быть исключены из списка.

      Если известно, что в составной документ нужно включить лишь несколько записей, можно снять флажок в строке заголовка, а затем выделить только нужные записи. Аналогично, если нужно включить в документ большую часть списка, установите флажок в строке заголовка, а затем снимите флажки с тех записей, которые не нужно включать.

    • Сортировка записей.     Щелкните заголовок столбца элемента, по которому требуется выполнить сортировку. Список отсортируется в алфавитном порядке по возрастанию (от A до Я). Снова щелкните заголовок столбца, чтобы отсортировать список в алфавитном порядке по убыванию (от A до Я).

      Если необходима более сложная сортировка, выберите команду Сортировка в группе Уточнить список получателей, а затем, перейдя на вкладку Сортировка записей диалогового окна Фильтр и сортировка, выберите свои критерии сортировки. Например, можно использовать этот тип сортировки, если нужно совместить адреса получателей с их фамилиями, расположенными в алфавитном порядке внутри каждого почтового индекса, а почтовые индексы перечислять в цифровой последовательности.

    • Фильтрация записей.    Эта функция полезна, если список содержит записи, которые не требуется видеть или включать их в составной документ. После фильтрации списка можно использовать флажки для включения и исключения записей.

      Для отбора записей выполните перечисленные ниже действия.

      1. В разделе Уточнить список получателей выберите пункт Фильтр.

      2. На вкладке Отбор записей диалогового окна Фильтр и сортировка выберите условия, которые нужно использовать для фильтрации.

        Например, чтобы создать копии основного документа только для адресов, в которых в качестве страны/региона указана Австралия, выберите пункт Страна в списке Поле, условие Равно в списке Оператор и название Австралия в списке Сравнение.

      3. Для дальнейшего уточнения действия фильтра щелкните оператор И или Или и укажите дополнительные условия.

        Например, чтобы создать копии основного документа только для предприятий Мюнхена, следует фильтрацией выделить записи, поле которых Город содержит слово Мюнхен, а поле Название организации не является пустым. Если в этом фильтре использовать оператор Или вместо оператора И, составной документ будет содержать все адреса Мюнхена, а также все адреса, которые включают название компании, независимо от названия города.

    • Добавление получателей.    Чтобы добавить получателей в список, выполните указанные ниже действия.

      1. На вкладке Рассылки в группе Начало слияния выберите команду Изменить список получателей.

      2. В разделе Источник данных щелкните имя файла данных.

      3. Нажмите кнопку Изменить.

      4. В диалоговом окне Изменение источника данных нажмите кнопку Создать запись и введите сведения о получателе.

        Совет : В зависимости от типа используемого источника данных некоторые функции могут быть недоступны. По возможности проверьте полноту файла данных перед его подключением к основному документу наклеек.

    • Поиск получателя.

      Вы можете выполнить поиск определенного получателя или группы получателей, имеющих общий атрибут. Для поиска получателя или группы получателей, имеющих общие атрибуты (например, фамилию, почтовый индекс или месяц рождения), можно осуществить поиск в списке.

      1. В диалоговом окне Получатели слияния нажмите кнопку Найти получателя.

      2. В диалоговом окне Поиск элемента введите характеристику, которую нужно найти в текстовом поле Найти, укажите поле или поля, в которых нужно осуществить поиск, а затем нажмите кнопку Найти далее.

Примечание : Если установлено программное обеспечение для проверки адреса, для выполнения проверки адресов получателей можно выбрать команду Проверить адреса в диалоговом окне Получатели слияния.

К началу страницы

Добавление в документ текстовых заполнителей (полей слияния)

После подключения основного документа к файлу данных можно вводить текст документа и добавлять текстовые заполнители, указывающие места, где в каждой копии документа должны появляться уникальные данные.

Пользователи, знакомые с полями слияния, могут сразу перейти к преобразованию и слиянию.

Для получения дополнительных сведений о принципах работы полей слияния прочтите данный раздел.

Текстовые заполнители, такие как адрес или приветствие, называются полями слияния. Поля в приложении Word соответствуют выделенным заголовкам столбцов в файле данных.

Файл данных со столбцами (категориями) и строками (записями)

1. Столбцы файла данных представляют собой категории данных. Поля, добавляемые к основному документу, являются текстовыми заполнителями для этих категорий.

2. Строки файла данных представляют собой записи данных. При выполнении слияния приложение Word создает копию основного документа для каждой записи.

При помещении поля в основной документ подразумевается, что в месте его расположения должны появиться данные определенной категории, например фамилия или адрес.

Поля, вставленные в документ Word

Примечание : При вставке поля слияния в основной документ имя поля всегда заключается в двойные угловые скобки (« »). В составных документах эти скобки служат не для выделения. Они лишь позволяют отличать поля в основном документе от нормального текста.

Что происходит при слиянии

При слиянии данные первой строки файла данных замещают поля в основном документе, тем самым, образуя первый составной документ. Данные второй строки файла данных замещают поля, образуя второй составной документ, и т. д.

Слияние данных из файла данных с документом

Примеры работы с полями

Из файла данных в основной документ в качестве поля можно добавить любой заголовок столбца. Это дает определенную гибкость при составлении бланков писем, наклеек, сообщений электронной почты и других составных документов. Ниже перечислены примеры.

  • Подготовка письма, уведомляющего местные предприятия о том, что они выбраны для включения в ежегодный выпуск городского путеводителя. Если файл данных содержит столбец «Компания» с названием каждого предприятия бизнеса, с которым нужно войти в контакт, вместо того, чтобы вводить имя каждой компании в отдельности, можно вставить в документ поле «Компания».

  • Рассылка ежеквартальных сообщений электронной почты заказчикам, оповещающих о появившихся новых продуктах и скидках. Чтобы персонализировать эти сообщения для лучших заказчиков, в файл данных можно добавить столбец «Строка приветствия», где можно ввести такое обращение, как «Уважаемая г-жа Ильина, это новое украшение, как раз то, что Вы искали». Поместив поле «Строка приветствия» в основной документ, можно таким образом включать эти обращения в конце определенных сообщений.

  • Список рассылки для подписчиков информационного бюллетеня. Если файл данных включает столбец с названием «Срок истечения», содержащий даты истечения срока каждой подписки, то поместив, поле «Срок истечения» в основной документ наклейки перед выполнением слияния, можно с помощью информации на почтовой наклейке показать каждому из подписчиков дату окончания срока действия его подписки.

Можно комбинировать поля и разделять их с помощью знаков препинания. Например, чтобы сформировать точный адрес, необходимо в основной документ вставить следующие поля:

«Имя» «Фамилия»

«Строка адреса»

«Город», «Страна» «Почтовый индекс»

Для часто встречающихся случаев, таких как блоки адреса или строки приветствия, приложение Word предоставляет сложные поля — сочетание из нескольких полей. Ниже перечислены примеры.

  • Поле «Блок адреса» комбинируется из нескольких полей, включающих имя, фамилию, дом и улицу, город и почтовый индекс.

    Элементы поля ''Блок адреса''

  • Поле «Строка приветствия» может включать в себя одно или более полей имен, в зависимости от используемых слов приветствия.

Содержимое каждого из сложных полей можно настроить. Например, в обращении можно указать официальное имя (г-н Иванов), а в приветствии использовать "Г-ну" вместо "Уважаемый".

Установление соответствия полей слияния файлу данных

Чтобы не было сомнений, что приложение Word найдет в файле данных столбец, соответствующий каждому адресу или элементу приветствия, необходимо установить соответствие полей слияния в Word столбцам в файле данных.

Для установления соответствия полей выберите пункт Подбор полей в группе Составление документа и вставка полей на вкладке Рассылки.

Изображение ленты Word

Откроется диалоговое окно Подбор полей.

Диалоговое окно «Подбор полей»

Элементы адреса и приветствия приводятся слева. Заголовки столбцов из файла данных приводятся справа.

Word подыскивает соответствующий столбец для каждого элемента. На иллюстрации показано, что Word автоматически нашел соответствие столбца Фамилия файла данных полю Фамилия. Но он не смог противопоставить друг другу другие элементы. В частности, из этого файла данных Word не нашел соответствия полю Имя.

В списке справа можно выделить столбец файла данных, соответствующий элементу слева. Теперь на иллюстрации видно, что столбец Имя соответствует полю Имя. Нет ничего страшного в том, что для полей Обращение, Уникальный идентификатор и Отчество не нашлось соответствия. Составной документ не нуждается в использовании каждого поля. Если добавить поле, для которого нет данных в файле данных, оно будет фигурировать в составном документе как пустой текстовый заполнитель — обычно это пустая строка или скрытое поле.

Диалоговое окно «Подбор полей»

Ввод содержимого и добавление заполнителей (полей)

  1. В основном документе введите содержимое, которое должно отображаться во всех его копиях.

    Чтобы добавить рисунок (например, эмблему), на вкладке Вставка в группе Иллюстрации нажмите кнопку Рисунок.

  2. Щелкните то место, куда нужно вставить поле.

  3. Воспользуйтесь группой Запись и вставка полей на вкладке Письма и рассылки.

    Изображение ленты Word

  4. Добавьте нужные поля из перечисленных ниже.

    Блок адресов с именем, почтовым адресом и прочими сведениями

    1. Щелкните ссылку Блок адреса.

    2. В диалоговом окне Вставка блока адресов выберите элементы адреса, которые необходимо включить, и нужный формат этих элементов, а затем нажмите кнопку OK.

    3. Появление диалогового окна Подбор полей может означать, что приложению Word не удалось найти некоторые сведения, необходимые для блока адресов. Щелкните стрелку рядом с параметром (нет соответствия), а затем выберите поле источника данных, соответствующее полю, которое нужно включить в слияние.

    Строка приветствия

    1. Щелкните ссылку Приветствие.

    2. Выберите формат строки приветствия, которая включает обращение, имя и знак пунктуации, следующий за именем.

    3. Выберите текст строки приветствия для случаев, когда имя получателя недоступно, например, когда источник данных не содержит имени или фамилии получателя, а содержит только название компании.

    4. Нажмите кнопку ОК.

    5. Появление диалогового окна Подбор полей может означать, что приложению Word не удалось найти некоторые сведения, необходимые для строки приветствия. Щелкните стрелку рядом с параметром (нет соответствия), а затем выберите поле источника данных, соответствующее полю, которое нужно включить в слияние.

    Отдельные поля

    Сведения можно вставлять из отдельных полей, таких как фамилия, номер телефона или сумма вклада спонсоров. Чтобы быстро добавить поле из файла данных в основной документ, щелкните стрелку рядом со списком Вставка поля данных, а затем выберите имя поля.

    Чтобы использовать большее количество параметров при вставке отдельных полей в документ, выполните следующие действия.

    1. На вкладке Рассылки в группе Составление документа и вставка полей выберите команду Вставить поле слияния.

    2. В диалоговом окне Вставка поля слияния выполните одно из указанных ниже действий.

      • Для выбора полей адреса, которые будут автоматически сопоставляться соответствующим полям в источнике данных, даже если их имена не совпадают, выберите параметр Поля адреса.

      • Чтобы выбрать поля, которые всегда содержат данные непосредственно из столбцов в файле данных, выберите параметр Поля базы данных.

    3. В списке Поля выберите нужное поле.

    4. Нажмите кнопку Вставить, а затем — кнопку Закрыть.

    5. Появление диалогового окна Подбор полей может означать, что приложению Microsoft Word не удалось найти некоторые сведения, необходимые для вставки поля. Щелкните стрелку рядом с параметром (нет соответствия), а затем выберите поле источника данных, соответствующее полю, которое нужно включить в слияние.

      Примечание : Если вставить поле из списка Поля базы данных, а затем перейти в источник данных, в котором столбец с таким же именем отсутствует, Microsoft Word не сможет вставить сведения из этого поля в документ слияния.

Настраиваемые поля из списка контактов приложения Outlook

Единственный способ включить настраиваемые поля списка контактов в основной документ — это начать слияние из приложения Outlook. Предварительно нужно настроить отображение списка контактов с применением именно тех полей, которые должны быть использованы при слиянии. После этого можно начинать слияние. Как только будут установлены все необходимые параметры настройки, автоматически откроется приложение Word, и можно будет завершить слияние.

Настройка отображения списка контактов, включающего настраиваемые поля

  1. В разделе Контакты Outlook в меню Вид наведите указатель на элемент Текущее представление и выберите Список телефонов.

  2. Щелкните правой кнопкой мыши заголовок столбца и выберите команду Выбрать поля.

  3. В раскрывающемся списке в верхней части диалогового окна Выбрать поля выберите пункт Поля пользователя в папке.

  4. Перетащите добавляемое поле из диалогового окна к заголовкам столбцов. Маленькая красная стрелка поможет поместить его там, где нужно.
    Перетаскивание настраиваемого поля из диалогового окна "Выбор полей" в представление папки "Контакты"

    Примечание : В диалоговом окне Выбрать поля можно добавить новое поле, нажав кнопку Новое в верхней части.

  5. После добавления в представление всех настраиваемых полей закройте диалоговое окно Выбор полей.

  6. Чтобы удалить поле, которое не должно использоваться при слиянии, поместите указатель мыши на имя поля в заголовке столбца представления «Список телефонов» и стащите поле из заголовка.

    Запуск слияния из приложения Outlook

  7. В представлении «Контакты» приложения Outlook выберите отдельные контакты путем выделения мышью диапазона контактов при нажатой клавише SHIFT или путем выделения мышью отдельных контактов при нажатой клавише CTRL. Если нужно использовать при слиянии все контакты, которые отображаются в данный момент, никакого выделения не требуется.

  8. В меню Сервис выберите команду Слияние.

  9. Если для включения в составной документ выделены только отдельные контакты, выберите пункт Только выбранные контакты. Если в составной документ нужно включить все отображаемые в представлении контакты, выберите пункт Все контакты в текущем представлении.

  10. Если представление «Список телефонов» настроено таким образом, что оно отображает как раз те самые поля, которые нужно использовать при слиянии, выберите пункт Поля контактов в текущем представлении. Если же выбрать пункт Все поля контактов, то все поля списка контактов будут доступны для слияния.

  11. Если для слияния нужно создать новый основной документ, выберите пункт Новый документ. В противном случае выберите пункт Существующий документ и, чтобы найти необходимый основной документ, нажмите кнопку Обзор.

  12. Если нужно сохранить выделенные контакты и поля для использования в дальнейшем, установите флажок Постоянный файл и для сохранения файла нажмите кнопку Обзор. Разделенные запятыми данные будут сохранены в документе Word.

  13. Выберите необходимые параметры слияния.

    • Документы на бланке      Подготовка партии писем для массовой рассылки.

    • Наклейки     Подготовка адресных наклеек для массовой рассылки.

    • Конверты     Подготовка конвертов для массовой рассылки.

    • Каталог     Создание единого документа, содержащего каталог или список адресов.

    • Новый документ     Создание составных документов, которые можно отдельно редактировать в приложении Word.

    • Принтер     Отправка составных документов непосредственно на установленный по умолчанию принтер.

    • Электронная почта     Создание составных документов в виде, удобном для их рассылки в качестве сообщений электронной почты. Когда все готово к завершению слияния в приложении Word, на вкладке Рассылки в группе Готово выберите команду Найти и объединить, а затем Отправить электронные сообщения. Строка Тема содержит текст, введенный в диалоговом окне Контакты для слияния приложения Outlook.

  14. Нажмите ОК. Когда документ откроется в приложении Word, то на вкладке Рассылки, в группе Составление документа и вставка полей нажмите стрелку рядом с Вставить поле слияния, а затем щелкните те поля, которые нужно вставить в документ.

Примечание : 

  • Нельзя вводить знаки поля слияния («« »») вручную или использовать для этого команду Символ в меню Вставка. Необходимо использовать процедуру слияния.

  • Если поля слияния отображаются заключенными в фигурные скобки, например { MERGEFIELD Город }, это означает, что в Microsoft Word отображаются коды полей, а не значения полей. Независимо от режима отображения, результат слияния остается неизменным. Если требуется просмотреть значения полей, щелкните код поля слияния правой кнопкой мыши, а затем в контекстном меню выберите команду Коды/значения полей.

Форматирование данных слияния

Приложения для работы с базами данных и с электронными таблицами, такие как Microsoft Office Access и Microsoft Office Excel, сохраняют вводимые сведения в ячейки в необработанном виде. Форматирование, применяемое в Access или Excel, такое как шрифты и цвет, не сохраняется вместе с необработанными данными. При слиянии данных из файла данных в документ Word выполняется слияние необработанных данных без примененного к ним форматирования.

Применение форматирования

  1. Выделите поле слияния вместе с шевронами (« »), в которые оно заключено.

  2. На вкладке Главная в группе Шрифт задайте параметры форматирования или нажмите кнопку запуска диалогового окна Шрифт, чтобы получить доступ к дополнительным параметрам.

Важно : Чтобы уменьшить расстояние между строками в адресе на наклейке, выделите их, нажмите на вкладке Главная кнопку запуска диалогового окна Абзац и введите 0 в поля, определяющие величину отступа перед строкой и после нее. Если используется поле слияния "Блок адреса", выделите все поле, включая угловые кавычки (« »), и настройте междустрочный интервал.

К началу страницы

Предварительный просмотр, завершение слияния и печать документов

После того, как все поля добавлены в основной документ, можно просмотреть предварительные результаты слияния. Если эти результаты соответствуют ожиданиям, можно завершить слияние.

Предварительный просмотр результатов слияния

Перед фактическим завершением слияния можно просмотреть составные документы и, если нужно, внести соответствующие изменения.

Для просмотра выполните одно из следующих действий в группе Просмотреть результаты вкладки Рассылки :

Изображение ленты Word

  • Щелкните Просмотреть результаты.

  • Просмотрите постранично каждый составной документ с помощью кнопок Следующая запись и Предыдущая запись в группе Просмотр результатов.

  • Просмотрите конкретный документ с помощью команды Найти получателя.

Примечание : Чтобы открыть диалоговое окно Адресаты слияния, позволяющее отфильтровать список или исключить получателей, если в список попали нежелательные записи, на вкладке Рассылки в группе Начать слияние выберите пункт Изменить список получателей.

Word Ribbon Image

Завершение слияния

Составные документы можно печатать или видоизменять по отдельности. Это может быть сделано как для всех документов, так и для подмножества документов.

Чтобы распечатать подмножество документов, можно задать нужный набор, указав диапазон номеров записей. Чтобы распечатать страницы, не указывая номера записей, выполните действия, описанные в разделе Изменение отдельных копий документов.

Печать составных документов

  1. На вкладке Рассылки в группе Завершение нажмите кнопку Найти и объединить и выберите команду Печать документов.

    Изображение ленты Word

  2. Выберите, следует ли печатать весь набор документов, только копию, отображаемую в настоящий момент, или подмножество документов, определяемое по указанному номеру записи.

Изменение отдельных копий документа

  1. На вкладке Рассылки в группе Завершение нажмите кнопку Найти и объединить и выберите команду Изменить отдельные документы.

    Изображение ленты Word

  2. Выберите, следует ли редактировать весь набор документов, только копию, отображаемую в настоящий момент, или подмножество документов, определяемое по указанному номеру записи. Приложение Word сохраняет копии, которые требуется отредактировать, в виде единого файла, где они отделены друг от друга с помощью разрывов страницы.

После внесения всех изменений в новый файл наклеек можно их распечатать их. Для этого нажмите кнопку Microsoft Office  Изображение кнопки Office и выберите Печать.

Сохранение основного документа

Помните, что составные документы сохраняются отдельно от основного. Основной документ удобно хранить отдельно, поскольку он может оказаться полезен при выполнении последующих слияний.

При сохранении основного документа сохраняется и его подключение к файлу данных. В следующий раз, когда документ будет открыт, приложением будет задан вопрос, нужны ли сведения из этого файла данных для нового слияния в основной документ.

  • В случае ответа Да документ открывается с данными из первой записи, полученными в результате слияния.

  • В случае ответа Нет подключение между основным документом и файлом данных разрывается. Основной документ становится стандартным документом Word. Поля замещаются на уникальные данные из первой записи.

К началу страницы



Были ли сведения полезными?

Что мы могли бы улучшить?

Что мы могли бы улучшить?

Чтобы защитить вашу конфиденциальность, не указывайте контактные данные в своем отзыве. Обзор наших политика конфиденциальности.

Спасибо за ваш отзыв!