Переход на Access 2010

Общие сведения

Переход на Access 2010 с предыдущей версии приложения  Курс предназначен для опытных пользователей Access. В данном курсе описан процесс перехода на Access 2010 с предыдущей версии приложения. В нем описано выполнение в приложении Access 2010 стандартных задач, таких как работа с существующими базами данных, создание новых баз данных и таблиц, а также создание и редактирование форм и отчетов.

После завершения данного курса вы сможете:

  • открывать существующие базы данных и создавать новые с помощью представления Backstage;

  • сохранять существующую базу данных в виде файла Access 2010;

  • запускать режим конструктора для таблиц, форм, отчетов и запросов с помощью ленты;

  • редактировать формы и отчеты в режиме макета;

  • группировать данные в отчетах в режиме макета.

Данный курс включает следующие разделы:

  • одно занятие для самостоятельного изучения;

  • небольшой тест в конце занятия (тест не оценивается);

  • краткий справочник в конце курса, который можно распечатать.

Данный курс рассчитан на пользователей, имеющих некоторый опыт работы с приложением Access, которые уже создали несколько баз данных, знакомы с основами их проектирования и понятием отношений между таблицами. Новичкам следует начать с раздела Приступая к работе с приложением Access 2010.

Автономная версия (65,7 МБ)

Приступая к работе с приложением Access 2010

Браузер не поддерживает видео. Установите Microsoft Silverlight, Adobe Flash Player или Internet Explorer 9.

Работа с областью навигации

Браузер не поддерживает видео. Установите Microsoft Silverlight, Adobe Flash Player или Internet Explorer 9.

Знакомство с лентой

Браузер не поддерживает видео. Установите Microsoft Silverlight, Adobe Flash Player или Internet Explorer 9.

Работа с файлами более ранних версий приложения Access

Браузер не поддерживает видео. Установите Microsoft Silverlight, Adobe Flash Player или Internet Explorer 9.

Быстрое знакомство с шаблонами и веб-базами данных

Браузер не поддерживает видео. Установите Microsoft Silverlight, Adobe Flash Player или Internet Explorer 9.

Быстрое проектирование баз данных в режиме макета

Браузер не поддерживает видео. Установите Microsoft Silverlight, Adobe Flash Player или Internet Explorer 9.

Рекомендуемые упражнения

Этот курс предназначен для пользователей, имеющих определенный опыт работы с Access 2003 или более ранними версиями приложения (с несколькими небольшими базами данных). Ниже описаны некоторые способы практической проработки материалов данного курса.

Важно    Для выполнения этих действий требуется установленное на компьютере приложение Access 2010, а также подключение к Интернету.

Создание новой пустой базы данных

При выполнении этих действий можно воспользоваться одной из собственных схем баз данных.

  1. Запустите программу Access 2010. В ней автоматически откроется представление Backstage.

  2. Откройте вкладку Создать. На ней уже выбран шаблон Новая база данных.

  3. В правой части вкладки в поле Имя файла введите имя для новой базы данных.

  4. Можно также щелкнуть значок папки справа от поля Имя файла.

    При этом откроется диалоговое окно Файл новой базы данных, в котором можно выбрать для базы данных другое расположение.

  5. Нажмите кнопку Создать.

    Откроется база данных (в режиме таблицы) с пустой таблицей, готовой к добавлению полей.

Добавление полей в таблицу

В программе Access есть несколько способов добавления полей в таблицу. Ниже описаны наиболее распространенные из них.

  1. В таблице, открытой в режиме таблицы, откройте вкладку Поля.

  2. В группе Добавление и удаление откройте список Другие поля.

  3. В нижней части списка в разделе Краткое руководство выберите пункт Имя
    Список ''Другие поля''

  4. Щелкните заголовок пустого поля справа от новых полей (слова Щелкните для добавления) и повторите действие 4, чтобы добавить в таблицу поля Адрес и Телефон.

  5. Щелкните правой кнопкой мыши заголовок пустого поля (слова Щелкните для добавления) и выберите из списка пункт Поле MEMO.

    При этом будет определен тип данных для поля, а его заголовок станет доступным для редактирования.

  6. В заголовке поля введите текст Примечания и щелкните любое место за его пределами, чтобы сохранить изменения.

Перемещение в области навигации

Примечание.    Для выполнения этих действий требуется подключение к Интернету. Сначала необходимо загрузить учебную базу данных "Борей". Чтобы сделать это, откройте вкладку Создать и выберите команду Образцы шаблонов. Установите доверие к базе данных (в желтом окне сообщения нажмите кнопку Включить содержимое) и войдите в базу данных.

  1. В данном шаблоне область навигации скрыта, поэтому откройте ее, щелкнув двойную стрелку.

    Кнопка открытия и закрытия области навигации

  2. В области навигации щелкните панель Отчеты, чтобы развернуть эту группу.

    Обратите внимание на отображаемый в группе набор ярлыков для объектов базы данных. Так выглядит настраиваемая категория или группа.

  3. Щелкните строку вверху панели (с надписью "Борей") и выберите пункт Тип объекта. Будет отображен список объектов базы данных.

  4. Щелкните элемент Формы, а затем щелкните правой кнопкой мыши форму Список клиентов и выберите команду Режим макета.

  5. Щелкните группу Таблицы, чтобы развернуть ее, а затем дважды щелкните таблицу Клиенты.

  6. Щелкните правой кнопкой мыши строку вверху панели и выберите команду Строка поиска.

    Чтобы отобразить строку поиска, повторите это действие.

  7. Отобразив строку поиска, разверните все группы и медленно введите в ней слово клиент. Обратите внимание, как фильтруется список объектов по мере ввода текста.

Навигация по ленте

Выполните эти действия для базы данных, например "Борей".

  • Откройте таблицу в режиме таблицы и обратите внимание на появившиеся контекстные вкладки. Изучите эти вкладки, чтобы узнать, какие команды на них содержатся.

  • Откройте запрос в режиме конструктора и обратите внимание на появившиеся контекстные вкладки. Изучите эти вкладки, чтобы узнать, какие команды на них содержатся.

  • Откройте форму в режиме макета и обратите внимание на появившиеся контекстные вкладки. Изучите эти вкладки.

Дополнительные действия

  1. Откройте один из объектов базы данных и вкладку Главная, а затем нажмите клавишу ALT.

    Появится набор подсказок клавиш.

    Подсказки клавиш

    В приложении Access подсказки клавиш доступны для всех вкладок ленты, а также для всех команд на них.

  2. Еще раз нажмите клавишу ALT и обратите внимание, что подсказки клавиш исчезли.

  3. Нажмите сочетание клавиш ALT+C, чтобы открыть вкладку Создание.

    Отображается набор подсказок клавиш для всех команд вкладки Создание, поскольку переход на нее выполнен с вкладки Главная. 

  4. Еще раз нажмите клавишу ALT и обратите внимание, что подсказки клавиш исчезли.

  5. Теперь нажмите сочетание клавиш ALT+C, и подсказки клавиш для всех команд появятся снова.

    Если подсказки клавиш для определенной вкладки случайно закрыты, нажмите клавишу ALT и букву этой вкладки, чтобы снова отобразить их.

  6. Нажмите клавиши QD, чтобы открыть конструктор запросов.

  7. В конструкторе запросов нажмите сочетание клавиш ALT+Г, чтобы перейти на вкладку Главная.

    Обратите внимание, что подсказки клавиш для отключенных команд (серого цвета) также отключены.

Публикация веб-базы данных

Сначала загрузите один из шаблонов веб-базы данных, например шаблон веб-базы данных активов. Для этого откройте вкладку Создать и выберите команду Образцы шаблонов. Установите доверие к базе данных (в желтом окне сообщения нажмите кнопку Включить содержимое) и войдите в базу данных.

  1. В представлении Backstage откройте вкладку Сохранить и опубликовать.

  2. Выберите команду Опубликовать в Access Services.

  3. Нажмите кнопку Проверка совместимости.

  4. Нажмите кнопку Да, чтобы закрыть все открытые объекты и запустить средство проверки совместимости.

    Если при проверке совместимости проблемы не выявлены или обнаружены только предупреждения, база данных готова к публикации.

  5. Введите URL-адрес сервера и имя сайта. URL-адрес можно узнать у системного администратора.

  6. Нажмите кнопку Опубликовать в Access Services.

    Затем дождитесь завершения процесса публикации и обработки нового сайта сервером.

  7. Откройте веб-браузер, загрузите сайт, откройте форму "Текущие активы" и введите какие-либо данные.

Изменение веб-базы данных и сохранение изменений через Интернет

  1. Откройте веб-базу данных активов в приложении Access.

  2. Откройте форму "Основная" в режиме макета.

  3. Щелкните правой кнопкой мыши вкладку Приступая к работе в форме и нажмите кнопку Удалить, а затем нажмите сочетание клавиш CTRL+S, чтобы сохранить изменения.

  4. Откройте вкладку Файл, чтобы перейти в представление Backstage.

  5. На вкладке Сведения нажмите кнопку Синхронизировать все, чтобы записать (сохранить) изменения через Интернет.

    Кнопка ''Синхронизировать все''

Проверьте себя

Пройдите следующий тест, чтобы проверить, как вы поняли материал. Результаты не будут разглашаться и не будут оцениваться.

Формы и отчеты веб-базы данных можно изменять в режиме конструктора.

Верно.

Неправильно. Режим конструктора можно использовать только для форм или отчетов, не предназначенных для публикации в службах Access. Создавать и изменять формы и отчеты веб-баз данных необходимо в режиме макета.

Неверно.

Правильно. Формы и отчеты веб-базы данных можно изменять в режиме макета, но не в режиме конструктора.

База данных Access 97 открыта в приложении Access 2010. Теперь можно вводить данные и изменять структуру базы данных.

Верно.

Попробуйте еще раз. Если открыть базу данных Access 97 в приложении Access 2010, можно только просматривать данные.

Неверно.

Правильно. Можно только просматривать данные. Для выполнения других действий файл необходимо сохранить в формате Access 2010.

Веб-базу данных можно опубликовать на любом веб-сайте.

Верно.

Неправильно. Веб-базы данных можно публиковать только на серверах SharePoint со службами Access.

Неверно.

Правильно. На сервере SharePoint 2010 должны быть запущены службы Access.

Чтобы открыть форму для ввода данных, нужно выполнить в области навигации указанные ниже действия.

Щелкнуть форму правой кнопкой мыши и выбрать команду "Режим конструктора".

Неправильно. В этом случае форма будет открыта для изменения ее структуры, а не для обычного использования.

Дважды щелкнуть форму.

Запишите себе два очка. Можно также щелкнуть объект правой кнопкой мыши и выбрать команду "Открыть".

Область навигации использовать не нужно. Нужно выбрать команду "Открыть" на вкладке "Главная" ленты.

Повторите попытку. Безусловно, область навигации можно использовать для того, чтобы открыть объект.

Если сохранить MDB-файл в новом формате (ACCDB), его можно будет открыть в Access 2003.

Верно.

Повторите попытку. ACCDB-файлы нельзя открывать в приложении Access 2003.

Неверно.

Правильно. ACCDB-файлы можно открывать только в приложении Access 2007 или 2010. Кроме того, следует помнить, что функции, уникальные для версии 2010, не будут работать в версии 2007.

Обратная связь

Краткий справочник

Дополнительное обучение

Серия курсов для новичков.

Проектирование таблиц для новой базы данных

См. также

Настройка ленты

Книга сопоставления команд на ленте Access

Отображение и скрытие области навигации

Диалоговое окно "Параметры навигации"

Преобразование базы данных Access 2010 в формат предыдущей версии

Видео: общие сведения о макетах Access 2010

Какой режим следует использовать: режим макета или конструктора?

Перемещение в представлении Backstage

  • При запуске приложения Access 2010 открывается представление Backstage. Чтобы открыть или закрыть это представление, щелкните вкладку Файл.

  • Чтобы открыть базу данных, щелкните ее имя на вкладке Файл или откройте вкладку Последние.

  • На вкладке Создать можно создать новую базу данных, включая пустые базы данных и шаблоны.

  • На вкладке Сохранить и опубликовать можно сохранить базу данных в другом формате файла, упаковать и подписать ее, преобразовать ее в исполняемый файл и опубликовать базу данных на сервере SharePoint 2010 с запущенными службами Access.

  • Если выбрать команду Параметры, открывается диалоговое окно Параметры Access, в котором можно настроить параметры базы данных и самого приложения Access.

Создание пустой базы данных

  1. Дважды щелкните нужный шаблон.

  2. Примите имя по умолчанию или введите другое.

  3. Нажмите кнопку Создать.

Использование области навигации

  • Дважды щелкните объект, чтобы открыть его для работы.

  • Щелкните объект правой кнопкой мыши, чтобы изменить структуру, экспортировать, переименовать его или открыть окно свойств выбранного объекта.

Настройка категорий для отображения объектов на панели

  1. Щелкните строку вверху панели. Откроется список категорий и групп.

  2. Выберите категорию из верхней половины списка или группу из нижней половины.

Настройка параметров панели

  • Щелкните правой кнопкой мыши строку вверху панели и выберите команду Параметры навигации.

Поиск объектов

  1. Если строка поиска скрыта, щелкните правой кнопкой мыши строку вверху области навигации и выберите команду Строка поиска.

  2. Введите часть имени или полное имя объекта в поле Поиск. Список объектов будет фильтроваться по мере ввода текста.

Предотвращение наложения объектов базы данных друг на друга

  1. В представлении Backstage выберите команду Параметры.

  2. Выберите пункт Текущая база данных.

  3. Выберите параметр Вкладки и установите флажок Отображать вкладки документов.

  4. Чтобы увидеть изменения, закройте и снова откройте базу данных.

Использование ленты

  • Лента не является статичной — ее вид зависит от активного объекта и выполняемой задачи.

  • Команды ленты организованы в группы, размещенные на вкладках.

  • На вкладке Главная представлены наиболее популярные команды.

  • Кроме того, наиболее часто используемые команды вынесены на панель быстрого доступа в верхнем левом углу окна приложения Access. Содержимое панели быстрого доступа не зависит от того, какая вкладка ленты открыта.

  • Панель быстрого доступа и ленту можно настроить.

Использование подсказок клавиш

  • Нажмите клавишу ALT, чтобы отобразить подсказки клавиш для всех вкладок ленты. Чтобы открыть одну из вкладок, нажмите клавишу ALT в сочетании с назначенной ей буквой.

  • Если вкладка открыта с помощью подсказки клавиши, для ее команд также отображаются подсказки клавиш. Чтобы вызвать команду, нажмите показанное число, букву или буквы. Если подсказки клавиш для команд вкладки исчезли, нажмите клавишу ALT в сочетании с буквой вкладки.

Настройка панели быстрого доступа

  1. Щелкните стрелку в правой части панели, чтобы открыть меню с командами.

  2. Выберите команду, которую нужно добавить на панель.

  3. Если нужная команда не отображается, выберите в меню пункт Другие команды. Откроется диалоговое окно Параметры Access.

  4. Добавьте команды из панели слева на панель в правой части.

Настройка ленты

При настройке ленты изменения применяются к приложению Access в целом, а не к отдельной базе данных.

Важно    При помещении команды на настраиваемую вкладку или в настраиваемую группу ленты разрывается связь между этой командой и соответствующим разделом справки (F1).

  1. Откройте вкладку Файл, чтобы перейти в представление Backstage, и нажмите кнопку Параметры.

  2. Выберите команду Настройка ленты.

  3. Под правой панелью нажмите кнопку Создать вкладку, Создать группу или Переименовать в зависимости от того, что нужно сделать.

  4. На панели слева введите имя для вкладки или группы.

  5. При создании новой вкладки или группы выберите нужную команду на панели слева и либо дважды щелкните ее, либо нажмите кнопку Добавить, чтобы переместить ее на панель справа.

Правила использования файлов из более ранних версий приложения Access

  • Базы данных, созданные в Access 2000, Access 2002 и Access 2003, можно использовать в приложении Access 2010, но некоторые функции, включая окно базы данных и репликацию, работать не будут.

  • Файлы Access 97 открываются в приложении Access 2010, но в них можно только просматривать объекты и добавлять записи. Изменения в структуре базы данных невозможно сохранить, если она не преобразована в формат файла Access 2010.

  • После сохранения старой базы данных в виде ACCDB-файла с ней можно будет работать только в Access 2007 и 2010.

  • Если открыть базу данных Access 2010 в приложении Access 2007, функции, уникальные для Access 2010, работать не будут.

Использование шаблонов и веб-баз данных

В приложении Access предлагаются шаблоны двух типов — локальные и из Интернета. Локальные шаблоны устанавливаются на компьютер вместе с приложением Access. Шаблоны из Интернета доступны при наличии подключения к Интернету.

Использование шаблонов из Интернета

  1. В представлении Backstage на вкладке Создать выберите команду Образцы шаблонов или дважды щелкните одну из категорий шаблонов в разделе Шаблоны Office.com.

  2. Присвойте имя новой базе данных, при необходимости укажите нужное расположение и нажмите кнопку Создать, чтобы загрузить и открыть шаблон.

  3. Включите все заблокированное содержимое и начинайте вводить данные или измените шаблон согласно своим потребностям.

Публикация веб-базы данных

  1. В представлении Backstage откройте вкладку Сохранить и опубликовать (если она еще не открыта) и выберите команду Опубликовать в Access Services.

  2. Нажмите кнопку Проверка совместимости.

  3. Нажмите кнопку Да, чтобы закрыть все открытые объекты и запустить средство проверки совместимости.

  4. Если проблемы не обнаружены, база данных готова к публикации.

  5. Введите URL-адрес сервера и имя сайта.

  6. Нажмите кнопку Опубликовать в Access Services.
    После завершения процесса публикации таблицы базы данных станут списками SharePoint, а формы будут выглядеть и работать так же, как в приложении Access.

Использование режима макета

Режим макета в приложении Access 2010 представляет собой визуальный конструктор форм и отчетов. Это единственный конструктор для форм и отчетов веб-баз данных.

Работа в режиме макета

  • В области навигации щелкните правой кнопкой мыши форму или отчет и выберите команду Режим макета.
    Другой вариант:
    щелкните правой кнопкой мыши ярлык любой открытой формы или отчета и выберите команду Режим макета.

Некоторые изменения, которые можно быстро внести в режиме макета

  • Выделите один элемент управления или подпись и перетащите этот объект, чтобы изменить размеры всех элементов управления или подписей в этом столбце.

  • Выделите подпись, откройте вкладку Формат и с помощью ее команд измените шрифт, цвет шрифта или выравнивание текста.

  • Нажмите клавишу CTRL, чтобы выделить несколько подписей, и отформатируйте их.

  • Чтобы внести глобальные изменения в макет, щелкните элемент выделения макета (крестик в его левом верхнем углу). Выделите, например, весь макет. На вкладке Конструктор нажмите кнопку Страницасвойств, чтобы открыть окно свойств формы, и задайте для элементов управления другую высоту.

Перемещение или размещение элементов управления путем добавления в макет пустых столбцов и строк

  1. На вкладке Конструктор выберите команду Добавить поля.

  2. Перетащите в макет нужные поля.

  3. При необходимости перетащите элементы управления отдельно от их подписей в нужное место. Новое расположение будет обозначено оранжевой рамкой.

Группировка и сортировка данных в отчетах

  1. На вкладке Конструктор выберите команду Группировка.

  2. На панели Группировка, сортировка и итоги нажмите кнопку Добавить группировку и выберите поле, по которому нужно сгруппировать данные. Изменения вступают в силу немедленно.
    Можно добавить до семи уровней группировки.

Применяется к: Access 2010



Были ли сведения полезными?

Да Нет

Что мы могли бы улучшить?

255 осталось символов

Чтобы защитить вашу конфиденциальность, не указывайте контактные данные в своем отзыве. Обзор наших политика конфиденциальности.

Спасибо за ваш отзыв!

Ресурсы поддержки

Изменить язык