Формулы и функции

Функция СУММ

Функция СУММ: формула суммы в Excel

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

Функция сумм , одна из математические и тригонометрические функции, добавляет значения. Вы можете добавить отдельные значения, ссылки на ячейки или диапазоны или одновременно все три.

Пример

  • =СУММ(A2:A10)

  • =СУММ(A2:A10;C2:C10)

Браузер не поддерживает видео. Установите Microsoft Silverlight, Adobe Flash Player или Internet Explorer 9.

СУММ(число1;[число2];…)

Имя аргумента

Описание

число1    (обязательный)

Первое число для сложения. Это может быть число 4, ссылка на ячейку, например B6, или диапазон ячеек, например B2:B8.

число2–255    (необязательный)

Это второе число для сложения. Можно указать до 255 чисел.

В этом разделе рассматриваются некоторые рекомендации по работе с функцией сумм. Большая часть этого можно применять к работе с других функций.

Метод =1+2 или =A+B. Вы можете ввести =1+2+3 или =A1+B1+C2 и получить абсолютно точные результаты, однако этот метод ненадежен по ряду причин.

  1. Опечатки. Допустим, вы пытаетесь ввести много больших значений такого вида:

    • =14598,93+65437,90+78496,23

    Попробуйте проверить правильность записей. Намного проще установить следующие значения в отдельных ячеек и использовать формулу СУММ. Кроме того можно форматировать значения, когда они находятся в ячейках, что делает их более удобным для чтения, а затем, когда они находятся в формуле.

    Используйте функцию СУММ, вместо того чтобы указывать значения прямо в формулах.  Ячейка D5 содержит формулу =СУММ(D2:D4)
  2. Ошибки #ЗНАЧ!, если ячейки по ссылкам содержат текст вместо чисел

    Допустим, вы используете формулу такого вида:

    • =A1+B1+C1 или =A1+A2+A3

    Пример неудачной формулы.  Ячейка D2 содержит формулу =A2+B2+C2

    Формулу можно вставить разрыв при наличии все значения — нечисловое (текст) в ссылках на ячейки, которые возвращают #VALUE! Ошибка. Сумма будет игнорировать текстовых значений и присвойте сумму только численные значения.

    Правильная формула.  Вместо выражения =A2+B2+C2 ячейка D2 содержит формулу =СУММ(A2:C2)
  3. Ошибка #ССЫЛКА! при удалении строк или столбцов

    Ошибка #ССЫЛКА! возникла из-за удаления столбца.  Формула приняла вид =A2+#ССЫЛКА!+B2

    При удалении строки или столбца формулы не обновляются: из них не исключаются удаленные значения, поэтому возвращается ошибка #ССЫЛКА!. Функция СУММ, в свою очередь, обновляется автоматически.

    Функция СУММ будет автоматически корректироваться при вставке и удалении строк и столбцов.
  4. Формулы не обновляют ссылки при вставке строк или столбцов

    Формулы =A+B+C не обновляются при добавлении строк

    Если вставить строку или столбец, формула не будут обновляться для включения добавленная строка, где функция сумм автоматически обновляется (при условии, что вы не вне диапазона, указанных в формуле). Это важно, особенно если предполагается, что формула для обновления и это не так, как он будет закрыто с неполные результаты, которые не может обнаружить.

    В примере показана формула СУММ, которая при добавлении столбца автоматически расширяется от =СУММ(A2:C2) до =СУММ(A2:D2)
  5. Функция СУММ — отдельные ячейки или диапазоны

    Используя формулу такого вида:

    • =СУММ(A1;A2;A3;B1;B2;B3)

    — Одинаково ошибки ошибкам при вставке или удалении строк в диапазоне, на который указывает ссылка по тем же причинам. Намного лучше использовать отдельные диапазоны, такие как:

    • =СУММ(A1:A3;B1:B3)

    Такая формула будет обновляться при добавлении и удалении строк.

Проблема

Возможная причина

Функция СУММ отображает символы ##### вместо результата.

Установите флажок ширину столбцов. ### обычно означает, что столбец слишком мала для отображения результата формулы.

Функция СУММ отображает саму формулу в виде текста, а не результат.

Проверьте, что ячейка не отформатировано как текст. Выделите ячейку или диапазон в вопросе и используйте сочетание клавиш Ctrl + 1 для открытия диалогового окна Формат ячеек , затем нажмите кнопку номер вкладку и выберите нужный формат. Если ячейка в текстовом формате и не изменяются после изменения формата, при необходимости можно использовать F2 > ввод принудительно формата для изменения.

Функция СУММ не обновляется.

Убедитесь, что вычисления имеет значение Авто. Вкладка "формулы" нажмите Параметры вычислений. Можно также использовать F9 принудительно для вычисления на листе.

Проверьте, выбрано ли для вычисления значение "Автоматически".  На вкладке "Формулы" откройте "Параметры вычислений".

Некоторые значения не добавляются.

В ссылке на функцию или диапазоне суммируются только числовые значения. Пустые ячейки, логические величины (например, ИСТИНА) и текст игнорируются.

Вместо ожидаемого результата отображается значение ошибки #ИМЯ?.

Обычно это означает, что в формуле содержится ошибка: например, вместо =СУММ(A1:A10) введено =сума(A1:A10).

Функция СУММ отображает целое число, хотя должно отображать десятичное.

Проверьте, выбрано ли отображение десятичных чисел в формате ячейки. Выберите соответствующую ячейку или соответствующий диапазон и нажмите клавиши Ctrl + 1, чтобы открыть диалоговое окно Формат ячеек, затем щелкните вкладку Число и выберите нужный формат, указав при этом нужное количество десятичных знаков.

  1. Мне нужно добавить, вычесть, умножить или поделить числа. Просмотрите серию учебных видео: Основные математические операции в Excel или Использование Microsoft Excel в качестве калькулятора.

  2. Как показать больше или меньше десятичных разрядов? Можно изменить формат номера. Выделите ячейку или диапазон в вопросе и для открытия диалогового окна Формат ячеек , а затем откройте вкладку число и выберите формат, который вы хотите сделать так указать количество десятичных разрядов, которые вы хотите использовать сочетание клавиш Ctrl + 1 .

  3. Как добавить или вычесть значения времени? Есть несколько способов добавить или вычесть значения времени. Например, чтобы получить разницу между 8:00 и 12:00 для вычисления заработной платы, можно воспользоваться формулой =("12:00"-"8:00")*24, т. е. отнять время начала от времени окончания. Обратите внимание, что Excel вычисляет значения времени как часть дня, поэтому чтобы получить суммарное количество часов, необходимо умножить результат на 24. В первом примере используется формула =((B2-A2)+(D2-C2))*24 для вычисления количества часов от начала до окончания работы с учетом обеденного перерыва (всего 8,5 часов).

    Если вам нужно просто добавить часы и минуты, вы можете просто вычислить сумму, не умножая ее на 24. Во втором примере используется формула =СУММ(A6:C6), так как здесь нужно просто посчитать общее количество часов и минут, затраченных на задания (5:36, т. е. 5 часов 36 минут).

    Расчет времени

    Дополнительные сведения см. в статье Сложение и вычитание значений времени

  4. Как получить разницу между датами? С помощью значениями времени, можно добавить и вычитание дат. Ниже приведен пример очень часто подсчета количества дней между двумя датами. Это же просто, как = B2-A2. Ключ для работы со значениями даты и времени — начать с конечная дата/время и вычитание значений даты и времени начала.

    Вычисление разницы между датами

    Другие способы работы с датами описаны в статье Определение количества дней между двумя датами.

  5. Как вычислить сумму только видимых ячеек? Иногда когда вы вручную скрываете строки или используете автофильтр, чтобы отображались только определенные данные, может понадобиться вычислить сумму только видимых ячеек. Для этого можно воспользоваться функцией ПРОМЕЖУТОЧНЫЕ.ИТОГИ. Если вы используете строку итогов в таблице Excel, любая функция, выбранная из раскрывающегося списка "Итог", автоматически вводится как промежуточный итог. Дополнительные сведения см. в статье Данные итогов в таблице Excel.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

См. также

Узнайте больше о сумм

Функция СУММЕСЛИ суммирует только те значения, которые соответствуют одному условию

Функция СУММЕСЛИМН суммирует только те значения, которые удовлетворяют нескольким условиям

Функция СЧЁТЕСЛИ подсчитывает только значения, которые соответствуют одному условию

Функция СЧЁТЕСЛИМН подсчитывает только значения, которые удовлетворяют нескольким условиям

Обзор формул в Excel

Как избежать появления неработающих формул

Поиск и исправление ошибок в формулах

Сочетания клавиш в Excel для Windows

Сочетания клавиш в Excel для Mac

Математические и тригонометрические функции

Функции Excel (по алфавиту)

Функции Excel (по категориям)

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×